Jump to content

DCS World TARGET profile for TM Cougar and Warthog + MFDs


DCS World TARGET profile for TM Cougar and Warthog + MFDs  

6 members have voted

  1. 1. DCS World TARGET profile for TM Cougar and Warthog + MFDs

    • Keep DH/DT with Hdg Hold and BA/RA with Alt Hold (keep apples with apples)
      1
    • Map BA/RA with Hdg Hold and DH/DTwith Alt Hold (like actual panel switches)
      5


Recommended Posts

Are you sure? I´m uninstalling following above instruction but when installing CTS I get a message that the CTSversion.txt file is missing and whatever I do it wont let me install. To me it behaves like a registrypost is stopping me. I have for now installed CTS on a second harddrive, so it works but not on C:

I assume that when you removed everything, you then tried to run ctsupdate.exe rather than re-installing using CTS_2_10_Installer.exe. If you reinstall to the same location with CTS_2_10_Installer, you should be fine.

 

Alternatively, you can create the DB folder again, then create a text file called version.txt. Then insert the following line:

http://blackveal.dlinkddns.com/MyWeb/TARGET/CTS/CTSversion.txt

Then that should allow you to update from scratch.

Link to post
Share on other sites
  • Replies 1.9k
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

UPDATE: Version 2.56 is available. The installer will now give you the option to install CTS for DCS 2.5 and 1.5.8 Legacy versions. Note: The DNS address in the old 2.10 installer is no longer va

In my case, it was a dns resolution problem. My ISP's DNS server does not resolve blackveal.tplinkdns.com. My solution was to replace the dns server ip on the pc with one of the google dns servers,

Version 2.57 is uploaded.  Big thing is the new T-45 profile, along with 2.7.1 compatibility.

I already have tried both 2.10 installer and ctsupdate.exe with no luck.

Inside the version file it already have the code you wrote first up. And it doesn´t work.

I also removed this code but when installing again it creates a new version file with that code already in it.

Link to post
Share on other sites
I already have tried both 2.10 installer and ctsupdate.exe with no luck.

Inside the version file it already have the code you wrote first up. And it doesn´t work.

I also removed this code but when installing again it creates a new version file with that code already in it.

 

So it creates a new version.txt, but doesn't actually unzip any of the files or create any folders? Do you get a message that says "Server Not Available"?

Link to post
Share on other sites

It creates the DB map with the file "version" and also the ctsupdate.exe. I have tried to install in many different ways and two or three times i have got the message Server not available.

I did a search in registry for cts.version.txt but it didn´t find nothing

Link to post
Share on other sites
It creates the DB map with the file "version" and also the ctsupdate.exe. I have tried to install in many different ways and two or three times i have got the message Server not available.

I did a search in registry for cts.version.txt but it didn´t find nothing

 

The installer will create both of those files you describe, but there is nothing in the registry. It is looking for ctsversion.txt at the html link in version.txt. If it doesn't find it or the files in its list you get the "Server Not Available" message. Has anything changed in your firewall (software or hardware) since you updated last?

 

Also, is anybody else having trouble updating?

Link to post
Share on other sites

Version 2.34 is available for download. You need DCS 2.5.5 for this version. This is a big changelog, as I've been holding off on releasing this until 2.5.5 made it to stable release.

 

Note that if you were using the AJS37 Custom Controller LUA (aka Funkyfranky's mod), this is obsolete with the latest version of DCS (these edits are now part of the default Viggen lua).

 

Changelog:

 

  • Fixed VR Hat1 functionality for Cougar users.
  • Added ability to select profiles on the fly without using MFDs (for VR users).
  • SA342: Added VAICOM TX5/SRS Intercom to MSP (Warthog).
  • Mi-8: Fixed station selection orientation on Hat1
  • MiG-21: Added option for context-sensitive weapon selector based on AA/AG Master Mode.
  • AJS37: Converted Custom Controller LUA option to forced default and fixed light panel mappings for 2.5.5 update.
  • P/TF-51: Changed landing gear from toggle function to discrete state actuation.
  • A-4E: Revised mappings for A-4E Community Mod version 1.3.1.
  • NS430: Compatibility with Chic's GPS Rotary Encoder Fix (Optional).
  • AV-8B: Removed two SnapViews and replaced with TDC Action and Cage/Uncage on H2U/D (Warthog).
    Added Flashlight to RMFD.

 

F-14 Changes (worthy of their own changelog :D ):

  • Swapped ICS and TACAN Cmd buttons, moved Emergency Stores Jettison to OSB18 on Pilot LMFD.
  • Added Air Source selection on Pilot RMFD (requires included Controller LUA mod).
  • Fixed Walkman volume control on RIO RMFD.
  • Added VAICOM Pro AI RIO support (updated VAICOM Pro Import file).
  • Added dynamic CAP drum and FLIR overlays for RIO MFDs in MFDisplay.
  • Added short TEMPO for DLC Toggle to prevent inadvertent toggling during use (Warthog H4P Only).
  • Remapped RIO HCU Selector (Hat3) from default DirectX to a more intuitive orientation.
  • Added two Instantaneous (held) RIO SnapViews to H3L/R Long.
  • Added support for H0RN4T's LANTIRN Pilot mod.
  • Added option to remap Boat Switch as Master Arm + ACM Mode (Warthog Only).

Link to post
Share on other sites

Just tried it (F14): suddenly the "comm hat" on the Warthog throttle works just for Jester... Left or right presses don't bring out the Comms menu... Probably did something wrong, anyway a quick check for the usual errors didn't brought up any glaring misstep in updating...

 

So here I am writing here to check if anybody else experienced same issue or if it's really just me...

 

UPDATE: reverting back to 2.33 solves the issue, so it seems that Comms menu disappearing is just a 2.34 thing... Anybody else with the same isse ? Because if nobody else has it, I'm really struggling to understand what's the problem on my side...


Edited by itarrow
Link to post
Share on other sites

Having issues using the RIO controls in Multiplayer.. not sure why this would be.. If im in single player and enter rio seat then s3 HL x2 it will change the profile to rio seat and works fine in single player.. then when i goto a multiplayer server and leave controls same they dont work in rio. even if i choose the f14 profile then the rio seat config with s3 HLx2 it wont work.. fresh install.

Link to post
Share on other sites
Just tried it (F14): suddenly the "comm hat" on the Warthog throttle works just for Jester... Left or right presses don't bring out the Comms menu... Probably did something wrong, anyway a quick check for the usual errors didn't brought up any glaring misstep in updating...

 

So here I am writing here to check if anybody else experienced same issue or if it's really just me...

 

UPDATE: reverting back to 2.33 solves the issue, so it seems that Comms menu disappearing is just a 2.34 thing... Anybody else with the same isse ? Because if nobody else has it, I'm really struggling to understand what's the problem on my side...

I'm unable to duplicate the error. Have you updated to the latest F-14 Pilot and RIO lua files? Also, do you have VAICOM enabled?

 

Having issues using the RIO controls in Multiplayer.. not sure why this would be.. If im in single player and enter rio seat then s3 HL x2 it will change the profile to rio seat and works fine in single player.. then when i goto a multiplayer server and leave controls same they dont work in rio. even if i choose the f14 profile then the rio seat config with s3 HLx2 it wont work.. fresh install.

I'm assuming you're using VR. Is this correct? If so, do you have the hat trim function set to 0 or 1?

Link to post
Share on other sites
I'm unable to duplicate the error. Have you updated to the latest F-14 Pilot and RIO lua files? Also, do you have VAICOM enabled?

 

I've updated to the new lua profiles (2.34) both for kb as well as WH, VAICOM is not enabled.

 

Checked also modifiers are still there (and they are).

 

Did some further testing without success, even after setting MFDs as -1 (it says to try it just for troubleshooting, so gave it a try).

 

I've discovered also that the speedbrake doesn't work with 2.34.

 

Reverting back to 2.33 F14 luas makes everything works again: comms menu appears as soon as I push comm hat left or right and speedbrakes correctly deploys/retreat.

 

Not sure what else to try... I will stick to 2.33 and see if I can came up with a solution... suggestions welcome of course...

Link to post
Share on other sites
Sorry everybody. The F-14 Pilot LUA export for the Warthog got corrupted into a hot mess. Here's a new diff.lua until I can get the hotfix out.

 

Well, there's no way you have to say sorry about something you do so well for the community and for free.

 

Thanks for what you do and keep doing so well.

Link to post
Share on other sites

Thank you so much for MFD less profile switch :D testet a few modules so far and almost everything works flawlessly.

 

Only thing i found until now, in mig 15 the selection is not working, S3 and speedbrake momentarily is just switching some speedbrake state and not the profile Selektion.

[sIGPIC][/sIGPIC]

Link to post
Share on other sites

Only thing i found until now, in mig 15 the selection is not working, S3 and speedbrake momentarily is just switching some speedbrake state and not the profile Selektion.

 

Thanks for the catch. The MiG-15 has its own braking routine that I overlooked. This will be in the hotfix.

Link to post
Share on other sites

One last thing (sorry about it): checked back the AV8B and the refueling probe switch on the WH throttle (rdr altm) doesn't work... can you check it ?

 

Thanks again...

 

EDIT: saw now that the layout jpg about the Harrier in first message of this thread is different from the one in the CTS docs folder. Here the refueling probe is in a different throttle switch, while on the one I was trying there’s anticollision lights.

 

Will test according to the layout in the first message here and report back if everything works OK according to it (meaning the jpg in the docs folder of CTS are outdated).


Edited by itarrow
Link to post
Share on other sites

Only thing i found until now, in mig 15 the selection is not working, S3 and speedbrake momentarily is just switching some speedbrake state and not the profile Selektion.

 

Edit: every warbird and every Helicopter and AWACS and Combined arms no getting again in the switching state after selecting them trough the state or on profile start.

 

 

direkt X is working, also all blue and red jets(-Mig15).

 

loading the profile is working for ever module so far.


Edited by JanRalle

[sIGPIC][/sIGPIC]

Link to post
Share on other sites
Edit: every warbird and every Helicopter and AWACS and Combined arms no getting again in the switching state after selecting them trough the state or on profile start.

 

 

direkt X is working, also all blue and red jets(-Mig15).

 

loading the profile is working for ever module so far.

 

Thanks. Didn't even think about the planes without airbrakes. I'll figure something out.

Link to post
Share on other sites

EDIT: saw now that the layout jpg about the Harrier in first message of this thread is different from the one in the CTS docs folder. Here the refueling probe is in a different throttle switch, while on the one I was trying there’s anticollision lights.

 

Yeah, don't trust the exemplars near the first post. I don't bother to update those.

Link to post
Share on other sites

2.34 Hotfix 1 is up.

 

  • Fixed F-14 Pilot Warthog diff.lua file.
  • Fixed minor bugs with Warthog CommState and APU switch assignements.
  • Fixed VR Mouse Scroll Wheel for Cougar users
  • Fixed HOTAS module cycle not working for MiG-15 and modules without speedbrakes.

Link to post
Share on other sites
Yeah, don't trust the exemplars near the first post. I don't bother to update those.

 

I've checked: the AV8B fuel probe switch doesn't work neither on the WH Throttle "RDR ALTM" switch (official docs) nor on the FUEL NOMR ENG L WH Throttle switch (jpg here on the first post).

 

Using latest luas (AV8B wh 2.28 and AV8B 2.34 kb).

Link to post
Share on other sites

Hello,

 

Google translation:

 

I am entering the world of DCS and of course I am looking for a script, which would save me time in my learning.

 

CTS seems to me to indicate all of them, given the multiple comments.

 

My equipment:

 

Warthog

TPR

VR

DCS Stable

French keyboard

 

I'm progressing on the configuration, but it's not easy, a lot of theme in the doc that I don't understand, my English leaves something to be desired

 

Here is one of the problems I have

 

Training with the KA-50:

 

When the throttle is applied with the slider, (Throttle friction control) the keyboard is no longer active in games, I have to open the port and close it so that the keyboard is active again.

 

UI LAYER SETUP IN DCS WORLD :

 

the setting of the VR, I don't understand or I have to load the lua file

 

thank you

Link to post
Share on other sites
I've checked: the AV8B fuel probe switch doesn't work neither on the WH Throttle "RDR ALTM" switch (official docs) nor on the FUEL NOMR ENG L WH Throttle switch (jpg here on the first post).

 

Using latest luas (AV8B wh 2.28 and AV8B 2.34 kb).

 

I'll fix this in next version/hotfix. In the meantime, the solution is to find

Air refueling probe toggle IN/OUT

and add the following to keyboard:

LWIN+A

Link to post
Share on other sites
Hello,

 

Google translation:

 

I am entering the world of DCS and of course I am looking for a script, which would save me time in my learning.

 

CTS seems to me to indicate all of them, given the multiple comments.

 

My equipment:

 

Warthog

TPR

VR

DCS Stable

French keyboard

 

I'm progressing on the configuration, but it's not easy, a lot of theme in the doc that I don't understand, my English leaves something to be desired

 

Here is one of the problems I have

 

Training with the KA-50:

 

When the throttle is applied with the slider, (Throttle friction control) the keyboard is no longer active in games, I have to open the port and close it so that the keyboard is active again.

 

UI LAYER SETUP IN DCS WORLD :

 

the setting of the VR, I don't understand or I have to load the lua file

 

thank you

 

Welcome to DCS! You are getting into a very rewarding sim/hobby, but one with a very steep learning curve. As much as I love that you are using my profile, you may wish to skip TARGET for now and use the default Warthog mappings for the Ka-50. This serves to eliminate variables, so you know if something doesn't work that it is not whether you set up the TARGET profile correctly.

 

Once you are comfortable with DCS, its controller interface, VR, and the Ka-50 itself, then you may wish to revisit TARGET. Much of my instructions rely on existing knowledge of the DCS controls and options menu, and using my profile will prove to be much less frustrating once you develop a foundation of knowledge in DCS.

 

Understand that I'm not trying to insult you or push you away. I just think that learning DCS without having to follow the exacting steps in also learning my profile will benefit you a lot more in the short term. I look forward to your return once you understand the basics.

Link to post
Share on other sites
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...