Jump to content

Huey AI does not use mini-guns in latest version


lennycutler
 Share

Recommended Posts

I posted this in the Huey Module Bug area, but no one as answered it yet...so maybe it belongs here.

 

I set up a simple mission of four Hueys attacking some light armor.

prior to the current version, 1.5...my flight would first attack with rockets and then mini guns.

 

Now....they attack with rockets, and then nothing...they don't engage with mini guns.

 

I originally set a way point action to attack the armor group.

 

When that didn't work to get the flight to use their mini guns...I just gave the command to attack targets of opportunity.

 

Again, in the prior version...I had no problems with my AI Hueys using their guns.

 

I have attached the mission file.

 

Am I doing something wrong in mission design....or is this a new bug?

 

ps....I downloaded the module again after the latest patch...and installed...and still my AI Hueys don't use their mini-guns.

 

Can someone please review this and comment if this is a new bug?

Attached Files

File Type: miz Armor Mission BTR 80 M261 HP Rockets.miz (6.5 KB, 4 views)

Armor Mission M261 HP Rockets.miz

Velocity MicroI7-4790 Windows 7 Home Premium 16Gigs RAM EVGA NVIDIA GTX 1070 500GB SSD TM Hotas Warthog

Link to comment
Share on other sites

I did not look at your mission, but created a short one of my own. They do attack with mini-guns, as you can see them spinning and tracking. However, they do not appear to have any ammo. I haven't done much with the UH1's so I don't know their behavior before now, but this does not seem correct.

Link to comment
Share on other sites

thanks for confirming that this is a bug....I am just surprised that no one else is mentioning it, since it was not an issue in the prior version.

Velocity MicroI7-4790 Windows 7 Home Premium 16Gigs RAM EVGA NVIDIA GTX 1070 500GB SSD TM Hotas Warthog

Link to comment
Share on other sites

I checked again after today's update...still the mini-guns show they are rotating.....but no rounds are exiting from the barrels. So, whatever the code that enables the bullets to leave the barrel and strike a target...is broken...and still needs to be fixed.

 

Again, I am surprised that no one from DCS or the developer has commented on such an obvious, significant bug.

Velocity MicroI7-4790 Windows 7 Home Premium 16Gigs RAM EVGA NVIDIA GTX 1070 500GB SSD TM Hotas Warthog

Link to comment
Share on other sites

  • 4 weeks later...

I was able to get the m134 miniguns to work. I tried out a Hip8 with various gun pods and they worked ok. One of those was a guv yakb gshb that had 3 gatling type guns, and they worked ok. I scoured through a bunch of .lua files and found that the russian gatling guns were controlled by gas and the m134 minigun was by rpm (electrically?). I also found that the "fire by rpm = true" means that it only fires when MAX RPM is reached. I could not find a max rpm setting for the m134 but did find some spinup/spindown numbers. I was thinking they might affect the max rpm reached (even if I didn't what that number was), so I played with those a bit. Didn't work. I then changed the fire by rpm to gas fired. Now they fire, majestically.

 

I'm guessing either some math is wrong in one of the .lua files preventing max rpm from being reached, or the max rpm number was changed causing it to be unreachable. or MAX RPM was removed, thus causing it to never work.

 

dcs world/config/weapons/aircraft_gun_mounts.lua

 

Original:

 

gun_mount_templates["M_134"] =

{

gun = dbtype("wGun",

{

rates = {4000,2000},

max_burst_length = 3200,

recoil_coeff = 0.7*1.3,

barrels_count = 6,

fire_by_rpm = true

 

Modified:

 

gun_mount_templates["M_134"] =

{

gun = dbtype("wGun",

{

rates = {4000,2000},

max_burst_length = 3200,

recoil_coeff = 0.7*1.3,

barrels_count = 6,

gas_driven = true


Edited by Evil.Bonsai
Link to comment
Share on other sites

I have not tried your fix (Evil.Bonsai), hoping that the latest version had fixed the A

I min-gun problem.

 

But, no, the AI mini-guns still spin but don't fire.

 

Seems to me that this would have been addressed by now, by the developers without us users having to look for a fix in the lua files.

 

But I will try your fix.

Velocity MicroI7-4790 Windows 7 Home Premium 16Gigs RAM EVGA NVIDIA GTX 1070 500GB SSD TM Hotas Warthog

Link to comment
Share on other sites

Just made the lua file changes you suggested....It worked....

 

Thanks, and I am sure others will thank you...

 

Hopefully, the developers are reading this bug report too.

Velocity MicroI7-4790 Windows 7 Home Premium 16Gigs RAM EVGA NVIDIA GTX 1070 500GB SSD TM Hotas Warthog

Link to comment
Share on other sites

  • 4 weeks later...

Now with today's update notes...this is supposed to be fixed.

 

I just tested it...it is worse...the AI do not fire any weapons...not rockets or guns..

 

Even the suggested change to the lua file which did fix it before...has no impact now for me.

Velocity MicroI7-4790 Windows 7 Home Premium 16Gigs RAM EVGA NVIDIA GTX 1070 500GB SSD TM Hotas Warthog

Link to comment
Share on other sites

Now with today's update notes...this is supposed to be fixed.

 

I just tested it...it is worse...the AI do not fire any weapons...not rockets or guns..

 

Even the suggested change to the lua file which did fix it before...has no impact now for me.

For me it works perfectly fine. AI wingmen and independend AI helos attack ground targets with rockets and mini guns.

Link to comment
Share on other sites

  • 1 month later...

Just Tried it out and mine fires as it should. Checked the files I previously altered and the 'fire by rpm" is now back to 'true' and it works. I checked the other gunpods file but didn't see any changes there. Why it works now and didn't previously I'm not sure about. I still have backups of the old files. I will check them more closely later and see if I can find what might have changed.

Link to comment
Share on other sites

  • 2 months later...

My guns mini guns do not work either I patched to 1.2.7 and LCTRL 3 and 4 do not have any effect on changing the fore modes. I can only find the settings in game mode not sim mode. Prior to the patch of 1.2.7 my beta worked fine. I uninstalled beta still no joy for the real 1.2.7. I cant get them to fire commands show up in options game uh1 but they dont work

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...