Jump to content

Can't set up controls for Su-25


tf_neuro
 Share

Recommended Posts

Hello there.

I'm posting here because I couldn't find a Su-25 section. Sorry if I picked the wrong forum.

 

I have some problems trying to set up the su-25: many items in the 'controls' page are greyed out, including some very important ones like gun trigger and rudder.

 

In some cases an item is greyed out for one controller but not the other. For example, I can assign the rudder axis to the joystick but not the pedals, gun trigger can be assigned to keyboard but not to the joystick.

 

Everything works fine on all other aircraft that I have tried so far, which includes P-51D, A-10C, Ka-50. The problem only shows up for the Sukhois, both Su-25 and Su-25T.

 

My game controllers are:

Kg-20 floor-mounted joystick from Schreinerschmidt (visible at http://www.thefoxbats.ch/forums/viewtopic.php?f=12&t=390 )

CH Pro pedals

CH Panel (6-slider throttle)

The throttle off an old Saitek X-52

"frankenstick" for additional buttons and sliders, built out of an old Logitech stick (visible at http://www.thefoxbats.ch/forums/viewtopic.php?f=12&t=92 )

 

As I said above, this rather unusual configuration gives me no problems at all on DCS, except for the Su-25. Everything else works just fine.

 

Can you think of any way to fix this problem?

If you need additional info, don't hesitate to ask.

Link to comment
Share on other sites

Only thing I can think of it to delete or move your su-25 folder in "C:\Users\<yourname>\Saved Games\DCS\Config\Input" (if you're using Win7.)

 

The game will then rebuild the controls files when you start it up next time. Might help.

i5 4590 @ 3.77GHz | GTX 1060 6GB | 16GB 1600MHz DDR3 | 1TB HDD+500GB HDD | Win10 Home X64

[sIGPIC][/sIGPIC]

Link to comment
Share on other sites

Here's another problem and how I got around it, in case someone is interested:

 

I was trying to set up the Su-25A, then save the profile, and finally load it in the Su-25T. However, every time I tried to do that I ended up with keyboard settings being loaded in the column that I have selected, and some fields were greyed out.

 

When I saw that mess I hit 'cancel' and it reverted to default, which might explain why there was no su-25T folder in the config directory... and then it hit me.

 

I simply made a copy of the su-25 folder and renamed it su-25T.

It will probably require some manual adjustments for stuff that is peculiar to the T model, but I got most of the stuff already in place.

Link to comment
Share on other sites

Neuro is your Su-25t a clickable cockpit? Or is anyone's for that matter? Mine is not, I do have the yellow X for the mouse but can't move or switch anything in the cockpit! Maybe I messed something up? btw good to see a squaddie on here, now get on TS!

 

The cockpits are not clickable in the Su-25A or Su-25T. They are "Flaming Cliffs" level of simulation with the Advanced Flight Model and not the DCS level of simulation. That may come later with some sort of upgrade but if so, that will be a while away me thinks.

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...