Jump to content

The Dreaded Firmware Issue


damnfoolman
 Share

Recommended Posts

Hi all

 

Well it's struck early here. WH only 7 weeks old.

 

Joystick just failed to respond in the A10 with no warning...

 

Joystick will not update firmware, and although it's showing as an installed device, working, yeah right, but not showing in game controllers, and of course not working in my A10.

 

Gutted. Spent hours today doing all of the things helpful members have already posted about. The bulk the normal the USB slots, the flashing.....:smilewink: Hold down these buttons put in the USB dont tick this......AAaRRgGgG

 

Diddly. So I've sent TM a message, lets see what they say.

 

I'm guessing Maplins will have to have it back for repair or better still replacement.

 

Throttle is fine.....so far.

 

So I get my seat and screen etc all set in perfect order and this happens....not one mission flown and I'm in withdrawal.

 

I am less than pleased as I was just getting the hang of the various short this, long that, soi here, etc etc.

 

Anyhow. I guess I'm stuffed for a little while.

 

Dave

Link to comment
Share on other sites

There are unclear items in your post:

"update firmware" You mean drivers?

When you click on driver update for the driver properties, an update will not happen if the MICROSOFT driver server doesn't store a driver for your device, or doesn't have a newer one in their database. That's doesn't mean an update is not available. You should check the website for the manufacturer for your device.

 

That the throttle works, but your stick does not, sounds suspicious. They use the same driver. Do you have another game besides Warthog to try? Have you tried the free plane in DCS World to make sure it's not your A10 messed up but your controller is OK?

 

1) You need to tell us the make and model of your controller and operating system with hardware specs.

2) You need to provide us the link to the forum thread where other people have tried to help you so we don't cover all the same ground again.

 

 

Also, have you started up your controller configuration software from the task bar and moved your joystick around, clicked the buttons, etc to see what works and what doesn't outside DCS World?

-Pv-


Edited by -Pv-
Link to comment
Share on other sites

There are unclear items in your post:

"update firmware" You mean drivers?

When you click on driver update for the driver properties, an update will not happen if the MICROSOFT driver server doesn't store a driver for your device, or doesn't have a newer one in their database. That's doesn't mean an update is not available. You should check the website for the manufacturer for your device.

 

That the throttle works, but your stick does not, sounds suspicious. They use the same driver. Do you have another game besides Warthog to try? Have you tried the free plane in DCS World to make sure it's not your A10 messed up but your controller is OK?

 

1) You need to tell us the make and model of your controller and operating system with hardware specs.

2) You need to provide us the link to the forum thread where other people have tried to help you so we don't cover all the same ground again.

 

 

Also, have you started up your controller configuration software from the task bar and moved your joystick around, clicked the buttons, etc to see what works and what doesn't outside DCS World?

-Pv-

 

TM Hotas Warthog...

Latest drivers from the TM site. Latest Firmware loads into the Throttle but not the Joystick.

The pc is an i7 with loads of ram etc etc 1gb graphics thing, and importantly it was all working just fine.

 

Ive tried all 6 USB slots on my pc MB and a powered hub too.

 

The throttle shows in the game controller and I can see axis buttons working etc and it works in the game, the joystick will not. But it does show as an HID device and on the device manager, drivers say they are working and the most up too date. I've uninstalled reinstalled using various techniques suggested in the many threads on several forums.

 

There are a number of threads, many great suggestions, sometimes it suddenly works after several reinstalls sometimes not. I guess mine is a not!

 

Thanks for the reply.

 

Dave

Link to comment
Share on other sites

Well it's sorted.....kinda.

 

Tried the setup on an older laptop with XP and another with Vista. No go on any.

 

So I called Maplins, hoping for a return to TM for fixing. They did not offer that option, and they have none in stock, so I boxed everything up and got a no quibble no effort refund in the local store.

 

Great customer service.

 

I tried to find a retail outlet, but there seem to be none stocking the TMHW here in the UK.

 

So I have a new one inbound from another online store for delivery on Tuesday. Same cost too which is a huge bonus.

 

Lets hope this one works for longer than 5 weeks.....

 

D

Link to comment
Share on other sites

update the firmware as soon as you get it.

The only way to make sense out of change is to plunge into it, move with it, and join the dance.

"Me, the 13th Duke of Wybourne, here on the ED forums at 3 'o' clock in the morning, with my reputation. Are they mad.."

 

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...