Jump to content

AI enemy detection bugs in 1.2.5


Bushmanni
 Share

Recommended Posts

Buildings don't seem to block optics LOS for AI. I used the new SSE functions to see when the AI sees me and what sensors can see me and outputting it as text to the screen. In the track you can see that AI sees me instantly in the beginning of the mission and flies straight to me and tries to shoot me through a building. At one point he also flies through a building.

 

So far I haven't seen any definite indication of AI requiring some time to see me. If I'm behind his 3/9 line he doesn't see me and when I get in front of that he instantly spots me as long as I'm close enough (about 12km is the largest starting separation I have had in my tests and always got instantly spotted).

 

When the AI follows last known trajectory he doesn't stop when the trajectory is above open featureless plain with no place to hide. There should be some kind of LOS check to a point in the ground under the targets assumed current position in order to detect this condition. When the LOS check determines there's LOS the AI could fly the route between points where the target was last seen and where he should have appeared again but didn't.

AI Spotting Bugs.trk

Test AI spotting urban.miz

DCS Finland: Suomalainen DCS yhteisö -- Finnish DCS community

--------------------------------------------------

SF Squadron

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...