Jump to content

Softth: render quality and no instrument exports


Nereid
 Share

Recommended Posts

Well... I have tried Softth a few months ago and it didn't worked for me. Now I'm using helios with a second screen and tried to give it another chance: Softth 2.08 alpha.

 

Ok, it's alpha but for some guys here it seems to work. At least I got it to work, but again it's unusable for me.

 

My options: fullscreen, resolution 3820x1080, exports to the right.

 

First the render quality: Well, it's mediocre at best. The screen resolution is ok but it looks like an 1024x768 resoultion just scaled up to 1920x1080. It's all a bit blurry and there is no visible sign of AA.

 

Second: In windowed mode without softth all cockpit instrument exports works flawless. in fullscreen with softth the second screen is just plain black, i.e. none of the exported cockpit instruments is drawn.

 

My Softth-Config:

 

 

[main]

renderResolution=3840x1080

nonlocalFormat=RGB16D

keepComposition=1

smoothing=1

debugD3D=0

zClear=0

vsync=0

tripleBuffer=0

screenshotFormat=jpg

dllPathD3D9=auto

dllPathDXGI=auto

dllPathD3D11=auto

 

[overrides]

forceResolution=0

antialiasing=0

processAffinity=0

FOVForceHorizontal=0

FOVForceVertical=0

 

[debug]

compatibleIB=0

compatibleTex=0

compatibleVB=0

enableVBQuirk=1

 

[head_primary]

; borderA=0

; borderL=0

sourceRect=0,0,1920,1080

screenMode=1920x1080

 

[head_1]

; borderA=0

; borderL=0

devID=1

sourceRect=1920,0,1920,1080

destRect=0,0,1920,1080

transportResolution=1920x1080

transportMethod=local

noSync=0

fpsLimit=0

 

 

 

Any ideas?


Edited by Nereid

DCS:A-10C / DCS:Ka-50 / DCS:UH-1H / DCS:Mig21bis / DCS:P-51D / DCS:Mi-8MTV2 / DCS:Fw190D9 / DCS:Bf109K4 / DCS:C-101EB / DCS:L-39C / DCS:F-5E / DCS:Spitfire LF Mk. IX / DCS:AJS37

Link to comment
Share on other sites

Haven't used it in a while but under "overrides" try turning Antialiasing and force resolution on, change from 0 to 1.

[sIGPIC][/sIGPIC]

i7 10700K OC 5.1GHZ / 500GB SSD & 1TB M:2 & 4TB HDD / MSI Gaming MB / GTX 1080 / 32GB RAM / Win 10 / TrackIR 4 Pro / CH Pedals / TM Warthog

Link to comment
Share on other sites

Haven't used it in a while but under "overrides" try turning Antialiasing and force resolution on, change from 0 to 1.

 

This won't work also. If I set force resolution to 1, the launcher extends over both screens but don't accept any mouse clicks. I couldn't start a mission this way and I will have to kill the process with the task manager.

 

Again, softth won't work.

 

Well, perhaps the path for d3d9.dll is incorrect? I have copied it into "DCS World/bin".

DCS:A-10C / DCS:Ka-50 / DCS:UH-1H / DCS:Mig21bis / DCS:P-51D / DCS:Mi-8MTV2 / DCS:Fw190D9 / DCS:Bf109K4 / DCS:C-101EB / DCS:L-39C / DCS:F-5E / DCS:Spitfire LF Mk. IX / DCS:AJS37

Link to comment
Share on other sites

Your path is correct.

 

More info is needed to solve your issues .

 

Post a screen shot and your exact in-game settings, your used GPU and drivers.

 

Also please recheck this:

My options: fullscreen, resolution 3820x1080, exports to the right.
and than:

My Softth-Config:...

renderResolution=3840x1080

Please make it equal = use the same res as your in-game resolution.

 

 

use also "antialiasing=2" when above doesn't makes a change.

 

Further:

Did you use the windows-desktop screen magnification ? (Control Panel\All Control Panel Items\Display) - if yes : set it to 100% - so you have your desktop in native resolution and windows doesn't hands out false x/y coordinates to SoftTh. - this will solve the 'mouse doesn't fits' problem.


Edited by PeterP

Link to comment
Share on other sites

Your path is correct.

 

Also please recheck this:

and than:

Please make it equal = use the same res as your in-game resolution.

 

 

use also "antialiasing=2" when above doesn't makes a change.

 

 

Ah! This is an useful finding. :) I will try it asap.

 

PS: Done. 3920 was a type in the posting. All configs have 3940x1080, so they are equal. :(

 

I will look into the other advices...


Edited by Nereid

DCS:A-10C / DCS:Ka-50 / DCS:UH-1H / DCS:Mig21bis / DCS:P-51D / DCS:Mi-8MTV2 / DCS:Fw190D9 / DCS:Bf109K4 / DCS:C-101EB / DCS:L-39C / DCS:F-5E / DCS:Spitfire LF Mk. IX / DCS:AJS37

Link to comment
Share on other sites

Post a screen shot and your exact in-game settings, your used GPU and drivers.

 

I will do this, but not today.

 

PS: At least I can post some system specs in the next posting

 

 

use also "antialiasing=2" when above doesn't makes a change.

 

Further:

Did you use the windows-desktop screen magnification ? (Control Panel\All Control Panel Items\Display) - if yes : set it to 100% - so you have your desktop in native resolution and windows doesn't hands out false x/y coordinates to SoftTh. - this will solve the 'mouse doesn't fits' problem.

 

"destop screen magnification"? Well, I'm working in the IT (some kind of linux/db admin and developer) but I've never heard of this. But obviously there is always something new to learn. ;)

 

But: Im using Win-7 so there is no "destop screen magnification". I can change the dpi, but this is already at 100%.

 

Now I will give antialiasing=2 a try...

 

PS: won't work. with force res=0, again no AA; with force res=1 the launcher wont work.

 

Regarding the launcher I have to be more precise I think:

1. the launcher is centered over both screens.

2. the menu items at the right side are highlighted, when the mousepointer moves over them.

3. a single mouse click is consistently NOT detected.

4. several mouseclicks in a short interval ARE detected.

 

It's a bit late today, so we will have to delay this (exspecially the screenshots) a few days.


Edited by Nereid

DCS:A-10C / DCS:Ka-50 / DCS:UH-1H / DCS:Mig21bis / DCS:P-51D / DCS:Mi-8MTV2 / DCS:Fw190D9 / DCS:Bf109K4 / DCS:C-101EB / DCS:L-39C / DCS:F-5E / DCS:Spitfire LF Mk. IX / DCS:AJS37

Link to comment
Share on other sites

I will do this, but not today.

 

 

 

"destop screen magnification"? Well, I'm working in the IT (some kind of linux/db admin and developer) but I've never heard of this. But obviously there is always something new to learn. ;)

 

But: Im using Win-7 so there is no "deskot screen magnification". I can change the dpi, but this is already at 100%.

 

 

Well,I switched to a english dektop... so I can't tell you without a restart how it is called in German. - anyway - 'Desktop magnification' is just a term of my own that describes what is happening behind 'the curtain' - with the new WDM driver architecture you don't scale DPI any-more -

you are zooming your desktop - and Windows prevents to spawn windows at this 'unused' space - and scales the contend that contains DX and video down to your native res again. - This works not well with SoftTH because the mouse gets messed up and/or softth acts 'funny' or doesn't initialises at all.

 

And its actually called "Make it easier to read what's on your screen" ... (<< yes no joke! ;) ...formally know as DPI scaling)

:)

 

win7-bigger-screen-text-display-2.png

 

 

- anyway - we ruled this out and you got my point.

 

So lets see what happens after you made the other changes and/or provide more info.


Edited by PeterP

Link to comment
Share on other sites

Post a screen shot and your exact in-game settings, your used GPU and drivers.

 

System specs:

- Win-7, 8GM RAM

- GTX-560ti, driver: 320.18

 

Ingame-Config:

 

 

options =

{

["difficulty"] =

{

["fuel"] = false,

["easyRadar"] = false,

["miniHUD"] = false,

["birds"] = 60,

["optionsView"] = "optview_all",

["permitCrash"] = false,

["immortal"] = false,

["easyCommunication"] = false,

["easyFlight"] = false,

["radio"] = false,

["labels"] = false,

["map"] = true,

["cockpitLanguage"] = "english",

["units"] = "imperial",

["tips"] = true,

["reports"] = true,

["externalViews"] = true,

["iconsTheme"] = "nato",

["padlock"] = true,

["weapons"] = false,

["setGlobal"] = true,

["geffect"] = "realistic",

}, -- end of ["difficulty"]

["graphics"] =

{

["multiMonitorSetup"] = "helios",

["color"] = "32",

["preloadRadius"] = 150000,

["heatBlr"] = 1,

["scenes"] = "high",

["water"] = 1,

["fullScreen"] = true,

["disableAero"] = false,

["visibRange"] = "High",

["treesVisibility"] = 6000,

["aspect"] = 3.5555555555556,

["haze"] = 1,

["HDR"] = 0,

["TranspSSAA"] = false,

["textures"] = 2,

["cockpitShadows"] = true,

["shadows"] = 1,

["effects"] = 3,

["MSAA"] = 2,

["height"] = 1080,

["sync"] = false,

["shadowTree"] = false,

["civTraffic"] = "low",

["width"] = 3840,

["clutterMaxDistance"] = 0,

["lights"] = 2,

}, -- end of ["graphics"]

["plugins"] =

{

["CA"] =

{

["kompass_options"] = 1,

["ground_target_info"] = false,

["ground_aim_helper"] = false,

["ground_platform_shake"] = false,

["ground_automatic"] = false,

}, -- end of ["CA"]

["P-51D"] =

{

["assistance"] = 0,

["autoRudder"] = false,

}, -- end of ["P-51D"]

["UH-1H"] =

{

["altUHTrimmingMethod"] = true,

["autoPilot"] = false,

["weapTooltips"] = false,

["UHRudderTrimmer"] = false,

}, -- end of ["UH-1H"]

["Ka-50"] =

{

["altTrimmingMethod"] = true,

}, -- end of ["Ka-50"]

}, -- end of ["plugins"]

["views"] =

{

["cockpit"] =

{

["mirrors"] = true,

["reflections"] = false,

["russianHud"] = false,

["avionics"] = 0,

}, -- end of ["cockpit"]

}, -- end of ["views"]

["sound"] =

{

["world"] = 0,

["radioSpeech"] = true,

["cockpit"] = 0,

["volume"] = 0,

["headphones"] = 0,

["music"] = -15,

["subtitles"] = true,

["gui"] = 0,

}, -- end of ["sound"]

["miscellaneous"] =

{

["Coordinate_Display"] = "Lat Long",

["accidental_failures"] = true,

["headmove"] = false,

["force_feedback_enabled"] = false,

["f5_nearest_ac"] = true,

["f11_free_camera"] = true,

["synchronize_controls"] = false,

["f10_awacs"] = true,

}, -- end of ["miscellaneous"]

} -- end of options

 

 

 

Monitor-Setup (Helios.lua):

 

 

_ = function(p) return p; end;

name = _('Helios');

Description = 'Helios'

Viewports =

{

Center =

{

x = 0;

y = 0;

width = 1920;

height = 1080;

viewDx = 0;

viewDy = 0;

aspect = 1.77777777777777778;

}

}

 

RIGHT_MFCD =

{

x = 1920+1406;

y = 120;

width = 445;

height = 445;

}

 

LEFT_MFCD =

{

x = 1920+67;

y = 120;

width = 445;

height = 445;

}

 

CMSC_SCREEN =

{

x = 1920+856;

y = 141;

width = 230;

height = 49;

}

 

CMSP_SCREEN =

{

x = 1920+1075;

y = 190;

width = 270;

height = 70;

}

 

RWR =

{

x = 1920+600;

y = 161;

width = 175;

height = 175;

}

 

DIGITALCLOCK =

{

x = 1920+480;

y = 830;

width = 122;

height = 122;

}

 

UHF_FREQUENCY_STATUS =

{

x = 1920+635;

y = 565;

width = 120;

height = 30;

}

 

UHF_PRESET_CHANNEL =

{

x = 1920+748;

y = 477;

width = 30;

height = 30;

}

 

UHF_REPEATER =

{

x = 1920+656;

y = 695;

width = 110;

height = 30;

}

 

UIMainView = Viewports.Center

 

 

 

Softth.config (the right one this time):

 

 

[main]

renderResolution=3840x1080

nonlocalFormat=RGB16D

keepComposition=1

smoothing=1

debugD3D=0

zClear=0

vsync=0

tripleBuffer=0

screenshotFormat=jpg

dllPathD3D9=auto

dllPathDXGI=auto

dllPathD3D11=auto

 

[overrides]

forceResolution=1

antialiasing=2

processAffinity=0

FOVForceHorizontal=0

FOVForceVertical=0

 

[debug]

compatibleIB=0

compatibleTex=0

compatibleVB=0

enableVBQuirk=1

 

[head_primary]

; borderA=0

; borderL=0

sourceRect=0,0,1920,1080

screenMode=1920x1080

 

[head_1]

; borderA=0

; borderL=0

devID=1

sourceRect=1920,0,1920,1080

;destRect=0,0,1920,1080

transportResolution=1920x1080

transportMethod=local

noSync=0

fpsLimit=0

 

 

 

I will add screenshots in the next days.


Edited by Nereid

DCS:A-10C / DCS:Ka-50 / DCS:UH-1H / DCS:Mig21bis / DCS:P-51D / DCS:Mi-8MTV2 / DCS:Fw190D9 / DCS:Bf109K4 / DCS:C-101EB / DCS:L-39C / DCS:F-5E / DCS:Spitfire LF Mk. IX / DCS:AJS37

Link to comment
Share on other sites

BTW: Which files/mod/tool did you used to to enable the viewport rendering at the left monitor for the cockpit instruments ?

 

Does it work when you use a 3840x1020 windowed DCS setting ? (this should work without SofTH )

 

And make sure you use a aero-theme at windows level and have set "keepComposition=1" in Softth - if you don't , you wont be able to see Helios on a secondary screen while DCS is full-screen mode AFAIK.


Edited by PeterP

Link to comment
Share on other sites

BTW: Which files/mod/tool did you used to to enable the viewport rendering at the left monitor for the cockpit instruments ?

 

Does it work when you use a 3840x1020 windowed DCS setting ? (this should work without SofTH )

 

I'm using a mix of my own files and some included in the "Loz SM V2.1" profile for helios.

 

PS: But I'm exporting them to the RIGHT (!) monitor, not to the left one.

 

And yes, they work in windowed mode like a charm. But in 3840x1080.

DCS:A-10C / DCS:Ka-50 / DCS:UH-1H / DCS:Mig21bis / DCS:P-51D / DCS:Mi-8MTV2 / DCS:Fw190D9 / DCS:Bf109K4 / DCS:C-101EB / DCS:L-39C / DCS:F-5E / DCS:Spitfire LF Mk. IX / DCS:AJS37

Link to comment
Share on other sites

And make sure you use a aero-theme at windows level and have set "keepComposition=1" in Softth - if you don't , you wont be able to see Helios on a secondary screen while DCS is full-screen mode AFAIK.

 

Argh... now I'm notice this. I have set keepComposition=1 some day. Now its set to 0. Dunno why...

 

So another try... (but I dont think thats it, because there is nothing to see even with helios NOT running).

 

No... I have postet a wrong softth-config by mistake. It was just C&P from the editor; unfortunately there was an second config open, locatetd at C:/tmp/config.SoftTHconfig and I have choosen the wrong one. I will correct this in the last post ASAP.


Edited by Nereid

DCS:A-10C / DCS:Ka-50 / DCS:UH-1H / DCS:Mig21bis / DCS:P-51D / DCS:Mi-8MTV2 / DCS:Fw190D9 / DCS:Bf109K4 / DCS:C-101EB / DCS:L-39C / DCS:F-5E / DCS:Spitfire LF Mk. IX / DCS:AJS37

Link to comment
Share on other sites

Sorry - left was a Typo - I meant the right.

 

 

...

But in 3840x1080.

Please elaborate a little more - why the 'But' and in which res you want to run your secondary screen ? , as your SoftTh file also is set to 3840x1020 (as posted in #8 ) spilled in half equally on both screens and as determined by your 'monitorsetup.lua'.


Edited by PeterP

Link to comment
Share on other sites

Well,I switched to a english dektop... so I can't tell you without a restart how it is called in German. - anyway - 'Desktop magnification' is just a term of my own that describes what is happening behind 'the curtain' - with the new WDM driver architecture you don't scale DPI any-more -

 

And its actually called "Make it easier to read what's on your screen" ... (<< yes no joke! ;) ...formally know as DPI scaling)

:)

 

In german: "Die Lesbarkeit auf dem Bildschrim erleichtern." ;) I have never used this feature so far. And it is at 100%.

 

It's really a bit late today and I had a long day. Let's delay this a few days. I have checked the most obvios mistakes but din't found any at the moment.

 

At least there is an improvement. I have tried softth a few months ago and there was not even some kind of display - just a crash. Now at least I can see the "SoftTH" Screen on the right monitor, when DCS starts. Unfortunately it's black and the left monitor works with no AA, but perhaps we will resolve this too - but not today.

DCS:A-10C / DCS:Ka-50 / DCS:UH-1H / DCS:Mig21bis / DCS:P-51D / DCS:Mi-8MTV2 / DCS:Fw190D9 / DCS:Bf109K4 / DCS:C-101EB / DCS:L-39C / DCS:F-5E / DCS:Spitfire LF Mk. IX / DCS:AJS37

Link to comment
Share on other sites

Sorry - left was a Typo - I meant the right.

 

Please elaborate a little more - why the 'But' and in which res you want to run your secondary screen ? , as your SoftTh file also is set to 3840x1020 (as posted in #8 ) spilled in half equally on both screens and as determined by your 'monitorsetup.lua'.

 

"but", because you mentioned 3840x1020 and I'm using 3840x1080 (I have corrected the wrong config; that was my fault)

 

Both screen should be 1920x1080; so 3840x1080 ingame resolution. 1920x1080 for cockpit on the left screen; 1920x1080 for the helios/instrument screen to the right.

 

Perhaps it's the nvidia driver; I have checked the nvidia settings too, but didn't get a clue what to change so far.

 

I will test the newest driver until weekend. We will see... but there's only a little hope for improvement by installing a fresh driver.

 

PS: Switching to an old driver may be a problem. I had some issued with "kerbal space program" with an older driver. And other issues with Civ5 with some newer ones.


Edited by Nereid

DCS:A-10C / DCS:Ka-50 / DCS:UH-1H / DCS:Mig21bis / DCS:P-51D / DCS:Mi-8MTV2 / DCS:Fw190D9 / DCS:Bf109K4 / DCS:C-101EB / DCS:L-39C / DCS:F-5E / DCS:Spitfire LF Mk. IX / DCS:AJS37

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...