Jump to content

Blade comes off when doing auto-start


Milli
 Share

Recommended Posts

Hi

 

I'm new to the huey. Flew a few missions using the automatic start sequence, which worked fine. But for some reason, when I have tried it today, during the automatic start sequence, there is a loud bang and the blade ends up on the ground underneath the helicopter. The sequence keeps on going but I end up with just the rotor spinning round with no blade attached to it.

 

Any ideas what is happening? I'm touching nothing as the start sequence is active.

 

Regards,

Milli

Link to comment
Share on other sites

Thanks enigma, I think that is the problem from memory. I'm not at the DCS computer at the moment so can't try it. I'm using a Thrustmaster Warthog with the left throttle lever set as the throttle (for the moment) and i had it set at full throttle as I started the start-up sequence.

 

Regards,

Milli

Link to comment
Share on other sites

Thanks enigma, I think that is the problem from memory. I'm not at the DCS computer at the moment so can't try it. I'm using a Thrustmaster Warthog with the left throttle lever set as the throttle (for the moment) and i had it set at full throttle as I started the start-up sequence.

 

Regards,

Milli

 

I too use a Thrustmaster Warthog. I use the little gray wheel on the throttle quadrant as my official "throttle" for the Huey.

Link to comment
Share on other sites

Its the cyclic that's causing this whatever you do don't move it on the ground to erratically or aggressively as it seems to eject the rotor off the Huey.

Happened to me twice now upon landing and on the ground in a stationary position I have moved the cyclic in a clockwise and counter clockwise circle each time be it small circle but a little fast and pop of it went.

Eagles may soar high but weasel's don't get sucked into jet engines.

 

 

System Spec.

Monitors: Samsung 570DX & Rift CV1

Mobo: MSI Godlike gaming X-99A

CPU: Intel i7 5930K @ 3.50Ghz

RAM: 32gb

GPU: EVGA Nvidia GTX 980Ti VR Ready

Cooling: Predator 360

Power Supply: OCZ ZX Series 80 Plus Gold

Drives: Samsung SSD's 1tb, 500g plus others with OS Win10 64 bit

 

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...