Jump to content

Hosting Server : cannot select interface


sigzegv
 Share

Recommended Posts

Hello,

 

When I want to host a game with DCS, my server is never visible on the internet browser, and not reachable from direct connection.

 

On server's creation interface, I am stuck to network 127.0.0.1 ( internet or LAN ), and I think this is the main issue that prevents me to host a game.

(Game ports 10308 are already opened on my router.)

 

Does some knows I way to force/modify network's interface on DCS ?


Edited by sigzegv
Link to comment
Share on other sites

Some have resolved issues by opening up ports 10308-10309.

 

If you look at your ip from your network side it will be your network side IP that shows up- not your outside looking in ISP assigned IP. So make sure that is the IP that you are forwarding through (to your computer assigned address not the ISP assigned address.

 

 

You won't be able to see your own browser in the Internet section no matter what type of game type you select- you are only visible to yourself in LAN.

"ENO"

Type in anger and you will make the greatest post you will ever regret.

 

"Sweetest's" Military Aviation Art

Link to comment
Share on other sites

I tried to open ports up to 10309 but that didn't solve the issue.

 

But I don't really understand your answer, how could my port-forwarding fix the IP binding for server ? If I had firewall or routing issues, my server wouldn't be visible on the browser, but I should be able anyway to see my 192.168.xx.xx IP on the interface selector, right ?

Link to comment
Share on other sites

The port forwarding suggestion wasn't meant to correct your IP issue, it was meant to possibly correct your server not being visible.

 

I have no idea what IP 127.0.0.1- I don't know where you're from so I don't know the stock IP assigned by a router versus what the common IP is from your ISP. But yes, in theory I'd expect that it would be 192.168.0.X provided it is going through the router. That's the problem with the forums is frequently neither side gives enough information.

 

In addition, some routers given out by ISPs are "bricked" in a sense that it is simply an input for a cable signal that is distributed directly to either another router or (gasp) directly into your computer. This would explain why it is that your IP is coming up as your external IP as opposed to an internal. I doubt this is the case since you were able to port forward.

 

But on that note- what IP did you port forward to? Your IP should be assigned by the router and I'm going to assume (since you seem to have an idea about such things) that you have port forwarded your 192.168.0.X address as opposed to your external one.

 

At this point I'd be inclined to delete the DCS folder in the "saved games" folder- a lot of the config data for the network is saved therein. When you restart the game, it will "rebuild" this folder.


Edited by ENO

"ENO"

Type in anger and you will make the greatest post you will ever regret.

 

"Sweetest's" Military Aviation Art

Link to comment
Share on other sites

The 127.0.0.1 is an internal IP on a computer, it is never binded to a network card, and it's not possible to route any port on such IP from a router.

 

I tried to delete the DCS folder in saved games, doesn't changed my issue. Still looking for an idea.


Edited by sigzegv
Link to comment
Share on other sites

Hmmm... well on a hunch I went into the install directory and hunted down the server.lua in both script and net and couldn't find a default entry either so I won't bother suggesting looking there. A couple other basics that you may have covered but I'm going to hit anyway-

 

Where have you installed the game? Have you tried a fresh install into the default directory off a fresh download? Also, can you confirm it is the latest version? Have you tried the repair feature? Installed the redist C++ and DX9 when prompted? Which modules do you have installed?

 

I'm not sure if you can even get into the new server page without being logged in but I'm assuming you're logged into the master server properly. (Talking out loud here a bit now)

 

To be honest, as much as I want to see you through this hiccup I think c0ff is "the guy" who is going to be able to pinpoint this issue and hopefully offer some suggestions. He's frequently in the shadows hunting around for people with network related issues and is quite helpful but may be MIA over the weekend. Hopefully Monday he can offer some input.

 

I'm sorry my problem solving skills are VERY basic- but quite frequently it's a very basic problem that creates the maximum issue because they're oftren overlooked.

 

I've had to get through a few server problems of my own in the past but yours is truly unique.

"ENO"

Type in anger and you will make the greatest post you will ever regret.

 

"Sweetest's" Military Aviation Art

Link to comment
Share on other sites

Well I have not yet tried to reinstall the game because it seems too much painfull. I actually have the latest version, but we both know any new patch in DCS can cause more problems than fixes :D

 

I tried the repair feature without success and I am already up to date with redist packages...

 

I'll try to catch c0ff guy ;)

Link to comment
Share on other sites

Exit DCS and change this line:

interface = "192.168.1.101",

to

interface = "*",

 

how can this trick be effective ? I tried on initial's post issue to change this value to my network's card IP ( 192.xxx ), but when entering multiplayer mode, it's still locked to 127.0.0.1 and network.cfg file is then overwriten by 127.0.0.1

Link to comment
Share on other sites

Exit DCS and change this line:

interface = "192.168.1.101",

to

interface = "*",

 

c0ff Thank you for your answer! Problem SOLVED!!! My provider simply blocked port 10308. Now my server ON!!!


Edited by airwar
Link to comment
Share on other sites

  • 1 month later...
Exit DCS and change this line:

interface = "192.168.1.101",

to

interface = "*",

 

After updated my DCSW to 1.2.6 I`ve lost possibility to create on-line server, but as client I could connect to any on-line server. Trying to resolve the problem, I`ve tried a lot of tricks. I`ve reinstalled and finally uninstalled all AV&FW soft. Then reinstalled DCSW & modules - nothing. As it turned out a network.cfg was "guilty" due to being not updated by game. When my LAN IP address changed, eg. from 192.168.0.2 to 192.168.0.5, @ network.cfg there were still old (..02) value. Manually edited network.cfg solved my problem, but in my opinion it is some kind of bug..

 

Best,

qrdl

Boski Logos

Link to comment
Share on other sites

Server Can Not Be Seen

 

After updated my DCSW to 1.2.6 I`ve lost possibility to create on-line server, but as client I could connect to any on-line server. Trying to resolve the problem, I`ve tried a lot of tricks. I`ve reinstalled and finally uninstalled all AV&FW soft. Then reinstalled DCSW & modules - nothing. As it turned out a network.cfg was "guilty" due to being not updated by game. When my LAN IP address changed, eg. from 192.168.0.2 to 192.168.0.5, @ network.cfg there were still old (..02) value. Manually edited network.cfg solved my problem, but in my opinion it is some kind of bug..

 

Best,

qrdl[/QU

 

I was wondering if anybody could help me with this. I'm having the same issue of nobody being able to see my server. In my network.cfg file there's no portion for interface = "IPADDRESSHERE" and I'm sure there's something wrong or weird that's not allowing me to host a server that'll appear on the browser. Any and all help would be greatly appreciated. My network.cfg file is attached. Thank you for your time.

network.cfg

Link to comment
Share on other sites

I'm having a similar problem—the UI shows my external IP address in the Interface field, I can't change it, deleting my 1.2.5 network.cfg yielded a network.cfg with no interface entry, and adding an interface entry by hand, either with my local IP address or * as c0ff suggested, does nothing. I can still connect fine as a client. Ports are forwarded properly.

 

Any ideas?

Black Shark, Harrier, and Hornet pilot

Many Words - Serial Fiction | Ka-50 Employment Guide | Ka-50 Avionics Cheat Sheet | Multiplayer Shooting Range Mission

Link to comment
Share on other sites

Did you actually open up your server?

 

If you delete the entry and then just do a repair or start the program it will regenerate the file but you need to start your server in order to populate the information therein.

 

Try that and let us know what happens.

"ENO"

Type in anger and you will make the greatest post you will ever regret.

 

"Sweetest's" Military Aviation Art

Link to comment
Share on other sites

To be clear, the problem isn't that the server doesn't show up, or that it can't be connected to-- my friend can see my server and connect to it, and I see the diagnostic information when he connects, but he immediately gets "connection interrupted". The only things which have changed are 1.2.6 and the interface setting being broken.

 

Are there any network config files to delete besides network.cfg and .bault under Saved Games/DCS/Config?

Black Shark, Harrier, and Hornet pilot

Many Words - Serial Fiction | Ka-50 Employment Guide | Ka-50 Avionics Cheat Sheet | Multiplayer Shooting Range Mission

Link to comment
Share on other sites

I tried a repair install and resetting my Saved Games/DCS folder. Neither fixed it; I still can't change the interface in DCS away from my external IP, and hand-edits to network.cfg still don't do anything.

Black Shark, Harrier, and Hornet pilot

Many Words - Serial Fiction | Ka-50 Employment Guide | Ka-50 Avionics Cheat Sheet | Multiplayer Shooting Range Mission

Link to comment
Share on other sites

  • 2 weeks later...

Has anybody had any luck with the problem above? I having the exact same issue. Only since the new update, i cannot select other interfaces when trying to host a server.

 

Normally i just use Tunngle and select the tunngle ip usually 7.whatever. Before the update i could select either this or my normal ip (which has never worked for hosting hence tunngle).

 

EDIT: I have also tried the mentioned fixes, but no luck.

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...