Jump to content

DCS will not start


Blade_meister
 Share

Recommended Posts

I have a fresh install of Windows 7 64bit. All updates are current. I installed DCS World to C:\Flight_Sims\Eagle Dynamics\DCS World and upon attempting to start it, I always get the error, " DCS has stopped working, Windows is checking for a solution to the problem." DCS has never started period. I have bought all the Modules . I have not installed any of the Modules because I cannot get DCS working so far. I am attaching my log files. I have tried the noteworthy crash fix(first post in Game Crash Thread), but it did not solve this problem. I am brand new to Windows 7 (a diehard XP fan, just now converting), so your patience will be appreciated if I seem unfamiliar with Win 7 systems and operations. I am learning everyday.

System: Windows 7 Home Premium : 64 bit Service pack 1: Updates Current

AMD PhenomIIX4 965BE 3.40GHz

Corsair Vengeance Mem 8GB 1600 DDR3

Nvidia GTX570FTW 1.5Gb DDR5 Driver 311.06

SoundBlaster XFi : Current Drivers

Sea Gate HD 1TB 7200rpm

Corsiar 750watt PS

Directx 11 , I ran the C++ and the Directx 9.0c install that DCS provided

 

I would appreciate any help you may give me.:helpsmilie:

 

Sincerely S! Blade<><

Logs.zip

Link to comment
Share on other sites

Any reason why you're not installing to the default directory? Try moving the file out of "flight sims" and into C/ program Files/Eagle Dynamics/DCS World. I'm wondering if you're running it in the 32 bit environment (I'm guessing a little bit but my FIRST action if I were in your shoes would be to move it or reinstall it into the default directory)

"ENO"

Type in anger and you will make the greatest post you will ever regret.

 

"Sweetest's" Military Aviation Art

Link to comment
Share on other sites

Thanks for your input ENO, I uninstalled all of DCS and reinstalled it in its default folder path, but no joy. I am getting the same error. I am just going to have to do some more reading. I submitted a ticket last week with my logs and I haven't heard anything yet. There is nothing worse than chomping at the bit with a copy of each of the Modules waiting to install, but I know I must get DCS working first. I will figure it out.

 

S!Blade<><

Link to comment
Share on other sites

Eh Blade... I'd like to keep trying here.

 

First of all- which versions of each module did you install. Here is the problem recently:

 

They put out a patch last week and to keep a long story short they had an issue with it and then returned it to another version. I'm speedballing a bit here but I'm wondering if through that change up you have somehow downloaded different versions of multiple modules.

 

So I will ask you to verify which version you downloaded and installed and that all are similar. They should be 1.2.4.12913.

"ENO"

Type in anger and you will make the greatest post you will ever regret.

 

"Sweetest's" Military Aviation Art

Link to comment
Share on other sites

First off, thank you both, ENO and Terminal Meltdown for trying to help me. I have tried all that you have suggested but to no joy. I did verify versions and they are correct. I have only tried to install DCS World and get it working. I have never tried to install any of the Modules. I updated my Nvidia driver to the current WHQL signed driver. I honestly believe it has to do with how I installed Windows 7. I installed Windows 7 as an Administrator with a password and my friend(who is my PC building adviser) has said I shouldn't have done that. He is advising me to reformat my drive and reinstall Windows 7 and when it comes to the Admin and password screen, to skip it or cancel it and not install as an Admin. I have tried reading about the Admin passwords and permissions, but it is a bit to technical for me. I don't really understand the flow of how a Windows 7 Admin works. Any tips or advice here would be welcome, as I don't really know what is best to do at this stage. Reinstalling Win 7 is no big deal because I have virtually nothing to lose other than a few hours that I have invested to get this far. Again, any advice would be welcome from someone knowledgeable about Win7.:helpsmilie::lol:

 

S! Blade<><


Edited by Blade_meister
Link to comment
Share on other sites

If that was the problem running it as Admin should work. You can always remove the security on that folder. Right click and go in the security tab, but I have my doubts that it will fix it.

 

Installing the way you did does create a security structure that can cause problems, but it can also save you from other problems, like unwanted installs.

 

Are you sure you have the entire 5 file 5.73GB install package?

 

Sorry for asking the obvious, but the fact that you are crashing just trying to load the startup screen does seem quite strange.


Edited by Paganus
more
Link to comment
Share on other sites

This bit at the bottom of your ME log is something...

 

 
00000.814 ERROR   DXRENDERER: Create device failed, D3DERR_INVALIDCALL
00000.814 UNKNOWN main: GUI Error: [string ".\MissionEditor\MissionEditor.lua"]:220: renderer->initialize failed
GUI debug.traceback: stack traceback:
[C]: ?
[C]: in function 'CreateEdgeRender'
[string ".\MissionEditor\MissionEditor.lua"]:220: in function 'createGUI'
[string ".\MissionEditor\MissionEditor.lua"]:300: in main chunk
stack traceback:
[C]: ?
[C]: in function 'CreateEdgeRender'
[string ".\MissionEditor\MissionEditor.lua"]:220: in function 'createGUI'
[string ".\MissionEditor\MissionEditor.lua"]:300: in main chunk
00000.814 ALERT   LUACOMMON: Error: GUI Error: [string ".\MissionEditor\MissionEditor.lua"]:220: renderer->initialize failed
GUI debug.traceback: stack traceback:
[C]: ?
[C]: in function 'CreateEdgeRender'
[string ".\MissionEditor\MissionEditor.lua"]:220: in function 'createGUI'
[string ".\MissionEditor\MissionEditor.lua"]:300: in main chunk

 

Can you provide a dxdiag?


Edited by Paganus
more
Link to comment
Share on other sites

Next natural step is a "repair DCS World."

 

Also we should have asked before- do you have any multi monitor support? That invites a host of running issues that a person wouldn't expect- fortunately that are well known and easy to fix.

"ENO"

Type in anger and you will make the greatest post you will ever regret.

 

"Sweetest's" Military Aviation Art

Link to comment
Share on other sites

[/code]Can you provide a dxdiag?

 

Here it is Pagnus. I looked at it but nothing jumped out at me as being wrong? Thanks again to those of you spending your time trying to help me figure this out. ENO , I tried the repair option and it ran successfully, it also automatically ran the update and still no joy here. I honestly think it is rooted in windows security some how.

 

S! Blade

DxDiag.txt


Edited by Blade_meister
Link to comment
Share on other sites

ENO, I have a Single monitor system, so that is not a problem. I installed BS1 last night and it default installed to

"C:\Program Files (x86)\Eagle Dynamics\Ka-50\bin\stable\Launcher.exe" --console

BS1 runs fine, it executes all operation perfectly.

 

vs. DCS installing default to

"C:\Program Files\Eagle Dynamics\DCS World\bin\DCS_updater.exe"

 

Would installing DCS to the Program Files(x86) folder work, or is the Program Files(x86) folder for older 32 bit programs, or 32 bit mode only?

 

I am including 2 pictures of the Securities Tab from Properties of my DCS shortcut. I seem to have a lot of Group or user names. Can anyone confirm whether they do or do not have similar listing? The other thing i noticed is that the Administrator permissions are all light grey check marks vs the bright blue check marks in my other photo. Not sure if this is relevant. At this point I am strongly considering reformatting and reinstalling Win 7 and skipping the Admin setup during that installation. The only thing rather sad about this whole episode is that I submitted a ticket to ED on the 29th of last month (23334) and it has not even been acknowledged in any way. I am not sure how the ticket system works with ED, but I would at least expect some sort of auto reply. Does anyone have any additional info on how to get ED to respond? :helpsmilie: I want to :pilotfly:

 

S!Blade<><

Untitled.thumb.png.fa4896120ee68df91997db4863529842.png

Untitled1.thumb.png.486dca18ff3a3e01316186abc206ae88.png

Link to comment
Share on other sites

make sure your Visual C++ Versions are all up to date.

 

Make sure your DirectX 9.0C Runtimes are all up to date.

 

Make sure your GPU Drivers are up to date.

Windows 10 Pro, Ryzen 2700X @ 4.6Ghz, 32GB DDR4-3200 GSkill,

X470 Taichi Ultimate, 2x R7970 Lightnings Crossfired @ 1.1/6.0GHz,

3x ASUS VS248HP + Hanns·G HZ201HPB + Oculus HMD,

Thrustmaster Warthog HOTAS + MFDs, CH Fighterstick+Pro Throttle+Pro Pedals

Link to comment
Share on other sites

SkateZilla , I ran the Visual C++ and the Directx versions that were included with the DCS install. I am not sure how to check that they are up to date, specifically the Directx run times? I have installed the latest WHQL signed Nvidia driver 320.18 for my GTX570FTW from Nvidia. I have just re-downloaded DCS_World_1.2.4.12913_186 , all 5 files and I will try to uninstall and reinstall later tonight. I have Directx version 11, but as I said I installed both Directx 9.0c and Visuall C++ from the download at the end of the DCS World install. I am still looking for any tips or advice before I do a reformat and reinstall of Windows 7 tomorrow.

 

S!Blade<><

Link to comment
Share on other sites

Wow, I am amazed. I have posted in the places on this Forum that seem to be for technical help and submitted a ticket (23334) on 6/29/13, and still no one from ED has acknowledged me in anyway. I have to say, I do appreciate those that have tried to help out here, but this is possibly the poorest Customer Service I have ever experienced. I am merely trying to get the Free To Fly DCS World working before I install all of the other Modules(recently purchased them all), but to no avail . It seems the ticket system is a good idea, but 22 days later, after no return correspondence I am no wiser about this DCS World non start problem than I was at the beginning. DXRENDERER: Create device failed, D3DERR_INVALIDCALL . I would have to say that this seems to be the root of my problem, but after checking all Dx(9.0c , 11) , C++, Nvidia Drivers are up to date, I am still at an impasse as to what to do? I installed BS1 and ran the 2 patches and it works just fine. Not sure where to turn here?

 

Edit: I have now been contacted through the ticket system and am hopefully on the way to resolving this issue. Thank you EtherealN (Daniel Agorander) for your professional assistance in this matter.

Blade<>< AKA Drew

me.zip


Edited by Blade_meister
Link to comment
Share on other sites

  • 2 weeks later...

Ok, well after a week of no contact, after my initial one and only contact by Ed in which they asked for my logs and asked me to try updating C++ and Directx , which I did and provided to no avail, I am back to asking the community for help. Ed is either to busy to help me or runs the most incapable inept ticket (23334) customer service system that exists on this planet. After an initial contact by EtherealN (Daniel Agorander) at 20.07.201, whom was very curtious and asked me to try the 2 procedures listed above and provide my logs(which i did), i have not heard a word back from him since.

I have taken it upon myself to completely format my drive and reinstall Win 7 Home Premium as a non administrator to make sure that is not the problem. After completing all windows updates and checking my DxDiag and and even flashing my Bios to the latest Asus Bios, Nvidia current, Sound Blaster current, I installed DCS and the provided Directx 9.0c and C++ and i still get DCS Has Stopped working and the exact same errors i have had since the beginning. I am downloading the Bit Torrent version of DCS and I will try to install that tonight. Short of someone having some way to actually get ED to look at my problem in some detail, I am at an impasse as to what to do? I have used Ed products for years and no problems, but I am closing in on a request to flat out ask for a total refund for the purchase of all the modules I just purchased during the sale because I cannot even get DCS to work, so i have not even tried installing one of the modules. Please understand that I am not injecting any attitude in this post, but I am a bit frustrated with the Customer Service response as it has been a month now and I have only received the most basic problem solving steps which do not work to resolve this problem. Any constructive help would be appreciated.

 

Blade<><:helpsmilie:

Link to comment
Share on other sites

your dxdiag:

---------------

Display Devices

---------------

Card name: NVIDIA GeForce GTX 570

Manufacturer: NVIDIA

Chip type: GeForce GTX 570

DAC type: Integrated RAMDAC

Device Key: Enum\PCI\VEN_10DE&DEV_1081&SUBSYS_15703842&REV_A1

Display Memory: 4049 MB

Dedicated Memory: 1233 MB

Shared Memory: 2815 MB

Current Mode: 1776 x 1000 (32 bit) (60Hz)

Monitor Name: Generic PnP Monitor

Monitor Model: VW26L HDTV20F

Monitor Id: VIZ0041

Native Mode: 1360 x 768(p) (60.015Hz)

 

Can you please tell in which exact res you try to run DCS and in which res your desktop is running?

Link to comment
Share on other sites

First, thank you for your time PeterP. My desktop is set through Nvidia control panel and is a custom resolution of 1776 x 1000 , which i created in Nvidia Control Panel. It is tested by Nvidia and it works with my GTX570. I run ROF and BS1 1.02 with this resolution and they both work just fine. I am curious as to one problem i have with them. ---> I have to run either game in a non full window mode to get the graphics(resolution?) to appear correct. In full window mode the graphics look grainy and not right. I am open to any info as to how this might be a problem? I am using a 26" Vizio (60Hz) Flat Screen TV as a monitor, connect to my GTX570 with a HDMI cable. I am not a wizard at knowing what limitations or problems go with using a non native(I assume by what you just pointed out in my Dxdiag file) resolution. Any info or advice or hopefully instructions are very welcome. Again thanks for your time.

 

Blade<><

 

P.s. DCS has never started so i have never set a resolution. The config file structure has changed and I do not have a config file in my saved games/DCS folder yet, so as far as i know I have no way to tell DCS what resolution to start in and this may very well be the problem? Just guessing here ?

P.s.s I have to leave for a few hours, but i will be back around 9:00p.m.(Gmt -5) and i will try to reinstall the Bit Torrent download i have now.


Edited by Blade_meister
Link to comment
Share on other sites

Ok. I changed my desktop resolution to 1360 x 768 which is native. Now DCS World will start. I have gone into saved games/DCS/Config/options.lua and changed the resolution to 1776 x 1000 and full screen false. Everything is working good :pilotfly: except one thing:(. On the actual screen where it shows the mission details, the actual launch buttons are off the screen(not showing) and I can not click them with the mouse. Does anyone know if this can be re-sized by editing a file ? I can just push Pause/Break for now, but it would be nice to correct this. I attached a pic so you can see what i am talking about. Thanks for any help in advance.

 

S!Blade<><

DCS_Screen.thumb.png.0e1c65463dd6ac49cfcb9481328c07d4.png

Link to comment
Share on other sites

Please use only the native res in DCS- that is 1360x768. And don't do it by editing the options.lua. Your #1 way to do it is via the launcher option screen.

 

 

And I'm a little astonished that you never before tried running a smaller windowed res yourself - just to see if DCS starts at a 'low-level' setting and to rule out internal GPU/Driver incompatibilities.

I highly recommend to upgrade to a higher Res monitor instead of using scaled up Resolutions that are not fully supported/and or forced by a driver customisation.

 

- Edit -

My conclusion:

Your crash is caused by a incompatibility of the customised GPU resolution timings and your TV.

It's not in the responsibility of ED to fix this.

And I can't be much off support any more in this , as I never tried seriously to run a TV on my PC as monitor and so I'm very inexperienced in this...

But this is what I know: This kind of combinations are a can of worms - as you have to fiddle around with under/over-scan settings that are just a workaround and never give a really crisp image.

 

-whatever-

 

Happy gaming!


Edited by PeterP

Link to comment
Share on other sites

Please use only the native res in DCS- that is 1360x768. And don't do it by editing the options.lua. Your #1 way to do it is via the launcher option screen.

 

 

And I'm a little astonished that you never before tried running a smaller windowed res yourself - just to see if DCS starts at a 'low-level' setting and to rule out internal GPU/Driver incompatibilities.

I highly recommend to upgrade to a higher Res monitor instead of using scaled up Resolutions that are not fully supported/and or forced by a driver customisation.

 

- Edit -

My conclusion:

Your crash is caused by a incompatibility of the customised GPU resolution timings and your TV.

It's not in the responsibility of ED to fix this.

And I can't be much off support any more in this , as I never tried seriously to run a TV on my PC as monitor and so I'm very inexperienced in this...

But this is what I know: This kind of combinations are a can of worms - as you have to fiddle around with under/over-scan settings that are just a workaround and never give a really crisp image.

 

-whatever-

 

Happy gaming!

 

Just wanted to say thanks again for posting that pic of my Dx diag test as that is what spurred me to try the native resolution. As far as the rest of your comments.

1. Don't be astonished, this is a DCS World specific problem, so uncommon that I never thought to try it. Ed does need to look into this because I have been running tweaked resolutions since back in the Navalogic Mig29 days, Flanker, Lock on, FC 1 & 2, BS1 , IL2 - IL2 1946, Falcon - Falcon AF, ROF , and never once had a Sim, or any of the numerous FPS I play, not start because of a Custom Desktop Resolution. There is no reason DCS shouldn't have started with my resolution, even if it looked bad, it should have started. They should at the least put a supported resolutions list with the game requirements.

2. Editing the options.lua(older ED graphics.cfg) is the only way to have some resolutions work in most ED Sims, which I have never had a problem with(in all ED Sims) in the past.

3. If I had the money for a high end Monitor right now I would buy one, but I don't. I have been using this 1080pi Tv for at least 4 years with no problems. I have compared my Screens(tweaked by me) to my friends expensive monitor and I can not see a noticeable difference. Of course without you being here and actually seeing the picture I get , with good frame rates(35+), you probably wouldn't believe me if I say it looks as good as any gaming monitor I have seen in action. Maybe I am naive, but I believe I have an excellent rig and I quite enjoy tweaking it to get the best picture I can out of it.

I have inserted no attitude in this post, please don't inject any, we merely come at PC gaming from 2 different camps.

And ED Customer Support ( EtherealN ), I have to be honest and tell you that the support I received was much to slow and basic(over 29 days from submitting From Blade at 29.06.2013 ) and the one acknowledgement suggested nothing more than reinstall Directx 9.0c and C++. After trying what you asked and submitting the files I was asked for(From Blade at 20.07.2013), I have not heard a word back from support. It is what it is, that is very poor support by any standard, and Ed needs to look into reorganizing Customer support into something that actually communicates and helps CUSTOMERS. While I have always enjoyed ED products(all Flight Sims since Flanker2.0) and the fascinating recreation of Military Equipment and Graphical presentation , some of the best in my opinion, I hope they get Customer Service reconstructed and actually help Customers with problems, or there might not be an ED period . Sorry if I have offended anyone, but I am reading Posts and Letters to the ED CEO of poor Customer(6 months of unresolved authentication of Modules after an ED update) Service in these Forums. The Good news is, that with some intuitive thought and a conscience effort, ED Customer Service can only get better.

 

S!Blade<><

 

P.S. Here are 3 pics. Tell me which one or 2 or all 3 are 1776x1000, or maybe none are, and which one(s) are Native 1368x768? One is from FC2, and the other two are from DCS last night. I just want to see if anyone sees the difference between the 2 resolutions?

Screen_130801_001313.thumb.png.af53c309a69bc0113e4fcd217c0a897b.png

ScreenShot_1886.thumb.png.74d60254655da0aaffb6beb42262e3ef.png

Screen_130801_015747.thumb.png.0a30a033be5872f72b371629b31a92c0.png


Edited by GGTharos
Link to comment
Share on other sites

Ok. I changed my desktop resolution to 1360 x 768 which is native. Now DCS World will start. I have gone into saved games/DCS/Config/options.lua and changed the resolution to 1776 x 1000 and full screen false. Everything is working good :pilotfly: except one thing:(. On the actual screen where it shows the mission details, the actual launch buttons are off the screen(not showing) and I can not click them with the mouse. Does anyone know if this can be re-sized by editing a file ? I can just push Pause/Break for now, but it would be nice to correct this. I attached a pic so you can see what i am talking about. Thanks for any help in advance.

 

S!Blade<><

Dunno why you'd run the Horizontal resolution 416px wider than you screen.....

 

But...

 

Restrain the GUI using the monitorsetup LUA, Copy and Paste one of the 2 codes i attached below

(i'd go with th 720P one first, since it's actually smaller than and centered to your screen)

 

Save as windowed.lua, put in your /Config/MonitorSetup/ Folder

 

Boot DCS, Goto Options, under Monitor Setup Choose "Windowed Corrected UI"

hit Ok, and go.

 

So:

For 720P Top Centered UI

_ = function(p) return p; end;
name = _('Windowed Corrected UI');
Description = 'Windowed w/ Corrected UI'
Viewports =
{
Center =
{
x = 0;
y = 0;
width = screen.width;
height = screen.height;
viewDx = 0;
viewDy = 0;
aspect = screen.aspect;
}
}

Gui =
{
x = 248;
y = 0;
width = 1280;
height = 720;
}

UIMainView = Gui

 

 

 

For Full Screen UI

_ = function(p) return p; end;
name = _('Windowed Corrected UI');
Description = 'Windowed w/ Corrected UI'
Viewports =
{
Center =
{
x = 0;
y = 0;
width = screen.width;
height = screen.height;
viewDx = 0;
viewDy = 0;
aspect = screen.aspect;
}
}

Gui =
{
x = 0;
y = 0;
width = 1776;
height = 1000;
}

UIMainView = Gui

 

 

 

Screenshots Attached:

restrained_gui.thumb.jpg.6ee746659174ac13ed534f39cb6e92af.jpg

restrained_gui-2.thumb.jpg.579465796a2831d73cc3eb86b0b1be1b.jpg


Edited by SkateZilla

Windows 10 Pro, Ryzen 2700X @ 4.6Ghz, 32GB DDR4-3200 GSkill,

X470 Taichi Ultimate, 2x R7970 Lightnings Crossfired @ 1.1/6.0GHz,

3x ASUS VS248HP + Hanns·G HZ201HPB + Oculus HMD,

Thrustmaster Warthog HOTAS + MFDs, CH Fighterstick+Pro Throttle+Pro Pedals

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...