Jump to content

Rudder Pedal Brakes


Johnpilot
 Share

Recommended Posts

They are driving me crazy with the Saitek Pro Pedals. I cannot seem to get them calibrated correctly, and the last flight I came out of the revetment and I began to turn right with the brakes. When I released it the bird kept turning right into the wall and then I was stuck. Had to start over as you can't back it up:).

 

I turned off the brakes axis and I can fly and land just fine by using only the wheel brakes, BUT I don;t always know if I have them on or off. Is there some kind of "cue" that the wheel brakes are set? I am thinking like in FS2004 and FSX you get the text line saying "Brakes". Thanks.

 

John

Link to comment
Share on other sites

RCtrl + Enter will turn on a little red indicator of your controls (stick, throttle, rudder and brakes).

ASUS ROG Maximus VIII Hero, i7-6700K, Noctua NH-D14 Cooler, Crucial 32GB DDR4 2133, Samsung 950 Pro NVMe 256GB, Samsung EVO 250GB & 500GB SSD, 2TB Caviar Black, Zotac GTX 1080 AMP! Extreme 8GB, Corsair HX1000i, Phillips BDM4065UC 40" 4k monitor, VX2258 TouchScreen, TIR 5 w/ProClip, TM Warthog, VKB Gladiator Pro, Saitek X56, et. al., MFG Crosswind Pedals #1199, VolairSim Pit, Rift CV1 :thumbup:

Link to comment
Share on other sites

I'm sorry I can't speak from experience, I have a set of CH pedals myself. Never given me problems, but I've never seen anyone say this was happening with their Saitek pedals either.

 

Which module are you trying this in? If it's P-51D, taxiing is tough period. There's probably nothing wrong with your setup.

 

Otherwise, the FC3 stuff doesn't have pedal toe brakes incorporated (yet, at least), and I haven't spent much time with the Su-25T, but there could be something funny with how the toe brakes work.

Link to comment
Share on other sites

If PeterP suggestions doens't work then try and map the common brake to one of the pedal brakes and see if this works. If it does then map each pedals.

 

I have previously tried to bypass the Saitek controller board and send the potentiometers directly to my Leo Bodnar BU0836X card. I was very suprised to find out that a simple potentiometer hooked up to the BU0836X card and mapped in DCS for right or left wheel brake acted in the exact same way as the when using the Saitek pedals. Setup is only done in DCS.

When setting up the same potentiometer and same analogue input channel for anything else than wheel brakes it worked perfectly. As soon as I mapped the same input to right or left wheel brake it was misbehaving again.

 

Eventually I tried to map left toe brake on the Saitek pedals to wheel brake (common). There the input was fine as smooth. Then I tried mapping right toe brake on the Saitek to right wheel brake in DCS..... Surprice now that was working perfectly. I then remapped left toe brake on Saitke to left wheel brake in DCS....now it worked perfectly.

 

Having said so it didn't work for NoCarrier but it may be worth a shot if everthing else fails.

 

Cheers

Hans

Link to comment
Share on other sites

DXTweak shows that everything is working OK. When I use RCRTL + ENTER in the sim I see some "wierd" behavior with the pedal brakes. They don't always seem to return to zero when released. I will continue to mess around to see if I can see what is going on.

 

John

Link to comment
Share on other sites

DXTweak shows that everything is working OK. When I use RCRTL + ENTER in the sim I see some "wierd" behavior with the pedal brakes. They don't always seem to return to zero when released. I will continue to mess around to see if I can see what is going on.

 

John

 

I would like you to reset the calibration and/or have a look at this post and note the deadzone setting at top and end of each break axis:

 

 

Mower,

Just for you.

(But I think it will come handy to show it others too)

 

This is how I set-up my Saitek rudder:

 

 

I set the Deadzones also at the Toe-brakes So there is no input when they snap not back to absolute zero.

And I add also some at the upper end , so I don't have to press with 100% strength to get them to send 100%. - just a security measure to not overstress them by daily use.

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...