Jump to content

Autoupdate / Repair Installation broken!?


Flagrum
 Share

Recommended Posts

Whenever I start the autoupdater atm, it says nothing - i.e. no update available. But when I try a repair installation, I am told that there is an update available. I think, this is the same problem, this fellow encounters: http://forums.eagle.ru/showthread.php?t=108519

 

Anyways, this is the log file generated by such an attempt:

 

00000.000 INFO   : === MiniLog opened UTC 2013-06-20 18:35:30
00000.426 INFO   : Current version: 1.2.4.12913.167
00000.426 INFO   : Arch: x86_64
00000.426 INFO   : Lang: EN
00000.426 INFO   : Installed modules: A-10C,WORLD,KA-50bs1,P-51D,CA,FC3,UH-1H
00000.426 INFO   : Checking for updates...
00000.555 INFO   : Repair is available.
00000.811 INFO   : Actualizing local cache...
00001.282 INFO   : Downloading update: version=1.2.4.12913.167, timestamp=20130525-061650, database_id=c9a1cd2182fc3fa0cbb79ccde3054d465a72ccce518f435ebf3a04c60a5f3a6e, database_size=1597767
00001.445 INFO   : Downloading 0 bytes in 0 objects
00001.445 INFO   : Cached 1597767 bytes in 1 objects
00001.449 INFO   : Applying updates...
00001.529 INFO   : === MiniLog closed.
00000.000 INFO   : === MiniLog opened UTC 2013-06-20 18:35:33
00000.000 INFO   : LOAD_NEW_DB_CORE "T:\temp\DCS\update\c9\c9a1cd2182fc3fa0cbb79ccde3054d465a72ccce518f435ebf3a04c60a5f3a6e"
00000.008 INFO   : LOAD_OLD_DB_CORE "C:\Games\DCS World\autoupdate.db"
00000.015 INFO   : LOAD_CONFIG "C:\Games\DCS World\autoupdate.cfg"
00000.015 INFO   : LOAD_OLD_DB_FILES "C:\Games\DCS World\autoupdate.db"
00000.121 INFO   : LOAD_CACHE "C:\Users\User001\Saved Games\DCS\autoupdate.cache"
00000.159 INFO   : LOAD_NEW_DB_FILES "T:\temp\DCS\update\c9\c9a1cd2182fc3fa0cbb79ccde3054d465a72ccce518f435ebf3a04c60a5f3a6e"
00000.351 INFO   : DELETE "C:\Games\DCS World\autoupdate.db"
00000.351 INFO   : MOVE "T:\temp\DCS\update\c9\c9a1cd2182fc3fa0cbb79ccde3054d465a72ccce518f435ebf3a04c60a5f3a6e" -> "C:\Games\DCS World\autoupdate.db"
00000.351 INFO   : Using copy-then-delete fallback
00000.351 INFO   : COPY "T:\temp\DCS\update\c9\c9a1cd2182fc3fa0cbb79ccde3054d465a72ccce518f435ebf3a04c60a5f3a6e" -> "C:\Games\DCS World\autoupdate.db"
00000.361 INFO   : DELETE "T:\temp\DCS\update\c9\c9a1cd2182fc3fa0cbb79ccde3054d465a72ccce518f435ebf3a04c60a5f3a6e"
00000.362 INFO   : RMDIR "T:\temp\DCS\update\c9"
00000.703 INFO   : SAVE_CACHE "C:\Users\User001\Saved Games\DCS\autoupdate.cache"
00000.984 INFO   : SAVE_CONFIG "C:\Games\DCS World\autoupdate.cfg"
00000.984 INFO   : SETUP found 5 commands
00000.984 ERROR  : SETUP database error: unknown file "distr/vcredist_x86.exe"
00000.984 INFO   : SETUP skipped "distr/vcredist_x64.exe"
00000.984 ERROR  : SETUP database error: unknown file "distr/vc2010redist_x86.exe"
00000.984 INFO   : SETUP skipped "distr/vc2010redist_x64.exe"
00000.984 INFO   : SETUP skipped "distr/DirectX/DXSETUP.exe"
00001.098 INFO   : === MiniLog closed.
00000.000 INFO   : === MiniLog opened UTC 2013-06-20 18:35:38
00000.000 INFO   : LAUNCH found 1 commands
00000.006 INFO   : LAUNCH started "C:\Games\DCS World\bin/Launcher.exe"
00000.006 INFO   : === MiniLog closed.

I find this line quite interesting:

00001.282 INFO   : Downloading update: version=1.2.4.12913.167, timestamp=20130525-061650, database_id=c9a1cd2182fc3fa0cbb79ccde3054d465a72ccce518f435ebf3a04c60a5f3a6e, database_size=1597767

Does that mean, I have vers. xxx.167 and it tries to update to current (which I believe should be xxx.168 ? Or does it even try to just update up to xxx.167??

 

And then these:

00000.984 INFO   : SETUP found 5 commands
00000.984 ERROR  : SETUP database error: unknown file "distr/vcredist_x86.exe"
00000.984 INFO   : SETUP skipped "distr/vcredist_x64.exe"
00000.984 ERROR  : SETUP database error: unknown file "distr/vc2010redist_x86.exe"
00000.984 INFO   : SETUP skipped "distr/vc2010redist_x64.exe"
00000.984 INFO   : SETUP skipped "distr/DirectX/DXSETUP.exe"

Is the update only trying to install those dreaded redist-files? And why does it fail? In my DCS World folder all these are present and looking good ...

 

edit: fresh install of 1.2.4.11652.168immediately prompts me to update to 1.2.4.12914.167. First, that 1.6MB file is downloaded and applied (or not, didnt check) but then, the update continues to download 167MB of the actual patch. Soooo ... I guess, the behaviour of the autoupdater - or at least of the repair install tool - is somewhat un-intuitive, but not harmfull ...?


Edited by Flagrum
Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...