Jump to content

I have a weird problem...


RvEFoxteR
 Share

Recommended Posts

I bought X52 yesterday...everything is cool with it, in the SST software I made a profile for it and everything was working great for some time but then Starforce started poping up whenever I would like to load the game. And it was not that well known starforce window where you just cancel it, load the game again and everything is cool. Nope, in my situation starforce popped up and I couldn't do anything but to restart my computer. (I have a download version of FC btw). I was trying out stuff to see where the problem is and realised that it has something to do with my joystick profile in SST software. When the joystick profiler is on and my profile is loaded I cannot load the game, starforce appears. If the joystick profiler is on but my profile is not loaded game loads without any problems. Then as a temporary solution I just load without a profile then when the game is loaded I alt tab it and load the profile. It works but anyone may admit that this is very anoying and not nearly a solution to the problem. Also if I do like mentioned above, next time I want to load the game with the profile included it works. If anyone had similar problems when using X52 or any other saitek stick with SST software please let me know, I would like to find a solution to this. The stick is great but this kind of kills the fun of using it.

Link to comment
Share on other sites

You were right Goya, the shift key is depressed (or any other similar one) when my profile is loaded. I loaded the profile and opened a notepad, couldn't write a dam thing, the cursor went mad and also the "find" function poped up when I wanted to write something. Do you have a solution how should i fix this in my profile? I'm new to this software so I would really appreciate a little help. Thanks alot in advance!

S!

Link to comment
Share on other sites

I checked the sticky keys and they were disabled already, thanks for the tip bflagg

Yeah the X52 has a mode selector switch that switches between 3 different modes + additional 3 modes if you hold the pinkey switch withe the certain mode. Makes it 6 different modes. I'll check whats wrong with my modes in the profiles, thanks for all your help Goya.

Link to comment
Share on other sites

I had a similar thing happen. Turned out to be the way I had my flaps mapped to the slider on the throttle. Especially the slider (but rotories as well depending on what and how you've mapped them to various commands) make sure you leave a small "dead zone" at either end of it's travel. If you don't you'll get spurious key commands being constantly active (which can cause the SF window to pop up).

Link to comment
Share on other sites

Guest EVIL-SCOTSMAN

as far as i know, the aux keys are missing from the 52, i just got mine, and i dont se any aux keys like there was on the 45.

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...