Jump to content

Mouse axis for camera view / control of vehicles is reverse of Aircraft camera axis


Recommended Posts

Have setup external camera views of Aircraft, to be:

 

  • mouse X axis as Move Left = Look Left, Move right = Look right
  • mouse Y axis as Move Down = Look UP and Move UP = Look Down.

However when I use the same config (change nothing) for CA in a vehicle and try to steer the guns:

 

  • mouse X axis as Move Left = Look right, Move right = Look left
  • mouse Y axis as Move Down = Look Down and Move UP = Look UP.

This has been a pet peev for a while please fix or give me a solution.

 

cheers, Ian.

Asus p877v-pro, Intel I7 3770k 4.2ghz, 32gb Ripjaw X ram, Nvidia RTX-2070 Super, Samsung 32" TV, Saitek x52 pro Joystick and Combat rudder pedals, TrackIR 5, Win8.1 x64 with SSD and SSHD protected by (Avast AV).

 

DCS Tech Support.

Link to post
Share on other sites

check the axis for view in General not for Ground units... that's the camera CA uses. I had the same annoying problem first then I realized it doesn't get the controls from there. The controls for CA are a bit messed up.

[sIGPIC][/sIGPIC]

I5 4670k, 32GB, GTX 1070, Thrustmaster TFRP, G940 Throttle extremely modded with Bodnar 0836X and Bu0836A,

Warthog Joystick with F-18 grip, Oculus Rift S - Almost all is made from gifts from friends, the most expensive parts at least

Link to post
Share on other sites
check the axis for view in General not for Ground units... that's the camera CA uses. I had the same annoying problem first then I realized it doesn't get the controls from there. The controls for CA are a bit messed up.

 

Realize that, but as stated in original message, general view is also used when looking at aircraft externally, and controls were fine then, just when looking at vehicles, they are reversed.

 

Thanks for the reply though, have since fixed problem.

 

Added the mouse axis to the ground Unit setup by modifying the mouse.lua for ground units with the following.

 

axisCommands = {

{combos = {{key = "MOUSE_X", filter = {saturationX = 1, saturationY = 1, deadzone = 0, invert = false, slider = false, curvature = {0}}}, }, action = iCommandPlaneViewHorizontal, name = "Camera Horizontal View"},

{combos = {{key = "MOUSE_Y", filter = {saturationX = 1, saturationY = 1, deadzone = 0, invert = false, slider = false, curvature = {0}}}, }, action = iCommandPlaneViewVertical, name = "Camera Vertical View"},

{combos = {{key = "MOUSE_Z", filter = {saturationX = 1, saturationY = 1, deadzone = 0, invert = true, slider = false, curvature = {0}}}, }, action = iCommandPlaneZoomView, name = "Camera Zoom View"},

},

 

Now all I have to do is get the rudder pedals setup for steering, accelerator, braking, etc.

 

Not sure how to get that done as yet, but I did see in a forum something alluding to doing it.

 

Regards, Ian

Asus p877v-pro, Intel I7 3770k 4.2ghz, 32gb Ripjaw X ram, Nvidia RTX-2070 Super, Samsung 32" TV, Saitek x52 pro Joystick and Combat rudder pedals, TrackIR 5, Win8.1 x64 with SSD and SSHD protected by (Avast AV).

 

DCS Tech Support.

Link to post
Share on other sites
  • 2 months later...

I have steering by rudder pedals and throttle on one throttle from G940... but there is no braking and acceleration axis is also bugged severely (read: useless so far).

[sIGPIC][/sIGPIC]

I5 4670k, 32GB, GTX 1070, Thrustmaster TFRP, G940 Throttle extremely modded with Bodnar 0836X and Bu0836A,

Warthog Joystick with F-18 grip, Oculus Rift S - Almost all is made from gifts from friends, the most expensive parts at least

Link to post
Share on other sites
  • 4 weeks later...
  • 3 months later...

Any more info on this? I too want to have my mouse inverted on the Y axis while using vehicle gunner views. I can't seem to be able to do it. I can't find a mouse.lua to do with ground units either, just one's for UH1,A10,Su25,Su25t.

 

Can we get an official implemenation of a reverse Y axis option for Combined Arms please?

Specs: GA-Z87X-UD3H, i7-4770k, 16GB, RTX2060, SB AE-5, 750watt Corsair PSU, X52, Track IR4, Win10x64.

 

Sim Settings: Textures: ? | Scenes: ? |Water: ? | Visibility Range: ? | Heat Blur: ? | Shadows: ? | Res: 1680x1050 | Aspect: 16:10 | Monitors: 1 Screen | MSAA: ? | Tree Visibility: ? | Vsync: On | Mirrors: ? | Civ Traffic: High | Res Of Cockpit Disp: 512 | Clutter: ? | Fullscreen: On

Link to post
Share on other sites
  • 10 months later...
  • 1 year later...

I tried step by step like in the video, but it the " invert " option won't save the settings

Any ideas, guys ?

Thank you

I7 9700K@5.1 GHz | 32 GB DDR4 | Gigabyte Z390 AORUS Ultra | RTX 3090 | 6 TB SSD + 8 TB HDD | 4K Samsung Q90R 55" | VKB MK III PRO L | Virpil Throttle MONGOOST-50 | MFG Crosswind | TrackIR5

Link to post
Share on other sites
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...