Jump to content

FC3 A-10A can use NVG?


Recommended Posts

Is this a mod Morkva? Looks interesting!!

No. It's only a small correction in one file...

 

Open file: ...\DCS World\Mods\aircrafts\Flaming Cliffs\Input\a-10a\keyboard\default.lua

Uncomment line 25: --{combos = {{key = '5'}}, down = iCommandPlaneModeHelmet, name = '(5) Close Air Combat HMD Helmet Mode', category = 'Modes'},

 

That's all!

 

Now in game pressing button "5" will turn on NVG.

This method don't work for any fighter plane.

Edited by Morkva_55

[sIGPIC][/sIGPIC]

Link to post
Share on other sites

I can't seem to get this to work. I'm doing exactly as you have said. Odd.

 

Nevermind: I got this to work. My fix was to select the 'Keyboard' column, then click Load Profile. Then I just selected the default.lua located in the \keyboard folder listed above. Works like a charm. Спасибо.

Edited by MauganRa84



...Sheila rides on crashing nightingale. Intake eyes leave passing vapor trails...

 

[sIGPIC][/sIGPIC]

Link to post
Share on other sites
No. It's only a small correction in one file...

 

Open file: ...\DCS World\Mods\aircrafts\Flaming Cliffs\Input\a-10a\keyboard\default.lua

Uncomment line 25: --{combos = {{key = '5'}}, down = iCommandPlaneModeHelmet, name = '(5) Close Air Combat HMD Helmet Mode', category = 'Modes'},

 

That's all!

 

Now in game pressing button "5" will turn on NVG.

This method don't work for any fighter plane.

Can I enable the Su-25T NVGs the same way?

Link to post
Share on other sites
Hi Morkva....can you help with su25t

 

Just do the same thing as for A-10A...

...\DCS World\Mods\aircrafts\Su-25T\Input\su-25T\keyboard\default.lua

 

Uncomment line 28: --{combos = {{key = '5'}}, down = iCommandPlaneModeHelmet, name = '(5) Close Air Combat HMD Helmet Mode', category = 'Modes'},

You will have to reassign your keyboard mapping for Su-25T in the game, or load new altered profile.

 

If nothing happens - then delete file: ...\UserName\Saved Games\DCS\Config\Input\su-25T\keyboard\Keyboard.lua

This will reset the keyboard mapping to default.

Edited by Morkva_55

[sIGPIC][/sIGPIC]

Link to post
Share on other sites

Thanks Morkva. Nice Work.

Consequently, I've discovered you can add gain control by using a slightly different method.

 

Instead of modifying the default file in your Mods/aircrafts folder, try this:

Add the following lines to your User/Saved Games/DCS/Config/Input/a-10a/keyboard/keyboard.lua file.

 

Backup the file

After opening in Notepad++, Scroll down to the last "combos" entry and paste the following lines in after the last entry:

 

{combos = {{key = "H", reformers = {"RWin", "RAlt", }}, }, pressed = iCommandPlane_Helmet_Brightess_Down, name = "Gain goggles down", category = "Sensors"},
{combos = {{key = "H", reformers = {"RWin", "RCtrl", }}, }, pressed = iCommandPlane_Helmet_Brightess_Up, name = "Gain goggles up", category = "Sensors"},
{combos = {{key = "H", reformers = {"RWin", }}, }, down = iCommandViewNightVisionGogglesOn, name = "Toggle goggles", category = "Sensors"},

 

You don't have to use this code exactly if you prefer different keys, or reformers, but this one works well for me.

 

Method works for the A-10A, Su-25T, Su-25, and the P-51D.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...