Jump to content

Gun and unguided rocket training is driving me insane


Recommended Posts

I'm very new to this sim and have started going through the weapons training. I've flown the gun and unguided rockets mission nearly ten times now and I can never get past the same point. When the instructor asks to set waypoint 3 as the steerpoint and navigate towards it, I wait for him to disable autopilot, press DMS up and verify that steerpoint 3 is on the HUD then turn towards it.

 

Then I fly up to, through, and past waypoint 3 and the instructor never utters a word. I make sure to maintain ~6000ft altitude, same as the previous waypoint but no dice.

 

I checked out the video of the same lesson in youtube on the eagledynamicstv channel and I'm doing pretty much exactly the same thing as the person in the video but the training never resumes.

 

I only managed to get the mission to resume once when I flew over waypoint three and decided to fly all the way back to waypoint 2. Midway between points 2 and 3 the lesson resumed as I'm flying AWAY from waypoint 3 with waypoint 2 selected as my steerpoint. But past a few more steps, I'm not instructed any further.

 

I've never had this happen to me in any other lesson and am really at a loss for what to do. The instructions up until that point are pretty simple so I'm positive I'm configured properly.

 

Anyone had this happen to them and what can be done about it?

Link to post
Share on other sites

Please save a track of your flight, so we can see exactly what happens and hopefully figure out what the issue is. You can save a track on the debriefing screen after quiting the mission if you start it out of the Mission Editor rather than the Training menu.

- EB

[sIGPIC][/sIGPIC]

Nothing is easy. Everything takes much longer.

The Parable of Jane's A-10

Forum Rules

Link to post
Share on other sites

I just flew that training in 1.2.2 and can confirm the OPs observation. I flew it as a training mission though and didn't save a track.

 

When the IP turns off the AP and instructs the pilot to head for WP3, I was still some 6nm away from WP2.

 

From a quick look at the mission, the trigger zone "Head for WP-3" has a radius of 3nm.

 

My guess is that with the reworked engine power (that was introduced with 1.2.1 IIRC), the aircraft is a lot slower than it used to be when the training was created, so in this particular mission we never get to the trigger zone.

 

Solution would be to check all training missions for such waypoints/trigger zones and rework them for the new engine power output that came with 1.2.1.

 

If necessary, I can record a track, but the problem looks to be easily reproducible.

 

Skall: To solve your problem in the mean time, simply ignore the instructor and fly all the way to WP2 before you head for WP3, that way the rest of the training should be just fine.

Link to post
Share on other sites

I have also experienced this gitch...training missions need a tweak in new version

System:Motherboard Asus ROG Strix Z390-E,Asus ROG GeForce RTX 2080Ti OC, GPU, 32GB Corsair Vengeance DDR4 Ram, Intel i9 9900K @ 5 GHz , cooled by NZXT Kraken X52, Acer XB270HU G-Sinc monitor, Windows 10 Pro, Warthog joystick and throttle with wasy extension, VBK Gunfighter Pro and MCG Pro,MFG Rudder, running on a dedicated 1TB Samsung 970 Pro M2 Nvme , Super Wheel Stand Pro, with a HP Reverb G2

Link to post
Share on other sites

Thanks for the help both of you.

 

Yurgon is correct in that the player is instructed to go to waypoint 3 well before reaching waypoint 2. What I find odd is that the video in eageldynamicstv on YouTube has the demonstrator turn to waypoint 3 also well before reaching waypoint 2 but his training continues.

 

 

I just flew the mission from the mission editor in order to save the track but it is 7+ MB in size and it says I can't upload a track bigger than 5MB. Tried putting it in a zip file but it only dropped the file size by a couple hundred KBs. Is there any other way of me making the track available?

 

I'll fly it again but I'll wait until the nav system switches to waypoint 3 on its own after getting to waypoint 2.

Link to post
Share on other sites

I've uploaded the file to the user files section. It's waiting to be reviewed by a moderator.

 

In the meanwhile, I played the mission a few more times to no success. I flew all the way to waypoint 2 to make sure I was in the trigger zone before turning to waypoint 3 but nothing happened.

 

I did, however, manage to get slightly farther in one instance: after receiving the instructions to turn to steerpoint 3, I counted 30 seconds in my head while still heading towards waypoint 2 (for no specific reason, just to pick a distance between steerpoint 2 and the time you are told to go to 3). I then pressed DMS up once to select steerpoint 3 and the lesson resumed immediately without even letting me turn in the direction of steerpoint 3.

 

It then covered the rocket reticle but when it asked me to select steerpoint and turn towards steerpoint 4, it again did nothing. I wish I understood the editor better but I'm certain there is something very wrong with the trigger conditions for this mission.

Link to post
Share on other sites

I can confirm that. Nothing happens after autopilot is disengaged and I turn in into steer point 3.

 

I just recorded a track. No need to wait for moderation as well, guys, check out box.com! ;) Hehe.

 

https://www.box.com/s/fb40b5mhnjyjsbm0r3fj

[sIGPIC][/sIGPIC]

System specs:

2500k @ 4.6 GHz

8GB RAM

HD7950 OC'd

Win7 x64

 

Posting tracks to make your DCS better - attention bump incoming!

Link to post
Share on other sites
[...] I'm certain there is something very wrong with the trigger conditions for this mission.

 

Looks that way. That's too bad, because personally I think these training missions are very well done and I played them all before I went on to explore the aircraft on my own.

 

But in the mean time, you'll find more than enough guides in the Wiki.

Link to post
Share on other sites

The Mission Trigger problem seems to be in all of the A-10C training missions now....Is this a known new issue since Ver 1.2.2.?

System:Motherboard Asus ROG Strix Z390-E,Asus ROG GeForce RTX 2080Ti OC, GPU, 32GB Corsair Vengeance DDR4 Ram, Intel i9 9900K @ 5 GHz , cooled by NZXT Kraken X52, Acer XB270HU G-Sinc monitor, Windows 10 Pro, Warthog joystick and throttle with wasy extension, VBK Gunfighter Pro and MCG Pro,MFG Rudder, running on a dedicated 1TB Samsung 970 Pro M2 Nvme , Super Wheel Stand Pro, with a HP Reverb G2

Link to post
Share on other sites

Yurgon

 

There does not seem to be an agknowlegement that there is a problem by EB. EvilBivol-1 only gave direction how to upload a large file. He did not say there was a problem with the training missions.

System:Motherboard Asus ROG Strix Z390-E,Asus ROG GeForce RTX 2080Ti OC, GPU, 32GB Corsair Vengeance DDR4 Ram, Intel i9 9900K @ 5 GHz , cooled by NZXT Kraken X52, Acer XB270HU G-Sinc monitor, Windows 10 Pro, Warthog joystick and throttle with wasy extension, VBK Gunfighter Pro and MCG Pro,MFG Rudder, running on a dedicated 1TB Samsung 970 Pro M2 Nvme , Super Wheel Stand Pro, with a HP Reverb G2

Link to post
Share on other sites
There does not seem to be an agknowlegement that there is a problem by EB. EvilBivol-1 only gave direction how to upload a large file. He did not say there was a problem with the training missions.

 

a) I was making a joke.

b) I'm sure EB and the devs are watching this thread as it develops.

 

From my perspective, it's obvious that there is a problem with the training missions, it's easily reproducible. But even if it was officially acknowledged, it may be months before they get fixed (or the fix may already be tested and deployed a few days from now).

 

My point being: It doesn't really matter whether or not it's officially acknowledged, does it?

Link to post
Share on other sites

Yurgon

 

You are absolutely right. As has been often stated, it is hard to judge the emotional content, humour, in posts. ED, at least in recent years, is not very forthconing in agknowledging problems/concerns :music_whistling: that being said, I exspect that this will be fixed in the short term:thumbup:

System:Motherboard Asus ROG Strix Z390-E,Asus ROG GeForce RTX 2080Ti OC, GPU, 32GB Corsair Vengeance DDR4 Ram, Intel i9 9900K @ 5 GHz , cooled by NZXT Kraken X52, Acer XB270HU G-Sinc monitor, Windows 10 Pro, Warthog joystick and throttle with wasy extension, VBK Gunfighter Pro and MCG Pro,MFG Rudder, running on a dedicated 1TB Samsung 970 Pro M2 Nvme , Super Wheel Stand Pro, with a HP Reverb G2

Link to post
Share on other sites

Thanks for uploading the track. The issue appears to be caused by a change in the way the heading check trigger works. It used to be reversed (i.e. reading from 0 to 360 counter-clockwise), but is now reading correctly. One of those situations where a bug fix leads to a new bug. Unfortunately this isn't the only mission which makes use of the heading trigger, so we'll need to check and update a number of other training missions as well.

 

It would not be unhelpful if you could provide other specific issues you encountered in the training to make sure we don't miss any holes. This particular issue should not affect all missions as only some of them utilized the heading trigger.


Edited by EvilBivol-1

- EB

[sIGPIC][/sIGPIC]

Nothing is easy. Everything takes much longer.

The Parable of Jane's A-10

Forum Rules

Link to post
Share on other sites

Glad to hear there's an explanation for this. At least I know I'm not going crazy. That would also explain why I got it to work that one time when flying away from waypoint 3. I'll probably go over the remaining lessons this weekend and provide feedback and tracks if I see anything strange happening.

 

Thanks for uploading the track. The issue appears to be caused by a change in the way the heading check trigger works. It used to be reversed (i.e. reading from 0 to 360 counter-clockwise), but is now reading correctly. One of those situations where a bug fix leads to a new bug. Unfortunately this isn't the only mission which makes use of the heading trigger, so we'll need to check and update a number of other training missions as well.

 

It would not be unhelpful if you could provide other specific issues you encountered in the training to make sure we don't miss any holes. This particular issue should not affect all missions as only some of them utilized the heading trigger.

Link to post
Share on other sites

As I promised, I went through all the other lessons. I'll post links to the tracks once they are approved by ED but here are the issues I ran into:

 

General purpose bomb training: After performing a practice CCIP dive in armament test mode, no further instructions are given to the player after being informed to head in the direction of waypoint 2.

 

Precision guided munitions: I was able to complete it but it had a quirk. When you are given your first target, you are told to set TGP as SOI and press TMS forward short to set track mode to Point. For some reason, despite maintaining the autopilot set by the mission since the beginning, I kept seeing INR-A and INR-P as if something was blocking my FOV even though I had a perfectly clear view of the target. After waiting for a while, I broke auto pilot and circled around the target until I was able to get a clean track. The lesson then resumed.

 

Maverick training: Another mission that fails to continue when asked to maintain a heading. In this case, turning to waypoint 3.

 

Air-to-air: I was able to complete it, albeit with a very minor issue. You are asked to use WHOT mode (Boat-switch aft) even though the instructor asks you to press the boat-switch forward. Didn't bother uploading a track just for that.

 

Countermeasures: Was able to complete it however it seemed to get a bit screwey when you are asked to make a custom program. After being asked to select flares to set to a number other than 0, the instructions did not continue. I started messing around and turning on and off the DISP switch made it continue to the next step (press the rocker switch up twice to add 2 flares to the program). However it stopped there again until I started messing with the DISP switch again. After doing this a few times, the mission resumed and I was able to complete it.

 

Edit:

 

My files have been approved. Here are the links:

Countermeasures: http://files.digitalcombatsimulator.com/en/249111/

Precision guided munitions: http://files.digitalcombatsimulator.com/en/249110/

Mavericks: http://files.digitalcombatsimulator.com/en/249109/

General purpose bombs: http://files.digitalcombatsimulator.com/en/249108/


Edited by Skall
Link to post
Share on other sites

I wanted to bump this post as it's a much more concise forum for what problems were being experienced. I originally posted here: http://forums.eagle.ru/showthread.php?t=75464 but it seems many of the training missions are buggy. While I won't quit flying, it IS a tad frustrating as I'm one of those newbies trying to learn everything before I start campaigns let alone multiplayer. I hate hopping into multiplayer and not having a single clue what I'm doing, and the bugs in the mission trainings are slowing my progress to getting into multiplayer.

 

Edit: Maybe ED should look into all of the training missions as Skall demonstrates many of them either have waypt issues or other odities.


Edited by MadCow
Link to post
Share on other sites

This is the second mission I fly with this problem! Very frsutrating as the lesson seems very well done but I cant continue and have to start all over again on the runway. I have this problem on the maverick and Guns/unguided rockets training mission. Do you guys proof check these missions or what? Its a great sim but please get this fixed ASAP.

 

Alex Bart

Link to post
Share on other sites
I wanted to bump this post as it's a much more concise forum for what problems were being experienced. I originally posted here: http://forums.eagle.ru/showthread.php?t=75464 but it seems many of the training missions are buggy. While I won't quit flying, it IS a tad frustrating as I'm one of those newbies trying to learn everything before I start campaigns let alone multiplayer. I hate hopping into multiplayer and not having a single clue what I'm doing, and the bugs in the mission trainings are slowing my progress to getting into multiplayer.

 

Edit: Maybe ED should look into all of the training missions as Skall demonstrates many of them either have waypt issues or other odities.

You describe exactly how I feel, I'm also new to the DCS and to the A10C and was using the training missions to learn.

Can we expect an update to this issue in short time?

Regards.

Link to post
Share on other sites
You describe exactly how I feel, I'm also new to the DCS and to the A10C and was using the training missions to learn.

Can we expect an update to this issue in short time?

Regards.

I'm sure we'll have the training missions fixed next week. Can't say if an auto-update will be released at that point to push the fix, but if not, we'll upload the fixed missions to the file exchange as a temporary measure.

- EB

[sIGPIC][/sIGPIC]

Nothing is easy. Everything takes much longer.

The Parable of Jane's A-10

Forum Rules

Link to post
Share on other sites
I'm sure we'll have the training missions fixed next week. Can't say if an auto-update will be released at that point to push the fix, but if not, we'll upload the fixed missions to the file exchange as a temporary measure.

Hi, thanks for the info.:thumbup:

Link to post
Share on other sites
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...