Jump to content

Saitek SST Problem on Win 7 64 bit


Joeben
 Share

Recommended Posts

Hi everyone,

 

I didn't know where else to post this, since I can't register at the Saitek forums. A couple of days ago I received my x52 pro. I was able to set up a custom profile using the SST software Ver. 7.0.2.7, and it was working fine. The next day though, the profile wouldn't register within DCS A10 and I couldn't open the profile editor without it becoming unresponsive and having to force exit it. I've tried uninstalling the software and drivers completely and reinstalling it with different versions but nothing has seemed to work.

 

I'm running windows 7 64 bit.

I was using the 64 bit software and drivers.

My windows is completely updated, so I'm not sure what's causing the problem.

 

If you can give any help, I'd really appreciate it so I can use my hotas to its fullest.

 

-Joeben

Specs:

i5 2500k @ 4.5Ghz

Asrock Z68

GTX 980

X52 Pro

Saitek Rudder Pedals

TrackIR

Link to comment
Share on other sites

I had same issue with mine it was because i made the mistake of plugging in my x52 before I had run the driver install problem. So the drivers and SST would install but wouldn't work correctly at all and drove me nuts. Even though I could change some settings and it appeared to kind of work, it wouldn't load profiles even if I made a simple one with 1 key and saved it (that would work) but try and load it and fail!

 

I had to follow the instructions from Saitek to properly remove all traces of the drivers and software. Then re-install driver then SST (and do not plug in the x52 until the driver program ASKS you to plug it in, and then do so).

 

 

Here are the instructions you have to follow them all or the same problem happens again:

 

1. Unplug your device from the computer

 

2. Uninstall the drivers

 

3. Uninstall the SST programming software

 

4. Delete the Saitek folders from the following paths :

C:\Program Files

C:\Windows\Temp

 

5. Delete Saitek registry entries:

-Press and hold the Windows key on your keyboard and then press the letter R. This will open the Run box. Type regedit and then click ok.

The Registry Editor will have a list of folders on the left hand side. Go down into the following folders in order by clicking the + next to the folder name.

 

+HKEY_CURRENT_USER

+System

+CurrentControlSet

+Control

+Media Properties

+Private Properties

+Direct Input

 

Delete any folder inside the Direct Input folder that begins VID_06A3.

6. Reboot

 

7. Install the latest drivers and DO NOT PLUG IN YOUR X52 until the install program ASKS you to or you will have to redo this whole process.

i7-920 @3.8Ghz / MSI X58m / 8GB DDR3 / 2 x HD5770 / Asus-vw226h @1920x1200 / 2x OCZ Vertex 2 80GB SSD's / Win 7-64 / TrackIR 5 / Saitek x52 / Razer BlackWidow Mech Keyboard / Razer Deathadder

 

Stuttering or fps problems? Updated April 25/11: http://forums.eagle.ru/showthread.php?t=68060

 

Check out this fantastic list of must have and FREE programs: http://www.logichaos.com/joomla/component/content/article/35-text-guides/82-ultimate-list-of-free-programs-for-windows.html

Link to comment
Share on other sites

Hey WTF,

 

So I followed your instructions, and it seems like the drivers are working fine. The game recognizes and responds to the stick using the in game profile. I'm just still having problems with the Smart technology software. It still keeps happening that every time I open the profile editor it becomes unresponsive, and I have to force quit. So I can't make a new profile or edit ones that I download.

 

I don't think its driver related. It has to be a problem with the software.

 

-Joeben

Specs:

i5 2500k @ 4.5Ghz

Asrock Z68

GTX 980

X52 Pro

Saitek Rudder Pedals

TrackIR

Link to comment
Share on other sites

Hey Joeben,

 

Sorry to hear that! Have you tried using older versions of the SST?

i7-920 @3.8Ghz / MSI X58m / 8GB DDR3 / 2 x HD5770 / Asus-vw226h @1920x1200 / 2x OCZ Vertex 2 80GB SSD's / Win 7-64 / TrackIR 5 / Saitek x52 / Razer BlackWidow Mech Keyboard / Razer Deathadder

 

Stuttering or fps problems? Updated April 25/11: http://forums.eagle.ru/showthread.php?t=68060

 

Check out this fantastic list of must have and FREE programs: http://www.logichaos.com/joomla/component/content/article/35-text-guides/82-ultimate-list-of-free-programs-for-windows.html

Link to comment
Share on other sites

  • 3 weeks later...

Just curious here which version drivers everyone is using for Win7 64 bit?

 

From my experience the newest DRIVER i was able to find for 64bit win7 is 6.2.2.4, so that's what im running with, BUT...as far as the SST software im running 7.0.3.7.

 

I think this may be why im having some stability issues and even blue screens form time to time as well as often losing calibration within the game, but i dont know where to get a 7.0.3.7 driver for win7 64bit.

 

So, what version drivers on win7-64 is everyone else running here?

Link to comment
Share on other sites

  • 2 months later...

Same here. Win7 64bit ultimate, same driver/profile versions. Stick works fine, profiler will eventually go nuts and hang. After that my system starts messing up too, like browsers can't get a page. Rebooting always resets this but killign the processes doesn't.

 

Can't regsiter and complain on the Saitek forums because they stopped taking new members (complaining about bots spamming).

 

This is a real issue because without the profiling software I lose a mouse and four sliders which renders the advantage of the stick over other cheaper ones pretty small if absolutely null.

___________________________________________________________________________

SIMPLE SCENERY SAVING * SIMPLE GROUP SAVING * SIMPLE STATIC SAVING *

Link to comment
Share on other sites

I have 6.2.2.4 and 7.0.2.7, which appear to the the latest available for download. Also have the X52 Pro and Windows 7 x64, fully up to date. The combination _should_ work.

 

I don't have the problem you do with the software becoming unresponsive, but pretty frequently the software stops applying the profile I select and no matter what I do I have to unplug the stick and reboot. After that it starts working again normally.

 

I love the stick hardware wise, but the software is junk. Wish I had an idea what might be causing you're issue, but honestly I do not.

 

 

I had that problem with the cases USB, I plugged the Controler into the Motherboards USB and it went away. PCs are finicky but it may be worth a shot for you. Assuming you are not already plugged into the MBs USB Port that is.

This was a Boutique Builder iBuypower rig. Until I got the tinker bug again i7 920 @3.6Mhz 12Gig Corsair XMS3 ram 1600 Nvidia 760 SLi w/4Gig DDR5 Ram Intel 310 SSD HDD 160 Gb + Western Digital 4Terabyte HDD Creative SB X-Fi HD Audio Logitech X-530 5.1 Surround Speaker System Dual Acer 32"Monitors. PSU 1200 w Thermaltake Win10 64Bit.

Link to comment
Share on other sites

  • 3 months later...
  • 2 weeks later...
  • 2 months later...

I can't get my X52 to work either. I have the profile name on the throttle controller screen and everything, but when I launch DCS A-10, the controllers are only default. Is there any way to check it in the profile editor once I load it?


Edited by Mallek
Link to comment
Share on other sites

If you download it to your editor, is there a way you can check to see that the commands are set up? For instance, when you click the second one: " Second Trigger" from the right side of the editor, should something be in that field or is it supposed to be blank? All mine are blank when I load the profiles I've downloaded onto the editor. Starting to think the downloads are bad. They're supposed to be .pr0 files correct?

Is there anything you have to do to the DCS folder or in the options menu?

 

 

Nvm. I apparently did something wrong. Works now.

In case anyone reads this with the same question, the answer is : Yes, the editor mirrors the corresponding commands to the kbd controls. if nothing's in those boxes, delete the file and get a working profile link. You don't have to do anything to the game files or in the game options menu unless it ends up causing the profile controller setup and the default game option to do both things simultaneously; in which case, simply delete it from the in-game controller options.


Edited by Mallek
Link to comment
Share on other sites

  • 1 month later...

That issue with the SST drivers is a LONG!!! standing known issue. It has to do with ATI Catalyst drivers messing with Siatek Drivers... Read the saitek forums

Modded CapLoz HeliosV2.1_1280x1024.zip

 

2x 1080p 22"Monitors, Saitek X52, Saitek Combat Rudder Pedals, Trackir5, Win7Pro Pro 64Bit, Intel Q9550 @3.8Ghz, EP45-UD3L, 8GB Ram, Nvidia 560Ti 2GB, 2x 500GB Velociraptor

 

Flaming Cliffs 3

DCS:A10C,KA-50, Huey, Mi-8, WWII Euro 40+ Supporter, Mig21

Falcon 4 BMS

IL-2 Sturmovik: 1946

Take on Helicopters

Arma 2 AO + PMC + BF All Addons Series

Arma 3

EECH & EEAH

Medivac & Search and Rescue 4 Series

 

 

Link to comment
Share on other sites

  • 9 months later...

The EDIT:

Bottom line is SAITEK programming software for the X52 Pro is crap.

I've seen so many people have issues with the programming software and I've had my share of them too.

The hardware is mid-range to OK .. but if you want a hassle free HOTAS experience with the X52 Pro, download JoyToKey (http://joytokey.net/en/) and use it plus the latest drivers from the the Saitek site.

 

The rest of the stuff mentioned further on in the thread about USB port 2 is correct as well. You should be able to change that setting in BIOS.


Edited by Teapot
update

"A true 'sandbox flight sim' requires hi-fidelity flyable non-combat utility/support aircraft."

Wishlist Terrains - Bigger maps

Wishlist Modules - A variety of utility aircraft to better reflect the support role. E.g. Flying the Hornet ... big yawn ... flying a Caribou on a beer run to Singapore? Count me in. Extracting a Recon Patrol from a hastily prepared landing strip at a random 6 figure grid reference? Now yer talking!

Link to comment
Share on other sites

  • 2 months later...
  • 8 months later...

I'm a bit late but maybe this is helpful (if not said elsewhere)...

 

To have the X52 Pro (I have this one) work you have to plug it on a USB2.0 port. Moreover it is not probably sufficient to plug it into a USB2.0 (I plugged it to a 2.0 hub connected to a 3.0 on the case...so it should be a downgraded 3.0 --> 2.0): what I've done is to uninstall the intel drivers for usb 3.0 support (it's under installed software list - control panel), and it worked very well.

 

install latest drivers and SST. it should work on the latest versions.

Link to comment
Share on other sites

  • 2 months later...
  • 2 weeks later...
I'm a bit late but maybe this is helpful (if not said elsewhere)...

 

To have the X52 Pro (I have this one) work you have to plug it on a USB2.0 port. Moreover it is not probably sufficient to plug it into a USB2.0 (I plugged it to a 2.0 hub connected to a 3.0 on the case...so it should be a downgraded 3.0 --> 2.0): what I've done is to uninstall the intel drivers for usb 3.0 support (it's under installed software list - control panel), and it worked very well.

 

install latest drivers and SST. it should work on the latest versions.

Yes, this works. Finally got mine updated to :thumbup:

Link to comment
Share on other sites

  • 2 months later...

Question. How do I uninstall the drivers when the stick is disconnected?

 

Figured it out so never mind.


Edited by Denco

i7 2600K 4.5 Ghz

Asus Maximus IV Gene-z

Gigabyte GeForce GTX 780 Ti 3GB WindForce 3X OC

Win7 64b

Corsair Vengance 8GB 1866Mhz

Windows 7 Ultimate 64b

Link to comment
Share on other sites

  • 1 month later...

I recently purchased the Saitek TPM (throttle, prop, mixture ) panel and had no option but to update to SST 7.0.27 as the older software does not support this panel. I am running SST on a PC with Windows 7 64 bit. SST repeatedly crashes the PC to a blue screen. I am able to program one or two switches, but eventually SST will crash after clicking on something, e.g. test profile or load profile.

 

I have submitted a ticket with Saitek. If I receive any encouraging feedback I'll post it here for anyone else who finds this thread as I did when researching the issue.

 

By the way, the nine switches on the TPM panel can be used with DCS. If I were knowledgeable about LUA programming, that might be a better way to go. For now, I simply map unused keyboard commands in DCS and then program the TPM switches accordingly. Of course, this has been a painful process given that SST crashes a lot!

 

Thanks,

Paul


Edited by pdmarsh
Link to comment
Share on other sites

  • 9 months later...

I just had the same Problem. Beside this Win 10 shoots commands on the X 52 Pro in an unacceptable way, so I decided to roll back to Win7 by a pure reinstall (for other reasons as well). I have tried the above mentioned procedures a few times (install from the CD and d'led Drivers with all the uninstall procedures etc pp) The way to solve the prob seems to only use the drivers marked "Saitek_X52Pro_Flight_Controller_SD6_64" and the according SST Software "SST_Software_64_6_6_6_9". Having installed them (offline) the editing- load test and test via text editor function works.

Google the appropriate drivers (I have found a French site "toutes le Drivers" or so ;)) and keep them save. Hope it helps...

Link to comment
Share on other sites

@Mole--Thanks for the information. If I recall, I believe Saitek said that they could not reproduce the issue. In meantime I have switched to using Flightpanels to program my TPM and other Saitek panels.

 

Paul

Link to comment
Share on other sites

  • 2 weeks later...
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...