Jump to content

performance issues (again..)


HAG
 Share

Recommended Posts

Hi Folks,

 

firstable according to allmost everything i have read through various forums, i still dont understand why i dont have decent fps in my game. I have a p4 2.8, 2gb pc3200 ram ddr and a GeForce 6800 GT 256mb ddr in AGP. I have recently reinstalled a fresh version of Win XP Pro + SP2, DX9c and the latest (?) nvidia 77.77 drivers. My desktop resolution is 1280x1024 32bits and my graphic settings in LO CF 1.1 are set to medium, same resolution 1280x1024 32bit. Also, in nvidia drivers settings i have set the anti aliasing to OFF and anisthoscopic to OFF, also i have set the next parameter to 'Maximum performance'. I remember there was memory pre-load problems in Lomac 1.02, this could be corrected by setting the game on pause, and switching between windows tasks with ALT+TAB key, after this manipulation the performance difference was like night and day. This is no longer possible in LO 1.1. I have the most serious annoyances while playing any mission with SU25T, especially when i activate the shkval system, my average fps is between 15 and 23.. this isnt really sufficient to have a decent graphic fluidity ...

 

so what is the TRICK? is there anything specific to set in the nvidia drivers? something else in Lockon graphic interface?? will LoMan help?

 

please post your configuration settings if you have geforce 6800 GT

 

thanks in advance.

Link to comment
Share on other sites

I have a AMD64 3500 1GB RAM and a 6800GT. I run the same driver settings but @ 1600X1200.

 

I run everything on med, and effects off (because of guns FPS drop).

 

I have about 60-80FPS in the air.

 

I used to get in the 30's when I had Vis on high, made a huge difference when I put to med.

 

Check BIOS setting for AGP fast write.

Link to comment
Share on other sites

Try the Latency tool to change your card latency. Might help you.

 

Unzip and run LtcyCfg2

 

Find your graphics card on the list (latency is usually 256), right click on it, click change settings, enter 64, click ok. Go to settings menu, click save. then reboot.

 

Helps improve FPS and stops the stutter found in the likes of BF2.

 

Although the usual "I take no responsibilty for your system yada yada yada" applies here. :p

Link to comment
Share on other sites

Did some side by side tests with the same cpu and video card on two motherboards, but one of the systems had dual channel memory support - the sustained framerates on this box were significantly higher than on the other one.

Link to comment
Share on other sites

hi hag...hi all,

i think your problem is a cpu limitation....so you can use some little mods to improve you performance... first of all is hardware audio acceleration, set it to minimum(start\programs\accessories\system utilities\microsoft system informations\diagdx); another thing we use to improve performance is to reduce the number of audio files that lomac can elaborate so go to C:\Programs\Ubisoft\Eagle Dynamics\Lock On\Sounds\Effects and read all .ogg file's name in this list, you'll find some effetcs that (for you) are not essential (for example water effets)and move them in a temp folder, i have chosen about 20 files.

P.S. sometime when you set hw audio acceleratiom to minimum you can have some audio problems when going in cockpit(that you can resolve going in ab for a second); if you get this problem then set hw audio acceleration to 1 step over minimum..

 

good luck and let me know if you get some improvements

Link to comment
Share on other sites

hi hag...hi all,

i think your problem is a cpu limitation....so you can use some little mods to improve you performance... first of all is hardware audio acceleration, set it to minimum(start\programs\accessories\system utilities\microsoft system informations\diagdx); another thing we use to improve performance is to reduce the number of audio files that lomac can elaborate so go to C:\Programs\Ubisoft\Eagle Dynamics\Lock On\Sounds\Effects and read all .ogg file's name in this list, you'll find some effetcs that (for you) are not essential (for example water effets)and move them in a temp folder, i have chosen about 20 files.

P.S. sometimes when you set hw audio acceleratiom to minimum you can have same audio problems when going in cockpit(that you can resolve going in ab for a second); if you get this problem then set hw audio acceleration to 1 step over minimum..

 

good luck and let me know if you get some improvements

 

Hi,

Sorry but there is something that I can't understand in your post: if the problem causing the hog is that his CPU is not powerful enough ¿why should he turn sound hardware acceleration to minimum? This would allow more workload to the CPU.

 

Best regards,

Asterix

Link to comment
Share on other sites

uhh.. well, i have noticed SIGNIFICANT performance improvement when i have switched in the bios the agp aperture from 256 to 64mb and video spectrum to disabled. I went to diagdx and have there audio hw acceleration to 'standard' or normal. Im getting the most of FPS slowdown and allmost stutters when im flying over citites and especially the goddam' smoking cheminees, i think there are too too many of them , all the same .. i think its a real annoyance and sometimes it makes look the citiscape view generic an unrealistic. I wonder if somebody did any mods to extinct the cheminee smokes, i think that will help a lot.

Link to comment
Share on other sites

Hi,

Sorry but there is something that I can't understand in your post: if the problem causing the hog is that his CPU is not powerful enough ¿why should he turn sound hardware acceleration to minimum? This would allow more workload to the CPU.

 

Best regards,

Asterix

 

yes - normally you would be right.

 

for some reason the LOMAC process to offload the sound processing to the soundcard hardware takes up more processing power than you save by doing it.

Link to comment
Share on other sites

uhh.. well, i have noticed SIGNIFICANT performance improvement when i have switched in the bios the agp aperture from 256 to 64mb and video spectrum to disabled.

 

Cool Nice to hear. I had the same performance increase also.

 

Here a verry good link that explains lots about tweaking your bios settings;

 

http://www.rojakpot.com/default.aspx?location=9

 

About your sound Card. What model do you have?

 

I Initialy had lots of issues with my old Soundblaster live and onboard sound. I tried different things. from changing PCI slots, also tried the PCI latency utility mentioned in this thread & Different drivers. Always gave me crackling noice from time to time. Especialy if I used Teamspeak at the same time. True the issue was only apparent with lomac. Got tired of playing and tweaking things to resolve that problem. Time is money so I decided to invest on a sound card upgrade, It elimitate the problem all together.

 

Presently using a Creative SB Audigy LS. Verry not expensive and it serve it purpose for now.

 

NOTE I still use the pci latency tool. Verry usefull for tweaking. For my setup, 64 pci latency, is a good value for my sound card and Video compatible controller.

 

You can download it here also http://downloads.guru3d.com/download.php?det=951

 

 

 

Cheers

Happy Tweaking

Link to comment
Share on other sites

thanks for that link about the bios settings, i have got finally *answers* about various bios options that i had never any ideas of what they really do, anyways tweaking the bios requires some real engineering studying etc...

 

i have just tried to modify the video card latency by using that tool, originally it was on 248 , so i have set it to 64; after a reboot , when i have launched the game , i have experienced a very curious 'total blackout' screen phenomen as i have never seen before; i have started flying a CAS mission with the A10 and during the flight at different external view modes {F2 , F3 .. ] ; the monitor just turned in total BLACK... within the next minutes it was only possible to view anything on the screen by returning in the cockpit mode (F1) then, a few seconds later the game crashed and went to desktop. so this latency changer didnt really fix anything here ;o) im still continuing tweaking

Link to comment
Share on other sites

The 'maxmimum performance' setting in your Nvidia Control Panel.

Move this slider or select 'High Quality' instead. I found that anything other than 'high quality' setting would cause bad fps, graphic glitches, overall bad gameplay.

Leave your AGP on 128 or 256! Its a setting for video addressable memory. Important.

 

On a final note* Never trust the latest drivers. Performance still bad on drivers that came with video card CD(driver cd)?

 

Hope you get it fixed soon.

dredd4hd0.jpg

---= 169th Panthers -Flt Lt.- =---

http://www.169thpanthers.com.au

 

tbdreddey7.png

AMD64 S939 3700 | 2GB Corsair DDR500 | 21" CRT

ATI Radeon X800Pro | 2x36GB WD Raptors | SB Audigy

TIR3 | TM-868 | X52 | CH Pedals | Creative 5.1 Spkrs

Link to comment
Share on other sites

Sounds like there's cleverer brains on the case than mine, but you say you alt+tab away & back to improve performance... I think I remember that the read me txt specifically says that Alt+Tab-ing away from the game and back will cause memory leaks...

Cheers.

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...