Jump to content

Arcaze Konfigurieren


Recommended Posts

So, damit wir Toyojoes Trhead nicht immer weiter Offtopic aufblasen mach ich hier mal einen neuen auf.

 

@ Wupper:

 

Wenn du mit der Arcaze LEDs steuern willst kannst du das ueber Ausgaenge machen. Dazu legst du einfach einen neuen Ausgang an (Die Gluebirne, 3 Icons neben dem normalen Schalter).

 

Dann bekommst du den Dialog, den ich unten angehaengt habe. Bei "Input Trigger" musst du den Eingang auswaehlen, der die LED steuern soll. Also, nehmen wir an, du willst mit dem schalter an Eingang A01 eine LED einschalten, dann musst du das da einstellen. Fuer die Startbedingung gilt das gleiche wie bei den Schaltern .

 

"RisingEdge" :es passiert, wenn der Taster runter gedrueckt wird/der Kippschalter eingeschaltet wird

 

"FallingEdge" :es passiert, wenn der Taster losgelassen wird /der Kippschalter ausgeschaltet wird

 

"Repeat" : es passiert solange der Taster gedrueckt wird/der Kippschalter eingeschaltet ist

 

 

Unter Output Funktion kannst du den Port anwaehlen, an dem die LED angeschlossen ist und die Aktion einstellen, die Passieren soll.

 

"Toggle Output" : der Zustand der LED wird gewechselt. Ist sie an, wird sie ausgeschaltet, ist sie aus, wird sie angeschaltet

 

"SetOutput" : Die LED wird eingeschaltet

 

"ClearOutput" : Die LED wird ausgeschaltet

 

 

Wird ein Port des Arcaze als Ausgang benutzt, und "Eingeschaltet", dann liegen da ca 3,2V an. Das ist wichtig, damit du den Vorwiderstand der LEDs berechnen kannst.

925390512_ArcazeBeispiel2.jpg.fa2ac5a11b4789984741f45c27486c64.jpg


Edited by Hakon
Korrektur bei der Voltzahl
Link to post
Share on other sites

Hallo Hakon

Finde ich gut, das du fuer den Arcaze einen neuen Thread eroeffnet hast.

Wie ich sehe hast du den Fehler mit den 5 Volt bereits korrigiert.

 

Mich wuerde es denoch interessieren, woher du denn die Anleitung fuer die Belegung mit den Led`s hast?

 

Sowie es aussieht hat Stepan mit den Led Boards Fortschritte gemacht. Preislich sollen die Boards unter dem Preis eines Arcazes angesiedelt werden.

 

Gruesse

toyojoe


Edited by toyojoe
Link to post
Share on other sites

Das mit den LEDs hab ich durch ausprobieren und vor allem Nachfragen bei Stephan raus gefunden. Bin gerade dabei mein kleines Pult zu konfigurieren. Ich bin schon soweit, das mein Teilchen ZB beim druecken auf den "Moving Ground Target"-Knopf die "A/A" LED ausschaltet und die "Moving Ground Target" LED ein, oder beim druecken des Resetknopfes alles betreffenden LEDs ausschaltet.

 

Nur das Problem, das die "A/A HO" LED nur angehen soll, wenn die "A/A"-LED schon leuchtet habe ich noch nicht geloest.. werde da mal beim Stephan im Forum nachfragen..

 

 

unten ein Bildchen von der ersten Haelfte meine SimptLight

Simpitlight.thumb.jpg.3ba27f71b97b24484930ee2003359aef.jpg

Link to post
Share on other sites

Alle Achtung.

Sieht Spitzenmaesig aus.:thumbup:

 

Hast du fuer die Drehschalter Drehencoders genutzt?

Wie hast du denn mehrere Befehle einprogrammiert.

Ich selbst benutze dazu einen mehrstufigen Schalter. Der verbraucht aber alleine schon 8 Tastaturbefehle.

 

Wie weit bist du denn mit der moeglichkeit Daten aus BS auszulesen?

 

Wir koennten, wenn ich irgendwann zum Panelbau komme, mal unsere Arcaze Belegungen austauschen.

 

Gruesse

toyojoe

Link to post
Share on other sites

Ich habe Encoder benutzt, die kann man beim Arcaze ja als Drehknopf anlegen. Ein Drehknopf belegt 2 Eingaenge und man kann einen Befehl fuer "links-rum" und einen fuer "rechts-rum" eingeben.

 

Ich habe bei Pollin guenstige Encoder mit eingebautem Drucktaster bekommen, also habe ich bei dem Abris-Drehknopf die Funktionalitaet wie im Original. Bei anderen Drehknoepfen werde ich den Drucktaster dann mit "Pause" und "ESC" belegen, dann kann ich die Tastatur ganz beiseite legen.

 

Leider muss ich noch ein wenig sparen, da ich noch 3 Arcaze-Karten brauche, bis ich alle Schalter verkabelt habe. In dem ganzen Ding steckt im Moment nur eine Karte. Das heisst, die Haelfte der Schalter ist noch gar nicht angeklemmt. Von meinem zweiten Pult (noch nicht lackiert und der Seitliche Stromanschluss fehlt noch) ganz zu schweigen.

 

So wies bisher aussieht, gibt es derzeit keine Moeglichkeit die Daten, die ich haben will auszulesen, deswegen hab ich das Thema bisher nicht weiter verfolgt....


Edited by Hakon
umlaute korrigiert
Link to post
Share on other sites
  • 2 weeks later...

Hallo Hakon

Bin zur Zeit am verkabeln des Panels fuer IL2. Darin sind die Trimmung und die Flaps per Poti angeschlossen. Moechte diese nun an den Arcaze anschliessen.

Es sind also 4 Potis anzuschliessen.

Das Video auf simple-solution ist ja eigentlich selbsterklaerend.

 

Jedoch habe ich eine Frage zur Spannung die angelegt weden soll (oder Fehler in der Anleitung?).

 

Original Text

"Maximal 6 analoge Quellen sind anschliessbar, sie sind benannt mit AIN0 bis AIN5, bzw. A0-A5.

Jedes Poti hat 3 Anschluesse, die beiden Enden der Kohlebahn aussen und den Schleifer in der Mitte. An der Schleifbahn soll eine Spannung angeschlossen werden, an derwub.gif

 

leider hoert der Text hier auf.

 

 

 

Da du du mittlerweile mein Arcaze Guru bist

worthy.gif hoffe ich du kannst mir weiterhelfen.

 

 

Gruesse

Joerg


Edited by toyojoe
Link to post
Share on other sites

Eine extra Spannung musst du nicht anlegen. Bei meinen Ex-DIY-Pedalen hab ich das Poti einfach wie in dem Video angeklemmt und gut iss. Also, nur die 3 Ausgaenge des Potis wie beschrieben mit den 3 Pinnen eines Analogen Einganges verbinden und wenns in die Falsche Richtung geht, die beiden aeusseren vertauschen. Sollte klappen.

 

Allerdings musst Du beim Konfigurieren ja drauf achten, das das erste Geraet ein Keyboard sein muss und das Poti muss ueber ein Analoges Gamepad konfiguriert werden.

 

Arcaze Guru.... wenn das der Herr Schirrmann hoeren wuerde....

Link to post
Share on other sites

Hallo Hakon

 

Vielen Dank fuer die Info.

 

Habe die letzten Tage etwas zu viel Qualm beim loeten eingeatmet.

Im Moment ist erst mal Baustopp ( kein Bock mehr !!!!). Werde aber versuchen am Wochenende die Potis anzuklemmen.

 

Gruesse

toyojoe

Link to post
Share on other sites
  • 6 months later...

Hallo

Irgendetwas läuft immer nicht.pilotfly.gif

 

Nachdem der Einbau des 19 Zoll Abris abgeschlossen war, habe ich in der Bedienkonsole die zwei Schalter gegen Drehencoder ausgetauscht.

 

Diese werden auch im Arcaze erkannt. Jedoch wenn ich zb. die Helligkeit am Abris einstellen will, zeigt er in Wordpad 90909090 an. Das gleiche zeigt er in die andere Drehrichtung auch an.

 

Meine Einstellungen in Arcaze sind Teiler=1

(alles andere funktioniert nicht)

Pulsweite=1

Periodendauer=2

Einstellungen daran ändern nicht viel.

 

Angeschlossen habe ich ihn laut Plan unter SImple Solution (GND) Wollte das ganze dort auch posten, kann mich aber im Moment nicht einloggen????

 

Grüße

toyojoe

Link to post
Share on other sites

Hallo Hakon

Bin mir ziemlich sicher, das ich die Encoder richtig angeschlossen habe.

Hatte extra unter Simple Solution nachgeschaut.

Bei meinen Encodern ist Gnd auch nicht in der Mitte.

Werde aber trotzdem die Verkabelung nochmals überprüfen.

 

Encoder sind übrigens von der Bucht.

 

Grüße

Jörg

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...