Jump to content

Problem with Warthog Throttle


Jg2001_Rasputin
 Share

Recommended Posts

I don t remember to have to put the serial too.

There no fix to a brick but to send it to thrustmaster, they pay the trip, or send you a only the throttle mobo if you wish.

the best way to prevent it, and TM doesn t say it does prevent it, but number of issues have diminished up to zero for now, is to go to the site, download the latest target, latest drives and upgrade the Throttle to 2.0 and stick to 1.1, then install target.

Also check for the calibration program some seems to have come a little out of calibration almost nothing, but that make you almost hit.

HaF 922, Asus rampage extreme 3 gene, I7 950 with Noctua D14, MSI gtx 460 hawk, G skill 1600 8gb, 1.5 giga samsung HD.

Track IR 5, Hall sensed Cougar, Hall sensed TM RCS TM Warthog(2283), TM MFD, Saitek pro combat rudder, Cougar MFD.

Link to comment
Share on other sites

  • Replies 317
  • Created
  • Last Reply

Top Posters In This Topic

  • 4 weeks later...

My thorttle bricked today... 4/23/11.....

 

 

right after the new firmware. Which i was not aware of until today. A day too late...

 

 

ASUS motherboard with intel chip user.

 

 

Im boned... Sent TM this:

 

 

I have bought this system and it worked like a charm up until today 4/23/11

 

I plugged in both the stick and throttle and the throttle went unrecognized by my PC.

 

The 5 lights turn on and then i get the unknown device message. I googled the problem and found that it is an issue with your product and the compatibility with ASUS motherboards, which i have.

 

I live in NYC, and do not think its a good idea to ship this all the way to France for a replacement just for the same thing to happen again, unless you are shipping out a fixed version that will guarantee me my throttle function.

 

Yes, i have tried booting up with the engage disengage and LG silence buttons pressed down for 5 seconds, no change.

 

Yes, i have completely uninstalled the drivers, and reinstalled the NEW drivers which have been just recently released.

 

Yes, i have plugged in the device into other USB ports in my PC to no avail, INCLUDING trying to connect the device to another computer with no difference.

 

Please dont tell me I just wasted 500$ for a few days fun... Life is hard as it is paying bills every month.

 

 

 

 

Lets see what they say...

Link to comment
Share on other sites

Hope for the best buddy. what was your serial ?

HaF 922, Asus rampage extreme 3 gene, I7 950 with Noctua D14, MSI gtx 460 hawk, G skill 1600 8gb, 1.5 giga samsung HD.

Track IR 5, Hall sensed Cougar, Hall sensed TM RCS TM Warthog(2283), TM MFD, Saitek pro combat rudder, Cougar MFD.

Link to comment
Share on other sites

I have noticed that with the leds enabled, the slider THR_FC thingy will jump back and forth between settings, not much but enough to cause problems ingame, especially if I have zoom mapped to it, as it will then auto zoom in and out a little touch by itself constantly.

 

If the leds are disabled then no such problem exists, its obviously interference coming from the led's/led power wires, but it is annoying and something I wouldnt of expected with something that cost so much.

 

I am in touch with thrustmaster atm to see what can be done, but after telling them I am using the latest firmware and the latest target, they told me to install the latest target and make sure I am using the latest firmware, huh, I already told them I was in my email.

 

Anyway, I will go through the rigmaroll of reinstalling target and doing what they said in the email and then I will reply to them, but I have a feeling that unless I wanna keep my throttle but never have the leds enabled I will have to send it back to them to get fixed.

Link to comment
Share on other sites

  • 1 month later...

fixed hotas

 

I had my throttle broke down this weekend too, when i plugged it in, it said incorrect steering program, and the sound you normally hear when plugging in an usb device (the "ding-dong" sound) was replaced by three short "dong" sounds, all lights were dead and it wouldn't show in TARGET. Following the instructions from sofie_59 on page 10 from this thread fixed my problem.

 

Just ran the http://ts.thrustmaster.com/eng/index...&pid=311&cid=1 file, and proceeded with Firmware Update. Lights went on and everything showed in target again. Happy as can be!

 

Hope this works for others who still suffer problems with TM hotas!

Link to comment
Share on other sites

I had my throttle broke down this weekend too, when i plugged it in, it said incorrect steering program, and the sound you normally hear when plugging in an usb device (the "ding-dong" sound) was replaced by three short "dong" sounds, all lights were dead and it wouldn't show in TARGET. Following the instructions from sofie_59 on page 10 from this thread fixed my problem.

 

Just ran the http://ts.thrustmaster.com/eng/index...&pid=311&cid=1 file, and proceeded with Firmware Update. Lights went on and everything showed in target again. Happy as can be!

 

Hope this works for others who still suffer problems with TM hotas!

 

Glad that i could help :)

MB:MSI X79A-GD45

CPU:Intel Core i7 3930K 3.2GHz

Ram:16 gb

Grafik :GTX 680 Sli

Win 7 64 bit

1200 W

2 ssd 120 gb

1 2 TB western Digital Caviar Green

Link to comment
Share on other sites

  • 5 weeks later...

Well..My throttle died yesterday (7-24-11) after 2 months working flawlessly...yes..Asus and Intel..tried all the tricks I've read here (and elsewhere) and on my 2nd email go around with TM. I noticed the last post here was a month ago....has anyone else had trouble since then or am I just on the wrong thread?

Thanks

Link to comment
Share on other sites

Awesoem MuthFuDark eagle.. rep inbound for the link...

  • Like 1

HaF 922, Asus rampage extreme 3 gene, I7 950 with Noctua D14, MSI gtx 460 hawk, G skill 1600 8gb, 1.5 giga samsung HD.

Track IR 5, Hall sensed Cougar, Hall sensed TM RCS TM Warthog(2283), TM MFD, Saitek pro combat rudder, Cougar MFD.

Link to comment
Share on other sites

  • 4 years later...

My New Warthog Throttle had only been used for two days ONLY and stopped

working. I get a "USB device not recognised" message every time I plug

into a USB port on the PC. Joystick and Pedals work fine. HELP !!!

 

I cant get the "Throttle Bulk Driver" thing to work at all either ????

 

6-25-2016%2012-23-15%20PM%20%20Throttle_zps9kocupxv.jpg

Link to comment
Share on other sites

My New Warthog Throttle had only been used for two days ONLY and stopped

working. I get a "USB device not recognised" message every time I plug

into a USB port on the PC. Joystick and Pedals work fine. HELP !!!

 

Sounds like it is bricked unfortunately, rare but does happen on occasion. I would think you should be able to get a replacement from where your purchased from if it is that new.

Don B

 

My VKB Gunfighter MK III Pro L Review

EVGA Z390 Dark MB | i9 9900k CPU @ 5.2 GHz | EVGA RTX 3090 FTW3 Ultra | 32 GB G Skill Trident Z 3200 MHz CL14 | Corsair H150i Pro Cooler |VKB GF MK III Pro L Ultimate Grip| Virpil CM3 Throttle |Reverb G2 | Valve Index| Vive Pro 2 |

Link to comment
Share on other sites

try updating the firmware from another PC. I had mine stopped working then went to my sister's PC and it came alive again.

[sigpic]http://forums.eagle.ru/signaturepics/sigpic4448_29.gif[/sigpic]

My PC specs below:

Case: Corsair 400C

PSU: SEASONIC SS-760XP2 760W Platinum

CPU: AMD RYZEN 3900X (12C/24T)

RAM: 32 GB 4266Mhz (two 2x8 kits) of trident Z RGB @3600Mhz CL 14 CR=1T

MOBO: ASUS CROSSHAIR HERO VI AM4

GFX: GTX 1080Ti MSI Gaming X

Cooler: NXZT Kraken X62 280mm AIO

Storage: Samsung 960 EVO 1TB M.2+6GB WD 6Gb red

HOTAS: Thrustmaster Warthog + CH pro pedals

Monitor: Gigabyte AORUS AD27QD Freesync HDR400 1440P

 

Link to comment
Share on other sites

  • 1 year later...

Joining the club. Had been using TM Hotas Warthog since january 2017 without problems until now. Windows simply doesnt recognize throttle, it just flashes those 5 leds and its dead brick. Stick and everything else USB peripheral is working just fine, and i've tried different USB ports. Tried to reinstall drivers, software etc. and tried to reset throttle firmware doing that autopilot & L/G warning button press thing but nothing helps. Windows just doesnt recognize the throttle no matter what i do. Could it be possible that the wire is broken? If its broken, would it flash those 5 leds? For reasons i cannot try it with another computer now. Fortunately theres still warranty left and i have backup (Saitek x52) throttle.

Link to comment
Share on other sites

Joining the club. Had been using TM Hotas Warthog since january 2017 without problems until now. Windows simply doesnt recognize throttle, it just flashes those 5 leds and its dead brick. Stick and everything else USB peripheral is working just fine, and i've tried different USB ports. Tried to reinstall drivers, software etc. and tried to reset throttle firmware doing that autopilot & L/G warning button press thing but nothing helps. Windows just doesnt recognize the throttle no matter what i do. Could it be possible that the wire is broken? If its broken, would it flash those 5 leds? For reasons i cannot try it with another computer now. Fortunately theres still warranty left and i have backup (Saitek x52) throttle.

 

 

 

Sadly, I too have joined the club this week (after 3+ years of use). I went through the exact same troubleshooting procedure (on multiple pcs, win10 & win7) with identical results. NahkaSukka, are you running windows 10? I started having issues after installing the most recent win10 update (which included more system reboots than usual). I'm curious if there was something special about that update which interfered with USB power management.

Link to comment
Share on other sites

Sadly, I too have joined the club this week (after 3+ years of use). I went through the exact same troubleshooting procedure (on multiple pcs, win10 & win7) with identical results. NahkaSukka, are you running windows 10? I started having issues after installing the most recent win10 update (which included more system reboots than usual). I'm curious if there was something special about that update which interfered with USB power management.

 

Windows 7 64bit. Seems like most people who have this problem have Windows 8 or 10.

Link to comment
Share on other sites

Yea I had this 6 months ago was a blown control board in the throttle. Unfortunatley it took 2 months to get the replacement but that did fix it.

 

Sent from my SM-G955U using Tapatalk

I7 3930 4.2GHz ( Hyperthreading Off), GTX1080, 16 GB ddr3

Hotas Warthog Saiteck Combat Pedals HTC Vive, Oculus CV1.

 

GTX 1080 Has its uses

Link to comment
Share on other sites

  • 3 months later...

Warthog throttle boat switch

 

Good Morning all,

 

I am new to the forums and relatively new to DCS. I have had my Warthog since late January 2016. About three days ago I noticed that the boat switch is not responding every time I use it. It seems that the harder I press it down while moving it will make it work but without the additional pressure it is very hit or miss. I have written to Thrustmaster support but have not heard anything back from them yet. I did open the right throttle and blow it out using some compressed air but it was not helpful. I removed a small screw on the board itself but could not get the board to come lose with normal pressure and I was afraid of damaging it further so I stopped at that point. I am not experienced with soldering but am willing to learn if I need to. I need to know if anyone knows how to replace the boat switch and what is involved.

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...