Jump to content

DCS: How to gain performance on Windows Vista (Windows 7)


Recommended Posts

Dear PE Tigar ... with respect to your working with PC's for years, I must disagree and display my shock that you would encourage people to not use antivirus software... If you do not browse the web, never download anything, and never get email, and are not hooked up to a network where any of those things happen, then sure, you don't need antivirus. BUT the simple act of hitting a web site that tells you to install a codec is enough to get infected. You don't have to do something stupid to get infected. And there are so many types of virus; ones that steal your information, ones that use your computer to perform attacks, ones that try to destroy your system ... you might be infected and not even know it... and it's more about the world of virus ... if everyone had anti-virus programs that were regularly updated, then these massive infections we all see every few months would not happen. That is why anti-virus companies are glad to give free software to home users, so they can reduce the potential of infections spreading.

 

In short, using a computer that is connected to the internet and not using anti-virus is pretty similar to having sex without a condom with whoever shows up in the truck-stop bathroom. Not only are you putting yourself at risk, but you are increasing the risk for the rest of us.

 

I used to use AVG but now I have been using Avast! for the past few weeks and it seems effective, seems pretty fast and does not get in the way. Both have free versions for home users.

 

And btw, I personally feel that Norton Anti-Virus (which is possibly what you have in your "centrally managed" system at your work) is more like a virus than an anti-virus. Norton is not symbolic of the rest of the anti-virus world.

  • Like 1

2600K @ 4.2GHz, MSI P67A-GD55, 16GB G.Skill @2133 , GTX 970, Rift, SSD boot & DCS drive

[sIGPIC][/sIGPIC]

Link to post
Share on other sites
Hi,

I downloaded and used Jesse's program for about a week which worked great and was easy to use. Today i found it was deleted from my windows and wheni tried to re download it my AVG anti virus kept reporting a virus and would not allow to overide it. I see on Jesse's page that this might be a false reporting problem with some anti virus softeware. Any one else have this problem and a work around, as it is so good i want to keep using it? !

thanks

drummer

 

I'm using the latest AVG Free with the latest virus database update here, on Vista 64 bit. I just ran BS using Jesse's Affinity tool without a hitch.

 

I would say it is worth making sure that you have AVG updated with the latest version of the AVG executable as well as the latest version of the virus database. (2 very different things).

[sIGPIC][/sIGPIC]

There's no place like 127.0.0.1

Link to post
Share on other sites

In this situation I recommend you use Virustotal to have it scanned with almost 40 other anti viruses and draw a conclusion from that. I scan with it after every release so it will tell you the results of the last scan that I did on the 26th of January.

 

I personally feel that Norton Anti-Virus is more like a virus than an anti-virus.

QFT


Edited by Jesse

Link to post
Share on other sites
I'm using the latest AVG Free with the latest virus database update here, on Vista 64 bit. I just ran BS using Jesse's Affinity tool without a hitch.

 

I would say it is worth making sure that you have AVG updated with the latest version of the AVG executable as well as the latest version of the virus database. (2 very different things).

 

Hi thanks for your suggestion. I have searched the AVG website but can't find any updated exe files, do you know where I might be able to get it? I have the virus data base updated daily.

thanks

drummer

Link to post
Share on other sites
Hi thanks for your suggestion. I have searched the AVG website but can't find any updated exe files, do you know where I might be able to get it? I have the virus data base updated daily.

thanks

drummer

 

Do a manual update within AVG's controls. If it gives you anything, do another manual update. Repeat until it doesn't give you any new updates. Once you've done that, you should be up to date on both the virus database, and the executable. (You may be already, but it is worth checking).

[sIGPIC][/sIGPIC]

There's no place like 127.0.0.1

Link to post
Share on other sites
Do a manual update within AVG's controls. If it gives you anything, do another manual update. Repeat until it doesn't give you any new updates. Once you've done that, you should be up to date on both the virus database, and the executable. (You may be already, but it is worth checking).

 

 

Thanks Cy, that seemed to work. I kept updating until i could update no more and it has now stopped reporting it as a virus! Great!

I do like Jesse's script as it is functional, easy and pretty, so hats off to him to.

Thanks again Cy

drummer:drunk:

Link to post
Share on other sites

...just 2 Scanners still report as virus - avast corrected its false positiv.

 

virusscanriru.jpg

 

Greets

S@uDepp

// Hasi @4,5 GHz @ H100i // Asrock Z87M Extreme 4 // Avirex 4x4GB // PALIT 1070 GTX SuperJetStream // Corsair 350D // Plextor extern // DELL 2407WFP // Razer Lancehead // 2xThrustmaster T.16000M + Saitek Pedals Pro // Oculus Rift // 3x amBX // Win10 Pro x64

Link to post
Share on other sites
I personally feel that Norton Anti-Virus (which is possibly what you have in your "centrally managed" system at your work) is more like a virus than an anti-virus.

 

I can't agree more. Norton A/V is virus for witch you pay.

 

I use ESET Nod32 A/V and it doesn't cause me any trouble while playing (and I don't have fast computer).

Gigabyte Z490 Gaming X | i5 10600K@4700 | 32 Gb DDR4 @ 3200Mhz | Gigabyte Aorus GeForce GTX 1080 Ti 11G |

MONITOR IIYAMA 24,5" LED LCD @ 1920 x 1080 | Windows 10 64 bit Pro | Saitek X-55 Rhino | TrackIR 5 Pro
Link to post
Share on other sites
I can't agree more. Norton A/V is virus for witch you pay.

 

I use ESET Nod32 A/V and it doesn't cause me any trouble while playing (and I don't have fast computer).

 

 

True. Good friends don't tell good friends to use Norton anyway. :smilewink:

Gigabyte GA-Z87-UD3H | i7 4470k @ 4.5 GHz | 16 GB DDR3 @ 2.133 Ghz | GTX 1080 | LG 55" @ 4K | Cougar 1000 W | Creative X-Fi Ti | TIR5 | CH HOTAS (with BU0836X-12 Bit) + Crosswind Pedals | Win10 64 HP | X-Keys Pro 20 & Pro 54 | 2x TM MFD

Link to post
Share on other sites

Most false positives and slowdowns come from heuristic analysis, which tries to detect unknown possible virus. The funny thing that it often identifies legit programs as malware and still lets true malware to slip through. I tend to turn heuristics off, as its provided additional security isn't worth for me the resources it eats.

Wir sehen uns in Walhalla.

Link to post
Share on other sites
  • 4 weeks later...

Yep worked a treat on my system also.

 

Custom Built

Quad Core Q9550 2.8ghz

2 x 8800 GTX 768MB GFX Cards in SLI

Galaxy 1000watt PSU

Striker Extreme MB

4Gig RAM

 

Sweet as...

 

Mithandra

Custom built W10 Pro 64Bit, Intel Core i9 9900k, Asus ROG Maximus Code XI Z390, 64GB DDR4 3200 RGB, Samsung 1TB NVme M.2 Drive, Gigabyte AORUS 2080TI, 40" Iiyama Display. Wacom Cintiq Pro 24, HOTAS Virpil T50 Stick / FA-18C TM Stick and Virpil T50 Throttle, MFG Crosswind Graphite Pedals. HP Reverb

 

SPECTER



[sIGPIC][/sIGPIC]

 

Lead Terrain Developer / Texture Artist

Link to post
Share on other sites

Just want to thank the guys who developed these tools.

Added massive playability to the game especially over cities:thumbup:

added at least 30fps with Jessies app,

 

Vista ultimate sp1

P5N32-E SLI

2.40 gigahertz Intel Core 2 Duo

8800 GTX

2Gb RAM

DELL 2407WFP

1920x1200 native res.

TY:book:

i5 8600k@5.2Ghz, Asus Prime A Z370, 32Gb DDR4 3000, GTX1080 SC, Oculus Rift CV1, Modded TM Warthog Modded X52 Collective, Jetseat, W10 Pro 64

[sIGPIC][/sIGPIC]

Link to post
Share on other sites

Mate of mine has just tested this with his setup (havent confirmed this with mine yet but he said when using the gui based one trackIR does not work.

 

Anyoine else experienced this?

 

Mithandra

Custom built W10 Pro 64Bit, Intel Core i9 9900k, Asus ROG Maximus Code XI Z390, 64GB DDR4 3200 RGB, Samsung 1TB NVme M.2 Drive, Gigabyte AORUS 2080TI, 40" Iiyama Display. Wacom Cintiq Pro 24, HOTAS Virpil T50 Stick / FA-18C TM Stick and Virpil T50 Throttle, MFG Crosswind Graphite Pedals. HP Reverb

 

SPECTER



[sIGPIC][/sIGPIC]

 

Lead Terrain Developer / Texture Artist

Link to post
Share on other sites

No BS registry entries ?

 

Hi can anyone :helpsmilie:? When I try to launch Affinity I get an error message saying "Could not detect Black shark registry entries" now am I missing something simple or am I just being thick:dunno:. by the way I have PriFinitty up and running which is ok but I would like to try Affinity to see which one is best.

 

Many thanks

Float like a butterfly, sting like a bee



Muhammad Ali-(Cassius Clay)

[sIGPIC][/sIGPIC]

Link to post
Share on other sites

Hey,

 

Thank you so much for tools like Affinity.

My DCS is running nearly twice as fast than normal using Affinity on an Intel Core 2 Duo E6700.

 

Since DCS is mainly CPU dependant I wonder what will happen if I upgrade to a quadcore CPU or to the new i7-CPUs from Intel with up to 4 physical and 4 virtual cores.

 

What performance gain may I expect? Is there any at least? How will the frame rate change if I double the cores? Will DCS benefit from more than 2 cores at all?

 

Thanks :)

Kind regards,

JaBoG32_Chrissi

Link to post
Share on other sites
When I try to launch Affinity I get an error message saying "Could not detect Black shark registry entries"

 

It only looks for one registry key that describes where you installed the game to:

 

32 Bit Vista or Win7:

HKEY_LOCAL_MACHINE\SOFTWARE\Eagle Dynamics\BlackShark\Path

64 Bit Vista or Win7

HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Eagle Dynamics\BlackShark\Path

If you don't know what the hell I'm talking about, just PM me the following:

 

  1. OS Type (32 bit / 64 bit)
  2. Where DCS is installed. (e.g C:\Program Files\Eagle Dynamics\Ka-50)

I will create a registry key that you can import into your registry and potentially fix the problem in one or two clicks.

Link to post
Share on other sites
Uploaded 2.1.2 with a couple of fixes:

 

  • 8 core/thread support.
  • Fixed issue causing TrackIR window to disappear / not launch correctly.

http://code.google.com/p/dcsbsaffinitytool/

 

Found it yesterday by accident :D

 

T

H

X

 

Keep up the good work!

 

Greets

S@uDepp

// Hasi @4,5 GHz @ H100i // Asrock Z87M Extreme 4 // Avirex 4x4GB // PALIT 1070 GTX SuperJetStream // Corsair 350D // Plextor extern // DELL 2407WFP // Razer Lancehead // 2xThrustmaster T.16000M + Saitek Pedals Pro // Oculus Rift // 3x amBX // Win10 Pro x64

Link to post
Share on other sites
  • 1 month later...

I really wonder that it was not posted in this thread before....:

 

Go to your Blackshark\Blackshark\data\scripts folder and open the options.lua

 

Make a backup first!

 

Change(red marked):

 

(look at the end of the file)

       }, -- end of ["display_mode"]
[color=Red]        ["effects"] = 3,
       ["lights"] = 2,[/color]
       ["haze"] = 0,
       ["terrPrld"] = "40",
       ["height"] = 1024,
       ["resolution"] = "1280x1024",
       ["civTraffic"] = 1,
       ["width"] = 1280,

To:

 

       }, -- end of ["display_mode"]
[color=Red]        ["effects"] = 2,
       ["lights"] = 1,[/color]
       ["haze"] = 0,
       ["terrPrld"] = "40",
       ["height"] = 1024,
       ["resolution"] = "1280x1024",
       ["civTraffic"] = 1,
       ["width"] = 1280,

This gives me a boost of 20-50 fps(depends on mission and if shkval is on or off) and I now can use much higher settings then before!

(Even with my crappy rig(see in my signature) I now have 25+ fps in all situations, with higher settings then before)

 

What it does is, turning off some volumetric lights and reduce and/or turning off some dust( i.e. when flying at low altitude)

 

Backup first!

 

Works for all windows versions.


Edited by Duke49th
Link to post
Share on other sites
Stop using antivirus software. I've been using PCs since 1994, building PCs since 1998, never used antivirus software, never had a virus. My main problem in my work PC is the centrally managed antivirus, it's intrusive and blocks completely random stuff left and right...

 

Wow. That has to be the crappiest advice I have ever seen someone give anyone, anywhere. I really hope no-one at your work goes to you for computer advice. If your in IT , I really feel for your company.

Link to post
Share on other sites

I'd try setting haze back to 1. Take a look at the Shooting Range mission with and without it. Without haze it looks pretty messed up! Use an external view and zoom way out. A lot of the ground seems to get covered in an odd fog without haze on.

 

Effects 1 looks good enough to me, considering the FPS boost it gives in combat!

 

And I've been playing with lights = 0 for a while now and haven't noticed any problems. Maybe at night, though, the lack of dynamic lights becomes a problem. Too bad they hurt the framerate so much!

 

I think I was CPU-limited in XP, but under Vista with the affinity fixed it seems to run as fast as my GPU will let it, so these options tweaks are really helping me have a smooth time :)

Link to post
Share on other sites
Uploaded 2.1.2 with a couple of fixes:

 

  • 8 core/thread support.
  • Fixed issue causing TrackIR window to disappear / not launch correctly.

http://code.google.com/p/dcsbsaffinitytool/

 

 

Im a rookie with Black Shark, since yesterday.

Im trying to get it running nicely with my E8600 cpu.

 

But when i try the link of Jesse,

i got an Google Error;

 

Forbidden

 

Your client does not have permission to get URL /p/dcsbsaffinitytool/ from this server.

 

 

 

Is there another way, to get dcsbaffinitytool 2.1.2 ?

Thanks

Asus ROG Maximus X HERO | I7 8700k @ 5.1Ghz | Corsair Vengeance 32GB DDR4-3200 | Samsung 960 PRO m2 1TB | ASUS GeForce GTX 1080 Ti Strix OC Gaming 11G

Tagan TG900-BZ PipeRock 900W | Oculus Rift CV | TM Warthog #67074 | Saitek Pro Flight Combat Rudder Pedals | Windows 10 Enterprise x64

Link to post
Share on other sites
Im a rookie with Black Shark, since yesterday.

Im trying to get it running nicely with my E8600 cpu.

 

But when i try the link of Jesse,

i got an Google Error;

 

Forbidden

 

Your client does not have permission to get URL /p/dcsbsaffinitytool/ from this server.

 

 

 

Is there another way, to get dcsbaffinitytool 2.1.2 ?

Thanks

 

DCS Max

 

http://forums.eagle.ru/showthread.php?t=39261&highlight=DCS+MAX

Novice or Veteran looking for an alternative MP career?

Click me to commence your Journey of Pillage and Plunder!

[sIGPIC][/sIGPIC]

'....And when I get to Heaven, to St Peter I will tell....

One more Soldier reporting Sir, I've served my time in Hell......'

Link to post
Share on other sites

Thank you

Asus ROG Maximus X HERO | I7 8700k @ 5.1Ghz | Corsair Vengeance 32GB DDR4-3200 | Samsung 960 PRO m2 1TB | ASUS GeForce GTX 1080 Ti Strix OC Gaming 11G

Tagan TG900-BZ PipeRock 900W | Oculus Rift CV | TM Warthog #67074 | Saitek Pro Flight Combat Rudder Pedals | Windows 10 Enterprise x64

Link to post
Share on other sites
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...