Jump to content

Windows 7 Beta and Star Force


RobDog
 Share

Recommended Posts

Just wanted to let anyone considering the Windows 7 beta know that Star Force does not recognize the new O.S. and states that it does not meet the minimum requirements for Lock On Flaming Cliffs.

 

I have sent an email and error log to Star Force to inform them.

 

Rob

Link to comment
Share on other sites

Sure did PCat. I'm a pc tech by day and an aircraft nut the rest of the time. Tried Compatibility mode on both the main Loc On exe and the Protect.exe that StarForce uses.

 

I found a post on a forum stating that I could play Lock on if I installed the 1.01 - 1.02? patch over the Flaming Cliffs 1.12B. It works but I'm not sure HyperLobby will pass it for multiplay.

 

I've recieved a reply from Star Force on the issue, but they sent me a cookie cutter "try this" email that was written for Vista users to update thier version of Star Force Protection.

 

I have replied explaining "again" that the problem is specific to Windows 7 because it does not recognize Windows 7 as a compatible version of windows.

 

I'll keep everyone up to speed as things go, but with Win 7 being beta I'm not sure how fast they will move on it.

 

Thanks,

Rob

Link to comment
Share on other sites

I think the 1.12b patch, or whatever the Vista one is called, is specifically for Starforce. Meaning Starforce needs an update to recognize Vista. If I'm right, I'm not surprised it doesn't work with Windows 7. I'm surprised the fix you found worked, I would assume you'd just be totally screwed. :(

Link to comment
Share on other sites

...I found a post on a forum stating that I could play Lock on if I installed the 1.01 - 1.02? patch over the Flaming Cliffs 1.12B. It works but I'm not sure HyperLobby will pass it for multiplay....

 

Yeah, sadly I can confirm that the Starforce drivers included with LOFC & Patch 1.12b will not recognize Windows 7 Beta1 as a configurable OS. I've read somewhere that any version of Starforce before 3.5 won't work. I've tried using sfdrvup.exe (Starforce driver update utility) after removing the old starforce drivers with sfdrvrem.exe utility, but without any success using any of these methods.

 

I've also read that copying and pasting the entire folder from a previous install on Vista worked for some games, but I don't see the point. Perhaps you might try that.

 

Rerunning the 1.02 patch basically downgrades your LOMAC from 1.12 or 1.1 back to 1.02 if you've applied Flaming Cliffs or the 1.12 patch. Since 1.02 has no Starforce protection, you can run LOMAC (which is why this works). This means that you won't be able to connect to anyone who's on a 1.1 or 1.12 server.

 

So, the ball's in Star Force and ED's court, for the time being. Whether they want to do anything about it (rapidly, slowly, or not at all) remains to be seen. Hope you have a dual-boot! :doh:


Edited by Rhen
Link to comment
Share on other sites

Yeah, sadly I can confirm that the Starforce drivers included with LOFC & Patch 1.12b will not recognize Windows 7 Beta1 as a configurable OS. I've read somewhere that any version of Starforce before 3.5 won't work. I've tried using sfdrvup.exe (Starforce driver update utility) after removing the old starforce drivers with sfdrvrem.exe utility, but without any success using any of these methods.

 

I've also read that copying and pasting the entire folder from a previous install on Vista worked for some games, but I don't see the point. Perhaps you might try that.

 

Rerunning the 1.02 patch basically downgrades your LOMAC from 1.12 or 1.1 back to 1.02 if you've applied Flaming Cliffs or the 1.12 patch. Since 1.02 has no Starforce protection, you can run LOMAC (which is why this works). This means that you won't be able to connect to anyone who's on a 1.1 or 1.12 server.

 

So, the ball's in Star Force and ED's court, for the time being. Whether they want to do anything about it (rapidly, slowly, or not at all) remains to be seen. Hope you have a dual-boot! :doh:

http://forums.eagle.ru/showthread.php?t=36145&page=3

Link to comment
Share on other sites

Dude, I know you can be spring loaded towards the "YOU'RE WRONG!" direction, but if you would just do me the courtesy of reading past the first sentence of my first post, you'll see that I addressed everything in your post above. :smartass:

Link to comment
Share on other sites

Here is the reply from Star Force:

 

Unfortunately, at this moment protection system is not compatable with Windows 7. We are planning to make drivers update in approximately 2 months starting from Windows 7 Beta 1 release.

 

Sorry for the inconveniences

 

Sounds like they intend on doing something which is encouraging.:)

 

I'll update as I get any on this.

 

BTW - With the exception of a couple of odd behaviours in I.E. 8, Win 7 is pretty darn cool. If you have a spare machine or don't mind messing with your main pc and reloading it, you should give it a try.

 

L8er,

Rob

Link to comment
Share on other sites

I think due to OS being beta 1 we will probably just have to wait a bit longer for SF to support. I am quite certain they eventually will. All in all I do not see a whole lot of difference between W7 and Vista. I do think it more what Vista could have been at launch. Not sure it is much different under the hood but I like it so far.

 

Out

Link to comment
Share on other sites

Better hurry with those mystical 1.13 patch :D

GAU-8/A Avenger / PGU-14/B API / PGU-13/B HEI/ LAU-68 rocket pods / 2× AIM-9 Sidewinders / 2× AGM-65 Maverick / 4× Mk20 Rockeye / ALQ-131 ECM / Two General Electric TF34-GE-100 turbofans

Link to comment
Share on other sites

  • 2 weeks later...
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...