Jump to content

Radeon, Freesync, 60fps cap...Possible?


Recommended Posts

HI guys,

This week I have had too much time on my hands and wanted to settle a curiosity. I have a 6800xt and use Track IR so I play all my flight sims with V-sync enabled to synchronise with my displays 60hz. However, I like to fly low now and then and if I hit a very highly populated area, Syria. I can get an odd fps drop and it naturally halves the rate down to 30fps.

So I tried enabling freesync "VRR" on the display and in Radeon and in Windows With enhanced sync, v-sync off in DCS and a Radeon chill cap of min=60 max=60, Thinking if I hit somewhere that causes a dip it will only drop to the low 50's for a second or two and will not be so noticable.

Am I wrong in thinking this should have been as smooth as V-sync 60hz? The result was bad, smoooth running for about 5-6 seconds and then a noticable 1/4 second pause on a loop the whole time. Similar appeared in another sim I use.

Am I missing something or is this normal?

Link to comment
Share on other sites

Hello,

We have the same card and it looks like the same goals in terms of where the focus is on.

Since I also use Track IR, Smoothness when panning is key for me too. I have a 32"4k Phillips which supports adaptive sync, if not mistaken down to 52 fps.

In the beginning I played around with different methods for the best result. At the end I settled on this.

Vsync Application controlled, Dcs Vsync on. 

Adrenaline setting for Monitor, adaptive sync.

 

Biggest contributions for smooth gameplaying is too keep fps 99% of all times  between 58-60fps based on the Graphic settings. So I give my card lots of headroom. Terrain Shaddows off and trees to 70% MSAA (only) 2x But I have view distance on Extreme. With the Harrier low level and with the tpod on is the benchmark (which puts my card very often to the limit and of course still sometime tanks my fps below the smoothest range)

Also very important is full screen, sometimes I need to alt Tab until I am sure its right otherwise the Smoothness is not there and fps are for some reason just outside the range...

 

The only  game that halfed  my fps sometimes because of vsync was red dragon wargame, but when alt tabbing twice it jumped back to 60. But forgot what setting I had back then... maybe vsync always on or so. I found it's best to let the game control vsync. Also tried fps cap and no vsync and lots of other settings but best smooth panning is with the settings for me like explained above...


Edited by HansPeter1981
Link to comment
Share on other sites

On 11/17/2021 at 5:46 PM, HansPeter1981 said:

Also very important is full screen, sometimes I need to alt Tab until I am sure its right

This bugs me since they changed the Full Screen behaviour a few patches ago. How on earth does one see the difference between real full screen and borderless (if real full screen even exist since then)?

Win10 Pro 64-bit, i7-4770K @ 4.5 GHz, Corsair H100i, AsRock Extreme4, ASUS Strix 1080Ti OC 11GB, 32 GB DDR3 G.Skill 2400. Monitors: LG 27GL850-B27 2560x1440 + Samsung SyncMaster 2443 1920x1200, HOTAS: Warthog with Virpil WarBRD base & hegykc MFG Crosswind modded pedals, TrackIR4, Oculus Rift S.

Personal Wish List: A6 Intruder, Vietnam theater, decent ATC module, better VR performance!

Link to comment
Share on other sites

I have tried over and over again to get this to work. I cannot get it to run limited to 60fps with Freesync enabled.

I dont use fullscreen because I enjoy DCE campaigns, running fullscreen can interfere with the little pop up progress windows that pops up. I have tried it with fullscreen enabled but the result was the same.

I have tried every version of settings I can think of, however its always the same. Smooth gameplay, pause, smooth gameplay, pause and so on. 5-7 seconds ok then a 1/4 second pause.

Disable any VRR and freesync, put V-sync on. Its still 60fps but smooth as butter.

I was trying to do this so I can turn a few settings up. DCS runs fine in the air with higher settings but when landing for example at Khasab as you go over the patch of trees the game understandably drops fps down to 55ish. With freesync this would not be noticeable.  With V-sync you get those few seconds when it forces a drops to 30fps. I know I am missing something but I cant think what. Its that or freesync at 60fps and flight sims just doesn't work as well as a fps game, I dont know.

Link to comment
Share on other sites

I also can not get FreeSync to work with my 4K screen and my RX5700XT, and limited to 60 (or 61) but, truth be told, it's an issue with other games as well (not just with DCS).

I use V-Sync ON (60FPS) because that's what results better for me (most smooth gameplay).

The funny part is that, with DCS, I feel I need to Alt+Enter until I am sure its right, especially when down there right over the trees - the improvement is noticeable after it.
And it always has been like that ever since DCS1.5, and across different GPUs, Nvidia and AMD.


Edited by LucShep

aka Luke Marqs; aka DucFreak -  my mods/files
LM transparent DCS icons_hs_LESSshdw - DEZ21.png
Win10 Pro x64 | i7 10700KF (all-core 4.9GHz OC) | 64GB DDR4 3466MHz CL16 (OC) | RX 5700XT 8GB | 1TB NVMe + 500GB SSD + 4TB TB HDD | MSI Z490-A Pro | 650w 80+Gold PSU (Seasonic GM)
55'' curved 4K Samsung NU8500 | M-Audio USB + Senn HD-599SE | VKB NXT stick + X52 Pro throttle | TrackHat w/ OpenTrack

 

Link to comment
Share on other sites

I might have just got this to work ok, but, I have not tested properly yet. Found it and gave it a quick test before I shut my gaming PC down.

DCS, full screen or not didn't matter. V-sync off, Freesync on with monitor and Radeon, also in Windows display settings.

Then in Radeon "global" graphics settings in the advanced drop down menu, "frame rate target control". I set it to 60fps. Had enough time to test a DCE mission in DCS and a quick mission in Sturmovik. It looked like it was ok, even with my Track IR. 

I'll test this more tomorrow. Its always a setting in a setting then hidden in a corner. 


Edited by Bossco82
Link to comment
Share on other sites

From my experience, using both AMD and Nvidia cards, DCS have issues with Full screen enforcing even though you mark it in Options.

When you load in a mission, enable fps monitoring (Rctrl+Pause), monitor the fps and then try to enforce Fullscreen with alt+enter. You should see noticeable difference when it changes to true full screen.

I don't know if this is only happening on my system (I have 3 screens but play only on 1) but it always helps me to get better fps results. I always play with Free/Gsync off and enforce Vsync to get rid of tearing.

I have 100Hz monitor but I enforce 60fps cap for DCS in drivers to reduce the overal drag on GPU, I do not need 100fps in DCS.

Just tested it, I had to hit alt+enter twice to get it working as expected.


Edited by Jumbik

Do, or do not, there is no try.

--------------------------------------------------------

Sapphire Nitro+ Rx Vega 64, i7 4790K ... etc. etc.

Link to comment
Share on other sites

Hi Guys,

I think I have got this sorted out. I've got an AOC U32E2N 4k monitor which has adaptive sync. However I also had a chance to try a LG 32QN600 1440p monitor that has freesync, my mates selling it for an upgrade.

As I use a AMD Radeon 6800xt, I wanted to keep my graphics settings up but avoid the very odd fps dips you can get when landing at a place such as Khasab. For about 2-3 second I can get a dip to 55fps just as you fly over the tree's. Now I have been a long term V-sync user, its always given me the smoothest experience with my Track IR.

So I tried the following V-sync=OFF in DCS and all VRR and Freesync settings set to ON in Windows and Radeon. Then I first tried to limit fps with Radeon Chill set to min=60 and max=60. I tried other numbers but it was always a jumpy stutter festival. I disabled chill and used the "autoexec" trick to limit fps to 60 in DCS itself. Same again more stutter and pauses. The GPU clock was also all over the place. However if you look in Radeon "Global Graphics", look for "Frame Rate Target Control" then set max fps to 60fps. So far for me this has worked with my Track IR and is even smoother than V-sync. I have even tried provoking stutters by flying low and moving my head around quickly. 

It also works fine with Sturmovik, U Boat, Sniper Elite, Battlefield and Call of Duty. V-Sync off in all games. The 60fps limit left to that setting in Radeon. The GPU clock is so much more stable as if it anticipates it needs to go faster. It happily fluctuates between about 65%-95% load.

If you have a Radeon GPU and a Freesync monitor something to try over the weekend maybe. It worked on the AOC adaptive sync too.

Link to comment
Share on other sites

17 hours ago, Jumbik said:

From my experience, using both AMD and Nvidia cards, DCS have issues with Full screen enforcing even though you mark it in Options.

When you load in a mission, enable fps monitoring (Rctrl+Pause), monitor the fps and then try to enforce Fullscreen with alt+enter. You should see noticeable difference when it changes to true full screen.

Just tested it, I had to hit alt+enter twice to get it working as expected.

Full screen behavior changed since the 2.7 release:

I'm still looking for a decent way to see if DCS is running Full Screen or Windows Borderless Mode.
I can only tell the difference if i click anywhere on my second monitor and DCS minimizes.
If i press Alt-Enter, the screen flickers briefly but i can't really tell if i'm on Full Screen or Borderless.

Win10 Pro 64-bit, i7-4770K @ 4.5 GHz, Corsair H100i, AsRock Extreme4, ASUS Strix 1080Ti OC 11GB, 32 GB DDR3 G.Skill 2400. Monitors: LG 27GL850-B27 2560x1440 + Samsung SyncMaster 2443 1920x1200, HOTAS: Warthog with Virpil WarBRD base & hegykc MFG Crosswind modded pedals, TrackIR4, Oculus Rift S.

Personal Wish List: A6 Intruder, Vietnam theater, decent ATC module, better VR performance!

Link to comment
Share on other sites

  • 5 weeks later...
On 11/18/2021 at 11:52 PM, LucShep said:

I also can not get FreeSync to work with my 4K screen and my RX5700XT, and limited to 60 (or 61) but, truth be told, it's an issue with other games as well (not just with DCS).

I use V-Sync ON (60FPS) because that's what results better for me (most smooth gameplay).

The funny part is that, with DCS, I feel I need to Alt+Enter until I am sure its right, especially when down there right over the trees - the improvement is noticeable after it.
And it always has been like that ever since DCS1.5, and across different GPUs, Nvidia and AMD.

 

OK, I finally solved the FreeSync with 60fps cap problem with my screen (Samsung NU8500 55'').
Turns out that it needs somewhat of a different method that, I think, some of you may have also found.

For those with same issues as I had (awful tearing and stuttering with FreeSync ON and 60fps cap), maybe this will help:

  • On the Monitor/TV options, enable FreeSync.
    NOTE: in the specific case of Samsung TVs with FreeSync, you need to enable "Game Mode" and set FreeSync to either "Moderate" or "Ultimate" (this last one works best).
     
  • In the AMD Radeon Software options, in the Display options enable VRR, and in the Global Graphics options set VerticalSync to either "Always OFF" or "OFF Unless Aplication Specifies".
    I'd recommend to also create a specific game profile. For DCS, point to the DCS.EXE (inside BIN folder) and for its profile options, set VerticalSync to "Always OFF" and enable FreeSync to "ON".
     
  • Now here's the tricky part that I was unaware of... most (if not all) of these 4K 60Hz panels actually run at 59.94Hz, not 60Hz.
    So, because of this, you need to set framerate cap to 59fps (instead of 60fps) in the AMD Radeon Software options. Otherwise FreeSync won't work as intented.
    You can do this in two different ways with AMD Radeon Software options (try either one or the other):
    - 1) in Global Graphics settings, Framerate Target Control, set MaxFPS to 59fps (to keep Frame Rate capped).
    - 2) or, alternatively, with Radeon Chill by setting both Min FPS and Max FPS to 59 (to keep Frame Rate capped), in Global Graphics settings (also of specific game profile).
    Either way should stop tearing and give best low input lag. It may be the case that only one method works and the other doesn't - use whichever works best for you.
    While you can cap to 59fps with RivaTuner, this one is not recommended as it can induce screen-tearing with some games (documented, and can confirm to be true in my case), whereas capping to 59fps with AMD Radeon Software options (either with Radeon Chill or Frame Rate Target Control) it runs perfect. 
  • Now all that remains to be done is to make sure in the game options (of DCS in this case) that V-Sync is set to OFF, and that Fullscreen is set to ON.


FreeSync now works great in my case, no issues with headtracking here (FWIW, using TrackHat-Clip with Opentrack software, and a modified PS3Eye cam capturing at 75Hz). 

 


Edited by LucShep

aka Luke Marqs; aka DucFreak -  my mods/files
LM transparent DCS icons_hs_LESSshdw - DEZ21.png
Win10 Pro x64 | i7 10700KF (all-core 4.9GHz OC) | 64GB DDR4 3466MHz CL16 (OC) | RX 5700XT 8GB | 1TB NVMe + 500GB SSD + 4TB TB HDD | MSI Z490-A Pro | 650w 80+Gold PSU (Seasonic GM)
55'' curved 4K Samsung NU8500 | M-Audio USB + Senn HD-599SE | VKB NXT stick + X52 Pro throttle | TrackHat w/ OpenTrack

 

Link to comment
Share on other sites

A good way to tell if you’re in full screen or windowed borderless is to change the volume, I’ve got a volume wheel on my keyboard and when adjusting it (up or down) you get a small osd representation in windowed borderless mode but nothing in full screen, thats how I go about telling the 2 apart.

 

I use an nvidia card but also cap my frames to 60 as it keeps trackir nice and smooth, having the game in fullscreen is also smoother than windowed borderless but to me this feels more like a trckir issue, not graphics card.

System Specs: Intel Core i9-9900K 3.6GHz @ 5GHz, Gigabyte Z390 Aorus Master, 32 GB Patriot Viper Steel RAM, GeForce GTX 2080 Ti, Crucial SSD (750 GB), TrackIR 5, TMWH, TM T-Flight Rudder Pedals, Samsung 49” Odyssey G9

Link to comment
Share on other sites

If it helps anyone, I am running butter smooth with Track IR and FRTC at a 60fps limit in Radeon. This is as long as my FPS in DCS can maintain a solid 60fps.

I fly pretty low a lot of the time so any panning related stutters would show up.

This is using a LG 48-75 Freesync monitor. Not just for DCS but all my games. 

Link to comment
Share on other sites

5 hours ago, Dr Zaius said:

A good way to tell if you’re in full screen or windowed borderless is to change the volume, I’ve got a volume wheel on my keyboard and when adjusting it (up or down) you get a small osd representation in windowed borderless mode but nothing in full screen, thats how I go about telling the 2 apart.

Nice find, however after testing this sadly it doesn't work for me. I don't have a scrollwheel for the volume but 2 extra keys. My osd volume overlay shows up all the time...🤔

Win10 Pro 64-bit, i7-4770K @ 4.5 GHz, Corsair H100i, AsRock Extreme4, ASUS Strix 1080Ti OC 11GB, 32 GB DDR3 G.Skill 2400. Monitors: LG 27GL850-B27 2560x1440 + Samsung SyncMaster 2443 1920x1200, HOTAS: Warthog with Virpil WarBRD base & hegykc MFG Crosswind modded pedals, TrackIR4, Oculus Rift S.

Personal Wish List: A6 Intruder, Vietnam theater, decent ATC module, better VR performance!

Link to comment
Share on other sites

@Dr Zaius: Just out of curiosity...
When are you in FullScreen, when the screen has blinked or when the screen didn't blink when pressing Alt-Enter?

Win10 Pro 64-bit, i7-4770K @ 4.5 GHz, Corsair H100i, AsRock Extreme4, ASUS Strix 1080Ti OC 11GB, 32 GB DDR3 G.Skill 2400. Monitors: LG 27GL850-B27 2560x1440 + Samsung SyncMaster 2443 1920x1200, HOTAS: Warthog with Virpil WarBRD base & hegykc MFG Crosswind modded pedals, TrackIR4, Oculus Rift S.

Personal Wish List: A6 Intruder, Vietnam theater, decent ATC module, better VR performance!

Link to comment
Share on other sites

13 hours ago, Dr Zaius said:

A good way to tell if you’re in full screen or windowed borderless is to change the volume, I’ve got a volume wheel on my keyboard and when adjusting it (up or down) you get a small osd representation in windowed borderless mode but nothing in full screen, thats how I go about telling the 2 apart.

7 hours ago, Lange_666 said:

Nice find, however after testing this sadly it doesn't work for me. I don't have a scrollwheel for the volume but 2 extra keys. My osd volume overlay shows up all the time...🤔

I tried the goold old method on the game's executable and it seems to work in FullScreen as expected (FreeSync working fine, etc).

Select the DCS.EXE (located inside the "bin" folder in game installation folder) and create a desktop shortcut from it. 

Now, right-click in that desktop shortcut of DCS.EXE (the one you've just created). 
Go to the bottom of the dropdown menu and you’ll see Properties. Click it and you’ll open a Properties window, which will open up to the Shortcut tab.
You’re looking for the Run drop-down menu. It will be just a few selections down from the top of the tab.

Currently, you’ll notice that it’s set to Normal window.
However, if you click on the down arrow, you’ll be shown choices for Normal Window, Minimized, or Maximized.
Click on Maximized, and "Apply" to save the changes. Now whenever you open the program in the future, it will default to full screen mode. 

Note that you still have to choose "FullScreen ON" in the game options, of course. 

My Win10 is not in english language, so I'll drop here an image of other app (chrome in this case) taken from the interweb, just as mere example of the process I've just described:

ib app full screen 1


Edited by LucShep

aka Luke Marqs; aka DucFreak -  my mods/files
LM transparent DCS icons_hs_LESSshdw - DEZ21.png
Win10 Pro x64 | i7 10700KF (all-core 4.9GHz OC) | 64GB DDR4 3466MHz CL16 (OC) | RX 5700XT 8GB | 1TB NVMe + 500GB SSD + 4TB TB HDD | MSI Z490-A Pro | 650w 80+Gold PSU (Seasonic GM)
55'' curved 4K Samsung NU8500 | M-Audio USB + Senn HD-599SE | VKB NXT stick + X52 Pro throttle | TrackHat w/ OpenTrack

 

Link to comment
Share on other sites

I dont know if it helps out. I dont use fullscreen in DCS. The only reason is because I use DCE campaigns and I am too lazy to "Tab" out to see the post mission pop ups.

I have tested with fullscreen enabled and disabled in DCS and I did not see any difference in smoothness regarding Track IR. I also checked with Radeon overlay and MSI Afterburner. I could not see any measurable difference on my system. This is using Windows 10.

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...