Jump to content

Trying to figure out why datalink doesn't work in the practice mission I'm using...


Recommended Posts

Hello, complete ME noob/idiot here, trying to make some sense of things.

 

I've been using a modified version of this mission to practice weapon employment and systems management in the modules I've bought:

https://www.digitalcombatsimulator.com/en/files/3301568/

 

I've modified it by adding and removing some stuff, making almost all planes on the ground start cold, allowed labels, etc.

 

The current version of the modified mission is included as an attachment, with a track file that also showcases the issue I'm having. And that issue is that I'm not getting the datalink to work at all with either the JF-17 or F-16C when in SP or MP, and when trying in MP even Ka-50 datalink wasn't working properly.

 

When I play missions generated by Liberation I get datalink working just fine, and to my memory datalink HAS worked in the recent past (meaning not that many months ago) even in this practice mission.

 

I have no idea where to get started solving this, and would appreciate some help. Even just a confirmation whether or not the datalink works for anyone else when running the mission could be useful.

 

One thing that I did try, but isn't included in this version, was to assign the AWACS plane in the mission to do the task Nothing, then back to AWACS. That at least made the AWACS plane itself pop up in the datalink though none of the targets it sees are in there. And it does actually work and sees targets, because if I tune to the AWACS radio channel it gives me non-stop information about enemy units.

 

So this would somewhat hint that something in the mission has gotten bugged at some point, and things aren't initializing in a proper way for them to be showing up in datalink? Perhaps because it's an older mission (2.5 period), and ME does some things differently now?

 

Thanks in advance to anyone who even looks at this mess...

JF-17 and F-16C datalink testing 2.zip

Link to comment
Share on other sites

8 hours ago, jubuttib said:

Welp, I guess I'm stuck with this. Thanks to anyone who had a look anyway!

I had a quick look:

I only checked the Ka-50's on both sides in SP by enabling the other flight members as AI and seeing if they showed up in the ABRIS map with their wingman ID's, so that was fine, obviously if playing MP, other human flight members would have to have their Datalink ID set appropriately and the other selector on Wingman to work correctly, also they would only show up when they spawned in as a client which is not always at mission start.

I see no glaring issues with the mission as such and was not in a position to fly DCS to test the F-16 and AWACS.

You could try toggling the aircrafts task from "Nothing" to "CAS" or some other appropriate behaviour to prep them for engaging, it didn't need to be done to the Ka-50 to work though.

This might be relevant also: F-16 datalink issue.

Regards, Ian.


Edited by MadDog-IC
added link to possible solution
  • Like 1

Asus p877v-pro, Intel I7 3770k 4.2ghz, 32gb Ripjaw X ram, Nvidia RTX-2070 Super, Samsung 32" TV, Saitek x52 pro Joystick and Combat rudder pedals, TrackIR 5, Win8.1 x64 with SSD and SSHD protected by (Avast AV).

 

DCS Tech Support.

Link to comment
Share on other sites

Big thanks for taking a look Ian! Good to know about the Ka-50, I'll need to test that again with my friend to see if we can get it working. Unfortunately it's the Jeff and F-16C that are the more important ones.

I did try changing some of the planes first to nothing and then to CAS, but I think that was a red herring. I loaded up the original version of the mission and it would appear that the AWACS plane does indeed show up in that as well, so it had nothing to do with me changing its task, I just thought it did.

I think the datalink itself on the F-16/Jeff end is probably working, since the AWACS pops up in it, but for some reason none of the planes the AWACS sees are getting transmitted.

I did check out the F-16 datalink issue thread while trying to sort this out, I couldn't see it making a difference unfortunately, tried various TACAN channels.

Well, thankfully it seems limited to just this training mission, so anything that really matters does still work, but it would still be great to know what's causing this. The mission does use a fair bit of scripting, so it might be that getting in the way too, but I have no way to check if that's the issue.

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...