Jump to content

CH47 Chinook, flyable, clickable, EFM


Dweeeeb

Recommended Posts

I encounter a strange problem: when on ground, when I increase either the throttle or the collective, it jumps back to idle and goes up again. In this way, I cannot take off.  There is a message keeps popping up "Engines started...ELF to FLT...". However, when the chopter is up in the air, the problem does not exist.

 

I wish there are more functions be able to map to the joystick button;.

 

Thank you.


Edited by VFGiPJP

VR Flight Guy in PJ Pants -- this is how I fly

We do not fly at treetop height, we fly between trees(TM)

YouTube: https://www.youtube.com/channel/UCc9BDi-STaqgWsjNiHbW0fA

Link to comment
Share on other sites

4 hours ago, Hawkeye60 said:

 We are making a CH-47 discord. And a team. We are looking for people to assist in its development and improvement. Coders, Skinner's and anything else you can bring to the table. If you have any interest in making it the best CH-47 in the sim, PM me. Discord invite will be provided. Thanks for your attention! Cheers!

PM sent

~

Link to comment
Share on other sites

https://discord.gg/jMy6fJst

 

Join us would you?

 

Cheers!

  • Like 1

"Yeah, and though I work in the valley of Death, I will fear no Evil. For where there is one, there is always three. I preparest my aircraft to receive the Iron that will be delivered in the presence of my enemies. Thy ALCM and JDAM they comfort me. Power was given unto the aircrew to make peace upon the world by way of the sword. And when the call went out, Behold the "Sword of Stealth". And his name was Death. And Hell followed him. For the day of wrath has come and no mercy shall be given."

Link to comment
Share on other sites

Hola EL_LEJI

 

He seguido tu consejo al piede la letra , pero aùn asì no va , me explico , paso a FLT , aumento las RPM , y poco a poco voy subiendo el colectivo 

Intenta elevarse y de hecho lo hace , pero se me escora hacia babor o sea la izquierda , y no hay manera de enderezarlo 

Es una pena , pues me encanta el aparato y veo que hay un gran trabajo y tiempo invertido en èl 

He tratado de  todas las meneras el corregir ese defecto de caida lateral , pero nada de nada 

Decir que tengo un Hotas Warthog y un colectivo de Virpil , que es una joya , pero no puedo hacer que se mantenga bien en el aire , y es una pena

Link to comment
Share on other sites

Really enjoying the mod so far.  Looking forward to the progress on this one.  Hopefully ground mechanics such as taxing while on the ground can be worked among others additions that would be nice.  This post is not for suggestions just yet but congrats on an solid free mod.  This was my first flight below and in VR. Really digging it.  Hope to see this one grow like the Anubis C-130.  Is there anyway to get the notifications in the upper right turned off?  

 

  • Like 2
Link to comment
Share on other sites

On 9/12/2021 at 6:58 PM, flyingscotsman said:

HI Dweeb, Still struggling. Can start in the air and with adjustments to curves I can land it. 

 

Try the different ch47.dll ..... posted in main topic.....

CH47.dll.zip

14 hours ago, VFGiPJP said:

I encounter a strange problem: when on ground, when I increase either the throttle or the collective, it jumps back to idle and goes up again. In this way, I cannot take off.  There is a message keeps popping up "Engines started...ELF to FLT...". However, when the chopter is up in the air, the problem does not exist.

 

I wish there are more functions be able to map to the joystick button;.

 

Thank you.

 

Hmmm...... please follow the startup procedure....... all notifications in the top right will disappear if you follow through the procedure properly........ the collectives and throttle are restricted unless you follow the procedure ....... the startup procedure is there to make sure you turn everything on/off in the correct order so that systems work properly.... this feeds into the EFM and other systems (electric) ..... if you dont follow the startup procedure, things will not work properly

  • Like 1
Link to comment
Share on other sites

10 hours ago, Dweeeeb said:

Try the different ch47.dll ..... posted in main topic.....

CH47.dll.zip 21.62 kB · 10 downloads

Hmmm...... please follow the startup procedure....... all notifications in the top right will disappear if you follow through the procedure properly........ the collectives and throttle are restricted unless you follow the procedure ....... the startup procedure is there to make sure you turn everything on/off in the correct order so that systems work properly.... this feeds into the EFM and other systems (electric) ..... if you dont follow the startup procedure, things will not work properly

 

Regarding notifications, there seems to be an issue with them detecting throttle. It keeps repeatedly showing the notice to increase to 100% even with throttle at 100%. Still repeats even with lowering then pushing the throttle back up again (have assigned to an axis on my HOTAS with the traditional throttle axis as the collective).

 

Link to comment
Share on other sites

Thanks for the new DLL. Some improvement in handling when in the air, however, still sticking to the ground like glue. With 8/10 collective it starts to lift the back wheels and roll to the left onto it's side.

So started in the air and was able to put it on the ground with about 7/10 collective. Putting the collective further down cause it to roll in my 'normal' fashion. I'm just using the throttle in invert mode. Same as I do for all my other helicopters with engines at full tilt all the time. So will keep doing airstarts and playing with it, thank you  

Link to comment
Share on other sites

6 hours ago, STABROSS said:

Hola de nuevo 

Por fin he levantado vuelo , gracias a ese bendito " dll "

Es una gozada volarlo , por cierto , donde encuentro el procedimiento de arranque en frio ..? 

En el pedestal de abajo a la izquierda lo tienes y si clicas en el se abre en pantalla.

Tambien lo tienes dentro de la carpeta del mod, "CH47 Engine startup procedure.txt"

 

BOEING CH47 Startup Procedure

***** COLLECTIVE MUST BE SET=0,  & PARKING BRAKE SET ******
            LOCK IGNITION TO RESET

ENGINE OFF
0.    Ignition Lock  —             OFF.
0.    BATT  —                 ON.
1.    APU —                 Start..
1.    APU GEN  —             ON.
2.     PWR XFER 1 and 2  —         ON.
3.    EAPS 1 Fan  —             ON
(delay 10-15seconds between turning on No. 1 and No. 2).
3.    EAPS 2 Fan  —             ON
3.5.    Fuel X-feed —             ON
4.    ECL     —             Set 'Ground'    
4.    Engine     —             Start..
4.    RPM —                 Set 2800
5.    GEN 1 and 2  —             ON
6.    APU GEN  —            OFF
6.    PWR XFER 1 and 2  —         OFF
6.    APU  —                 OFF
ENGINE STARTED

GET FLIGHT READY
    ECL     —             Set 'FLT'    
    RPM     —             Set 100%
    PARKING BRAKE ---            OFF

 

 

 

http://www.cruzdesanandres.com/

My skins

Windows 10 Pro -Asus rog strix z490-e gaming  - I7 10700K - Ram Corsair 32 GB 3600 - Samsung 970 evo plus 1tb  - RTX 2070 8Gb - Gigabyte G32QC  2‎560 x 1440 (QHD)- Hotas Saitek Rhino X56 - Saitek pro flight rudder pedals - Track IR 5 - VR samsung odyssey plus

 

Link to comment
Share on other sites

Guys....... I cant tell you enough times...... If you FOLLOW THE STARTUP PROCEDURE exactly....... all your problems will go away.......

 

To thos perople saying that "HOTSTART" dont work.... it works fine,...... but you start with the engine STARTED....i.e "HOT" ....... you are not flight ready....... the popups tell you what needs to be done...... "ECL to Flight"........ then increase RPM....... then take off parking brake...... then increase collective....... SIMPLES!!!!!!!!!!

On 9/14/2021 at 5:22 PM, Patrick56 said:

Congratulations on the good work we see and we know how long it must have taken.

Bravo du bon travail on voit et on sait le temps que cela a du demander.

Thanks Patrick.... means a lot coming from you!!!     Hope to be as good as you guys one day!!

 

  • Thanks 1
Link to comment
Share on other sites

Ease down, mate. Some time, me users are quite dumb.

 

Edit: Okay, I map the throttle to a slider and when the RPM meter reaches 45, it still says I need to get the RPM to 100%. Did I do something wrong?

 


Edited by VFGiPJP
  • Like 1

VR Flight Guy in PJ Pants -- this is how I fly

We do not fly at treetop height, we fly between trees(TM)

YouTube: https://www.youtube.com/channel/UCc9BDi-STaqgWsjNiHbW0fA

Link to comment
Share on other sites

14 hours ago, Dweeeeb said:

Guys....... I cant tell you enough times...... If you FOLLOW THE STARTUP PROCEDURE exactly....... all your problems will go away.......

 

To thos perople saying that "HOTSTART" dont work.... it works fine,...... but you start with the engine STARTED....i.e "HOT" ....... you are not flight ready....... the popups tell you what needs to be done...... "ECL to Flight"........ then increase RPM....... then take off parking brake...... then increase collective....... SIMPLES!!!!!!!!!!

Thanks Patrick.... means a lot coming from you!!!     Hope to be as good as you guys one day!!

 

For the most part yes especially for flying issues. But the popups don't tell you everything listed there. It gets to increase RPM to 100% and even with throttle all the way it keeps flashing the same thing. Something with the RPM/Throttle registering for the popups is not detecting the engines being revved up.

Link to comment
Share on other sites

Your Chinook is a masterpiece mate, just cos we’re too busy to read paperwork in our short “flying widow” it’s our problem to sort, have a habit of climb in fire whatever it is up and launch to squeeze as much enjoyment before the...”You’re dinner’s going cold. Thanks for your work

 

Link to comment
Share on other sites

On 9/15/2021 at 9:50 PM, EL_LEJI said:

En el pedestal de abajo a la izquierda lo tienes y si clicas en el se abre en pantalla.

Tambien lo tienes dentro de la carpeta del mod, "CH47 Engine startup procedure.txt"

 

BOEING CH47 Startup Procedure

***** COLLECTIVE MUST BE SET=0,  & PARKING BRAKE SET ******
            LOCK IGNITION TO RESET

ENGINE OFF
0.    Ignition Lock  —             OFF.
0.    BATT  —                 ON.
1.    APU —                 Start..
1.    APU GEN  —             ON.
2.     PWR XFER 1 and 2  —         ON.
3.    EAPS 1 Fan  —             ON
(delay 10-15seconds between turning on No. 1 and No. 2).
3.    EAPS 2 Fan  —             ON
3.5.    Fuel X-feed —             ON
4.    ECL     —             Set 'Ground'    
4.    Engine     —             Start..
4.    RPM —                 Set 2800
5.    GEN 1 and 2  —             ON
6.    APU GEN  —            OFF
6.    PWR XFER 1 and 2  —         OFF
6.    APU  —                 OFF
ENGINE STARTED

GET FLIGHT READY
    ECL     —             Set 'FLT'    
    RPM     —             Set 100%
    PARKING BRAKE ---            OFF

 

 

Great work on this brilliant mod just a couple questions , is development ceased on this project or is it still in development and , I just recently started getting an IC check failure and the file in question was in saved games/mods/ac/ch47/textures/ch47textures.zip

 

Any way to prevent this ???

 

Thanks.

Link to comment
Share on other sites

20 hours ago, Badass1982 said:

Great work on this brilliant mod just a couple questions , is development ceased on this project or is it still in development and , I just recently started getting an IC check failure and the file in question was in saved games/mods/ac/ch47/textures/ch47textures.zip

 

Any way to prevent this ???

 

Thanks.

 

There is a group of people working on improving the mod. To keep up to date with the progress in the project you have the Discord of the mod.

On 9/14/2021 at 8:38 PM, Hawkeye60 said:

https://discord.gg/jMy6fJst

 

Join us would you?

 

Cheers!

 

  • Like 1

 

http://www.cruzdesanandres.com/

My skins

Windows 10 Pro -Asus rog strix z490-e gaming  - I7 10700K - Ram Corsair 32 GB 3600 - Samsung 970 evo plus 1tb  - RTX 2070 8Gb - Gigabyte G32QC  2‎560 x 1440 (QHD)- Hotas Saitek Rhino X56 - Saitek pro flight rudder pedals - Track IR 5 - VR samsung odyssey plus

 

Link to comment
Share on other sites

Amazing module man. I was wondering do you have any code like from Hercules that allows the troops and cargo that are dropped to actually stay and appear as cargo and ammo crate after it's dropped? Right now troops fall through the map and ammo crate does too ... it's really cool but just for looks. If you have it, can you share the Cargo file that you load? I believe the cargo would have to be ctld. However, if you don't drop it and you just despawn on say a FARP then the ammo would be loaded. I would just be happy with trooops ending up on the ground though that would be awesome.

We need a file to run in order to get the cargo to place in the game so when you drop troops they appear in the game.

I know you're done with this you mentioned, but if anyone could get this to work it would make something great become something amazing I think.
Two files need to be created:
1. Hercules_Cargo.lua   --> Look at for reference 
2. Hercules_Cargo_CTLD.lua --> Look at for reference


I'm guessing you already know this, I can't imagine that you'd spend all this time making this module and not get those two parts to work.
Would love to get those files if you have them working for your excellent mod.


Edited by DoctorNo
  • Like 1
Link to comment
Share on other sites

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...