Jump to content

Randomly opening commands window


hreich
 Share

Recommended Posts


Is it possible that VAICOM by itself opens radio commands window randomly during flight? I get this problem where during flight radio comms window opens by itself and i didnt push any of transmit buttons
 
Sent from my M2003J15SC using Tapatalk
 
 

[sIGPIC][/sIGPIC]

Pilot from Croatia

Link to comment
Share on other sites


Is it possible that VAICOM by itself opens radio commands window randomly during flight? I get this problem where during flight radio comms window opens by itself and i didnt push any of transmit buttons
 
Sent from my M2003J15SC using Tapatalk
 
 


It normally means something has got slightly corrupted. If shutting everything down and restarting doesn't work try:

1. Close DCS and VA, copy Export.lua in your saved games > scripts folder and then delete export.lua. Restart to see if it works. Copy back any other lines in your saved export.lua (put them back in the same order). If still not fixed then

2. Use the set custom path option in Vaicom config. Point this to your main DCS folder, tick fix reg, set the sliders the right way and then restart VA - go back into config and uncheck set custom path.

If neither work, post your Vaicom log file here (with Vaicom debug turned on) and we will have a look.

Sent from my SM-T835 using Tapatalk

  • Like 1

Windows 10 Home ¦ Z370 AORUS Gaming K3 motherboard ¦ i5-8600K oc to 4.3GHz ¦ 48GB Corsair PC4 memory @ 3000MHz ¦ Samsung 960 EVO M.2 SSD for OS, Samsung 860 EVO 1TB SSD for DCS ¦ ASUS ROG GTX 2060 Super 8GB ¦ Virpil WarBRD base with VFX grip, Thrustmaster A10c and F/A-18 grips ¦ VKB Gunfighter Mk2 and MCG ¦ Thrustmaster Warthog Throttle ¦ MFG Crosswinds ¦ Oculus Rift S

Link to comment
Share on other sites

I don't know why this happens, but it happens with too much regularity.

 

My solution...

  • Close DCS
  • Open VA,
  • Press [CTRL] + [ALT] + [C] to open VAICOM window
  • Click "Config" tab
  • Uncheck "Use custom DCS path:" option
  • Check "Use custom DCS path:" option
  • Click "SET" button next to "Use custom DCS path:" option
  • Locate and highlight DCS install folder
  • Click "OK"
  • Close VAICOM window
  • Open DCS

i7-5820K 4.3GHz ● 1080Ti ● 32GB 2666MHz ● Evo M.2 ● Reverb G1 ● TM Throttle/A10C/FA18C/TPR ● Win10E 21H1.19043
A10CII ● AH64D ● AJS37 ● AV8BNA ● C101 ● CEII ● F16C ● F5EII ● F86F ● FA18C ● FC3 ● I16 ● KA50 ● M2000C ● MI8 ● P47D ● SA342 ● SPIT ● UH1H ● Y52

Link to comment
Share on other sites

Ok I'll try bot suggestion.. I foegot to mention that my expprt.Lua has different entries for mfd screen export, tac view etc.. I'll add my exporr.lua later when i am home here so maybe someone can help me figure out what the problem is..

Sent from my M2003J15SC using Tapatalk

[sIGPIC][/sIGPIC]

Pilot from Croatia

Link to comment
Share on other sites

Here's my export.lua:

 

local dwlfs=require('lfs'); dofile(dwlfs.writedir()..[[Scripts\DEVICEWORKS\DEVICEWORKS.lua]])
-- run Helios export script supporting drivers generated by Helios Profile Editor and Capt Zeen modules
dofile(lfs.writedir()..[[Scripts\Helios\HeliosExport16.lua]])

-- example calls for other programs you may have:
-- dofile(lfs.writedir()..[[Scripts\SimShaker.lua]])
-- dofile(lfs.writedir()..[[Scripts\SimShaker-export-core\ExportCore.lua]])
-- dofile(lfs.writedir()..[[Mods\Services\DCS-SRS\Scripts\DCS-SimpleRadioStandalone.lua]])

local vaicomlfs = require('lfs'); dofile(vaicomlfs.writedir()..[[Scripts\VAICOMPRO\VAICOMPRO.export.lua]])

-- IVMOBS Modification
-- v109
local default_output_file = nil
function LuaExportStart()
end
function LuaExportBeforeNextFrame()
end
function LuaExportAfterNextFrame()
end
function LuaExportStop()
    if default_output_file then
        default_output_file:close()
        default_output_file = nil
    end
end
function LuaExportActivityNextEvent(t)
    local tNext = t
    return tNext
end
--{{A10C}}
-- dofile(".\\VCSServer\\Main.lua")
--{{MIRAGE}}
-- dofile(".\\VCSServer\\M2000C.lua")
--{{AV8BNA}}
-- dofile(".\\VCSServer\\AV8BNA.lua")
--{{FA18C}}
-- dofile(".\\VCSServer\\FA18C.lua")
-- ========= Modules =========
dofile(".\\VCSServer\\FA18C.lua")
dofile(lfs.writedir()..[[Scripts\Helios\HeliosExport16.lua]])

-- run Helios export script supporting drivers generated by Helios Profile Editor and Capt Zeen modules
--dofile(lfs.writedir()..[[Scripts\Helios\HeliosExport16.lua]])
local vaicomlfs = require('lfs'); dofile(vaicomlfs.writedir()..[[Scripts\VAICOMPRO\VAICOMPRO.export.lua]])
local Tacviewlfs=require('lfs');dofile(Tacviewlfs.writedir()..'Scripts/TacviewGameExport.lua')
 

[sIGPIC][/sIGPIC]

Pilot from Croatia

Link to comment
Share on other sites

14 hours ago, Dunx said:

I don't know why this happens, but it happens with too much regularity.

 

My solution...

  • Close DCS
  • Open VA,
  • Press [CTRL] + [ALT] + [C] to open VAICOM window
  • Click "Config" tab
  • Uncheck "Use custom DCS path:" option
  • Check "Use custom DCS path:" option
  • Click "SET" button next to "Use custom DCS path:" option
  • Locate and highlight DCS install folder
  • Click "OK"
  • Close VAICOM window
  • Open DCS

You might want to check the "fix registry" box. Then the DCS install path gets saved in the registry and VAICOM will not have to go hunting for it. DCS itself saves the install path if you install it from scratch. If you have moved DCS or changed the installation type without using DCS's own installer then the registry key may be incorrect, and the above will fix it.

  • Like 1

I'm Softball on Multiplayer. Dell XPS-8500 24GB, i7-3770@3.40GHz, Win 10Pro, Nvidia GeForce GTX 1060 6GB, TiR, VKB Gunfighter III with MCG Ultimate grip, CH throttle and pedals, all maps, most modules

Link to comment
Share on other sites

I'm having this same issue. I've tried so many ways to fix it, but nothing seems to work.

 

Even when just doing an instant action, free fly mission, flying around and not interacting with anything, the coms menu will still pop up by itself, every 20 seconds or so.

 

- I've deleted the export.lua file in saved games dir

- I've set custom path in the vaicom config

- I've done a reset of lua files in vaicom config

- I've repaired the DCS installation (while voice attack / vaicom was not running)

- I've checked regedit, and the correct install path is listed there. 

 

I deleted the vaicom log file, turned on debug, then ran a free flight mission for about 5 minutes. Getting quite a few pop-ups during that time. Here's the log file:

VAICOMPRO.log

 

 

For now, I guess I'll go with disabling the coms menu, and using the option voice command.


Edited by Photon
Link to comment
Share on other sites

On 9/11/2021 at 5:42 AM, hreich said:

Here's my export.lua:

 

local dwlfs=require('lfs'); dofile(dwlfs.writedir()..[[Scripts\DEVICEWORKS\DEVICEWORKS.lua]])
-- run Helios export script supporting drivers generated by Helios Profile Editor and Capt Zeen modules
dofile(lfs.writedir()..[[Scripts\Helios\HeliosExport16.lua]])

-- example calls for other programs you may have:
-- dofile(lfs.writedir()..[[Scripts\SimShaker.lua]])
-- dofile(lfs.writedir()..[[Scripts\SimShaker-export-core\ExportCore.lua]])
-- dofile(lfs.writedir()..[[Mods\Services\DCS-SRS\Scripts\DCS-SimpleRadioStandalone.lua]])

local vaicomlfs = require('lfs'); dofile(vaicomlfs.writedir()..[[Scripts\VAICOMPRO\VAICOMPRO.export.lua]])

-- IVMOBS Modification
-- v109
local default_output_file = nil
function LuaExportStart()
end
function LuaExportBeforeNextFrame()
end
function LuaExportAfterNextFrame()
end
function LuaExportStop()
    if default_output_file then
        default_output_file:close()
        default_output_file = nil
    end
end
function LuaExportActivityNextEvent(t)
    local tNext = t
    return tNext
end
--{{A10C}}
-- dofile(".\\VCSServer\\Main.lua")
--{{MIRAGE}}
-- dofile(".\\VCSServer\\M2000C.lua")
--{{AV8BNA}}
-- dofile(".\\VCSServer\\AV8BNA.lua")
--{{FA18C}}
-- dofile(".\\VCSServer\\FA18C.lua")
-- ========= Modules =========
dofile(".\\VCSServer\\FA18C.lua")
dofile(lfs.writedir()..[[Scripts\Helios\HeliosExport16.lua]])

-- run Helios export script supporting drivers generated by Helios Profile Editor and Capt Zeen modules
--dofile(lfs.writedir()..[[Scripts\Helios\HeliosExport16.lua]])
local vaicomlfs = require('lfs'); dofile(vaicomlfs.writedir()..[[Scripts\VAICOMPRO\VAICOMPRO.export.lua]])
local Tacviewlfs=require('lfs');dofile(Tacviewlfs.writedir()..'Scripts/TacviewGameExport.lua')
 

Your export.lua file loads the vaicom scripts twice. Could possibly be related.

  • Like 1

I'm Softball on Multiplayer. Dell XPS-8500 24GB, i7-3770@3.40GHz, Win 10Pro, Nvidia GeForce GTX 1060 6GB, TiR, VKB Gunfighter III with MCG Ultimate grip, CH throttle and pedals, all maps, most modules

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...