Jump to content

Air Raid alarm to sound at Mission start or when I set conditions


Recommended Posts

Hello

I have set up a trigger zone but I cannot, despite all my best efforts, get an Air Raid alarm whose sound I downloaded in .wav format and set in the ME, get the effect that I am looking for. I set the alarm to start and stop either at Mission Start or under different local conditions but all to no avail. Has anyone had better luck at using such an alarm as this? I want the alarm to start close to the mission beginning as soon as we are in our 'pits.

Thank for any assistance.

- 'The Dog's Rollocks' - [sIGPIC][/sIGPIC] is a water cooled behemoth :



i9 9900K@5GHz/RTX 2080Ti/32 Gb 3600MHz RAM/M.2 NVMe onboard drives/System driving Pimax 5K Plus/TM Warthog/MFG Crosswind/Gametrix Jetseat

Link to comment
Share on other sites

Yes, I have a mission where I use the Air Raid alarm sound in .ogg format and it works.  I have it set up to start at mission start.  But you can do basically anything to have it start at any time.  Basically the way I set it up was to create a regular "Once" script in the rules for triggers section of the mission editor.  Then in condition I put the command script "Time More" and had it execute at say 30 seconds.  Remember all timings in the mission editor scripting menu use seconds so if you want something in the mission to start in 2 minutes, you have to set the "Time More" rule as 120 seconds.

 

Then in Trigger Actions section of the trigger I set up I have "Sound to Group" play the "Air Raid Alarm" sound for that particular group.  You can use this or "Sound to All" or "Sound to Coalition".  There are several actions you can set.

 

You can as well set it up where a Trigger zone will set it off.  Instead of using a "Time More" condition, just use "Part of Group in Zone" or "All of Group in Zone" and once you or part of your particular flight or Group enter the zone, it will set off the Air Raid Alarm.

 

Hope this helps.  I wrote this on the fly but if you have additional questions, please post and when I can I'll answer them to the best of my knowledge.  Cheers.


Edited by enigma6584
Link to comment
Share on other sites

Posted (edited)

I had tried all the above except the 'Time More' so I shall try that. The ME may even be somewhat  'buggy' as when I first tried to set the alarm up it did work but after trying to improve the settings it has  steadfastly refused each time. I shall persevere, thank you for your assistance.

 

EDIT: I have gone through lots of different combinations in the trigger settings but nothing works now. The alarm did sound when I first set it and since then the ME refuses to play, with the same conditions as initially set. Strange!


Edited by Euan Emblin

- 'The Dog's Rollocks' - [sIGPIC][/sIGPIC] is a water cooled behemoth :



i9 9900K@5GHz/RTX 2080Ti/32 Gb 3600MHz RAM/M.2 NVMe onboard drives/System driving Pimax 5K Plus/TM Warthog/MFG Crosswind/Gametrix Jetseat

Link to comment
Share on other sites

Hi.

Try to remove the .wav file from it's location, restart the ME and erase the trigger. Then, redownload the .wav file, save it in a different folder so the ME has to "effectively"search for it, and redo the trigger, pointing to the new location of the .wav file. I had a similar problem wit a sound file I created that was corrupted, and the ME even refused to open the file browser. The only solutioin I found was to erase all sound files, delette the trigger and start from scratch with the sound file and the trigger. I hope this elps.

Saludos

Saca111

 

Link to comment
Share on other sites

Also, you could try and convert your .wav file to .ogg

 

I once had an issue with a .wav file. Switched to only using .ogg and never had an issue since.

 

(Plenty of online wav-to-ogg converters available)

System specs:

 

i7-8700K @stock speed - GTX 1080TI @ stock speed - AsRock Extreme4 Z370 - 32GB DDR4 @3GHz- 500GB SSD - 2TB nvme

HP Reverb G1 v2 - Saitek Pro pedals - TM Warthog HOTAS - TM F/A-18 Grip - TM Cougar HOTAS (NN-Dan mod) & (throttle standalone mod) - VIRPIL VPC Rotor TCS Plus with ALPHA-L grip - Pointctrl & aux banks <-- must have for VR users!! - Andre's SimShaker Jetpad - Fully adjustable DIY playseat - VA+VAICOM

 

~ No war today... the enemy just called in sick ~ GUMMBAH

Link to comment
Share on other sites

If everything fails, simply post the miz here. What you are trying to do seems quite straight-forward and has been done successfully often enough (after all, it's one of the easiest ways to test a trigger: have it play a sound (the other being writing a message. Do that as well to see if the trigger actually fires and you know that you probably have an issue with the sound source file).

 

Link to comment
Share on other sites

... which reminds me of something I think I experienced once: "Sound Out" sometimes fails when used with a "MISSION START" type trigger. Make sure it's "ONCE" and use "Time More (1)" as condition. 


Edited by cfrag
Link to comment
Share on other sites

Everything above I tried so I'll post the mission file here and I bet that it's something so bloody simple and obvious that I will kick myself.

332nd Fighter Group OTU.miz

- 'The Dog's Rollocks' - [sIGPIC][/sIGPIC] is a water cooled behemoth :



i9 9900K@5GHz/RTX 2080Ti/32 Gb 3600MHz RAM/M.2 NVMe onboard drives/System driving Pimax 5K Plus/TM Warthog/MFG Crosswind/Gametrix Jetseat

Link to comment
Share on other sites

Thank you , I will take a look at this

 

- 'The Dog's Rollocks' - [sIGPIC][/sIGPIC] is a water cooled behemoth :



i9 9900K@5GHz/RTX 2080Ti/32 Gb 3600MHz RAM/M.2 NVMe onboard drives/System driving Pimax 5K Plus/TM Warthog/MFG Crosswind/Gametrix Jetseat

Link to comment
Share on other sites

Okay, first thing I would do is get rid of the "Or" command in the "Conditions" section of the trigger.  In addition, why in the initial triggers first column is the trigger set to "On Take Control?"  I have mine set as a "NO EVENT" trigger.

 

Second, in the "Actions" section of the trigger, why have the "Stop" command there at all?  All you really need is the one command "Sound to All" with the Air Raid Alarm sound.  It will then just run it's course and be done.  If you want the Air Raid Alarm sound to continue in a continuous loop you have to either have a longer sound file or make another separate trigger which has a "Time More" condition in order to set it off after the first one is done.

 

It almost looks to me like you are trying to do everything in one little trigger, and thus different conditions and actions are cancelling each other out.  Break it down to separate, simple triggers.

 

Here is my version of your mission.  I had to make it with the use of the trainer P-51 since I don't have the combat version for DCS and I just made it single player but it should work with "client" as well.  Also, you have to be in the cockpit in order to hear the Air Raid Alarm sound and not outside view.  I've set it up where when the Red Coalition Aircraft enter the trigger zone, the first alarm goes off.  The Air Raid Alarm sound file I'm using is longer at 39 seconds but I could have used yours with just more separate triggers.  Anyway, when the first sound alarm is finished at 39 seconds, the next trigger kicks in and the Air Raid Alarm sound in that trigger sounds off.  I could repeat this and make the Air Raid Alarm go on for minutes if needed.  My test of your mission is attached below.

 

I hope this helps.

 

 

332nd Fighter Group OTUTest1.miz

  • Like 1
Link to comment
Share on other sites

Thanks for the reply mate. The 'On Take Control' refers to simply the moment when I am in the cockpit which is momentarily after the start. Without there being a user manual, it is so difficult to understand the logic here in the trigger section but there are three columns so my assumption was that conditions can be set to fine tune the experience. This is clearly much more basic than at first appears. Thanks very much for your assistance here and for the alarm sound too.

- 'The Dog's Rollocks' - [sIGPIC][/sIGPIC] is a water cooled behemoth :



i9 9900K@5GHz/RTX 2080Ti/32 Gb 3600MHz RAM/M.2 NVMe onboard drives/System driving Pimax 5K Plus/TM Warthog/MFG Crosswind/Gametrix Jetseat

Link to comment
Share on other sites

The second part of the mission involves flying over the Channel towards Le Havre where a high altitude interception should happen. I set a flight of 190s to spawn in around 45 minutes after Mission Start and then to search and engage within a pre-defined area. By the time I get over there they are nowhere to be seen, so I guess my method of getting them to appear is not working. I have the flight placed on the map, what more do I need to do for them to come alive?

- 'The Dog's Rollocks' - [sIGPIC][/sIGPIC] is a water cooled behemoth :



i9 9900K@5GHz/RTX 2080Ti/32 Gb 3600MHz RAM/M.2 NVMe onboard drives/System driving Pimax 5K Plus/TM Warthog/MFG Crosswind/Gametrix Jetseat

Link to comment
Share on other sites

13 hours ago, Euan Emblin said:

Without there being a user manual, it is so difficult to understand the logic here in the trigger section but there are three columns so my assumption was that conditions can be set to fine tune the experience.

 

Not sure if you know this but there is a user manual for DCS, which I believe has only been updated to 2020 but it is there and it does explain things regarding the mission editor.  In case you did not know this you can find it in your Program Files then the Eagle Dynamics folder and drill down to Docs and it is in there.  Whole section on the mission editor and what the individual triggers do etc.

 

Also, I would recommend this guy's channel.  He does a phenomenal job showing how to do things in the Mission Editor.  I learned much from his videos along with the people here in this particular part of the forum.

 

SUNTSAG ANCIENT GAMER

 

12 hours ago, Euan Emblin said:

I set a flight of 190s to spawn in around 45 minutes after Mission Start and then to search and engage within a pre-defined area. By the time I get over there they are nowhere to be seen,

 

Do you have TacView?  With TacView you can view the action of your mission and see what happened with every object in your mission.  I can only guess here but perhaps the AI FW-190s moved onto the next waypoint if you did not set a time frame for them to search the area.  Perhaps they flew, searched for a few minutes and then left.  Maybe they just didn't see you?  

Link to comment
Share on other sites

Many thanks  for your help here. I have already started watching Sunstag's videos, he taught me about removing objects from the base map for example, and I will continue searching through his tutorials. I knew there was a User Manual for DCS but I just didn't think it might include the ME, the IL-2 User Manual never did but I will have a good  read of that now. Yes, TacView which I do have is a great idea. I hadn't thought of that as a way to find out what happens to certain othe a/c in the mission. Great tips mate, thank you.

  • Like 1

- 'The Dog's Rollocks' - [sIGPIC][/sIGPIC] is a water cooled behemoth :



i9 9900K@5GHz/RTX 2080Ti/32 Gb 3600MHz RAM/M.2 NVMe onboard drives/System driving Pimax 5K Plus/TM Warthog/MFG Crosswind/Gametrix Jetseat

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...