Jump to content

HP G2 causing X56 controllers to not work


Sirbum
 Share

Recommended Posts

So I just returned to DCS after about 6 months due to my Rift S taking a crap and not wanting to fly with out VR. Yesterday I received my new HP G2

and i spent most of the day in DCS resetting up all the settings to get a good picture versus FPS per Millisecond. Anyway, i got it dialed in fairly good and must say the clarity over the Rift S is ungodly.

 

But the issue I am having is when I went to setup my controllers, I mapped my throttle in the Axis window to Thrust and Radar i think it was. Then i mapped my Stick to the Pitch, Roll, ETC. and I saved that profile out as mine. 

 

Started back into the game and went to take off but noticed that when i move my Throttle, it doesn't move the throttle in game, it moves the Stick instead. I was like HUH. so i went back in to controls and double checked and they were still there correctly. when I would move my throttle it would show the throttle moving. I went through this on every module for about 3 hours. Finally i said the hell with it and I completely uninstalled DCS

and reinstalled it. 

 

First thing I did, was went into the game with no VR ticked nothing, just normal 2D gameplay and i set up just the axis for the plane. Throttle, pitch etc.

went to take off and everything worked perfect. Throttle moved what it should and stick moved what it should. So i was like ok well guess reinstalling must have fixed some file. So i went back over and put a Tick mark onto Enable VR so that i could close out, come back in and set everything up again.

 

Soon as i got back in, i checked that my controllers were still mapped correctly and they were, so i went to take off and BAM right back to the same thing.

 

So i have figured out, that something with the HP G2 is causing DCS to not work with my controllers correctly. I don't know what to do to fix this.

 

Has anyone else had this issue with a G2 and controllers? or any VR headset and controllers, and if so could you please tell me what to do to fix it.

i really want to get back to flying in VR lol.

Link to comment
Share on other sites

57 minutes ago, dburne said:

Check in Steam settings and make sure controller is not enabled in there.

when you check in steam settings, what do mean. I still want to be able to use the controller while i am in the game, for like switches and stuff.

 

but do you mean in here?

 

image.png

Link to comment
Share on other sites

What do you have your G2s USB cable and X36 USB cable plugged into?  I have run into strange controller issues when I was just starting out with VR on a Rift CV1, and it turned out to be because I was trying to run the headset and HOTAS off of the motherboard USB ports.  They don't provide enough juice to run all of those things.  Its possible that the G2 has a power requirement that's just that much higher than your Rift S to where it puts it over the threshhold if you were using motherboard USB ports.

ASRock Z370 Professional Gaming i7, Intel i7 8700K Coffee Lake processor @4.7GHz, Corsair H105 Liquid Cooler, G.SKILL Ripjaws V Series 64GB DDR4 3400 memory, EVGA RTX3090 FTW3 Ultra 24GB video card, Samsung 840PRO 256MB SSD for Windows 10 64-bit OS, Samsung 850PRO 2TB SSD for program files, LG WH14NS40 Blu-Ray burner. HOTAS Warthog, Saitek Pedals, HP Reverb G2. Partridge and pear tree pending. pilotfly.gif

Link to comment
Share on other sites

35 minutes ago, eaglecash867 said:

What do you have your G2s USB cable and X36 USB cable plugged into?  I have run into strange controller issues when I was just starting out with VR on a Rift CV1, and it turned out to be because I was trying to run the headset and HOTAS off of the motherboard USB ports.  They don't provide enough juice to run all of those things.  Its possible that the G2 has a power requirement that's just that much higher than your Rift S to where it puts it over the threshhold if you were using motherboard USB ports.

nope this isnt it for a couple reason. 

1. the x56 is plugged into a powered USB hub not on the mother board

2. the G2 is plugged into the Video card and the G2 actually has a power cord that powers the headset. They changed that due to being power hungry.

 

no something else seems to be conflicting in DCS I just don't know what. i tried changing the G2 controller settings in steam to see if that was it but

that did nothing either. I even turned the controller off while in game to see if it would change.

Link to comment
Share on other sites

The power cord on the G2 is for the display only.  It doesn't provide extra power to the USB functions of the headset.  

ASRock Z370 Professional Gaming i7, Intel i7 8700K Coffee Lake processor @4.7GHz, Corsair H105 Liquid Cooler, G.SKILL Ripjaws V Series 64GB DDR4 3400 memory, EVGA RTX3090 FTW3 Ultra 24GB video card, Samsung 840PRO 256MB SSD for Windows 10 64-bit OS, Samsung 850PRO 2TB SSD for program files, LG WH14NS40 Blu-Ray burner. HOTAS Warthog, Saitek Pedals, HP Reverb G2. Partridge and pear tree pending. pilotfly.gif

Link to comment
Share on other sites

oh i see. well either way the Headset is working just fine. and the controllers are plugged into the wall power as I had said so i dont think that is the issue.

 

I may flop it around though and see if it changes anything

Link to comment
Share on other sites

yep checked that as well lol. for what ever reason it sees them as Vive controllers for the G2 but none the less there were no mappings.

 

and like i said i actually turned my controller off to see if that was the problem but it changed nothing.

 

I dont think the issue is the hand controller for the G2 i think it has to do with the headset just dont know what the heck to check other then what i have.

 

i am going to see if i still have my old X52 and see if it happens with that as well.

Link to comment
Share on other sites

2 hours ago, Sirbum said:

when you check in steam settings, what do mean. I still want to be able to use the controller while i am in the game, for like switches and stuff.

 

but do you mean in here?

 

 

 

Well I thought I knew but now not so sure, not finding what I thought it was at the moment.

In any event have a look around in the settings tab of Steam for controllers and see if anything looks amiss.

 

 

 

 

 

 

 

 


Edited by dburne

Don B

 

My VKB Gunfighter MK III Pro L Review

EVGA Z390 Dark MB | i9 9900k CPU @ 5.2 GHz | EVGA RTX 3090 FTW3 Ultra | 32 GB G Skill Trident Z 3200 MHz CL14 | Corsair H150i Pro Cooler |VKB GF MK III Pro L Ultimate Grip| Virpil CM3 Throttle |Reverb G2 | Valve Index| Vive Pro 2 |

Link to comment
Share on other sites

1 hour ago, dburne said:

 

Well I thought I knew but now not so sure, not finding what I thought it was at the moment.

In any event have a look around in the settings tab of Steam for controllers and see if anything looks amiss.

 

 

 

 

 

 

 

 

 

Yep i took a look and nothing. which is what boggles my mind. i even kicked out the profile mapping as HTML to see that it showed the correct axis mappings in there, and it does.

 

The Vive controller that is in there isnt mapped to anything. But then i even turned off the G2 controller while in game and still same damn thing. only axis that seems to work

is the stick left,right, up and down.

 

Funny thing is that with the throttle, like i said when i move it up down it moves the stick up and down at an angle.

and when i turn one of the knobs that i have on there it moves the feet pedals, so more or less it works the rudder lol. but that knob is not even mapped at all.

 

sucks so bad because i waited so long to get back in with VR and seems i can only play while not in VR again 😞

Link to comment
Share on other sites

Just curious.  Which aircraft are you trying to fly at this point?  Just wondering if its something goofy like DCS wanting to switch over to the "game" bindings versus the "sim" bindings when you're in VR.  From what you describe, it definitely sounds like its grabbing default bindings from somewhere.


Edited by eaglecash867

ASRock Z370 Professional Gaming i7, Intel i7 8700K Coffee Lake processor @4.7GHz, Corsair H105 Liquid Cooler, G.SKILL Ripjaws V Series 64GB DDR4 3400 memory, EVGA RTX3090 FTW3 Ultra 24GB video card, Samsung 840PRO 256MB SSD for Windows 10 64-bit OS, Samsung 850PRO 2TB SSD for program files, LG WH14NS40 Blu-Ray burner. HOTAS Warthog, Saitek Pedals, HP Reverb G2. Partridge and pear tree pending. pilotfly.gif

Link to comment
Share on other sites

i am flying the F18 right now. 

 

But here is something i am wondering. say i set up my throttle, then i setup my stick. 

 

now i click on the throttle column and i hit save profile. it saves. now i click on the stick profile and instead of saving

a file for the column it asks me to overwrite.

 

its only saving one file, not two.

Link to comment
Share on other sites

That could be where you're having issues.  The only time I have ever saved profiles is when I know that I'm going to be doing a reinstallation.  I remember how clunky and counter-intuitive that process was, so that might be what's messing things up.  IIRC, I think I ended up just getting frustrated with that whole profile saving process and started just manually setting things up after a reinstallation.  I don't think I ever figured out exactly how the hell the profile saving feature was supposed to work.  Try setting a few axes up manually and then just go into the plane without saving any profiles and see what that does.  Don't worry, it will retain all of your controller settings for a given aircraft when you exit the sim.  The only time those get wiped out is when you do a reinstallation.

ASRock Z370 Professional Gaming i7, Intel i7 8700K Coffee Lake processor @4.7GHz, Corsair H105 Liquid Cooler, G.SKILL Ripjaws V Series 64GB DDR4 3400 memory, EVGA RTX3090 FTW3 Ultra 24GB video card, Samsung 840PRO 256MB SSD for Windows 10 64-bit OS, Samsung 850PRO 2TB SSD for program files, LG WH14NS40 Blu-Ray burner. HOTAS Warthog, Saitek Pedals, HP Reverb G2. Partridge and pear tree pending. pilotfly.gif

Link to comment
Share on other sites

so here is a test i just tried after you said something about it trying to use another profile. 

i went back into the game with only my throttle connected.

 

i went into the game and i cleared all of the column for the throttle as well as the axis under the F18_Sim, this is the one i always use and have always used.

 

but i then switched over to F18_Game and all i set was the Thrust under axis, went back into the game and bam. it moved my throttle only. nothing else.

 

so i went back into controls and up at the top left it showed F18_SIM but nothing was mapped. so i switched over to the game one took out the mapping

and bam i had nothing.

 

So i am at a complete loss here because if i map the axis under Game it works but not Sim. and if you use only Game you lose a lot of Mappings.

 

EDIT: so i can definantly say now the issue is that even though i set the mappings for F18_SIM it is using the _Game, because i just went back in to the game with out VR at all, and only way i could get the throttle to work was if i mapped it under F18_Game.

 

under Sim it would do the same thing it was doing in VR. lol and all of this is with a fresh install of DCS. thats why im only doing it in the F18 because i havnt downloaded all the others yet


Edited by Sirbum
Link to comment
Share on other sites

so i have figured out that this all has to do with the F18, because i just installed the Av8B and everything works just fine.

 

So not sure what the issue is with the F18. so i think i am going to put this into the bugs area.

Link to comment
Share on other sites

  • 1 month later...

 

On 8/5/2021 at 7:24 PM, Sirbum said:

yep checked that as well lol. for what ever reason it sees them as Vive controllers for the G2 but none the less there were no mappings.

 

I had the same issue. Vive Controller wasn't mapped to any axis. Shutting off the controller didn't help, but when I disabled the Vive controller within the DCS control mapping the problem was solved.

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...