Jump to content

Update 2.7.4 stick trouble?


Go to solution Solved by cthulhu68,

Recommended Posts

I updated to the recent 2.7.4 with the new hind patches, and now my entire stick has a life of its own. Turning off all the autopilot switches does nothing and I can't even trim the stick to center. The stick always tries to level me off as if the AI is trying to fly whenever I am not inputting anything. Has there been any new settings that I missed? On startup, the stick automatically starts to try and move the heli around, represented by the pic.

Screen_210721_205215.png

Link to comment
Share on other sites

You need to delete the MI24P folder from Saved Games / DCS / Config and redo all your controls. Controls are now MI24P_pilot. As per usual everything is now bound to both stick and throttle by default.


Edited by cthulhu68

 

Link to comment
Share on other sites

5 minutes ago, cthulhu68 said:

You need to delete the MI24P folder from Saved Games / DCS / Config and redo all your controls. Controls are now MI24P_pilot. As per usual everything is now bound to both stick and throttle.

 

Ah I see, I assumed they deleted themselves. I already rebound all my controls and now I see the regular mi-24 folder lol. Testing

Link to comment
Share on other sites

8 minutes ago, cthulhu68 said:

Dont know if its just a CH Products thing but I also had to recalibrate my stick and throttle to get it working good.

So I deleted the folder and redid all my controls, but all of my attempts to get this weird autopilot thing off are a no go. The stick keeps swinging back and leveling me off, same with the rudder. All the autopilot knobs are turned off.

Link to comment
Share on other sites

On controls screen where you see the word "ALL" click on that to open drop down menu. Go to Axis Commands and there you'll see pitch, roll, rudder are bound to to your stick and throttle and whatever else you have plugged into your computer.


Edited by cthulhu68

 

Link to comment
Share on other sites

3 minutes ago, cthulhu68 said:

On controls screen where you see the word "ALL" click on that to open drop down menu. Go to Axis Assign and there you'll see pitch, roll, rudder are bound to to your stick and throttle and whatever else you have plugged into your computer.

image.png

I see what you are saying, but I had already gone and did that.

Here is a track as well.

mi-24questonable.trk

Like, it doesn't make much sense that it would be a double input because it always ends up leveling off my aircraft and makes me hover, which I would think a double input would certainly NOT do lol

 

Link to comment
Share on other sites

3 minutes ago, cthulhu68 said:

Is this in a training mission? Sometimes by default they use "Game" settings instead of Sim.  Also check under Options / Gameplay that you dont have Game Flight or Game Avionics checked.

This is in any time I run the mi-24 now, I've tested Syria, Mariana, and Caucaus and all lead to my stick constantly fighting to stay center. Even when I use trimmer, the stick just sticks to trying to keep me level instead of letting me do stuff.

image.pngimage.png

Link to comment
Share on other sites

I notice the yaw and pitch autopilots are automatically on every time I start up and when I turn them off, nothing happens, same wit turning them back on. Maybe it's a bug where the autopilot doesn't disengage?

 

1 minute ago, cthulhu68 said:

OK. I know what it is. Go to Options / Special MI24 and uncheck Control Helper

checking

 

Yep that was it! Man that was so confusing

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...