Jump to content

F-15C - Some RADAR controls stop working on the stick


Recommended Posts

Apparently there is a new bug on the F-15C.

I have all the radar controls mapped to my stick.

Sometimes, most of those controls stop working.

I can no longer designate targets or move the antenna up and down, but I can still slew the TDC and fire.

Another thing I can’t do is drop the bags using the controls on the stick.

I can still designate targets using the keyboard, but I had almost forgotten how to do that.

One curious thing is that the problem seems to be always preceded by a right engine flameout, or what seems to be a flameout.

When I notice that the engine is flamed out I relight it.

After that the controls stop working.

If I land and change slot everything goes back to normal.

Link to comment
Share on other sites

I have never had problems like this, and neither do I currently. More pissing me off is that the radar now has is like having cataracts again and since big holiday you can see something over 40 miles on it.

 

(Pierwsze słyszę o takich problemach jakie opisujesz. Wygląda raczej na problem z konkretnie Twoja kopią DCSa może przeinstaluj go. Bardziej wkurzające jest to, że znów radar jest prawie ślepy i jak złapie coś powyżej 40 mil to jest wielkie święto. Co wychodzi jakiś pacz który nie dotyczy F-15C od razu syfi w F-15 radar... )

Link to comment
Share on other sites

3 hours ago, Nahen said:

Bardziej wkurzające jest to, że znów radar jest prawie ślepy i jak złapie coś powyżej 40 mil to jest wielkie święto. Co wychodzi jakiś pacz który nie dotyczy F-15C od razu syfi w F-15 radar...

This is already reported and you exaggerate a bit, don't you?

https://forums.eagle.ru/topic/233863-anapg-63-range-is-under-represented/#comments

 

🖥️ i3-10100F 3.6-4.3GHz, 16GB DDR4 2666, GTX970 4GB, SSD SATA3   🥽 Rift S   🕹️ T16000M HOTAS   ✈️ FC3, F-14A/B   🚢 Supercarrier    🌍 NTTR, PG

Link to comment
Share on other sites

Explain to me what am I exaggerating? Except that pathe and update come out every now and then, where there is no word in the changelog about the F-15, and miracles happen with the radar in this module? In the last year, it has been about 4-5 times like this. Officially: "this patch did not change anything on the F-15" - in fact the radar "died". And so every now and then.

Link to comment
Share on other sites

Posted (edited)

The radar is working as it had before.   It'll be nice when they bump up the range, Chizh already said publicly that it is under-modeled.

 

As for your other problems, I would look really close at your controls with whatever diagnostic tools you have.  It looks like there might be some 'gotcha' combinations that will turn off your engine, switch a profile somewhere somehow, etc.


Edited by GGTharos
  • Like 1

[sIGPIC][/sIGPIC]

Reminder: SAM = Speed Bump :D

I used to play flight sims like you, but then I took a slammer to the knee - Yoda

Link to comment
Share on other sites

On 6/28/2021 at 3:34 AM, NightMan said:

Apparently there is a new bug on the F-15C.

 

I have all the radar controls mapped to my stick.

 

Sometimes, most of those controls stop working.

 

I can no longer designate targets or move the antenna up and down, but I can still slew the TDC and fire.

 

Another thing I can’t do is drop the bags using the controls on the stick.

 

I can still designate targets using the keyboard, but I had almost forgotten how to do that.

 

One curious thing is that the problem seems to be always preceded by a right engine flameout, or what seems to be a flameout.

 

When I notice that the engine is flamed out I relight it.

 

After that the controls stop working.

 

If I land and change slot everything goes back to normal.

 

 

 

 

 

 

I just found out that most of the controls appear reversed.

I had the right engine flame out, as usual, but when I tried to restart it I found out that the controls where affecting the left engine.

Also,  the throttle on the stick stopped working.

I had to land using keyboard controls.

And it isn't a hardware problem, because when I jumped into another slot everything was working properly.

 

Another problem is I can't launch any missiles.

 

I AM CERTAIN THIS IS A NEW BUG.

Please address it urgently, as I am frequently having to extend and RTB because I am helpless without controls.

Link to comment
Share on other sites

Sounds like it's software - specifically your HOTAS software if you have any.

[sIGPIC][/sIGPIC]

Reminder: SAM = Speed Bump :D

I used to play flight sims like you, but then I took a slammer to the knee - Yoda

Link to comment
Share on other sites

I just found out that the problem occurs also on the Su-25T, altough I didn't understand exactly what was reversed because I overshot the runway and died.

Each time Eagle Dynamics get one right they get two wrong.

It's really upseting.

How do they expect people to invest in new modules?... when the older ones are so full of bugs.

31 minutes ago, GGTharos said:

Sounds like it's software - specifically your HOTAS software if you have any.

 

That's ridiculous.

If it were then it would misbehave all the time.

It doesn't happen with the Kamov and neither with the A-10C.

Only FC3 modules.

32 minutes ago, GGTharos said:

Sounds like it's software - specifically your HOTAS software if you have any.

Ridiculous.

Another development;

It affects also the controls for the chat window.

They become all reversed, so it can't be related to the stick.

Link to comment
Share on other sites

Hey man, I feel your frustration, but what exactly got reversed?
Maybe the diff files got corrupted somehow. Have you tried to make a backup and delete them, to see if starting from scratch helps?
Does this only happen in MP?
Cheers!

Sent from my MAR-LX1A using Tapatalk

Link to comment
Share on other sites

Another update; I just found out that if I saty off the chat window, the bug doesn't occur.

7 minutes ago, MAXsenna said:

Hey man, I feel your frustration, but what exactly got reversed?
Maybe the diff files got corrupted somehow. Have you tried to make a backup and delete them, to see if starting from scratch helps?
Does this only happen in MP?
Cheers!

Sent from my MAR-LX1A using Tapatalk

 

Not at all.

There is a bug with the chat window.

And I have reasons to believe it messes with the controls.

And yes; I'm in MP.

I'm having a perfect flight since I decided to stay away from the chat window.
 

 

 

Link to comment
Share on other sites

11 minutes ago, MAXsenna said:

Hey man, I feel your frustration, but what exactly got reversed?
Maybe the diff files got corrupted somehow. Have you tried to make a backup and delete them, to see if starting from scratch helps?
Does this only happen in MP?
Cheers!

Sent from my MAR-LX1A using Tapatalk
 

...and why is it that the first answer people draw out of the toolbox points to damaged files and to replace them?!!!

As a matter of fact I have diferential backups.

I just compared the files with a backup set from April and they are equal.

I haven't changed the controls for the F-15C for years.

Link to comment
Share on other sites

...and why is it that the first answer people draw out of the toolbox points to damaged files and to replace them?!!!
As a matter of fact I have diferential backups.
I just compared the files with a backup set from April and they are equal.
I haven't changed the controls for the F-15C for years.
1. You didn't answer the question about what is reversed. Axis or functions?
2. Because that has happened to me. Both corruption and change in function of the control settings of the module where you have to delete the saved games files. I know from this forum others have experienced this as well. But it was always notification in the change log.
3. I can understand your frustration, but was my questions in any way unpolite or offensive?

Have a fantastic weekend, crossing my fingers for a solution.
Cheers!

Sent from my MAR-LX1A using Tapatalk

Since I hid the chat window and stopped using it everything has been working like a charm!!!
Hmm... Bummer, that's just a workaround at best.
You don't have VoiceAttack by chance?

Sent from my MAR-LX1A using Tapatalk

Link to comment
Share on other sites

11 hours ago, MAXsenna said:

1. You didn't answer the question about what is reversed. Axis or functions?
2. Because that has happened to me. Both corruption and change in function of the control settings of the module where you have to delete the saved games files. I know from this forum others have experienced this as well. But it was always notification in the change log.
3. I can understand your frustration, but was my questions in any way unpolite or offensive?

Have a fantastic weekend, crossing my fingers for a solution.
Cheers!

Sent from my MAR-LX1A using Tapatalk

Hmm... Bummer, that's just a workaround at best.
You don't have VoiceAttack by chance?

Sent from my MAR-LX1A using Tapatalk
 

Hi!

 

No, I don't have VoiceAttack.

I usually like to keep it simple and standard.

And yes. A whole day without any problems, since I stopped using the chat window.

I am now going to try to sistematicaly reproduce the bug by using the chat window in a more controlled situation.

 

I should have some results in a couple of hours.

  • Like 1
Link to comment
Share on other sites

I tinkered with the chat window until the bug manifested itself, making sure to note all the keystrokes I inputed.

I managed to land.

When on the ground I tried to redo what I had been doing before, and, to my surprise, after a few experiments, the effect was undone.

I am now able to reproduce the bug.

 

You open the chat window - <TAB> - (UI Layer: Multiplayer chat - mode Allies);

Then you select ALL - <CTRL+TAB> - (UI Layer: Multiplayer chat read/write all);

After that you hide the chat - <CTRL+SHIFT+TAB> - (UI Layer: Chat show/hide);

 

The bug happens.

The controls on the stick which depend on a keyboard Modifier stop working.

To undo the bug you proceed unhiding the chat window, opening it and finally closing it.

 

For that you unhide the chat - <CTRL+SHIFT+TAB> - (UI Layer: Chat show/hide);

Open the chat window - <TAB> - (UI Layer: Multiplayer chat - mode Allies);

Close the chat window - <TAB> - (UI Layer: Multiplayer chat - mode Allies);

 

I did all the steps using just the keyboard.

The controls depend on each one's configuration.

For me they are:

TAB

CTRL+TAB

CTRL+SHIFT+TAB

 

Then

CTRL+SHIFT+TAB

TAB

TAB

 

 

Could someone please warn EDiots about this and ask them to solve it?

 

Thank you very much.

Link to comment
Share on other sites




I tinkered with the chat window until the bug manifested itself, making sure to note all the keystrokes I inputed.
I managed to land.
When on the ground I tried to redo what I had been doing before, and, to my surprise, after a few experiments, the effect was undone.
I am now able to reproduce the bug.
 
You open the chat window - - (UI Layer: Multiplayer chat - mode Allies);
Then you select ALL - - (UI Layer: Multiplayer chat read/write all);
After that you hide the chat - - (UI Layer: Chat show/hide);
 
The bug happens.
The controls on the stick which depend on a keyboard Modifier stop working.
To undo the bug you proceed unhiding the chat window, opening it and finally closing it.
 
For that you unhide the chat - - (UI Layer: Chat show/hide);
Open the chat window - - (UI Layer: Multiplayer chat - mode Allies);
Close the chat window - - (UI Layer: Multiplayer chat - mode Allies);
 
I did all the steps using just the keyboard.
The controls depend on each one's configuration.
For me they are:
TAB
CTRL+TAB
CTRL+SHIFT+TAB
 
Then
CTRL+SHIFT+TAB
TAB
TAB
 
 
Could someone please warn EDiots about this and ask them to solve it?
 
Thank you very much.


I might try to reproduce, I just want to get it right, just in case I have misunderstood something.
This only happens in MP, (obviously).
The stick doesn't stop responding, but the button controls on it does.
The buttons that stops working are tied to modifiers.
You don't explicitly say, but I assume you mean
LShft
LCtrl
I also assume those are also used as modifiers.
If my assumptions are correct.
What happens if you stop using those as modifiers and try these instead?

LAlt
RAlt
RShft
RCtrl
Win
Spare button on throttle/stick/other controller.

It's almost looks like a modifier is "hung".
Anyway, I asked about VoiceAttack, as with a little tinkering in dictation mode you can use it to chat.

I also believe you'll get better support by not calling names and including the DCS.log and a track, since to my knowledge you're the first one I have seen to report this. Might be because everybody else is using TS3/Discord/SRS anyway.
But what do I know.
Cheers!


Sent from my MAR-LX1A using Tapatalk


Link to comment
Share on other sites

Posted (edited)
17 hours ago, MAXsenna said:



 

 


I might try to reproduce, I just want to get it right, just in case I have misunderstood something.
This only happens in MP, (obviously).   As far as I know, there is no chat window in SP!😉
The stick doesn't stop responding, but the button controls on it does. Not quite. Everything on the stick continues to work, except for the controls that have a modifier, no matter what it is. So, all the surfaces continue to move, as well as all the buttons and the hat switch. But if I use them with a modifier then they don't work.

For example:

Antenna Up: LCtrl+LShift+HatSwitch Forward

Antenna Down: LCtrl+LShift+HatSwitch Back

TDC Up: LCtrl+HatSwitch Forward

TDC Down: LCtrl+HatSwitch Back
The buttons that stop working are tied to modifiers.    They continue to work, but not when used with modifiers.
You don't explicitly say, but I assume you mean
LShft   CORRECT
LCtrl    CORRECT
I also assume those are also used as modifiers.   CORRECT
If my assumptions are correct.   Most of them.
What happens if you stop using those as modifiers and try these instead?

I use all the spare keys for modifiers, as my stick doesn't have too many buttons as something like the Warthog!

So I use:

LCtrl, LShift, LAlt, WinKey, RCtrl, RShift, RAlt.

And frequently a combination of those, like, for example the ones I point above for the antenna.

In the A-10C I have hundred of controls assigned with one or more modifiers at the same time.

Of course they are assigned in a way that makes sense to me, but it works.

And I am quite good with it too.

Same and especially with the Ka-50.

Try looking at the F-15C diff file I upload yesterday.

 

Thank you very much for your attention.

 

I just tried it again, this time without even leaving the ground.

I started the left engine and the right one spooled.

Then I tried moving the antenna up and down and it didn't work. This control is tied to LCtrl and Hat Switch.

 

I did it only to upload the log file and the track file you suggested.

I doubt it will show up in there, but I don't have anything to lose.

However, I couldn't upload the track file as it is WELLL OVER 5 MB, and there is no point in zipping because it is already a zip file with a diferent extension (TRK).

 

Quote

I just found a simpler way of reproducing it:

LCtrl+Tab

Tab

Tab

The bug occurs.

Then to unlock it, press:

Tab

Tab

 

dcs.log


Edited by NightMan
Link to comment
Share on other sites

  • 1 month later...
And another update was released and this bug is still pesking our flights.
Hey man. I've been playing the F-15 every day for a week in single player without a y problems. This is related to the chat function, right?
I did have some issues with that on another module, and I've seen it reported in other posts today.
You should head over to those and voice in with them.
Cheers!

Sent from my MAR-LX1A using Tapatalk

Link to comment
Share on other sites

  • 3 weeks later...
On 8/13/2021 at 1:03 AM, MAXsenna said:

Hey man. I've been playing the F-15 every day for a week in single player without a y problems. This is related to the chat function, right?
I did have some issues with that on another module, and I've seen it reported in other posts today.
You should head over to those and voice in with them.
Cheers!

Sent from my MAR-LX1A using Tapatalk
 

Yes, this problem is related with the chat function.

And, of course, it doesn't happen in single player!!!

It causes problems not only to the RADAR but to everything that depends on modifiers.

You talk about other posts; could you provide the links, please?!

On 7/3/2021 at 1:45 AM, GGTharos said:

Sounds like it's software - specifically your HOTAS software if you have any.

Negative.

  • Like 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...