Jump to content

Random crashes


Specter
 Share

Recommended Posts

I took some of the OC off my CPU - I am GPU limited anyway and it removed some very rare crash issues

 

The 222559 log show you getting the DXGI_ERROR_DEVICE_REMOVED issue, which I think is related to OC or undervolting - if you search the forums for it there have been several threads recently - these might give you more information

 

2021-07-01 22:25:58.483 ERROR   DX11BACKEND: DX device removed. Reason: 0x887A0006
2021-07-01 22:25:58.508 WARNING LOG: 3 duplicate message(s) skipped.
2021-07-01 22:25:58.508 ERROR   DX11BACKEND: failed to create vertex buffer. Reason: DXGI_ERROR_DEVICE_REMOVED
2021-07-01 22:25:58.508 ERROR   DX11BACKEND: Failed assert `false && "failed to create vertex buffer"` at Projects\render\dx11backend_win8\Source\DX11BufferManager.cpp:416
2021-07-01 22:25:58.508 ERROR   DX11BACKEND: failed to create vertex buffer. Reason: DXGI_ERROR_DEVICE_REMOVED
2021-07-01 22:25:58.508 ERROR   DX11BACKEND: Failed assert `false && "failed to create vertex buffer"` at Projects\render\dx11backend_win8\Source\DX11BufferManager.cpp:416
2021-07-01 22:25:58.513 ERROR   DX11BACKEND: DX device removed. Reason: 0x887A0006
2021-07-01 22:25:58.624 WARNING LOG: 17 duplicate message(s) skipped.
2021-07-01 22:25:58.624 ERROR   DX11BACKEND: failed to create vertex buffer. Reason: DXGI_ERROR_DEVICE_REMOVED
2021-07-01 22:25:58.624 ERROR   DX11BACKEND: Failed assert `false && "failed to create vertex buffer"` at Projects\render\dx11backend_win8\Source\DX11BufferManager.cpp:416
2021-07-01 22:25:58.624 ERROR   DX11BACKEND: failed to create vertex buffer. Reason: DXGI_ERROR_DEVICE_REMOVED
2021-07-01 22:25:58.624 ERROR   DX11BACKEND: Failed assert `false && "failed to create vertex buffer"` at Projects\render\dx11backend_win8\Source\DX11BufferManager.cpp:416
2021-07-01 22:25:58.624 ERROR   DX11BACKEND: failed to create vertex buffer. Reason: DXGI_ERROR_DEVICE_REMOVED
2021-07-01 22:25:58.624 ERROR   DX11BACKEND: Failed assert `false && "failed to create vertex buffer"` at Projects\render\dx11backend_win8\Source\DX11BufferManager.cpp:416
2021-07-01 22:25:58.624 ERROR   DX11BACKEND: failed to create vertex buffer. Reason: DXGI_ERROR_DEVICE_REMOVED
2021-07-01 22:25:58.624 ERROR   DX11BACKEND: Failed assert `false && "failed to create vertex buffer"` at Projects\render\dx11backend_win8\Source\DX11BufferManager.cpp:416
2021-07-01 22:25:58.629 ERROR   DX11BACKEND: DX device removed. Reason: 0x887A0006
2021-07-01 22:25:58.724 WARNING LOG: 15 duplicate message(s) skipped.
2021-07-01 22:25:58.724 ERROR   DX11BACKEND: failed to create structed buffer. Reason: DXGI_ERROR_DEVICE_REMOVED
2021-07-01 22:25:58.729 INFO    EDCORE: try to write dump information
2021-07-01 22:25:58.733 INFO    EDCORE: # -------------- 20210701-222559 --------------
2021-07-01 22:25:58.734 INFO    EDCORE: DCS/2.7.2.8165 (x86_64; Windows NT 10.0.19041)
2021-07-01 22:25:58.737 INFO    EDCORE: C:\Program Files\Eagle Dynamics\DCS World\bin\dxgi.dll

 

Windows 10 Home ¦ Z370 AORUS Gaming K3 motherboard ¦ i5-8600K oc to 4.3GHz ¦ 48GB Corsair PC4 memory @ 3000MHz ¦ Samsung 960 EVO M.2 SSD for OS, Samsung 860 EVO 1TB SSD for DCS ¦ ASUS ROG GTX 2060 Super 8GB ¦ Virpil WarBRD base with VFX grip, Thrustmaster A10c and F/A-18 grips ¦ VKB Gunfighter Mk2 and MCG ¦ Thrustmaster Warthog Throttle ¦ MFG Crosswinds ¦ Oculus Rift S

Link to comment
Share on other sites

I’ll give it a shot to check my overclocking, but I keep everything stock on my computer, so unless it’s something wild running in the bios I have no clue what it would be. 
when the crashes first started I noticed them in VR saying that my track IR was plugged in or unplugged. I have since removed Track Ir and it continues. 

i7-6700k| 32GB ram| GTX 2080 founders edition| Oculus Rift 2

My WIP Youtube

Link to comment
Share on other sites

New development, just when I thought that random crashes were behind me, I started to bump up the settings and OC the PC and GPU until the crashes started up again. All this was a waste of time. I learned in the Forum that if you fly the F-14 in MP, on the 3rd time that you select an F-14 slot, DCS locks up. I tested it and yes DCS locked up on the 3rd time. I was flying the A-10 and AV8B most of the time with no problems. Then I switched to the F-14 and the random crashes began, but turns out it was not random. The F-14 is such a complicated Module that it requires a gaming rig with the best hardware to run it.  But this is something else that will require some programing fixes. I'm just going to have to use the F-14 sparingly and hope that will keep DCS from "Not Responding" and locking my PC.

Link to comment
Share on other sites

From discord

Quote

So I’m not sure which it was but this has been the most stable flight I’ve had:
Used DDU to uninstall graphics driver and rolled back to previous version (I think 466)
Set my Bios to default and set ram to 2133 
Uninstall Bitdefender. Along with the using the CMD prompts you gave me <@665658091752259605>, I did not have any issues or crashes for about 2 hours of flying. All seems well!

Quote

<@728032949358034969> run cmd.exe as Administrator and type in the following commands:
sfc /scannow
and
dism /online /cleanup-image /restorehealth
That'll check your registry and compares files against Windows update to make sure everything is correct.
That error in nvwgf2umx.dll points to a problem in memory handling between your card and your RAM when swapping from VRAM to RAM. So it might be that a RAM chip of yours has issues.

Seems to have fixed the issue

i7-6700k| 32GB ram| GTX 2080 founders edition| Oculus Rift 2

My WIP Youtube

Link to comment
Share on other sites

On 7/2/2021 at 1:23 PM, Specter said:

Hi Flappie

 

Thanks for all your efforts with this. It is sort of comforting, in a strange kinda way, to know I am not the only one with this issue.

 

I have tried item 1 numerous times as I also get random IC failures with core DCS files!  Reproducing the CTD is difficult as it is random.  The last 2 I had, one was as I entered the cockpit (F-18) the second was as I was taxying and moving my head (VR).  3rd restart and got airborne with no CTD, same single player mission!

 

I will try 2-6 and see how it goes.

 

PS, I can zip up every crash log I have had since 2.7 and attach them here if it will help.

 

 

An update that is most probably the cause of my CTDs.

 

I noticed that I was also getting occasional BSOD when in MSFS.  I did a bit more reading and found out that errors involving nvwgf2umx.dll were related when the system was swapping data between RAM and VRAM.  I also noted that although my CTDs started after DCS 2.7, I had a month before I added a further 32Gb of RAM.

 

Everything was pointing at the RAM so I ran Memtest86 from a bootable USB and I had a failure after a few moments.  Long story short, by testing each stick on their own I discovered one of the new sticks I had added was faulty.

 

I am currently back at 32Gb and will run like that for a while to see if crashes reoccur while I wait for more RAM to arrive.

 

I'll report back if problem persists.

i7-10700K @ 5Ghz | Asus Z490 Tuf Pro Gaming | RTX 3090 | 64 Gb RAM @3.6Ghz | addlink S70 1TB M.2 SSD | 1TB Samsung 850 EVO | 4TB HDD | Reverb G2 | Thrustmaster Warthog HOTAS | Thrustmaster TPR rudder pedals | Thrustmaster Cougar MFDs

Link to comment
Share on other sites

12 hours ago, Specter said:

 

An update that is most probably the cause of my CTDs.

 

I noticed that I was also getting occasional BSOD when in MSFS.  I did a bit more reading and found out that errors involving nvwgf2umx.dll were related when the system was swapping data between RAM and VRAM.  I also noted that although my CTDs started after DCS 2.7, I had a month before I added a further 32Gb of RAM.

 

Everything was pointing at the RAM so I ran Memtest86 from a bootable USB and I had a failure after a few moments.  Long story short, by testing each stick on their own I discovered one of the new sticks I had added was faulty.

 

I am currently back at 32Gb and will run like that for a while to see if crashes reoccur while I wait for more RAM to arrive.

 

I'll report back if problem persists.

Interesting, I completely forget I had upgraded to 64gb as well recently! I am running memtest right now on my two new sticks

i7-6700k| 32GB ram| GTX 2080 founders edition| Oculus Rift 2

My WIP Youtube

Link to comment
Share on other sites

  • 5 weeks later...

As I have now not had a CTD in the 3 weeks since I removed the faulty RAM stick I am fairly confident that was the cause of my CTDs.  Next time I'm having random unrelated issues I will resort to Memtest86 sooner😄

  • Thanks 1

i7-10700K @ 5Ghz | Asus Z490 Tuf Pro Gaming | RTX 3090 | 64 Gb RAM @3.6Ghz | addlink S70 1TB M.2 SSD | 1TB Samsung 850 EVO | 4TB HDD | Reverb G2 | Thrustmaster Warthog HOTAS | Thrustmaster TPR rudder pedals | Thrustmaster Cougar MFDs

Link to comment
Share on other sites

On 7/1/2021 at 9:49 PM, Ramstein said:

add me to this nightmare... it worked fine until the patch I spent like 4 hours workng on this last night,, I can't fly at all before it crashes... frozen with save the dxdiag file and logs.... I haven't looked at al the threads yet,, but there have to be a zillion of us that cannot fly after the patch...

 

I have been flying in VR for several months... but apparently it doesn't care if you are 2d, 3d, or vr, stil crashes...

I already ran repair like 20x. I renamed files to save them and let it rebuild them. I have the latest drivers. I even re-installed the laatest Nvidia graphics yesterday to make sure.

 

I can run my other program and sims no issues. I say something inthe patch messed up something.

 

Guess I am off to go reading the ther threads to see what is going on with the patch we just had in OB.

Same here since last patch. Everytime a new patch arrives it’s getting troubles. No fun actually.

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...