Jump to content

Random crashes


Specter
 Share

Recommended Posts

Can anyone tell me the most likely cause of these random crashes I am experiencing from the attached Crash logs.

 

It is getting really frustrating, I get have been getting these crashes for several versions on OB regardless of Nvidia driver version and in either 2D or VR and whether vanilla install or with mods applied.

 

Thanks in advance

dcs.20210626-200710.crash dcs.log

i7-10700K @ 5Ghz | Asus Z490 Tuf Pro Gaming | RTX 3090 | 64 Gb RAM @3.6Ghz | addlink S70 1TB M.2 SSD | 1TB Samsung 850 EVO | 4TB HDD | Reverb G2 | Thrustmaster Warthog HOTAS | Thrustmaster TPR rudder pedals | Thrustmaster Cougar MFDs

Link to comment
Share on other sites

Hi Specter. Here's your crash:

 

2021-06-26 20:06:58.801 INFO    Dispatcher: loadMission Done: Сontrol passed to the player
2021-06-26 20:07:00.790 DEBUG   LuaGUI: ----onSimulationResume---
2021-06-26 20:07:00.799 INFO    TACVIEW.DLL: Recording flight data in [C:\Users\Jim\Documents\Tacview\Tacview-20210626-210700-DCS-F-5E QuickStart SoH - Free Flight.zip.acmi]
2021-06-26 20:07:10.840 INFO    EDCORE: try to write dump information
2021-06-26 20:07:10.841 INFO    EDCORE: # -------------- 20210626-200710 --------------
2021-06-26 20:07:10.842 INFO    EDCORE: DCS/2.7.2.7910 (x86_64; Windows NT 10.0.19042)
2021-06-26 20:07:10.844 INFO    EDCORE: C:\WINDOWS\System32\DriverStore\FileRepository\nv_dispi.inf_amd64_b2801df14ec7de03\nvwgf2umx.dll
2021-06-26 20:07:10.845 INFO    EDCORE: # C0000005 ACCESS_VIOLATION at CCCC30C5 00:00000000
2021-06-26 20:07:10.850 INFO    EDCORE: SymInit: Symbol-SearchPath: '.;C:\Eagle Dynamics\DCS World OpenBeta;C:\Eagle Dynamics\DCS World OpenBeta\bin;C:\WINDOWS;C:\WINDOWS\system32;SRV*C:\websymbols*https://msdl.microsoft.com/download/symbols;', symOptions: 528, UserName: 'Jim'
2021-06-26 20:07:10.852 INFO    EDCORE: OS-Version: 10.0.19042 () 0x300-0x1
2021-06-26 20:07:11.302 INFO    EDCORE: 0x00000000007A30C5 (nvwgf2umx): cask::SafeEnum<cask::md::WeightLayoutType_ENUMCLASS_SCOPEWRAPPER>::SafeEnum<cask::md::WeightLayoutType_ENUMCLASS_SCOPEWRAPPER> + 0x1608D5
2021-06-26 20:07:11.302 INFO    EDCORE: 0x00000000007F2581 (nvwgf2umx): cask::SafeEnum<cask::md::WeightLayoutType_ENUMCLASS_SCOPEWRAPPER>::SafeEnum<cask::md::WeightLayoutType_ENUMCLASS_SCOPEWRAPPER> + 0x1AFD91
2021-06-26 20:07:11.302 INFO    EDCORE: 0x00000000007B6D9F (nvwgf2umx): cask::SafeEnum<cask::md::WeightLayoutType_ENUMCLASS_SCOPEWRAPPER>::SafeEnum<cask::md::WeightLayoutType_ENUMCLASS_SCOPEWRAPPER> + 0x1745AF
2021-06-26 20:07:11.302 INFO    EDCORE: 0x00000000007B77D4 (nvwgf2umx): cask::SafeEnum<cask::md::WeightLayoutType_ENUMCLASS_SCOPEWRAPPER>::SafeEnum<cask::md::WeightLayoutType_ENUMCLASS_SCOPEWRAPPER> + 0x174FE4
2021-06-26 20:07:11.302 INFO    EDCORE: 0x00000000008ABA16 (nvwgf2umx): cask::SafeEnum<cask::md::WeightLayoutType_ENUMCLASS_SCOPEWRAPPER>::SafeEnum<cask::md::WeightLayoutType_ENUMCLASS_SCOPEWRAPPER> + 0x269226
2021-06-26 20:07:11.303 INFO    EDCORE: 0x00000000008ABB63 (nvwgf2umx): cask::SafeEnum<cask::md::WeightLayoutType_ENUMCLASS_SCOPEWRAPPER>::SafeEnum<cask::md::WeightLayoutType_ENUMCLASS_SCOPEWRAPPER> + 0x269373
2021-06-26 20:07:11.303 INFO    EDCORE: 0x00000000006AC712 (nvwgf2umx): cask::SafeEnum<cask::md::WeightLayoutType_ENUMCLASS_SCOPEWRAPPER>::SafeEnum<cask::md::WeightLayoutType_ENUMCLASS_SCOPEWRAPPER> + 0x69F22
2021-06-26 20:07:11.303 INFO    EDCORE: 0x0000000000623410 (nvwgf2umx): NVENCODEAPI_Thunk + 0x30B6A0
2021-06-26 20:07:11.303 INFO    EDCORE: 0x000000000064241C (nvwgf2umx): NVENCODEAPI_Thunk + 0x32A6AC
2021-06-26 20:07:11.303 INFO    EDCORE: 0x000000000061F95A (nvwgf2umx): NVENCODEAPI_Thunk + 0x307BEA
2021-06-26 20:07:11.304 INFO    EDCORE: 0x000000000005228A (nvwgf2umx): cask::ShaderList<cask::ConvShader,cask::Convolution>::availableShaders + 0x355A
2021-06-26 20:07:11.304 INFO    EDCORE: 0x0000000000484037 (nvwgf2umx): NVENCODEAPI_Thunk + 0x16C2C7
2021-06-26 20:07:11.304 INFO    EDCORE: 0x00000000001F918C (nvwgf2umx): cask::ShaderList<cask::ConvShader,cask::Convolution>::availableShaders + 0x1AA45C
2021-06-26 20:07:11.304 INFO    EDCORE: 0x000000000021C4C9 (nvwgf2umx): cask::ShaderList<cask::ConvShader,cask::Convolution>::availableShaders + 0x1CD799
2021-06-26 20:07:11.304 INFO    EDCORE: 0x000000000007666D (nvwgf2umx): cask::ShaderList<cask::ConvShader,cask::Convolution>::availableShaders + 0x2793D
2021-06-26 20:07:11.305 INFO    EDCORE: 0x00000000004162E9 (nvwgf2umx): NVENCODEAPI_Thunk + 0xFE579
2021-06-26 20:07:11.305 INFO    EDCORE: 0x0000000000416072 (nvwgf2umx): NVENCODEAPI_Thunk + 0xFE302
2021-06-26 20:07:11.305 INFO    EDCORE: 0x000000000058F85C (nvwgf2umx): NVENCODEAPI_Thunk + 0x277AEC
2021-06-26 20:07:11.305 INFO    EDCORE: 0x0000000001170F94 (nvwgf2umx): OpenAdapter12 + 0x3FD964
2021-06-26 20:07:11.305 INFO    EDCORE: 0x0000000000017034 (KERNEL32): BaseThreadInitThunk + 0x14
2021-06-26 20:07:11.305 INFO    EDCORE: 0x0000000000052651 (ntdll): RtlUserThreadStart + 0x21
2021-06-26 20:07:11.580 INFO    EDCORE: Minidump created.

 

 

Please try this:

  1. Download DDU
  2. Launch DDU and ask it to uninstall all graphics driver
  3. Reinstall your NVIDIA driver

A track or it didn't happen.

Link to comment
Share on other sites

Thanks Flappie but that is how I always update my Nvidia drivers included recently.  I'm afraid that is not the fix.

i7-10700K @ 5Ghz | Asus Z490 Tuf Pro Gaming | RTX 3090 | 64 Gb RAM @3.6Ghz | addlink S70 1TB M.2 SSD | 1TB Samsung 850 EVO | 4TB HDD | Reverb G2 | Thrustmaster Warthog HOTAS | Thrustmaster TPR rudder pedals | Thrustmaster Cougar MFDs

Link to comment
Share on other sites

Just checked and excluding beta bios there are 2 updates between mine and latest so I will give it a go later.  I'll report back.

i7-10700K @ 5Ghz | Asus Z490 Tuf Pro Gaming | RTX 3090 | 64 Gb RAM @3.6Ghz | addlink S70 1TB M.2 SSD | 1TB Samsung 850 EVO | 4TB HDD | Reverb G2 | Thrustmaster Warthog HOTAS | Thrustmaster TPR rudder pedals | Thrustmaster Cougar MFDs

Link to comment
Share on other sites

I can report after updating to the latest BIOS I am still getting these random CTD apparently linked to the Nvidia drivers!  😭

i7-10700K @ 5Ghz | Asus Z490 Tuf Pro Gaming | RTX 3090 | 64 Gb RAM @3.6Ghz | addlink S70 1TB M.2 SSD | 1TB Samsung 850 EVO | 4TB HDD | Reverb G2 | Thrustmaster Warthog HOTAS | Thrustmaster TPR rudder pedals | Thrustmaster Cougar MFDs

Link to comment
Share on other sites

OK. Please try this:

  1. Empty "C:\Users\username\AppData\Local\Temp\DCS.openbeta"
  2. Empty "C:\Users\username\Saved Games\DCS.openbeta\metashaders2"
  3. Empty "C:\Users\username\Saved Games\DCS.openbeta\fxo"
  4. Empty "C:\ProgramData\NVIDIA Corporation\NV_Cache" (Windows might refuse to delete some files unrelated to DCS - just hit "Ignore")

A track or it didn't happen.

Link to comment
Share on other sites

Posted (edited)

2 + 3 I always do every update.

 

I will try 1 and 4.  

 

PS. I don't have a "C:\Users\username\AppData\Local\Temp\DCS.openbeta"  do you mean "C:\Users\username\Saved Games\DCS.openbeta"?

 

PPS.  I've been looking back as I have crash logs all the way back to Sep 2018 and this particular crash happened for the first time on 15 Apr 21.  The day after 2.7 released so it has only been happening for me since 2.7.  The last hardware change to this machine was in early March 2021 so I don't think that is the cause.


Edited by Specter
New info

i7-10700K @ 5Ghz | Asus Z490 Tuf Pro Gaming | RTX 3090 | 64 Gb RAM @3.6Ghz | addlink S70 1TB M.2 SSD | 1TB Samsung 850 EVO | 4TB HDD | Reverb G2 | Thrustmaster Warthog HOTAS | Thrustmaster TPR rudder pedals | Thrustmaster Cougar MFDs

Link to comment
Share on other sites

try this. in file explorer, type %userprofile%\appdata\local\temp in the url box and then enter. (pro tip: copy paste) then browse that folder for DCS.openbeta 

 

image.png


Edited by silverdevil
  • Like 1
  • Thanks 1

AKA_SilverDevil AKA Forums My YouTube

==============================================================

Go to Heaven for the climate, Hell for the company. Mark Twain

==============================================================

Alienware Aurora R12, 2TB M.2 PCIe SSD, RTX 3090 24GB , i9 11900KF, 128GB Quad Channel DDR4 XMP at 3400MHz, Dell AW3420DW

Link to comment
Share on other sites

Ok, solved that issue, I have moved all my Win Temp files to another drive. found it there and emptied it. Will try again tomorrow to see if crashes are still an issue.

i7-10700K @ 5Ghz | Asus Z490 Tuf Pro Gaming | RTX 3090 | 64 Gb RAM @3.6Ghz | addlink S70 1TB M.2 SSD | 1TB Samsung 850 EVO | 4TB HDD | Reverb G2 | Thrustmaster Warthog HOTAS | Thrustmaster TPR rudder pedals | Thrustmaster Cougar MFDs

Link to comment
Share on other sites

On 6/27/2021 at 8:32 PM, Flappie said:

OK. Please try this:

  1. Empty "C:\Users\username\AppData\Local\Temp\DCS.openbeta"
  2. Empty "C:\Users\username\Saved Games\DCS.openbeta\metashaders2"
  3. Empty "C:\Users\username\Saved Games\DCS.openbeta\fxo"
  4. Empty "C:\ProgramData\NVIDIA Corporation\NV_Cache" (Windows might refuse to delete some files unrelated to DCS - just hit "Ignore")

I might be talking too soon but either item 1 or item 4 seems to have fixed my crashing.  It has gone from several times an evening to none in the last 2 days of regular playing.  If it raises it's head again I'll report back.

  • Thanks 1

i7-10700K @ 5Ghz | Asus Z490 Tuf Pro Gaming | RTX 3090 | 64 Gb RAM @3.6Ghz | addlink S70 1TB M.2 SSD | 1TB Samsung 850 EVO | 4TB HDD | Reverb G2 | Thrustmaster Warthog HOTAS | Thrustmaster TPR rudder pedals | Thrustmaster Cougar MFDs

Link to comment
Share on other sites

I spoke too soon! 😖  Started DCS today and had the very same CTD twice within 5 mins.  Restarted DCS both times and on the third restart managed to get into the mission!  Getting very tedious now!

i7-10700K @ 5Ghz | Asus Z490 Tuf Pro Gaming | RTX 3090 | 64 Gb RAM @3.6Ghz | addlink S70 1TB M.2 SSD | 1TB Samsung 850 EVO | 4TB HDD | Reverb G2 | Thrustmaster Warthog HOTAS | Thrustmaster TPR rudder pedals | Thrustmaster Cougar MFDs

Link to comment
Share on other sites

Posted (edited)

Please try the usual "don't know what's happening" procedure:

  1. Run a "slow" DCS repair, then try to reproduce the crash.
  2. Not fixed? Rename your "Saved Games\DCS (or DCS.openbeta)" folder into "DCS_backup" (do NOT delete it - it contains your custom controls)
  3. Launch DCS: it will create a brand new "Saved Games\DCS (or DCS.openbeta)" folder
  4. Exit DCS as soon as you reach main menu.
  5. Go into "Saved Games\DCS_backup\Config\Input" and copy all of its content
  6. Go into "Saved Games\DCS (or DCS.openbeta)\Config\Input", paste and accept overwriting. Then try to reproduce the crash.

Edited by Flappie

A track or it didn't happen.

Link to comment
Share on other sites

Posted (edited)

Hey @Flappie, I have done all you have listed and even tried the pagefile trick ( that just gave me BSODs after crashing so I reverted) still nothing.

Hell I even took all the components out of my pc and gave them a dusting. 

Not trying to hijack your thread @Specter but it looks like we are encountering the same issue.

 

Also I am not overclocking or underclocking my system, it is running completely stock. 


Edited by Calicrook

i7-6700k| 32GB ram| GTX 2080 founders edition| Oculus Rift 2

My WIP Youtube

Link to comment
Share on other sites

add me to this nightmare... it worked fine until the patch I spent like 4 hours workng on this last night,, I can't fly at all before it crashes... frozen with save the dxdiag file and logs.... I haven't looked at al the threads yet,, but there have to be a zillion of us that cannot fly after the patch...

 

I have been flying in VR for several months... but apparently it doesn't care if you are 2d, 3d, or vr, stil crashes...

I already ran repair like 20x. I renamed files to save them and let it rebuild them. I have the latest drivers. I even re-installed the laatest Nvidia graphics yesterday to make sure.

 

I can run my other program and sims no issues. I say something inthe patch messed up something.

 

Guess I am off to go reading the ther threads to see what is going on with the patch we just had in OB.

ASUS Z170, WartHog HOTAS and MFG Crosswind

G.Skill 32 GB, Samsung 1TB SSD

EVGA Nvidia RTX 2080-TI

 

 

Link to comment
Share on other sites

Posted (edited)

Apparently, Ramstein did fix his issue but we're not even sure it's the same issue (no log).

I need to go to work but I'll get back to you guys during the weekend.


Edited by Flappie

A track or it didn't happen.

Link to comment
Share on other sites

Posted (edited)
On 7/1/2021 at 7:51 PM, Flappie said:

Please try the usual "don't know what's happening" procedure:

  1. Run a "slow" DCS repair, then try to reproduce the crash.
  2. Not fixed? Rename your "Saved Games\DCS (or DCS.openbeta)" folder into "DCS_backup" (do NOT delete it - it contains your custom controls)
  3. Launch DCS: it will create a brand new "Saved Games\DCS (or DCS.openbeta)" folder
  4. Exit DCS as soon as you reach main menu.
  5. Go into "Saved Games\DCS_backup\Config\Input" and copy all of its content
  6. Go into "Saved Games\DCS (or DCS.openbeta)\Config\Input", paste and accept overwriting. Then try to reproduce the crash.

 

Hi Flappie

 

Thanks for all your efforts with this. It is sort of comforting, in a strange kinda way, to know I am not the only one with this issue.

 

I have tried item 1 numerous times as I also get random IC failures with core DCS files!  Reproducing the CTD is difficult as it is random.  The last 2 I had, one was as I entered the cockpit (F-18) the second was as I was taxying and moving my head (VR).  3rd restart and got airborne with no CTD, same single player mission!

 

I will try 2-6 and see how it goes.

 

PS, I can zip up every crash log I have had since 2.7 and attach them here if it will help.


Edited by Specter

i7-10700K @ 5Ghz | Asus Z490 Tuf Pro Gaming | RTX 3090 | 64 Gb RAM @3.6Ghz | addlink S70 1TB M.2 SSD | 1TB Samsung 850 EVO | 4TB HDD | Reverb G2 | Thrustmaster Warthog HOTAS | Thrustmaster TPR rudder pedals | Thrustmaster Cougar MFDs

Link to comment
Share on other sites

Jettax,  who was having the exact same crashes, has apparently put an end to them rolling back to the previous OB version then updating again. Please try his path:

  1. update to previous update: DCS_updater.exe update 2.7.2.8165.2
  2. then update to latest version: DCS_updater.exe update

 

 

A track or it didn't happen.

Link to comment
Share on other sites

Posted (edited)

Hi All,

I like to add that I too have been having DCS crashes since the 2.7 update. I have tried everything mentioned in this thread and I am still getting random crashes. I have a collection of crash logs dating back to May 14. Before that the last time I had a crash was in Oct 2020.

 

I updated drivers, reversed all OC back to normal settings, increased paging files, ran the game while monitoring temps, monitored ram usage. The only thing that I see that might be a problem is that RAM usage is almost maxed out. I have not had any trouble in the past running with 16GB, But I think that I will have to upgrade to 32GB of RAM to fix this.  But since I never monitored my RAM usage in the past, I don't know If it is the problem.

i9-9900K/ROG Strix Z390-E Gaming MB/ROG Strix 2080ti/Patriot Viper 16GB RAM/ADATA XPG 1TB M.2

dcs.20210702-193403[1].log


Edited by Heliflyr
Link to comment
Share on other sites

32 gb of ram would definitely be better. what is your swap file size? 

if you have room on an SSD try this. 

AKA_SilverDevil AKA Forums My YouTube

==============================================================

Go to Heaven for the climate, Hell for the company. Mark Twain

==============================================================

Alienware Aurora R12, 2TB M.2 PCIe SSD, RTX 3090 24GB , i9 11900KF, 128GB Quad Channel DDR4 XMP at 3400MHz, Dell AW3420DW

Link to comment
Share on other sites

10 hours ago, Heliflyr said:

Hi All,

I like to add that I too have been having DCS crashes since the 2.7 update. I have tried everything mentioned in this thread and I am still getting random crashes. I have a collection of crash logs dating back to May 14. Before that the last time I had a crash was in Oct 2020.

 

I updated drivers, reversed all OC back to normal settings, increased paging files, ran the game while monitoring temps, monitored ram usage. The only thing that I see that might be a problem is that RAM usage is almost maxed out. I have not had any trouble in the past running with 16GB, But I think that I will have to upgrade to 32GB of RAM to fix this.  But since I never monitored my RAM usage in the past, I don't know If it is the problem.

i9-9900K/ROG Strix Z390-E Gaming MB/ROG Strix 2080ti/Patriot Viper 16GB RAM/ADATA XPG 1TB M.2

dcs.20210702-193403[1].log 107.24 kB · 5 downloads

 

Your crash log is saying it has an issue with edterraingraphics41.dll.

 

Is this the same in the other crash logs?

 

Which map(s) are you flying and what graphics settings in DCS?

Windows 10 Home ¦ Z370 AORUS Gaming K3 motherboard ¦ i5-8600K oc to 4.3GHz ¦ 48GB Corsair PC4 memory @ 3000MHz ¦ Samsung 960 EVO M.2 SSD for OS, Samsung 860 EVO 1TB SSD for DCS ¦ ASUS ROG GTX 2060 Super 8GB ¦ Virpil WarBRD base with VFX grip, Thrustmaster A10c and F/A-18 grips ¦ VKB Gunfighter Mk2 and MCG ¦ Thrustmaster Warthog Throttle ¦ MFG Crosswinds ¦ Oculus Rift S

Link to comment
Share on other sites

Posted (edited)
On 7/1/2021 at 5:37 PM, Calicrook said:

I seem to be having the same issue as you Specter, not sure what's going on, I've tried the above steps as well. Do you happen to use Bitdefender? 

I have bitdefender. Game was stuttering, I didn't know what it was.. tried a repair and then a reinstall.. could not get the updater to reinstall DCS until I removed bitdefender.

 

Now finally downloading... worries me that bitdefender influences DCS so much in such a simple thing as installing. 

 

Any idea how to completely shut bitdefender off? Followed some internet suggestion about turning off shield for 1 hr.. still would not install. Only thing that worked was deleting bitdefender


Edited by Double Dutch

-----

Don't practise till you got it right.

Practise till you don't do it wrong

Link to comment
Share on other sites

I am running Bitdefender quite happily so I think it must be configuration

Windows 10 Home ¦ Z370 AORUS Gaming K3 motherboard ¦ i5-8600K oc to 4.3GHz ¦ 48GB Corsair PC4 memory @ 3000MHz ¦ Samsung 960 EVO M.2 SSD for OS, Samsung 860 EVO 1TB SSD for DCS ¦ ASUS ROG GTX 2060 Super 8GB ¦ Virpil WarBRD base with VFX grip, Thrustmaster A10c and F/A-18 grips ¦ VKB Gunfighter Mk2 and MCG ¦ Thrustmaster Warthog Throttle ¦ MFG Crosswinds ¦ Oculus Rift S

Link to comment
Share on other sites

12 hours ago, hornblower793 said:

Your crash log is saying it has an issue with edterraingraphics41.dll.

 

Is this the same in the other crash logs?

 

Which map(s) are you flying and what graphics settings in DCS?

Hi Hornblower793,

 

Since I don't know how to read the crash logs I could not tell you if the crashes are duplicates. The last 2 weeks I have been making changes to my graphic settings so often, its hard to say what settings are used. But I do see that the settings are recorded on the logs. As for what maps I am having crashes, that would be mostly be the Caucasus maps playing multiplayer on the 4YA servers. I also had many crashes on the A-10 Tactical Training Campaign. Also, I have had way more crashes that did not produce a Crash Log because the PC would be locked up or the game would crash to Desktop.

 

Today, I reset my 2080 ti back to normal settings, and reran the DCS World Repair and removed a MOD for the AV8B that removed the screen mesh from the TV sensor. So far No crashes on 4YA servers. I am going to run the game today without any changes, and hopefully have no crashes. Then tomorrow I'm going to try to OC the i9-9900K. 

 

Here are some more logs.

dcs.20210701-055128[1].log dcs.20210701-222559[1].log

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...