Jump to content

Trim not working for me?


Go to solution Solved by Blackeye,

Recommended Posts

Hi,

 

I'm feeling a bit stupid here. I have the latest DCS Openbeta, version 2.7.2.7910.

HOTAS springs so it centers

In DCS "Special" options - trimmer mode set to "Default" (see attached image).

 

I can see the trimmer control mapping is correct - when I depress it, the on-screen trimmer button on the stick depresses. I also tried using the "T" key, the results are the same.

 

So I hold the stick off-centre, press and release the trimmer button, then let the stick return to centre. No trimming occurs.

Then I try: hold the stick off-centre, press & hold the trimmer button, let the stick return to centre, release the trimmer button. No trimming occurs.

 

I also tried the second of the "Special" modes for trimmer control. It behaves the same for me.

 

Track file is attached (It's small).

Also a quick 30-second video of me failing miserably to trim : click here

 

Does anybody know what I'm doing wrong? Maybe some electric system not initialised?

mi24 special.png

mi24P trim.trk


Edited by animaal

Sinclair ZX Spectrum 48K, Kempston joystick Interface, Alba Cassette Recorder, Quickshot II Turbo Joystick

Link to comment
Share on other sites

My guess is the pitch and roll AP systems aren’t on.

 

I dunno if these are supposed to be required for trim or not, but I had a cold start last night where I increased collective too fast and got some electrical issues. Landed. Fixed. Started flying again and my trim didn’t work and it was because my pitch and roll Ap channels were off 

[sIGPIC][/sIGPIC]

M-2000C | F/A-18C | F-14B | Bf 109 K-4 | UH-1H | Ka-50 | Mi-8 | SA342

i5-9600K @ 4.8ghz | 32GB DDR4 RAM | RTX 2080

T16000M FCS | TWCS Throttle | MFG Crosswind.V2 Rudder Pedals

"Dialectic"

Link to comment
Share on other sites

hmm, try to switch on the Autopilot systems. check if your Trimmer reset is on an permanent "on" button.

ill use the second setting in trimmer mode.

you can trimm with the button, and fine tune in flight with the trimmer head.

 

Link to comment
Share on other sites

all Good suggestions, thanks. But no luck.

 

I unbound the "trim reset" control, set the trimmer mode in the "special" screen to the second one, and made sure the 3 stability buttons (Yaw, Roll, Pitch) were on/green.

 

The results were the same as in the track/video above. No trimming.

 

 

Sinclair ZX Spectrum 48K, Kempston joystick Interface, Alba Cassette Recorder, Quickshot II Turbo Joystick

Link to comment
Share on other sites

vor 2 Minuten schrieb animaal:

all Good suggestions, thanks. But no luck.

 

I unbound the "trim reset" control, set the trimmer mode in the "special" screen to the second one, and made sure the 3 stability buttons (Yaw, Roll, Pitch) were on/green.

 

The results were the same as in the track/video above. No trimming.

 

 

do you starup manualy?

maybe there is a failure in your sequence?

i get problems with the doppler when starting manual :=

Link to comment
Share on other sites

Thanks, that's another good idea.

 

I did the autostart sequence. It started things in an interesting order, but trim is still the same afterwards.

 

 

Sinclair ZX Spectrum 48K, Kempston joystick Interface, Alba Cassette Recorder, Quickshot II Turbo Joystick

Link to comment
Share on other sites

Thanks anyway for the suggestions, they were well worth trying. It's sure to be something basic I'm not aware of.

 

 

Sinclair ZX Spectrum 48K, Kempston joystick Interface, Alba Cassette Recorder, Quickshot II Turbo Joystick

Link to comment
Share on other sites

No luck I'm afraid. But I haven't much experience with helicopters, so I still think it's most likely I'm getting something basic very wrong. I'm hopeful that somebody in ED will look at the TRK file this week, and see the issue.

Sinclair ZX Spectrum 48K, Kempston joystick Interface, Alba Cassette Recorder, Quickshot II Turbo Joystick

Link to comment
Share on other sites

  • Solution
Posted (edited)
4 hours ago, animaal said:

No luck I'm afraid. But I haven't much experience with helicopters, so I still think it's most likely I'm getting something basic very wrong. I'm hopeful that somebody in ED will look at the TRK file this week, and see the issue.

 

Well I took control at the end of your track and could trim just fine, so I'd say you're not doing something wrong but rather have a problem with your controls/settings. Do you have FFB (force feedback) enabled in the (general) options?


Edited by Blackeye
  • Thanks 1
Link to comment
Share on other sites

Thanks Blackeye, that rules out a large number of potential sources of errors.

 

When I press the trimmer button on my HOTAS (or "T" on the keyboard) I see the trimmer button on the left side of the Hind's cyclic being depressed. I assume that means the control mapping works.

 

I liked Grennymaster's thought that there may be an "always on" control mapped to "reset trimmer". I don't think that's the case here (I unmapped all control mappings for "reset trimmer"), but it may be something similar that's causing problems.

Sinclair ZX Spectrum 48K, Kempston joystick Interface, Alba Cassette Recorder, Quickshot II Turbo Joystick

Link to comment
Share on other sites

Posted (edited)
2 hours ago, Blackeye said:

 

 Do you have FFB (force feedback) enabled in the (general) options?

 

That's it!

 

I had FFB enabled in the "Misc" settings, because I used to use a FFB stick from time to time. I haven't used it in many months.

 

Disabling that option fixed trimming in the Hind. I don't know how you thought to suggest that.

 

It's odd, I don't remember that option causing issues with any other modules. I wonder if it's something ED needs to correct in the Hind? Anyway, it's a quick and painless fix for the user.

 

Thanks, I'm very grateful!!!


Edited by animaal

Sinclair ZX Spectrum 48K, Kempston joystick Interface, Alba Cassette Recorder, Quickshot II Turbo Joystick

Link to comment
Share on other sites

11 minutes ago, animaal said:

I had FFB enabled in the "Misc" settings, because I used to use a FFB stick from time to time. I haven't used it in many months.

 

Disabling that option fixed trimming in the Hind. I don't know how you thought to suggest that.

 

Thanks, I'm very grateful!!!

 

 

You're welcome - glad that solved it for you, perhaps mark it as solution.

 

And as for thinking about FFB: Trim not working on a non-FFB device is one of the symptoms of having it enabled because with FFB trim enabled there is no software offset to the joystick position for trim since the forces actually move the joystick to that offset. However that offset is required for spring centering joystick as they always center on 0/0, so trimming fails.

Link to comment
Share on other sites

Trouble in trimmer land.  I have a TM WH grip and a Virpil WB base.  I have set the T for Trimmer to my TM WH pov up and the trimmer reset for the pov down.  I am using the default trimmer option.  So when I am in the game, I trim, press the trim button and let go of the joystick and the trim does not hold its position.  I noticed that in one video, the trim was centered at the beginning, but mine is much lower on the controller diagram.  Any thoughts?

Trackir4 using the latest Trackir 5 software, Win10 Pro [Creator Update] updated from Win7Pro Pro 64Bit, Intel® Core™ i5-2500 3.30 GHz 6M Intel Smart Cache LGA115 , GigaByte GA-Z68XP-UD4 Intel Z68 Chipset DDR3 16GB Ram, GTX MSI Gaming 1060 [6 GB] Video Card, Main Monitor 1 on left 1920x1080 Touchscreen Monitor 2 on right 1920x1080 .

Link to comment
Share on other sites

7 hours ago, sobe said:

Trouble in trimmer land.  I have a TM WH grip and a Virpil WB base.  I have set the T for Trimmer to my TM WH pov up and the trimmer reset for the pov down.  I am using the default trimmer option.  So when I am in the game, I trim, press the trim button and let go of the joystick and the trim does not hold its position.  I noticed that in one video, the trim was centered at the beginning, but mine is much lower on the controller diagram.  Any thoughts?

 

Make sure the FFB option in the menu is disabled otherwise trimming won't work for spring centered joysticks

Link to comment
Share on other sites

Double and triple checked FFB option and it is off.  I also calibrated my joystick in the Virpil software.  I am not sure what else to do before I just give up and go back to the F18.

Trackir4 using the latest Trackir 5 software, Win10 Pro [Creator Update] updated from Win7Pro Pro 64Bit, Intel® Core™ i5-2500 3.30 GHz 6M Intel Smart Cache LGA115 , GigaByte GA-Z68XP-UD4 Intel Z68 Chipset DDR3 16GB Ram, GTX MSI Gaming 1060 [6 GB] Video Card, Main Monitor 1 on left 1920x1080 Touchscreen Monitor 2 on right 1920x1080 .

Link to comment
Share on other sites

Posted (edited)

Have you checked that the main axes (roll/pitch/yaw) aren't bound to some other additional device/control?


Edited by animaal

Sinclair ZX Spectrum 48K, Kempston joystick Interface, Alba Cassette Recorder, Quickshot II Turbo Joystick

Link to comment
Share on other sites

Yes.  As an old hand on the screw ups of the controllers, I checked, but I will check again in about 1 hour. 

 

Trackir4 using the latest Trackir 5 software, Win10 Pro [Creator Update] updated from Win7Pro Pro 64Bit, Intel® Core™ i5-2500 3.30 GHz 6M Intel Smart Cache LGA115 , GigaByte GA-Z68XP-UD4 Intel Z68 Chipset DDR3 16GB Ram, GTX MSI Gaming 1060 [6 GB] Video Card, Main Monitor 1 on left 1920x1080 Touchscreen Monitor 2 on right 1920x1080 .

Link to comment
Share on other sites

Probably worth checking if the axes have any "curves", "saturation" etc as well.

Sinclair ZX Spectrum 48K, Kempston joystick Interface, Alba Cassette Recorder, Quickshot II Turbo Joystick

Link to comment
Share on other sites

  • 3 months later...

i've just signed up on this forum, just to say

Thank you @animaal for your clear report, i had the same problem as you and passed all my saturday afternoon trying same approaches as you with no luck.

and Thank you @Blackeye for you time and sharing, i was desesperate, you saved my week end !

Lets have fun now :D

  • Like 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...