Jump to content

Cant get the trimmer to do anything


Go to solution Solved by wowbagger,

Recommended Posts

Hey people!

 

anybody else having problems with the trimmer? i cant get it to do anything. i hot started a mission and want to trim the cyclic for takeoff, but it doesnt do anything.. i used the keyboard keybind for it and a hotas shortcut. am i missing something? when i hit trim the cyclic just returns to dead center.

did a full dcs repair also

added a track in case it turns out to be a bug.

 

hope someone can help me out 😉

trimmer.trk

Link to comment
Share on other sites

it depends if you have a FFB or not. 

defaut trim in special game menu for Mi24 are for FFB trim ( stick should stay where it is when trimmer used ) but not working as intented so far ( like Mi8 or Huey) 

If you have no FFB you should use the return to middle option. 

 

Edit allright 've got it right now for MSFFB 😉 ( checked in flight and with the axes indication ingame

 

Trim Button OK / Trimmer reset OK

for MSFFB in defaut mode : trimmer force 45 / shake 80  ( more trim force is not needed 

swap axis : YES 

invert X : YES ( not as usual )

invert Y YES ( not as usual )

 

defaut trim nose up nose down wing left down and wing right down are also ALL INVERTED ( not as usual )  : be aware 

 


Edited by snowsniper
  • Like 1

[sIGPIC][/sIGPIC]

all my skins :

here

 

Core i7-4790 @ 3.6- 4GHz - 16GB

- nVidia RTX 2070 - 2xSSD -

GRANDIN TV screen 39" in 1920x1080 cockpit scale 1:1

- MS FFB2 Joystick

- DIY MIDI Throttle with 14 analogic sliders and knobs

- Saitek Pro Flight Rudder Pedals

 

Link to comment
Share on other sites

31 minutes ago, eric-b92 said:

Hey people!

 

anybody else having problems with the trimmer? i cant get it to do anything. i hot started a mission and want to trim the cyclic for takeoff, but it doesnt do anything.. i used the keyboard keybind for it and a hotas shortcut. am i missing something? when i hit trim the cyclic just returns to dead center.

did a full dcs repair also

added a track in case it turns out to be a bug.

 

hope someone can help me out 😉

trimmer.trk 280.45 kB · 1 download

 

 

I tried your track and when I take control it works without issue. Check your control settings for trimmer button  and also trimmer - reset. Also make sure you're not in Game Mode, please.

CPU:5600X | GPU:RTX2080 | RAM:32GB | Disk:860EVOm.2

Link to comment
Share on other sites

  • Solution

Ya, that's a tough one. Can you try clearing the trimmer button and trimmer-reset bindings and then binding them to different keys and different buttons to see if there is a conflict with something else, in the UI layer maybe?

CPU:5600X | GPU:RTX2080 | RAM:32GB | Disk:860EVOm.2

Link to comment
Share on other sites

eric-b92 : what is your joystick ? 

  • Like 1

[sIGPIC][/sIGPIC]

all my skins :

here

 

Core i7-4790 @ 3.6- 4GHz - 16GB

- nVidia RTX 2070 - 2xSSD -

GRANDIN TV screen 39" in 1920x1080 cockpit scale 1:1

- MS FFB2 Joystick

- DIY MIDI Throttle with 14 analogic sliders and knobs

- Saitek Pro Flight Rudder Pedals

 

Link to comment
Share on other sites

also see in the quick manual page 28 : for non FFB stick 

  • Like 1

[sIGPIC][/sIGPIC]

all my skins :

here

 

Core i7-4790 @ 3.6- 4GHz - 16GB

- nVidia RTX 2070 - 2xSSD -

GRANDIN TV screen 39" in 1920x1080 cockpit scale 1:1

- MS FFB2 Joystick

- DIY MIDI Throttle with 14 analogic sliders and knobs

- Saitek Pro Flight Rudder Pedals

 

Link to comment
Share on other sites

got a msffb 2 and when i press trim and then release my stick my helo goes all over the place... so how exactly should this work? got the settings on default. when i press trim my ffb is gone and when i trim for steady flight i release both stick and pedals and it goes to sheits

 


Edited by rogonaut
Link to comment
Share on other sites

I think in the options tab you should set trimmer to ffb in stead of default. I read somewhere that the ffb axis act inverted right now. So you probably also need to invert them

Link to comment
Share on other sites

30 minutes ago, eric-b92 said:

I think in the options tab you should set trimmer to ffb in stead of default. I read somewhere that the ffb axis act inverted right now. So you probably also need to invert them

 

theres only one other option and it says "for joysticks without springs and ffb". so that shouldnt  be the correct one cause i would read it as without ffb... in a post above it says default is for ffb joystick. do u mean the special options tab for the mi24 right?

 

21 minutes ago, FrostCZ said:

Make sure your pitch/roll is NOT bound on another device at the same time. It will otherwise make conflicts like this issue.

 

i have to check on that again, maybe i overlooked something

 

 

when i release trim it recenters my ffb joystick and doesnt stay where i trimmed it at.

 


Edited by rogonaut
Link to comment
Share on other sites

1 hour ago, rogonaut said:

 

theres only one other option and it says "for joysticks without springs and ffb". so that shouldnt  be the correct one cause i would read it as without ffb... in a post above it says default is for ffb joystick. do u mean the special options tab for the mi24 right?

 

i have to check on that again, maybe i overlooked something

 

 

when i release trim it recenters my ffb joystick and doesnt stay where i trimmed it at.

 

 

 

I'm  MMSFB2 user:

 

When in Mi24p Sim Axis controls\settings, click on any axis of your bound axis (X, or Y it doesnt matter). Just one left click, so it's highlighted, then click FFB Tune. In the next window that opens, check ALL THREE BOXES. I don't remember exactly what they are called, I think Swap Axes, Invert X, Invert Y or something, all three should be ticked. At that point your FFB will work correctly in the Hind.


Edited by Lurker
  • Thanks 1

Specs: Win10, i9-9900KF@5Ghz, 32GB DDR4 RAM 3200XMP, 1 TB M2 NVMe SSD, KFA2 RTX3090, VR G2 Headset, Warthog Throttle+Saitek Pedals+MSFFB2  Joystick. 

Link to comment
Share on other sites

Wel thanks guys, resetting everything (including keyboard standard binds) finaly fixed it. Dont know what whas wrong, but hey if it works it works 😉 holding a hover is much easyer now haha

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...