Jump to content

Reticuli
 Share

Recommended Posts

2.7 has the actual iteration of DCS and W7 suport has been remove weeks ago. When Apache wil be release you need require a 2.7+ version to use them.

  • Like 2

More news to the front

Wishlist: ED / 3rd Party Campaings

My Rig: Intel I-5 750 2.67Ghz / Packard Bell FMP55 / 16 GB DDR3 RAM / GTX-1080 8 GB RAM / HD 1Tb/2Tb / Warthog / 2 MDF / TFPR

 

DCS: Roadmap (unofficial):https://forums.eagle.ru/showthread.php?t=116893

DCS: List of Vacant models: https://forums.eagle.ru/showthread.php?p=4076891#post4076891

21Squad DCS: World News: https://www.facebook.com/21Squad-219508958071000/

Silver_Dragon Youtube

Link to comment
Share on other sites

1 minute ago, Reticuli said:


Which is why I'm asking.

You require W10 to work on actual and future modules.

More news to the front

Wishlist: ED / 3rd Party Campaings

My Rig: Intel I-5 750 2.67Ghz / Packard Bell FMP55 / 16 GB DDR3 RAM / GTX-1080 8 GB RAM / HD 1Tb/2Tb / Warthog / 2 MDF / TFPR

 

DCS: Roadmap (unofficial):https://forums.eagle.ru/showthread.php?t=116893

DCS: List of Vacant models: https://forums.eagle.ru/showthread.php?p=4076891#post4076891

21Squad DCS: World News: https://www.facebook.com/21Squad-219508958071000/

Silver_Dragon Youtube

Link to comment
Share on other sites

Just now, Silver_Dragon said:

You require W10 to work on actual and future modules.


Not sure what you mean by "actual' but I'm increasingly understanding that future modules will be using 2.7 and above.

X65 and X52, Glide, Winx3D, and GlovePIE Profiles http://library.avsim.net/search.php?SearchTerm=reticuli&CatID=miscmisc

 

http://library.avsim.net/register.php

 

X52 + Silicone Grease = JOY stick

Link to comment
Share on other sites

5 minutes ago, Reticuli said:


Not sure what you mean by "actual' but I'm increasingly understanding that future modules will be using 2.7 and above.

 

Future modules requires the DCS 2.7. 

The DCS 2.7 supports Windows 10 only.

 

Windows 7 is unsupported. It doesn't mean you can't keep playing on it, but you are alone with all support. 

i7-8700k, 32GB 2666Mhz DDR4, 2x 2080S SLI 8GB, Oculus Rift S.

i7-8700k, 16GB 2666Mhz DDR4, 1080Ti 11GB, 27" 4K, 65" HDR 4K.

Link to comment
Share on other sites

29 minutes ago, Reticuli said:

I'm still on Windows 7.  Just curious.

 

For the AH-64D you will need DCS 2.7 which no longer supports windows 7 sorry. 

 

 

  • Like 1

smallCATPILOT.PNG.04bbece1b27ff1b2c193b174ec410fc0.PNG

Forum rules - DCS Crashing? Try this first - Cleanup and Repair - Discord BIGNEWY#8703 - Youtube - Patch Status

Windows 11, NVIDIA MSI RTX 3090, Intel® i9-10900K 3.70GHz, 5.30GHz Turbo, Corsair Hydro Series H150i Pro, 32GB DDR @3200, ASUS ROG Strix Z490-F Gaming, HP Reverb G2

Link to comment
Share on other sites

15 minutes ago, Reticuli said:


Not sure what you mean by "actual' but I'm increasingly understanding that future modules will be using 2.7 and above.


From January Newsletter

Quote

 

Support

Windows 7

 

hero1.png

 

We will no longer be supporting Windows 7. Users who do not want not to change their operating system can still enjoy DCS World 2.5.6. However, new updates will not be available. In order to attend to your needs more diligently, please download the latest version. 

 

 

From 2.7 Changelog
https://www.digitalcombatsimulator.com/en/news/changelog/openbeta/2.7.0.4625/
 

Quote

 

Eagle Dynamics Team

Changelog features

Please note that DCS does not support Windows 7 anymore. You will continue to be able to enjoy your existing version but all 2.7 updates will not install.

 

 


Edited by Silver_Dragon

More news to the front

Wishlist: ED / 3rd Party Campaings

My Rig: Intel I-5 750 2.67Ghz / Packard Bell FMP55 / 16 GB DDR3 RAM / GTX-1080 8 GB RAM / HD 1Tb/2Tb / Warthog / 2 MDF / TFPR

 

DCS: Roadmap (unofficial):https://forums.eagle.ru/showthread.php?t=116893

DCS: List of Vacant models: https://forums.eagle.ru/showthread.php?p=4076891#post4076891

21Squad DCS: World News: https://www.facebook.com/21Squad-219508958071000/

Silver_Dragon Youtube

Link to comment
Share on other sites

What about win 11?

MODUALS OWNED       MiG-21Bis, Fw-190D, Bf-109K, P-51D, F-86F, Ka-50, UH-1H, Mi-8MTV2, Mi-24, FC3, A-10C, A-10CII, CA, Mirage 2000C, Gazelle, L-39, MiG-15Bis, F-86, F-5E, AJS 37 Viggen, MiG-19, F-14 TOMCAT, F/A-18C HORNET, F-16C VIPER, AV-8B/NA, Spitfire IX, AH-64D APACHE, SYRIA, NEVADA, NORMANDY, PERSIAN GULF, MARIANA ISLANDS,SUPER CARRIER, WORLD WAR II ASSETS PACK, HAWK T1

SYSTEM SPECS            AMD FX 8350 4.0 Ghz CPU , ATI RX 560 4 gig GPU ,32 gig ram on Win11 64bit.

 

Link to comment
Share on other sites

 

Was there ever a new module or map working in a stable release from the start on?
At some point I left the stable releases behind and played only beta.

 

W10 support should official end 2025, but I think that they will extend the support anyway.

So there should be plenty of time without worrying.

wishlist: HH-60G Pave Hawk, MH-60R Sea Hawk, UH-60L Black Hawk, NH90, Super (Sea) Lynx / Mk.88, ME: A placeable animated LSE/marshaller for individual created FARPs

Apache beware of the Sikorsky Armed Black Hawk!

Link to comment
Share on other sites

7 hours ago, Marklar said:

W11 is not even released yet. Why did you bring it to this discussion at all?

maybe because I have win 11 but haven't installed it yet on any machine and would like to know if there will be any advantages to do so...that enough for a discussion for ya?

 

MODUALS OWNED       MiG-21Bis, Fw-190D, Bf-109K, P-51D, F-86F, Ka-50, UH-1H, Mi-8MTV2, Mi-24, FC3, A-10C, A-10CII, CA, Mirage 2000C, Gazelle, L-39, MiG-15Bis, F-86, F-5E, AJS 37 Viggen, MiG-19, F-14 TOMCAT, F/A-18C HORNET, F-16C VIPER, AV-8B/NA, Spitfire IX, AH-64D APACHE, SYRIA, NEVADA, NORMANDY, PERSIAN GULF, MARIANA ISLANDS,SUPER CARRIER, WORLD WAR II ASSETS PACK, HAWK T1

SYSTEM SPECS            AMD FX 8350 4.0 Ghz CPU , ATI RX 560 4 gig GPU ,32 gig ram on Win11 64bit.

 

Link to comment
Share on other sites

On 6/16/2021 at 12:30 PM, Reticuli said:

I'm still on Windows 7.  Just curious.

 

I have to ask the big question though... why haven't you upgraded to Windows 10? It was available as a free upgrade a few years ago, and just about everyone I know went forward with that upgrade.

 

Having said that, since that free-upgrade period has long since ended, you could still get it fairly cheap. Look up 'Windows 10 key reseller', and you can get legal keys for significantly less than a retail key. How this works is that a lot of these gaming rig companies have thousands of keys they can't use (by contract), so they just sell'em off to people who turn around and sell them for 10-15 bucks. It's all legal, and dirt cheap if you want to upgrade.

Link to comment
Share on other sites

10 hours ago, Raven434th said:

maybe because I have win 11 but haven't installed it yet on any machine and would like to know if there will be any advantages to do so...that enough for a discussion for ya?

 

You already have Win 11 ?

 

https://www.windowscentral.com/windows-11

 

According to this, it´s not even known if there will be a "Windows 11" and it is to be expected that Microsoft will anounce something this week. And you already have it ? 
 

  • Like 1
Link to comment
Share on other sites

I don't think that it's going to be anything more than a Windows 10 update. Then again, Windows 10 was nothing more than a glorified Windows 8.1 update, so that'd be par the course. 

 

I'm fully expecting them to try to make the UI even more hideous, advanced customization even more obtuse and to try to break the tricks I used to beat their product into something practical. Myself, I'd be happy if they just removed "Top Apps" thing from search. This useless crock had exposed peoples' sensitive data in the past.

Link to comment
Share on other sites

A) there's no point in discussing Windows 11 compatibility when it's not out yet and the only thing available is a leaked developer version. No one should expect compatibility with a leaked experimental OS.

B) It looks like a visual upgrade to the core of Windows 10. I don't expect we'll see any issues with it, once released and drives are out for it.

Virpil WarBRD | Thrustmaster Hornet Grip | Foxx Mount | Thrustmaster TWCS Throttle | Logitech G Throttle Quadrant | VKB T-Rudder IV | TrackIR 5

 

 

AMD Ryzen 5 3600 | Nvidia GTX 1060 6GB | 32GB DDR4 3200 | SSD

Link to comment
Share on other sites

On 6/23/2021 at 1:46 PM, Dragon1-1 said:

I don't think that it's going to be anything more than a Windows 10 update. Then again, Windows 10 was nothing more than a glorified Windows 8.1 update, so that'd be par the course. 

 

I'm fully expecting them to try to make the UI even more hideous, advanced customization even more obtuse and to try to break the tricks I used to beat their product into something practical. Myself, I'd be happy if they just removed "Top Apps" thing from search. This useless crock had exposed peoples' sensitive data in the past.

hmmm...well I've tried it on an old laptop and it seems to make it run snappy'r....I've not yet got up the nerve to install it on the main gamming rig yet though...

MODUALS OWNED       MiG-21Bis, Fw-190D, Bf-109K, P-51D, F-86F, Ka-50, UH-1H, Mi-8MTV2, Mi-24, FC3, A-10C, A-10CII, CA, Mirage 2000C, Gazelle, L-39, MiG-15Bis, F-86, F-5E, AJS 37 Viggen, MiG-19, F-14 TOMCAT, F/A-18C HORNET, F-16C VIPER, AV-8B/NA, Spitfire IX, AH-64D APACHE, SYRIA, NEVADA, NORMANDY, PERSIAN GULF, MARIANA ISLANDS,SUPER CARRIER, WORLD WAR II ASSETS PACK, HAWK T1

SYSTEM SPECS            AMD FX 8350 4.0 Ghz CPU , ATI RX 560 4 gig GPU ,32 gig ram on Win11 64bit.

 

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...