Jump to content

Constant and varying CTD's its always something


Recommended Posts

Hi @Rickling. I had never seen "Inter.dll" crash before.

Apparently, some DLL cannot be executed by DCS. It sounds like an antivirus software issue.

 

Please add this path as an exception in your antivirus software:

 

I:\DCS World OpenBeta\

 

2021-06-05 20:55:28.106 ERROR   SOUND: render time = 0.130293s exceeded allowed slice of 0.022313s
2021-06-05 20:55:30.105 ERROR   INTER: Failed to load edterrain4.dll : A dynamic link library (DLL) initialization routine failed.

2021-06-05 20:55:30.105 ERROR   TERRAIN: Can't create ITerrain interface for ./Mods/terrains/Caucasus\terrain.cfg.lua
2021-06-05 20:55:30.106 ERROR   Dispatcher: Can't load terrain from ./Mods/terrains/Caucasus\terrain.cfg.lua
2021-06-05 20:55:30.107 INFO    EDCORE: try to write dump information
2021-06-05 20:55:30.291 INFO    EDCORE: # -------------- 20210605-205530 --------------
2021-06-05 20:55:30.365 INFO    EDCORE: DCS/2.7.1.7139 (x86_64; Windows NT 10.0.19042)
2021-06-05 20:55:30.476 INFO    EDCORE: I:\DCS World OpenBeta\bin\Inter.dll
2021-06-05 20:55:30.570 INFO    EDCORE: # C0000005 ACCESS_VIOLATION at 9BA551E0 00:00000000
2021-06-05 20:55:30.666 INFO    EDCORE: SymInit: Symbol-SearchPath: '.;I:\DCS World OpenBeta;I:\DCS World OpenBeta\bin;C:\Windows;C:\Windows\system32;SRV*C:\websymbols*https://msdl.microsoft.com/download/symbols;', symOptions: 528, UserName: 'mikey'
2021-06-05 20:55:30.741 INFO    EDCORE: OS-Version: 10.0.19042 () 0x300-0x1
2021-06-05 20:55:31.750 INFO    EDCORE: 0x00000000000051E0 (Inter): edterrain::ITerrainGraphicsEntryPoint::createTerrainGraphics + 0x60
2021-06-05 20:55:31.759 INFO    EDCORE: 0x0000000000009418 (Terrain): createGlobalLand + 0x708
2021-06-05 20:55:31.774 INFO    EDCORE: 0x00000000000070D7 (lua-gui_map): (function-name not available) + 0x0
2021-06-05 20:55:31.836 INFO    EDCORE: 0x000000000001C2AB (lua-gui_map): (function-name not available) + 0x0
2021-06-05 20:55:31.853 INFO    EDCORE: 0x0000000000007AC5 (lua): luaD_growstack + 0x845
2021-06-05 20:55:31.882 INFO    EDCORE: 0x0000000000018D94 (lua): luaS_newlstr + 0x5254
2021-06-05 20:55:31.996 INFO    EDCORE: 0x0000000000007E04 (lua): luaD_growstack + 0xB84
2021-06-05 20:55:32.015 INFO    EDCORE: 0x0000000000006F7F (lua): lua_getinfo + 0x133F
2021-06-05 20:55:32.044 INFO    EDCORE: 0x000000000000812E (lua): lua_yield + 0x9E
2021-06-05 20:55:32.072 INFO    EDCORE: 0x0000000000002576 (lua): lua_pcall + 0x66
2021-06-05 20:55:32.088 INFO    EDCORE: 0x00000000000F2DA9 (edCore): ED_lua_pcall + 0x59
2021-06-05 20:55:32.126 INFO    EDCORE: 0x0000000000004005 (lua-dxguiWin): (function-name not available) + 0x0
2021-06-05 20:55:32.165 INFO    EDCORE: 0x00000000007D137D (DCS): SW + 0x4E087D
2021-06-05 20:55:32.185 INFO    EDCORE: 0x0000000001C59A06 (DCS): AmdPowerXpressRequestHighPerformance + 0xE6AA02
2021-06-05 20:55:32.187 INFO    EDCORE: 0x0000000000A07EEE (DCS): SW + 0x7173EE
2021-06-05 20:55:32.211 INFO    EDCORE: 0x0000000000017034 (KERNEL32): BaseThreadInitThunk + 0x14
2021-06-05 20:55:32.227 INFO    EDCORE: 0x000000000004D0D1 (ntdll): RtlUserThreadStart + 0x21
2021-06-05 20:55:32.754 INFO    EDCORE: Minidump created.
2021-06-05 20:55:32.755 INFO    Lua::Config: stack traceback:
	[C]: in function 'Init_edterraingraphics'
	[string "./dxgui/bind/NewMapView.lua"]:91: in function 'initEDTerrainGraphics'
	[string "./MissionEditor/modules/me_map_window.lua"]:797: in function 'initTerrain'
	[string "./MissionEditor/modules/me_mission.lua"]:1637: in function 'load'
	[string "./MissionEditor/modules/me_toolbar.lua"]:718: in function 'func'
	[string "./Scripts/UI/ProgressBarDialog.lua"]:154: in function 'updater'
	[string "./Scripts/UpdateManager.lua"]:64: in function <[string "./Scripts/UpdateManager.lua"]:40>
2021-06-05 20:55:32.755 INFO    Lua::Config: stack traceback:

 

Link to post
Share on other sites

In addition to what@Flappie has suggested, have you tried a slow repair of DCS?

The log is saying it has failed to load edterrain4.dll so this file might need repair

Sent from my SM-T835 using Tapatalk



Windows 10 Home ¦ Z370 AORUS Gaming K3 motherboard ¦ i5-8600K oc to 4.3GHz ¦ 48GB Corsair PC4 memory @ 3000MHz ¦ Samsung 960 EVO M.2 SSD for OS, Samsung 860 EVO 1TB SSD for DCS ¦ ASUS ROG GTX 2060 Super 8GB ¦ Virpil WarBRD base with VFX grip, Thrustmaster A10c and F/A-18 grips ¦ VKB Gunfighter Mk2 and MCG ¦ Thrustmaster Warthog Throttle ¦ MFG Crosswinds ¦ Oculus Rift S

Link to post
Share on other sites

Thanks guys. I looked into both things; disabled the antivirus and firewall, and i did the SLOWWW repair . Still having major problems. Sometimes it crashes right after I take off, sometimes i cant even get off the ground, sometimes i cant even load the mission without it crashing. I have the settings pretty low too. And low on the NVIDIA 1080 Graphics card. I Attached the logs from the most recent crash.

dcs.log dcs.log-20210610-023107.zip dxdiag.txt

Link to post
Share on other sites

Heres some more! Mosty recent crash. I actually got off the ground in one mission and was able to end the mission the right way by exiting it. In sam session though, I tweaked the shadows to medium and tried to load a mission and it crashed right away.

dcs.log dcs.20210610-035639.crash dcs.20210610-035639.dmp dcs.20210610-035639.log dcs.20210610-035639.miz dxdiag.txt hash

Link to post
Share on other sites

Looking at your logs it is always crashing edterrain4.dll as it is trying to load the Caucasus map. Do you own any of the other maps you could try?

 

This would help identify whether it is a map corruption issue or something else.

Windows 10 Home ¦ Z370 AORUS Gaming K3 motherboard ¦ i5-8600K oc to 4.3GHz ¦ 48GB Corsair PC4 memory @ 3000MHz ¦ Samsung 960 EVO M.2 SSD for OS, Samsung 860 EVO 1TB SSD for DCS ¦ ASUS ROG GTX 2060 Super 8GB ¦ Virpil WarBRD base with VFX grip, Thrustmaster A10c and F/A-18 grips ¦ VKB Gunfighter Mk2 and MCG ¦ Thrustmaster Warthog Throttle ¦ MFG Crosswinds ¦ Oculus Rift S

Link to post
Share on other sites

The game is having a hardtime loading the Caucasus map.

I see your DCS is installed on an SSD, which is a good thing.

 

Try adding this folder as an exception in your antivirus software: " I:\DCS World OpenBeta\bin "

 

If it doesn't help, try this:

  1. Go into " I:\DCS World OpenBeta\Mods\terrains "
  2. Delete the "Caucasus" folder
  3. Run another DCS repair

 

2021-06-10 02:31:07.293 INFO    EDTERRAIN4: Open terrain cfg "./Mods/terrains/Caucasus\terrain.cfg.lua"
2021-06-10 02:31:07.293 INFO    EDTERRAIN4: Build date: 
2021-06-10 02:31:07.293 INFO    EDTERRAIN4: Texture quality: "min"
2021-06-10 02:31:07.293 INFO    EDTERRAIN4: Language: "en"
2021-06-10 02:31:07.390 INFO    EDCORE: 0.098 s  terrain references
2021-06-10 02:31:07.390 INFO    EDCORE: 0.000 s  terrain models
2021-06-10 02:31:07.390 INFO    EDCORE: 0.000 s  terrain assets
2021-06-10 02:31:07.456 INFO    EDCORE: try to write dump information
2021-06-10 02:31:07.513 INFO    EDCORE: # -------------- 20210610-023107 --------------
2021-06-10 02:31:07.559 INFO    EDCORE: DCS/2.7.1.7139 (x86_64; Windows NT 10.0.19042)
2021-06-10 02:31:07.604 INFO    EDCORE: I:\DCS World OpenBeta\bin\edterrain4.dll
2021-06-10 02:31:07.648 INFO    EDCORE: # C0000005 ACCESS_VIOLATION at 3FB5F630 00:00000000
2021-06-10 02:31:07.692 INFO    EDCORE: SymInit: Symbol-SearchPath: '.;I:\DCS World OpenBeta;I:\DCS World OpenBeta\bin;C:\Windows;C:\Windows\system32;SRV*C:\websymbols*https://msdl.microsoft.com/download/symbols;', symOptions: 528, UserName: 'mikey'
2021-06-10 02:31:07.737 INFO    EDCORE: OS-Version: 10.0.19042 () 0x300-0x1
2021-06-10 02:31:09.581 INFO    EDCORE: 0x00000000000CF630 (edterrain4): assets::lSplineAsset::waterPolygonCount + 0x130
2021-06-10 02:31:09.714 INFO    EDCORE: 0x00000000002831F6 (edterrain4): operator>> + 0xF6
2021-06-10 02:31:09.716 INFO    EDCORE: 0x000000000027F82B (edterrain4): vd5::VectorData::serialize + 0x21B
2021-06-10 02:31:09.716 INFO    EDCORE: 0x0000000000124843 (edterrain4): operator>> + 0x103
2021-06-10 02:31:09.717 INFO    EDCORE: 0x000000000008A05B (edterrain4): assets::lAssetFile::save + 0x43B
2021-06-10 02:31:09.718 INFO    EDCORE: 0x000000000008901E (edterrain4): assets::lAssetFile::load + 0xE
2021-06-10 02:31:09.719 INFO    EDCORE: 0x000000000005EDC8 (edterrain4): landscape4::SetTerraDispatch + 0x86B8
2021-06-10 02:31:09.719 INFO    EDCORE: 0x000000000005EA47 (edterrain4): landscape4::SetTerraDispatch + 0x8337
2021-06-10 02:31:09.720 INFO    EDCORE: 0x000000000002A8B8 (edterrain4): ITerrainImpl4::init + 0x258
2021-06-10 02:31:09.720 INFO    EDCORE: 0x0000000000009756 (Terrain): createGlobalLand + 0xA46
2021-06-10 02:31:09.721 INFO    EDCORE: 0x0000000001C5BFEC (DCS): AmdPowerXpressRequestHighPerformance + 0xE6CFE8
2021-06-10 02:31:09.722 INFO    EDCORE: 0x0000000000035A80 (lua-MissionGenerator): (function-name not available) + 0x0
2021-06-10 02:31:09.722 INFO    EDCORE: 0x000000000002383D (lua-MissionGenerator): (function-name not available) + 0x0
2021-06-10 02:31:09.723 INFO    EDCORE: 0x0000000000007AC5 (lua): luaD_growstack + 0x845
2021-06-10 02:31:09.723 INFO    EDCORE: 0x0000000000018D94 (lua): luaS_newlstr + 0x5254
2021-06-10 02:31:09.724 INFO    EDCORE: 0x0000000000007E04 (lua): luaD_growstack + 0xB84
2021-06-10 02:31:09.724 INFO    EDCORE: 0x0000000000006F7F (lua): lua_getinfo + 0x133F
2021-06-10 02:31:09.725 INFO    EDCORE: 0x000000000000812E (lua): lua_yield + 0x9E
2021-06-10 02:31:09.725 INFO    EDCORE: 0x0000000000002576 (lua): lua_pcall + 0x66
2021-06-10 02:31:09.726 INFO    EDCORE: 0x00000000000F2DA9 (edCore): ED_lua_pcall + 0x59
2021-06-10 02:31:09.726 INFO    EDCORE: 0x0000000000004005 (lua-dxguiWin): (function-name not available) + 0x0
2021-06-10 02:31:09.727 INFO    EDCORE: 0x00000000007D137D (DCS): SW + 0x4E087D
2021-06-10 02:31:09.727 INFO    EDCORE: 0x0000000001C59A06 (DCS): AmdPowerXpressRequestHighPerformance + 0xE6AA02
2021-06-10 02:31:09.727 INFO    EDCORE: 0x0000000000A07EEE (DCS): SW + 0x7173EE
2021-06-10 02:31:09.728 INFO    EDCORE: 0x0000000000017034 (KERNEL32): BaseThreadInitThunk + 0x14
2021-06-10 02:31:09.728 INFO    EDCORE: 0x000000000004D0D1 (ntdll): RtlUserThreadStart + 0x21
2021-06-10 02:31:11.276 INFO    EDCORE: Minidump created.
2021-06-10 02:31:11.277 INFO    Lua::Config: stack traceback:
	[C]: in function 'generate_thread'
	[string "./MissionEditor/modules/me_generator.lua"]:118: in function 'generate'
	[string "./MissionEditor/modules/me_generator_dialog.lua"]:149: in function 'updater'
	[string "./Scripts/UpdateManager.lua"]:64: in function <[string "./Scripts/UpdateManager.lua"]:40>

 

Link to post
Share on other sites
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...