Jump to content

AIRIO commands are not available. Is still a thing


skunk160
 Share

Recommended Posts

everything up to date

 

Some missions works brilliantly as it should.   other missions  AIRIO commands are not available.

 

Done the repair/close VA/ delete export/open VA/close VA Dance still hit and miss when it work and when i just get the beep and know  AIRIO commands are not available.is showing in VA

skunk160 | Win10 PRO 64bit | i7-4770K 3.50 GHz | 32GB DDR3/1866MHz | GIGABYTE GeForce GTX 1080 x2 | Oculus Rift S | Virpil MongoosT-50CM2 | Virpil F-14B grip | Virpil 200m Curved Extension | PointCTRL | Delta Sim TM Slew | Sim Bandit AHCP | MFG Crosswind Pedals | //FOX2 Switch Boxes | RECARO SPG Seat | AuraSound AST-2B-4 Pro Bass Transducer x2

//FOXTWO Multi-Role Combat Pit Build http://forums.eagle.ru/showthread.php?t=134745

Link to comment
Share on other sites

bump

skunk160 | Win10 PRO 64bit | i7-4770K 3.50 GHz | 32GB DDR3/1866MHz | GIGABYTE GeForce GTX 1080 x2 | Oculus Rift S | Virpil MongoosT-50CM2 | Virpil F-14B grip | Virpil 200m Curved Extension | PointCTRL | Delta Sim TM Slew | Sim Bandit AHCP | MFG Crosswind Pedals | //FOX2 Switch Boxes | RECARO SPG Seat | AuraSound AST-2B-4 Pro Bass Transducer x2

//FOXTWO Multi-Role Combat Pit Build http://forums.eagle.ru/showthread.php?t=134745

Link to comment
Share on other sites

Any progress with having the Jester wheel work with VAICOM RIO? so its there when AI RIO commands dont work?

skunk160 | Win10 PRO 64bit | i7-4770K 3.50 GHz | 32GB DDR3/1866MHz | GIGABYTE GeForce GTX 1080 x2 | Oculus Rift S | Virpil MongoosT-50CM2 | Virpil F-14B grip | Virpil 200m Curved Extension | PointCTRL | Delta Sim TM Slew | Sim Bandit AHCP | MFG Crosswind Pedals | //FOX2 Switch Boxes | RECARO SPG Seat | AuraSound AST-2B-4 Pro Bass Transducer x2

//FOXTWO Multi-Role Combat Pit Build http://forums.eagle.ru/showthread.php?t=134745

Link to comment
Share on other sites

There is some technical reason why this cannot happen - there is a Vaicom version detailed in the manual

Windows 10 Home ¦ Z370 AORUS Gaming K3 motherboard ¦ i5-8600K oc to 4.3GHz ¦ 48GB Corsair PC4 memory @ 3000MHz ¦ Samsung 960 EVO M.2 SSD for OS, Samsung 860 EVO 1TB SSD for DCS ¦ ASUS ROG GTX 2060 Super 8GB ¦ Virpil WarBRD base with VFX grip, Thrustmaster A10c and F/A-18 grips ¦ VKB Gunfighter Mk2 and MCG ¦ Thrustmaster Warthog Throttle ¦ MFG Crosswinds ¦ Oculus Rift S

Link to comment
Share on other sites

  • 3 weeks later...

is AI RIO not available just me? mostly complex dynamic missions and MP are affected it seems

 

any progress @Hollywood_315on a solution? 

skunk160 | Win10 PRO 64bit | i7-4770K 3.50 GHz | 32GB DDR3/1866MHz | GIGABYTE GeForce GTX 1080 x2 | Oculus Rift S | Virpil MongoosT-50CM2 | Virpil F-14B grip | Virpil 200m Curved Extension | PointCTRL | Delta Sim TM Slew | Sim Bandit AHCP | MFG Crosswind Pedals | //FOX2 Switch Boxes | RECARO SPG Seat | AuraSound AST-2B-4 Pro Bass Transducer x2

//FOXTWO Multi-Role Combat Pit Build http://forums.eagle.ru/showthread.php?t=134745

Link to comment
Share on other sites

  • 2 months later...

Hi, i'm having the same problem. It used to work, then it completly stopped to work. Now i tried to reinstall everything, meaning va, and vaicom pro and the airio extension. I deleted the export lua and repaired dcs. Still i get this in my log:

 

11:00:37.646 (awaiting additional input)
11:00:37.644 AIRIO commands are not available.
11:00:37.641 Have result, identified as command: Rock and Roll
11:00:37.639 Captured sentence: rock and roll
11:00:37.623 Recognized : 'rock and roll'
11:00:37.198 Listening suspended
11:00:37.130 Joystick : 'Transmit TX5 release'
11:00:36.179 Listening resumed
11:00:35.823 Joystick : 'Transmit TX5 press'
11:00:34.049 Plugin 'VAICOM PRO 2.5' initialized.
11:00:34.036 Ready for commands.
11:00:34.035 Startup finished.
11:00:34.015 Listening suspended
11:00:33.883 No new DCS modules to import.
11:00:33.881 Success.
11:00:33.881 Building master labels table...
11:00:33.880 Success.
11:00:33.862 Building kneeboard tables...
11:00:33.859 Success.
11:00:33.851 Building master keywords table...
11:00:33.842 Adding 0 imported menu commands.
11:00:33.840 Adding 0 imported ATC aliases.
11:00:33.826 Done.
11:00:33.826 Updating aliases..
11:00:33.824 Success.
11:00:33.823 Loading F10 menu items...
11:00:33.822 Success.
11:00:33.807 Writing updates.
11:00:33.662 Loading keywords database...
11:00:33.628 Done.
11:00:33.544 Initializing database tables...
11:00:33.542 Done.
11:00:33.542 Importing RIO extension pack...
11:00:33.433 Checking VA profile.
11:00:33.425 DCS World version STEAM not found.
11:00:33.424 DCS World version 2.5 OpenBeta not found.
11:00:33.417    6/7 DCS-side files were updated.
11:00:33.415    Reset: gameMessages.lua
11:00:33.415    Reset: TabSheetBar.lua
11:00:33.414    Reset: common.lua
11:00:33.413    Reset: speech.lua
11:00:33.412    Reset: RadioCommandDialogsPanel.lua
11:00:33.411    Reset: VAICOMPRO.export.lua
11:00:33.410    Unchanged: Export.lua
11:00:33.410    Saved Games folder = C:\Users\Madog\Saved Games\DCS
11:00:33.407    Install path = C:\Program Files\Eagle Dynamics
11:00:33.407    Using Registry entry for 2.5
11:00:33.406 DCS World installation found: version 2.5
11:00:33.394 Executing automatic lua code installation.
11:00:33.155 License: PRO
11:00:33.154 Plugin version 2.5.25.3 (release)
11:00:32.605 Initializing..
11:00:32.605 Press LCtrl+LAlt+C for config.
11:00:32.605 VAICOM PRO for DCS World. License: PRO
11:00:31.993 Plugin support enabled.

 

 

I have enabled the Plugin, the license seems to be valid (its in the list of licenses). I pretty much purchased va and vaicom pro only to use it with jester, and i still cant use this software 😞

 

Also, maybe related, my radio menu in game periodically opens and closes when va with vaicom is running, just like described here:

 

@Hollywood_315: Is there something else i can do, or can i somehow help to diagnose this error? I would really like to get it working again.

Link to comment
Share on other sites

My RIO commands also stopped working after the update, with accompanying opening and closing of the radio menu when I hit any of the PTT buttons.

 

EDIT: Just plain restarting my game seemed to fix it somehow, so that was strange.


Edited by Croaker47
Link to comment
Share on other sites

4 hours ago, Croaker47 said:

My RIO commands also stopped working after the update, with accompanying opening and closing of the radio menu when I hit any of the PTT buttons.

 

EDIT: Just plain restarting my game seemed to fix it somehow, so that was strange.

 

Whenever there is an update you must, must, must restart VAICOM after the patch, and then restart DCS after VAICOM starts up. That's because the patches that VAICOM makes to DCS get overwritten during an update. So VAICOM needs to redo them, and then DCS needs to be restarted so it sees the modified versions of the files.

7 hours ago, Madog said:

Hi, i'm having the same problem. It used to work, then it completly stopped to work. Now i tried to reinstall everything, meaning va, and vaicom pro and the airio extension. I deleted the export lua and repaired dcs. Still i get this in my log:

 

11:00:37.646 (awaiting additional input)
11:00:37.644 AIRIO commands are not available.
11:00:37.641 Have result, identified as command: Rock and Roll
11:00:37.639 Captured sentence: rock and roll
11:00:37.623 Recognized : 'rock and roll'
11:00:37.198 Listening suspended
11:00:37.130 Joystick : 'Transmit TX5 release'
11:00:36.179 Listening resumed
11:00:35.823 Joystick : 'Transmit TX5 press'
11:00:34.049 Plugin 'VAICOM PRO 2.5' initialized.

Try holding the TX key down a bit longer. You should not release the TX key until after the sentence is recognized and you have heard the confirmation beep. Your log suggests you are releasing the TX key before "rock and roll" is recognized.


Edited by sthompson
  • Like 1

I'm Softball on Multiplayer. Dell XPS-8500 24GB, i7-3770@3.40GHz, Win 10Pro, Nvidia GeForce GTX 1060 6GB, TiR, VKB Gunfighter III with MCG Ultimate grip, CH throttle and pedals, all maps, most modules

Link to comment
Share on other sites

Hey,

thanks for the help and the suggestions, sadly i still have no luck. Also i wonder, the line „11:00:37.639 Captured sentence: rock and roll“ means, that Vaicom understood me, basically and refuses to execute the command, does it not? It seems to me, while Vaicom recognises my license, but somehow does not act on it.

 

@Hollywood_315: i also mailed you (?) on the e-mail provided in Vaicom - is my  (and @skunk160 ) license somehow broken maybe? Can i get further log output as to why my Vaicom reports „AIRIO commands are not available“?

Link to comment
Share on other sites

That was a really good tip, @Lt_Jaeger!!

It did not recognize the F-14, which is really strange, since vaicom did still turn the communications menu on and off!

Going from the tip i managed to fix the situation by:

  • setting the DCS custom path
  • shutting DCS and VA down
  • starting VA again (made sure to run as admin)
  • starting DCS
  • launching a Mission with the F-14

After this the config window does now correctly display the F-14 and accepts AIRIO commands. Also notice while testing i sometimes did not have DCS running at all, since i figured airio commands would be sent anyway. This is not the case! @Hollywood_315: Maybe include this in the log message or in the manual, airio can not be tested without DCS with F-14 running. Also quite strange is that vaicom obivously found the proper installation path since it was able to generate an export.lua, but did not properly hook into DCS to recognize the F-14. Maybe i stumbled over a bug?

 

@skunk160: does this help you fix your problem, too? Feel free to pm me, if you need further explenation; maybe we can set up a discord session with screenshare, if thats helpful?

@hreich: maybe this is the solution to your problem, too?

 

Thanks everyone for the help, @Lt_Jaeger thanks a lot, buddy!

 


Edited by Madog
Link to comment
Share on other sites

@MadogMy VAICOM recognizes my Ka-50 module correctly, export.lua is properly modded for VAICOM to work...But radio comm menu still turns itself on..On top of that my F12 key doesnt work for some reason..Other F-keys are working fine, but F12 doesn't work at all...Inside DCS it doesn't work and i cant exit comms menu with F12.Exit..I just noticed that when i close DCS and VA -my F12 key still doesn't work...Like something is reserving it...I have logitech g213 keyboard, and i have to use a profile - with which i program macro key that is used when i press F12 key to get it working (to press F12)..

 

[sIGPIC][/sIGPIC]

Pilot from Croatia

Link to comment
Share on other sites

Did you explicitly add your DCS path to the VAICOM config? This is what fixed it for me, i did not test with other modules, so i can not say if it did work in the last configuration or not. 

About the F12 Key not function - is it not working at all ever, or is it explicitly not functioning within DCS, also does it work with DCS when you are not using VA, are you using other Keyboard emulation software that might interfere? For example have you maybe mapped F12 to one of your joystick toggles so that is just pressed constantly?

 


Edited by Madog
Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...