Jump to content

Warthog Throttle - Get rid of Idle detent?


Recommended Posts

I posted this over in the BF-109K forum and Hardware before I knew this Forum existed. To sum up, I know the Idle detent is not removeable and would require a non-reversible mod to remove, not going there. What I want to accomplish is to convince the DCS software that the throttle throw starts at the Idle Detent and ends at the full forward position (post-AB detent, which I have already made a push-through).  I have this "appearing" to work properly in the Options/Axis window using Saturation but in the cockpit it's not. Out of Idle detent immediately goes to 1500 RPM, if I lift and bottom it out it's at idle... which is not what the option screen shows me (it shows full throw and the ID does nothing. Help!

Aerocool Mid-tower, Gigabyte Z390 Master MB, EVGA 1000w PS / Intel i9-9900K @4.7Gz - Nfortec Hydrus V2 Liquid CPU cooler - Noctua NT-H2 Themal paste

32GB Kingston HyperX DDR4 3200mhz / 1TB M.2 Crucial Boot Drive (DCS World Beta installed here), 1TB M.2 Data drive, 1TB WD SATA drive

Gigabyte RTX 2080 w/ 8GB - Nvidia 471.11 drivers /3 Samsung LC32G53TQWUXEN 32" 7680x1440 at 144Hz  / Win10 Pro Ver. 21H1 - Build 19043.1055

TIR 5, TM Warthog HOTAS\VirPil stick base, CH Pedals, TM MFDs  on 2 8" Lilliputs/ ICP by Sebastian

Link to post
Share on other sites

You might have miscalibrated the controller. Is the output as seen in Windows joy.cpl for the axis zero for both the off and idle positions? Normally it would be.

 

If idle to mil range is not 0% to 100% then use of saturation and deadzone combined should allow making the tuned output as desired.

Link to post
Share on other sites
Posted (edited)
12 minutes ago, Frederf said:

You might have miscalibrated the controller. Is the output as seen in Windows joy.cpl for the axis zero for both the off and idle positions? Normally it would be.

 

If idle to mil range is not 0% to 100% then use of saturation and deadzone combined should allow making the tuned output as desired.

 

Thx Frederf, the gear's calibration is spot-on, works perfectly from stop to stop (from below the Idle Detent and past AB detent. The issue is that the Idle detent "area" uses 20% of the  overall throttle throw. and that area is being seen in DCS as the first part (20%) of the throttle. It "works" but when the throttle pops out of Idle its unrealistic and inaccurate. Ideally the throttle at the Idle stop would be 0% and messing with saturation I can get it to work how I envision in the Options window, but in the sim it's like I never changed anything! Yes, I saved the profile (BF-109K Real IIRC).... 


Edited by GaryR

Aerocool Mid-tower, Gigabyte Z390 Master MB, EVGA 1000w PS / Intel i9-9900K @4.7Gz - Nfortec Hydrus V2 Liquid CPU cooler - Noctua NT-H2 Themal paste

32GB Kingston HyperX DDR4 3200mhz / 1TB M.2 Crucial Boot Drive (DCS World Beta installed here), 1TB M.2 Data drive, 1TB WD SATA drive

Gigabyte RTX 2080 w/ 8GB - Nvidia 471.11 drivers /3 Samsung LC32G53TQWUXEN 32" 7680x1440 at 144Hz  / Win10 Pro Ver. 21H1 - Build 19043.1055

TIR 5, TM Warthog HOTAS\VirPil stick base, CH Pedals, TM MFDs  on 2 8" Lilliputs/ ICP by Sebastian

Link to post
Share on other sites

To confirm the axis tuning is doing something can you set some ridiculous, obvious setting like 45% deadzone and 55% saturation?

 

Look for a second axis bound to the same control and make sure the buttons in the axis off positions aren't bound to anything unexpected.

  • Like 1
Link to post
Share on other sites

I'll double check, thanks.

Aerocool Mid-tower, Gigabyte Z390 Master MB, EVGA 1000w PS / Intel i9-9900K @4.7Gz - Nfortec Hydrus V2 Liquid CPU cooler - Noctua NT-H2 Themal paste

32GB Kingston HyperX DDR4 3200mhz / 1TB M.2 Crucial Boot Drive (DCS World Beta installed here), 1TB M.2 Data drive, 1TB WD SATA drive

Gigabyte RTX 2080 w/ 8GB - Nvidia 471.11 drivers /3 Samsung LC32G53TQWUXEN 32" 7680x1440 at 144Hz  / Win10 Pro Ver. 21H1 - Build 19043.1055

TIR 5, TM Warthog HOTAS\VirPil stick base, CH Pedals, TM MFDs  on 2 8" Lilliputs/ ICP by Sebastian

Link to post
Share on other sites
Posted (edited)

Ok, solved. Just found the Warthog Throttle calibration software here. By ignoring the part which told me to set throttle to OFF (which means to lift the Idle Detent and go full back) and just leaving it at the Idle Detent stop, I now have full throttle from the Idle Stop to buried past AB! I have lost the "Idle Detent" capability (in BMS anyway) but really don't care as it's only used for Ramp starts and Alt-i works fine..

woohoo.gif

 

Just tested in DCS BF-109, IL2 and BMS.. all is A-OK!


Edited by GaryR
  • Like 1

Aerocool Mid-tower, Gigabyte Z390 Master MB, EVGA 1000w PS / Intel i9-9900K @4.7Gz - Nfortec Hydrus V2 Liquid CPU cooler - Noctua NT-H2 Themal paste

32GB Kingston HyperX DDR4 3200mhz / 1TB M.2 Crucial Boot Drive (DCS World Beta installed here), 1TB M.2 Data drive, 1TB WD SATA drive

Gigabyte RTX 2080 w/ 8GB - Nvidia 471.11 drivers /3 Samsung LC32G53TQWUXEN 32" 7680x1440 at 144Hz  / Win10 Pro Ver. 21H1 - Build 19043.1055

TIR 5, TM Warthog HOTAS\VirPil stick base, CH Pedals, TM MFDs  on 2 8" Lilliputs/ ICP by Sebastian

Link to post
Share on other sites

There is a (really better) way of doing it in BMS anyway. The virtual buttons which are held down can be bound to SimThrottleIdleDetentLeft and SimThrottleIdleDetentRight which move the throttle(s) to off when the button is pressed and to idle when released. That way you'll be able to enjoy DCS and BMS using the standard out of the box calibration of the Warthog.

  • Like 1
  • Thanks 1
Link to post
Share on other sites
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...