Jump to content

Some tests about crash on exit mission.


Recommended Posts

   As I experience those crashes since last update, I decided to make some tests.

 

First, I started with a fresh install (brand new DCS folder in saved games)

 

Flew A-10C II Instant mission Free Flight Syria

Flight was 6 mins long... put autopilot making plane flying circles for 6 minutes

On mission exit, had a crash. I figured out something was wrong in settings, aspect ratio (by default) was not matching my resolution (1980*1080). It was 1.3333333 instead of 1.7777777. Setting right aspect ratio, quit DCS and after restart I was able to fly for 6 min on same mission without any crash on exit.

 

so I made more tests...

 

Using predifined settings (bottom right corner of setting page)

 

High ----------------------------------------------> No crash on exit

High with SSAO OFF (put it manually) ------------> Crash on exit

High with SSAO ON (put back on manually) ------> Crash on exit

High (predifined setting) -------------------------> No crash on exit

 

Medium (predifined settings) --------------------> No crash on exit

Medium (SSAA *1.5 set manually) ---------------> Crash on exit

Medium (SSAA OFF set manually) ---------------> Crash on exit

Medium (predifined setting) ---------------------> No crash on exit

 

It seems DCS have some trouble with dealing with customs settings.

 

If some users experiencing same crash could try this protocol and see if they got same result....

 

  • Like 1
Link to post
Share on other sites

@Fra298

 

It seems as if you found a valid solution. As per your suggestion, I changed my video settings to match the driver settings and chose one of the predifined settings one and could play normally, it did not even require a fresh install.

 

Thanks a million!

 

Cepheus

Link to post
Share on other sites

And a Post Scriptum to my previous post:

 

Even use of the "R-Shift R" key combination works now again; previously, its use lead inevitably to a crash.

 

Cepheus

Link to post
Share on other sites
Posted (edited)

Glad to ear it helped you! @Cepheus76

 

Made some more research. This time I selected MEDIUM preset. Once done, I canged some settings on this preset; mainly CLOUDS QUALITY and ANTIALIASING.

In all cases I flew the same mission during 2:00 2:10. After changing a setting, always doing the same : Closing and Restarting DCS. Here are the results :

 

Mission : A-10C II Free Flight Caucasus

Preset : MEDIUM

Changed settings :

 

    CLOUDS HIGH - FXAA 16X -----> Crash

    CLOUDS HIGH - FXAA 8X ------> Crash

    CLOUDS HIGH - FXAA 4X ------> No Crash

    CLOUDS HIGH - FXAA 2X ------> No Crash

    CLOUDS HIGH - FXAA OFF ----> CRASH

 

    CLOUDS ULTRA - FXAA OFF ---> Crash

    CLOUDS ULTRA - FXAA 2X -----> No Crash

    CLOUDS ULTRA - FXAA 4X -----> No Crash

    CLOUDS ULTRA - FXAA 8X -----> No Crash

    CLOUDS ULTRA - FXAA 16X ----> Crash

 

    CLOUDS STANDART - FXAA OFF ----> CRASH

    CLOUDS STANDART - FXAA 2X -----> No CRASH

    CLOUDS STANDART - FXAA 4X -----> No CRASH

    CLOUDS STANDART - FXAA 8X -----> CRASH

    CLOUDS STANDART - FXAA 16X ----> CRASH

 

    CLOUDS LOW - FXAA OFF ----------> Crash

    CLOUDS LOW - FXAA 2X ------------> Crash

    CLOUDS LOW - FXAA 4X ------------> No Crash

    CLOUDS LOW - FXAA 8X ------------> Crash

    CLOUDS LOW - FXAA 16X -----------> Crash

 

If someone else could make some similar tests, it could be kind. At least to be sure I'm not the only one in this case.


Edited by Fra298
Link to post
Share on other sites
1 minute ago, CarbonFox said:

So I tried doing preset graphics on high and still got a crash right after exiting the mission.

 

    Maybe give it another try with deleting fxo folder in saved games\DCS

 

Link to post
Share on other sites

    I did not make tests changing MSAA. but there are some other tricks as mentioned on another thread... Incresing preload radius prevent from crashing. I tested quickly yesterday and it seems to work :

 

CLOUDS HIGH - FXAA 16X - Preload radius 150000 -------------------> No crash

CLOUDS HIGH - FXAA 16X - Preload radius 150000 - Water HIGH -----> Crash

 

The way I proceed again is choosing a predifined prest in setting page in this case Medium. I click OK then shut down and restart DCS. Then change one or 2 settings > OK> restart DCS

I restart DCS everytime I change a setting.

 

Again, if anybody with a low end rig could make this kind of tests, maybe it could help.

I'm running an i7-4770K - GTX 1050Ti - 32Gb RAM -1Tb SSD.

Link to post
Share on other sites
28.05.2021 в 18:44, Fra298 сказал:

I decided to make some tests.

If you have time, could you repeat your experiments with exactly the same settings?

I think you will get completly  defferent res from "crash/ No crash" point of view.

Link to post
Share on other sites
Posted (edited)

ok, no problems, i'll give it a try but made some testings this morning and was able to recreate crash in same conditions.


Edited by Fra298
Link to post
Share on other sites
Posted (edited)

Are the tests made with or without Full Screen option? 

 just installed windows 21H1 update (have also to install Cumulative Update Preview for Windows 10 Version 21H1 for x64-based Systems), I'll check if there have any changes about crashing


Edited by zampe
Link to post
Share on other sites
Posted (edited)
5 hours ago, PeevishMonkey said:

If you have time, could you repeat your experiments with exactly the same settings?

I think you will get completly  defferent res from "crash/ No crash" point of view.

 

    You're right @PeevishMonkey did try 3 or 4 and no crash occured. This is pretty strange, cause I was able to recreate crashes in the same conditions. Something else must be interfering.

 

1 hour ago, zampe said:

Are the tests made with or without Full Screen option? 

 just installed windows 21H1 update (have also to install Cumulative Update Preview for Windows 10 Version 21H1 for x64-based Systems), I'll check if there have any changes about crashing

 

 

    Also using Windows 10 21H1

 

 

Edit :

 

    To be sure, I tried to recreate conditions. First setting preset in game setting to MEDIUM (I use that for my tests). What is acting different is that usually, when hitting a preset button, DCS restart by itself. It doesn't anymore now. And I did change nothing on computer not even a restart.


Edited by Fra298
Link to post
Share on other sites

Thanks for the work.  Haven't flown DCS in a while and started troubleshooting this myself too.  For me It seems random, as in make changes crash, make changes no crash, don't make changes, crash and don't make changes, no crash!  With or without reshade also same.  I have 2 files that show up in event viewer consistently (replaced yet same).  Details:

Faulting application name: DCS.exe, version: 2.7.1.6709, time stamp: 0x60adebf9
Faulting module name: d3d11.dll, version: 10.0.19041.746, time stamp: 0xfc177b9d
Exception code: 0xc0000005
Fault offset: 0x0000000000016bae
Faulting process id: 0x2c08
Faulting application start time: 0x01d7557dee5c425a
Faulting application path: d:\Program Files\Eagle Dynamics\DCS World\bin\DCS.exe
Faulting module path: C:\WINDOWS\SYSTEM32\d3d11.dll
Report Id: 0ac14466-522a-45e6-8887-79192a1c0a52
Faulting package full name: 
Faulting package-relative application ID: 

 

Posting to provide info and hopefully colab a solution.  On the good side, at least it's on exit!

 

R5 2600 @4.2 GHZ, 16GB ram @ 3133, 1060 6GB at 2100 and 4400 970 Evo, TM16000M FCS Flight Pack and old eyes. Just an old Hillbilly that does what he wants when he wants...if I can get out of bed!

Link to post
Share on other sites
Posted (edited)

    Same kind of of report in event viewer for me too.

 

Quote

Nom de l’application défaillante DCS.exe, version : 2.7.1.6709, horodatage : 0x60adebf9
Nom du module défaillant : d3d11.dll, version : 10.0.19041.746, horodatage : 0xfc177b9d
Code d’exception : 0xc0000005
Décalage d’erreur : 0x00000000000a77a4
ID du processus défaillant : 0x1f0c
Heure de début de l’application défaillante : 0x01d75545d9db2406
Chemin d’accès de l’application défaillante : C:\DCS World\bin\DCS.exe
Chemin d’accès du module défaillant: C:\Windows\SYSTEM32\d3d11.dll
ID de rapport : e95dfcf9-6a45-470e-9719-4ec0545c15cc
Nom complet du package défaillant :
ID de l’application relative au package défaillant :

 

    With previous openbeta version, had different events :

Quote

Détecteur d'erreurs , type 0
Nom d’événement : FaultTolerantHeap
Réponse : Non disponible
ID de CAB : 0

Signature du problème :
P1 : DCS.exe
P2 : 2.7.1.6430
P3 : 60A632D8
P4 : 256
P5 :
P6 :
P7 :
P8 :
P9 :
P10 :

Fichiers joints :

Ces fichiers sont peut-être disponibles ici :


Symbole d’analyse :
Nouvelle recherche de la solution : 0
ID de rapport : d9d73943-eaa3-4293-9546-539e8f7c7fc3
Statut du rapport : 262148

 

 

    When having those reports, I had no crashes. I noticed also a Registry key regarding this I think :

 

Quote

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\FTH\State]
"C:\\DCS World\\bin\\DCS.exe"=hex:0f,00,00,00,10,00,00,00,8d,d8,2d,0d,44,00,43,\
  00,53,00,2e,00,65,00,78,00,65,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,\
  00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,54,\
  3b,33,12,b4,5b,00,00,b5,9f,d4,89,02,00,00,00,07,00,00,00,00,00,00,00,1b,16,\
  00,00

 

 

   But that was before last open beta... And I removed the key before using last release.

 


Edited by Fra298
Link to post
Share on other sites

Thanks for replying.  Looking at this atm... you done any research on this?

The exception code 0xc0000005 indicates a memory access violation

R5 2600 @4.2 GHZ, 16GB ram @ 3133, 1060 6GB at 2100 and 4400 970 Evo, TM16000M FCS Flight Pack and old eyes. Just an old Hillbilly that does what he wants when he wants...if I can get out of bed!

Link to post
Share on other sites

    No, did not make any research about it. I focused on finding a pattern to reproduce crash. I'll try to have a look. Hollidays finish tonight, so i'll have less time, but i'll try to search.

Link to post
Share on other sites

Ok, I'm looking into it now... just didn't want to waste my time if had already been checked out.  Rabbit hole or rabbit.. off I go.

R5 2600 @4.2 GHZ, 16GB ram @ 3133, 1060 6GB at 2100 and 4400 970 Evo, TM16000M FCS Flight Pack and old eyes. Just an old Hillbilly that does what he wants when he wants...if I can get out of bed!

Link to post
Share on other sites
Posted (edited)

    Trying right now with "Activate DEP" for all software. I'll give report tomorrow. So far, so good... no crash yet... but it's safe to wait at least 24h 😛


Edited by Fra298
Link to post
Share on other sites

BTW, what video drivers ya running (all with this issue pls reply).  I'm on 461.72.

 

BTW, this was a deadend for me (rabbit hole imo).

 

FriendlyEventName=Stopped working
ConsentKey=APPCRASH

 

 

R5 2600 @4.2 GHZ, 16GB ram @ 3133, 1060 6GB at 2100 and 4400 970 Evo, TM16000M FCS Flight Pack and old eyes. Just an old Hillbilly that does what he wants when he wants...if I can get out of bed!

Link to post
Share on other sites
Posted (edited)

    Drivers rev is 466.55 (beta)

 

"Activate DEP" for all software is a dead end. Crash is back 😞


Edited by Fra298
Link to post
Share on other sites

This may be something...

*** WARNING: Unable to verify checksum for dx11backend.dll

*** WARNING: Unable to verify checksum for NGModel.dll

*** WARNING: Unable to verify checksum for GraphicsVista.dll

*** WARNING: Unable to verify checksum for webrtc_plugin.dll

*** WARNING: Unable to verify checksum for ed_sound.dll

 

And thinking about replacing ED's dx11backend with an older version I have from 2018.... sounds like bad idea but this still may be the file with issue for us.

 

Off to check these other files first tho

 

R5 2600 @4.2 GHZ, 16GB ram @ 3133, 1060 6GB at 2100 and 4400 970 Evo, TM16000M FCS Flight Pack and old eyes. Just an old Hillbilly that does what he wants when he wants...if I can get out of bed!

Link to post
Share on other sites

So I started running DCS in Windows 8 compatibility mode. Water set to Medium.

 

I haven't experience a crash so far after flying around in two different modules.

F/A-18C; A-10C; F-14B; Mirage 2000C; A-4E; F-16C; Flaming Cliffs 3

Link to post
Share on other sites
Posted (edited)

    I did not check Win  8 commpatibility since last release to be honest. So far focusing on something to find crash cause...

What is really annoying @CarbonFox is that yesterday, I was able to reproduce crashes listed in this thread on friday evening. And tonight, no way.


Edited by Fra298
Link to post
Share on other sites

dcs.log

 

Getting crash now on every mission everytime.......  Attached full log using the bignewy Autoconfig...............

 

2021-05-30 20:31:49.795 INFO    EDCORE: DCS/2.7.1.6709 (x86_64; Windows NT 10.0.19043)
2021-05-30 20:31:49.796 INFO    EDCORE: F:\Eagle Dynamics\DCS World OpenBeta\bin\dx11backend.dll
2021-05-30 20:31:49.797 INFO    EDCORE: # C0000005 ACCESS_VIOLATION at 3D7ACC13 00:00000000
2021-05-30 20:31:49.800 INFO    EDCORE: SymInit: Symbol-SearchPath: '.;F:\Eagle Dynamics\DCS World OpenBeta;F:\Eagle Dynamics\DCS World OpenBeta\bin;C:\WINDOWS;C:\WINDOWS\system32;SRV*C:\websymbols*https://msdl.microsoft.com/download/symbols;', symOptions: 528, UserName: 'wiz'

Link to post
Share on other sites
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...