Jump to content

MMJOY2 / MICRO PRO / Delete Firmware


Recommended Posts

Hello.

Is it possible to delete the MMJOY2 Firmware from the MICRO Pro?

I tried it with ARDOINO-Software. nothing happened. (Burn)

I tried it with GND/RST, nothing happened.

I have seen some Videos and read some internet postings, but nothing worked. 

(May be i did it wrong, cause i am a german and the Videos/Post were english.)

 

I need to delet and reinstall the FIrmware to give the MICRO PRO a new name and a new adress.

I alredy use one and the second one is nut functional in cause of the same VID/PID.

 

Help would be great. Thanks.

Link to comment
Share on other sites

Posted (edited)

I have not used MMJoy in while but I thought when I changed both through the MMJOY UI. As I was adding and uploading button data.

 

MMJOY-PIC.png


Edited by Brewnix

[sIGPIC][/sIGPIC]

Link to comment
Share on other sites

Posted (edited)

You do not need to re-flash the firmware 'MMJOY2' for change the VID/PID, 


When the stick is blue :

 

- Load sets from device

- Change your VID / PID and the Name 

- Save sets to device

 

and that's all 

 

unless you have already flashed another firmware, in that case, you must redo the complete procedure

pro-micro-firmware-instructions.pdf


Edited by Tanuki44
Link to comment
Share on other sites

Additional, before change change VID/PID and name is need remove the previous e.g. 8888/8888 from Windows Register, or Windows Games Controller will not recognize the new ID, although games recognize, is just a Windows thing.

 

Try with the button "Clear sets" in MMJoySetup software or use Windows Register tool.

Link to comment
Share on other sites

But it doesnt work to me.

1. Delete regedit entry

2. Changed the numbers to 7881 (see pic)

3. Saved it on the device

4. Restart device

5. Restart PC

6. Device has an error by imigration

7. opened MMJOY2

8. VID / PID are back to 8888

ZZ01.PNG

ZZ02.PNG

ZZ03.PNG

Link to comment
Share on other sites

On different sites, we can read:


don't use the currently latest version (at the moment that'd be v20161101), it's bugged. Use the previous one instead (at the moment v20160818upd1).

 

Without ever succeeding to know what bugs ...

 

 

Link to comment
Share on other sites

Posted (edited)

Try with other name in "USB name" that not MMjoy2 - used previous. E.g. Panel1, Panel2...

 

Think that bug in (v20161101) is something related with buttons above # 32, some are not reported.


Edited by Sokol1_br
Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...