Jump to content

Train Strafe Channel Instant Action changes view settings


Recommended Posts

Posted (edited)

The Train Strafe quick start mission for the Channel map contains a folder called config which itself contains Server, SnapViews, SnapViewsDefault, and View lua files. These get dumped into the Temp folder and override the user's settings, messing up the views.

 

train strafe Channel.png


Edited by wowbagger

CPU:5600X | GPU:RTX2080 | RAM:32GB | Disk:860EVOm.2

Link to comment
Share on other sites

  • wowbagger changed the title to Train Strafe Channel Instant Action changes view settings
Posted (edited)

@wowbagger I just can't use my custom views with ANY mission, even the ones I create in the mission editor.

 

Steps to reproduce:

  1. Create a mission with any P-47 model as client or player
  2. Hit Fly
  3. Move the pilot's head with Numpad keys
  4. Hit LWin + Numpad1 once
  5. Hit RAlt + Numpad0 once
  6. Press LWin + Numpad1: the custom span view is displayed. It's working. Yay!
  7. Reload the mission.
  8. Press LWin + Numpad1: this time, the default snap view number 1 is displayed...

Am I doing something wrong?


Edited by Flappie

A track or it didn't happen.

Link to comment
Share on other sites

Posted (edited)

Check the TEMP folder. If a mission dumped this dumb Config folder in there, it may still be there - in which case the game will read the views from that Config folder instead of your own defined views for all missions. I also had lua files with strange names show up in the TEMP folder which also had view settings inside and which over-rid  my own settings.

 

 

Just clear out the TEMP folder to solve this issue, if that's the cause.

 

 

I think custom snap-views are buffered until you exit the mission, at which time they actually get saved to your SAVED GAMES folder.


Edited by wowbagger

CPU:5600X | GPU:RTX2080 | RAM:32GB | Disk:860EVOm.2

Link to comment
Share on other sites

Posted (edited)

This is what I did after reading your post:

  1. Recorded my snap view. After exiting the mission, I saw my Snap View lua was changed accordingly.
  2. Emptied "Local\Temp\DCS...".
  3. Loaded Caucasus "Takeoff" instanct action mission.
  4. Once in the cokpit, my custom snap vew doesn't work.
  5. I see no "Config" folder in my "Local\Temp\DCS..." folder.

 

image.png

 

	[2] = {--LWin + Num1 : Snap View 1
		viewAngle		= 94.096327,--FOV
		hAngle			= 140.241257,
		vAngle			= -1.880616,
		x_trans			= 0.298479,
		y_trans			= 0.037436,
		z_trans			= -0.203056,
		rollAngle		= 7.745360,
		cockpit_version	= 0,
	},

 


Edited by Flappie

A track or it didn't happen.

Link to comment
Share on other sites

Posted (edited)

Hmmm...

 

Maybe check those files in the TEMP folder and open any non-zero files to see if they contain view settings. I had it happen with a couple of different missions, in different ways, and one definitely had view settings in a strange and unexpected file from which the game was reading the view settings - I thought it was a lua file but it might have been a ~mis file.


Edited by wowbagger

CPU:5600X | GPU:RTX2080 | RAM:32GB | Disk:860EVOm.2

Link to comment
Share on other sites

I just checked that mission, Flappie, and you are correct. This mission doesn't seem to dump anything into the TEMP folder that would override your custom snap-view settings.

 

And, when I fly it, my views work properly. So your problem must be rooted somewhere else.

CPU:5600X | GPU:RTX2080 | RAM:32GB | Disk:860EVOm.2

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...