Jump to content

Windows woes: Random CTD "fixed" by rolling back Win10 update KB4589212 (Intel microcode update)


Recommended Posts

In case it can help anyone:

 

In late March my otherwise fairly stable rig suddenly had massive stuttering and random crashes in DCS. I went through the usual process with mods, repairs, removing OC's and what not. I finally figured out that Windows Update had installed a number of update packages around the time the problems had started. Rolling back these updates restored stability.

 

After a month of stability I suddenly started getting random CTDs in DCS (now version 2.7) again earlier this week. Sometimes with an error log, sometimes without a log. The error log would usually show errors relating to video drivers:
 

EDCORE: DCS/2.7.0.5118 (x86_64; Windows NT 10.0.19042)
EDCORE: C:\WINDOWS\System32\DriverStore\FileRepository\nv_dispi.inf_amd64_7d91b2ed40558a26\nvwgf2umx.dll
EDCORE: # C0000005 ACCESS_VIOLATION at 6B88A9F3 00:00000000

 

After going through the first steps of disabling mods etc. I remembered my problems from March and looked for Windows Updates. It turned out that one of the packages from March had been reinstalled. Rolling back that particular update restored stability once again. The update was KB4589212, which apparently is the latest microcode updates for Intel processors, and for some reason does not really work well in DCS for my rig (specs below).

 

Hardly a long term fix, but perhaps rolling back that update can help someone else.

Specs:

Microsoft Windows 10 Home, 10.0.19042 Build 19042
i7-9700K CPU @ 4.9GHz, 32MB RAM, RTX 2080 (drivers 466.11), HP Reverb G2
Running DCS 2.7.0.5118 Open Beta

 

  • Thanks 2
Link to post
Share on other sites

Thanks for letting us know. 

 

I have just updated my windows moments ago, so maybe there is a fix out. 

smallCATPILOT.PNG.04bbece1b27ff1b2c193b174ec410fc0.PNG

Forum rules - DCS Crashing? Try this first - Cleanup and Repair - Discord BIGNEWY#8703 - Youtube - Patch Status

Windows 10 Pro x64, NVIDIA MSI RTX 2080Ti VENTUS GP, Intel® i9-10900K 3.70GHz, 5.30GHz Turbo, Corsair Hydro Series H150i Pro, 32GB DDR @3000, ASUS ROG Strix Z490-F Gaming, HP Reverb G2

Link to post
Share on other sites

Not working there are KB00154XXX has same problem but not working 

Several solutions are posted, but all are not relevant. This is a DCS programmer's problem, only have to wait for HOTFIX I sent a lot  autologs. They will solve


Edited by lee1hy
  • Like 1

creator of ED's official F-16C liveries 

Link to post
Share on other sites

That's the reason I clone my Windoze install before applying ANY updates, be it DCS or Windows Upbreaks. If it doesn't work for some reason and I don't have the time to investigate or I don't care to do the work of those fine programmers at Microsoup, I simply rollback to the last working state. Without these features I don't dare to work with any "product" that has a track record of being notoriously unstable.

  • Like 1
Link to post
Share on other sites
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...