Jump to content

Since version 2.7, it is impossible to obtain the name of the target STATIC unit.


Recommended Posts

I use Moose's SCORING function in my missions but since version 2.7 the unit name STATIC is no longer available. I asked the question on the Moose discord and here is their answer: " Applevangelist — Aujourd’hui à 14:44
@[LFDM] Maxime Had a deep look into what is passed from DCS on which event. For STATIC Units the DCS API is still bugged to obtain the name of the target unit. I'm afraid the workaround currently thus breaks scoring for STATICs, but there's no distinction possible from the data passed. ".
 My question: is this a bug that you are going to fix or is it a will on your part?

I am attaching the test mission and the log

TEST2.miz dcs.log

Link to post
Share on other sites

Not sure, if that is related, but we see the following errors in the logs. As it was an eject, I'm pretty sure it was not a static in this case.

 

2021-04-30 09:32:55.377 INFO    Scripting: event:type=eject,target=,t=30085.501,initiatorMissionID=1004162,targetMissionID=0,
2021-04-30 09:32:55.377 INFO    Scripting: event:type=kill,weapon=AIM-120C-5,target=F-4E,t=30085.501,initiatorMissionID=1004132,targetMissionID=1004162,
2021-04-30 09:32:55.377 ERROR   Lua::Config: Call error world.onEvent:[string "-- world events hook..."]:461: Unit doesn't exist
stack traceback:
    [C]: ?
    [C]: in function 'getName'
    [string "-- world events hook..."]:461: in function <[string "-- world events hook..."]:440>.
2021-04-30 09:32:56.367 INFO    Scripting: event:type=eject,target=,t=30086.501,initiatorMissionID=1004162,targetMissionID=0,
2021-04-30 09:32:56.367 ERROR   Lua::Config: Call error world.onEvent:[string "-- world events hook..."]:461: Unit doesn't exist
stack traceback:
    [C]: ?
    [C]: in function 'getName'
    [string "-- world events hook..."]:461: in function <[string "-- world events hook..."]:440>.
2021-04-30 09:32:57.820 INFO    Scripting: event:weapon=SM-2,t=30087.948,type=shot,initiatorMissionID=3,

Link to post
Share on other sites

The origin of the problem is the ejected pilot static objects are buggy and we had to work around that in MOOSE. Unfortunately, that workaround caused problems in other classes like the OP described.

 

We improved the workaround and this issue should be solved now. Check out the MOOSE branches for a recent version.

 

PS: I created a new threat for the root cause problem 

 

A warrior's mission is to foster the success of others.

i7-8700K | Asus RTX 2080Ti Strix OC | 32 GB Ram 3200 MHz DDR-4 | Asus Maximus Hero X | Samung EVO 960 Pro SSD | VKB Gunfighter Pro | MFG Crosswind | Rift S

RAT - On the Range - Rescue Helo - Recovery Tanker - Warehouse - Airboss

Link to post
Share on other sites
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...