Jump to content

Takes ages for DCS to close down .


Recommended Posts

Memory leaks or what ever is causing this . Exit DCS take ages for my computer to get back to normal . 

32GB ram . Same for 16Gb ram . Black screen and lock ups . 

Poor performance in multiplayer . Very poor . 

AsRock Steel  - B450 ~ RyZen - 2600X @ 4.2 - GTX 1080 - HyperX 16 :GB @ 2400 - Win10 - 64bit Pro - T-50 Mongoose - CM2 Throttle - VKB T-bar Rudders - Trackir5 . I'm a dot .

Link to post
Share on other sites

I've had these things happen. It can almost be anything.

In my case, I had a bad ethernet interface that caused drops -and- memory problems.

Process Lasso helped find the leaks and you can do memory trims that help right away, but in my case, I had to replace my ethernet interface.

Since then.. all problems solved.

Not saying I blame DCS entirely. Can't explain it. Next time it will be something else seemingly unrelated.

ASUS Z390 / Intel i7-9700K / 32 GB DDR4 / 1080Ti / HP Reverb 2 / Thrustmaster WH&TPR

Heath and Allen Zedi8 / TrackIR / Momo USB monitor / Akai MPD218

Link to post
Share on other sites

I had the same problem, also had terrible GPU frametime in multiplayer but after I disabled Tacview, all good now! 🤨

Asus Prime X570-P * Ryzen 5800X * RTX 3080 TUF OC * G.Skill 32GB DDR4 3600MHz * 2 x 256Gb M.2 * Samsung 850 EVO 512Gb SSD * Kingston HyperX 120Gb SSD * Corsair RM850x V2/2018 * HP Reverb G2 * CH Fighterstick/Pedals/Throttle

Link to post
Share on other sites
On 5/1/2021 at 2:52 AM, Flappie said:

Another user solved this issue by unticking"Run as administrator" in the DCS.exe and DCS_updater.exe properties.

I have this issue too I run the game normally no administrator and I have to close the game every time with task manager.

Link to post
Share on other sites

Thank you.

 

2021-05-04 10:19:35.892 INFO    NET: disconnected: 0 
2021-05-04 10:19:35.904 INFO    NET: disconnected from server
2021-05-04 10:19:36.321 INFO    NET: client has stopped
2021-05-04 10:19:36.380 INFO    Dispatcher: Stop
2021-05-04 10:19:38.724 INFO    Config: netview stopped
2021-05-04 10:19:39.362 INFO    TERRAIN: lSystem::CleanScenes()
2021-05-04 10:19:39.497 INFO    VISUALIZER: StopSimulation
2021-05-04 10:19:39.575 INFO    VISUALIZER: Stopped collection of statistic.
2021-05-04 10:19:39.789 INFO    EDCORE: (dDispatcher)enterToState_:3
2021-05-04 10:19:39.889 INFO    EDCORE: (dDispatcher)enterToState_:5
2021-05-04 10:19:39.934 INFO    DCS: application shutdown
2021-05-04 10:19:41.158 INFO    EDOBJECTS: lTypeObjectManagerImpl::clear 0
2021-05-04 10:19:41.163 INFO    EDOBJECTS: lTypeObjectManagerImpl::clear 1
2021-05-04 10:19:41.163 INFO    EDOBJECTS: lTypeObjectManagerImpl::clear 2
2021-05-04 10:19:41.285 INFO    EDOBJECTS: lTypeObjectManagerImpl::clear 3
2021-05-04 10:19:41.393 INFO    EDOBJECTS: lTypeObjectManagerImpl::clear 4
2021-05-04 10:19:41.400 INFO    EDOBJECTS: lTypeObjectManagerImpl::clear 5
2021-05-04 10:19:41.403 INFO    EDOBJECTS: lTypeObjectManagerImpl::clear 6
2021-05-04 10:19:41.405 INFO    EDOBJECTS: lTypeObjectManagerImpl::clear 7
2021-05-04 10:19:41.406 INFO    EDOBJECTS: lTypeObjectManagerImpl::clear 8
2021-05-04 10:19:41.409 INFO    EDOBJECTS: lTypeObjectManagerImpl::clear 9
2021-05-04 10:19:41.409 INFO    EDOBJECTS: lTypeObjectManagerImpl::clear 10
2021-05-04 10:19:41.410 INFO    EDOBJECTS: lTypeObjectManagerImpl::clear 11
2021-05-04 10:19:41.410 INFO    EDOBJECTS: lTypeObjectManagerImpl::clear 12
2021-05-04 10:19:41.411 INFO    EDOBJECTS: lTypeObjectManagerImpl::clear 13
2021-05-04 10:19:44.263 INFO    VISUALIZER: SceneManager_Implement::~SceneManager_Implement()
2021-05-04 10:19:44.269 INFO    VISUALIZER: TerrainRenderer::release
2021-05-04 10:19:44.373 WARNING LOG: 1 duplicate message(s) skipped.
2021-05-04 10:19:44.373 INFO    TERRAIN: lSystem::exit()
2021-05-04 10:19:44.373 INFO    TERRAIN: lSystem::CleanScenes()
2021-05-04 10:23:31.382 INFO    DX11BACKEND: DX11Renderer::shutdown()
2021-05-04 10:23:38.562 INFO    DX11BACKEND: NVIDIA API exit OK
2021-05-04 10:23:38.562 INFO    DX11BACKEND: textures_count: 0
2021-05-04 10:23:38.562 INFO    DX11BACKEND: textures_size: 0
2021-05-04 10:23:38.562 INFO    DX11BACKEND: buffers_count: 0
2021-05-04 10:23:38.562 INFO    DX11BACKEND: buffers_size: 0
2021-05-04 10:23:38.562 INFO    DX11BACKEND: CB_count: 0
2021-05-04 10:23:38.562 INFO    DX11BACKEND: CB_size: 0
2021-05-04 10:23:38.562 INFO    DX11BACKEND: SB_count: 0
2021-05-04 10:23:38.562 INFO    DX11BACKEND: SB_size: 0
2021-05-04 10:23:38.562 INFO    DX11BACKEND: IB_count: 0
2021-05-04 10:23:38.562 INFO    DX11BACKEND: IB_size: 0
2021-05-04 10:23:38.562 INFO    DX11BACKEND: VB_count: 0
2021-05-04 10:23:38.562 INFO    DX11BACKEND: VB_size: 0
2021-05-04 10:23:38.562 INFO    DX11BACKEND: total_buffers_size: 0
2021-05-04 10:23:38.562 INFO    DX11BACKEND: total_size: 0
=== Log closed.

 

Ouch. Indeed. It takes 3 minutes and 45 seconds to execute the "CleanScenes()" function.

 

Please try to add these folders as exceptions in your antivirus, even if it's the default W10 antivirus:

 

  • C:\Users\username\Saved Games\DCS
  • C:\Users\username\Saved Games\DCS.openbeta
  • \DCS World\
  • \DCS World OpenBeta\
Link to post
Share on other sites
15 minutes ago, Flappie said:

Ouch. Indeed. It takes 3 minutes and 45 seconds to execute the "CleanScenes()" function.

 

Please try to add these folders as exceptions in your antivirus, even if it's the default W10 antivirus:

 

  • C:\Users\username\Saved Games\DCS
  • C:\Users\username\Saved Games\DCS.openbeta
  • \DCS World\
  • \DCS World OpenBeta\


I don't think my Antivirus is the issue I tried it anyways and it's still the same, also it happens on my second computer which is way more powerful than the one I use regularly. 

I tested a bit and found out that the longer I play DCS and load performance heavy missions the longer it will take to close the game.

Link to post
Share on other sites

I have had the same issue since 2.7 update.  Added 32GB RAM, deleted programs to make more space on my M.2 SSD, overclocked CPU, short/long repair of DCS, and cleaned up all background programs....no change.  Long shutdown in VR and 2D.  I did notice that after the first small update of DCS, post 2.7, the program shut down normally once, but then the bug returned.  This leads me to believe it may be a core DCS problem.

Link to post
Share on other sites
7 minutes ago, Flappie said:

Usually, long DCS startup/closing times mean a drive is being accessed.

You can use Windows Resource monitor to check if dcs.exe reads or writes stuff during these long 3 m 45 s.

 
I tested it, during loading mission High CPU, Memory, SSD usage reaching 100% but when closing the game only high Memory usage(95%) and it slowly goes down until the game fully closes. I have DDR4 2400MHz 2x8GB RAM.

Could it be related to 

 

On 4/25/2021 at 7:24 PM, KoN said:

Memory leaks or what ever is causing this . Exit DCS take ages for my computer to get back to normal . 

32GB ram . Same for 16Gb ram .

 

On 4/25/2021 at 9:37 PM, InfinityWingman said:

-and- memory problems.

?

Link to post
Share on other sites
Posted (edited)

Thanks for your feedback.

 

I've read some users were having less crashes when meddling with the pagefile min size, since 2.7 came out. So yes, I don't know how to call it, but it seems 2.7 introduced a memory issue for some. But I really don't understand why this bug is not global. I don't have it, and only one of my ~20 regular DCS buddies experienced the second mission loading crashes. Maybe these issues are not related, but they came together in the same patch.


Edited by Flappie
Link to post
Share on other sites

Think you hit on the solution Flappie.  I checked my page file size and it was showing none.  I adjusted fixed pagefile min to 48000 (1.5x32GB) and max to 128000 (4x32GB) on my m.2 SSD.  DCE starts faster and shuts down immediately, both in VR and 2D.

 

Thanks!

Link to post
Share on other sites

Did a little more testing.  With the pagefile adjustments, DCS closes immediately from the menu screen.  When a mission is loaded (I am using the same mission...F-18, Supercarrier, cold start, Persian Gulf) it then takes anywhere from 30 seconds to 1 1/2 minutes to shut down from VR.  Occasionally DCS will shut down immediately from VR with the same mission loaded (I hate intermittent problems!).  Starting from a fresh computer boot does not seem to make a difference.  I think there is a memory leak somewhere or the cache is not getting cleared.  Still better now than without the pagefile adjustment.

Link to post
Share on other sites

So what i did was ordered more memory 32GB - 3200mhz , and updated my Nvidia drivers and  changed page file . 

so far so good get the odd stutter .Single player runs good , but multiplayer still a pain in the ASs. 

Sorry guys needs to be said online used to be a strong point for DCS , But since 2.5 its gone down hill .32GB need to fly online is just Wow !!  really .

  • Like 1

AsRock Steel  - B450 ~ RyZen - 2600X @ 4.2 - GTX 1080 - HyperX 16 :GB @ 2400 - Win10 - 64bit Pro - T-50 Mongoose - CM2 Throttle - VKB T-bar Rudders - Trackir5 . I'm a dot .

Link to post
Share on other sites
22 hours ago, Fuzzysham said:

Disable track recordings. 
 

Add disable_write_track = true to your autoexec.cfg in Users\<name>\Saved Games\DCS\Config

I cannot find this file anywhere is saved games or in the DCS program folders.  Do I need to create this?

Link to post
Share on other sites
Posted (edited)
41 minutes ago, Tshark said:

I cannot find this file anywhere is saved games or in the DCS program folders.  Do I need to create this?

You need to go your operating system drive by opening File Explorer and going to "This PC" or "Computer" on the left side and selecting the operating system drive which is usually the C drive and then make your way to C:\Users\{Your computer username}\Saved Games\DCS.openbeta\Config (Can be different from a computer to another). and no you don't need to create this the game creates this on first run.


Edited by RosyPlays
Link to post
Share on other sites
1 hour ago, Tshark said:

I cannot find this file anywhere is saved games or in the DCS program folders.  Do I need to create this?

Without any mods installed, I did not have that file in my folder and had to create it. You may have to do the same.

Link to post
Share on other sites

Thanks guys!  I created the autoexec.cfg file and added the disable track recordings entry.  No change as far as shut down is concerned.

Link to post
Share on other sites

I’m having the same issue. Takes an age for it to shut down. I’ve tried different page file settings too and it makes no difference. Weird...

i7 8700k @ 5.0ghz. Strix GTX1080Ti. 32GB RAM @ 3600. 2x Hyper X SSD’s with DCS on one. Oculus Rift S. Asus PG278-QR. Liquid Series PC with liquid CPU and GPU cooling.

Link to post
Share on other sites
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...