Jump to content

Recommended Posts

Hello

 

I'm currently facing some issues with my Quest 2 and the latest 2.7 update.

After updating to 2.7 the game started to crash quite frequently with distortions, black images and stutters between the crashes.

So I tried resetting all the Oculus settings to default (recommended) with no success.

 

After digging deeper I found out that either I can't disable Asynchronous Space Warp anymore or the game is locked to half the panel framerate. The debug settings have no effect on this anymore. It seems like this is the cause of my distortions and stutters. To make things worse the already low framerate seems to randomly collapse with no obvious reason. Last time it happened was on 20 000 ft over clouds on an empty server.

 

I've already seen some posts about similar issues but I couldn't find solutions or at least an official acknowledgment that something is wrong here.

Any input on this matter is much appreciated!

 

My Specs:

Ryzen 7 5800X

MSI GTX 3080

32 GB 3333 MHz DDR4 RAM

MSI Tomahawk X570 Wifi

Quest 2 connected to USB 3.2 Gen 2 10Gbps Type C port

 

Notable settings:

Quest 2 set to 72 Hz with 5408x2736 resolution

bitrate: 350 mbps

ASW: disabled

distortion curvature: low

DCS settings based on popular VR settings (nothing special or weird going on)

 

- Crysinator


Edited by TheCrysinator
Additional Info
Link to post
Share on other sites

I'm running a Quest 2 without any issues at the moment and on older, different  hardware to you, so that probably won't be much help, but I can check what settings I'm using in the Oculus software, later when I'm home, in case that's of any help.

 

Edit: So, I'm running my Quest 2 at 90 Hz with 3712 x 1872 resolution and ASW disabled. Bitrate 912 mbps

 

Like you I was running with the resolution cranked up to 5408 x 2736 but at 3712 x 1872 the resolution still seems perfectly good to me, surprisingly. 

 

Maybe your problem is your bitrate at only 350 mbps?


Edited by AlpineGTA

i7-3770 CPU, 32GB DDR3 RAM, Sapphire AMD Radeon 5700 XT, Oculus Rift S

Link to post
Share on other sites
Posted (edited)

Your settings are much appreciated. Regarding the bitrate I reduced the bitrate from 500 mbps to 350 mbps in a try to rule out problems with the encoder. How do you achieve such a high bitrate? The debug tool won't accept inputs over 500 mbps on my end. Maybe not available on higher resolutions? I'll give the lower resolution a shot next time I fly.

 

Btw I think I remember your name from the forum. You really got me into VR and I'm glad you did 🙂

 

Edit: I could set >500 mbps as dynamic bitrate. Will try how it looks and report back.


Edited by TheCrysinator
Link to post
Share on other sites

Oh dear, did I really? Don't blame me for your VR woes! Just kidding! 😀

 

I don't know about the bitrate, I don't use the debug tool or anything like that. I just use the standard Oculus software, plug it into the standard USB 3.0 on the motherboard, enable link and let it do it's own thing and I get what I get. I believe some people get much higher bitrates but I'm running on a fairly antiquated motherboard and CPU (an old Dell XPS ex work workstation that I threw a few new bits at). My Windows 10 is not even using UEFI mode. I'm currently waiting on some new bits I've ordered to upgrade.

 

Just FYI, my current spec:

 

Intel i7-3770 CPU

AMD RX 5700-XT

32GB DDR3 RAM

Dell OYJPT1 motherboard

 

I've ordered:

 

i5-11600K

Asus Z590 mb with wifi

and 32GB DDR4 3600Mz RAM

 

A new GPU would be nice but try and find one!

 

 

i7-3770 CPU, 32GB DDR3 RAM, Sapphire AMD Radeon 5700 XT, Oculus Rift S

Link to post
Share on other sites

No worries I just stumbled over your posts right when I was choosing between the Quest 2 and the Reverb G2 and so far I'm glad that I went with the Quest 2 :). 

 

The only thing I need the debug tool for is to disable ASW. I couldn't find that setting elsewhere. Is there a way?

I tried to play around with the settings some more and I got it pretty smooth again but now I'm sure it has to do something with ASW.

It is disabled in the debug tool and yet my image shows ASW-typical artifacts. Sometimes when I restart the debug tool and tab in and out of the game it will disengage and everything is fine.

 

I can feel you with the GPU. The PC hardware market is a nightmare right now...

Link to post
Share on other sites

I use: ctrl-keypad1 to disable ASW.

 

 

Here are all the keyboard shortcuts:

  • ctrl-keypad1 ASW Disabled.
  • ctrl-keypad2 Force 45 fps no ASW.
  • ctrl-keypad3 Force 45 fps with ASW.
  • ctrl-keypad4 Enabled ASW auto.

You have to Alt+Tab to the Oculus software window before you do it though, then Alt+Tab back to DCS, otherwise it won't take effect.

 

I definitely find it runs with less to no stutters for me with ASW disabled. An easy way to check is to go to F3 view. If your plane flies past smoothly then you have ASW disabled. If you see stutters or ghosting as it flies past then ASW is not disabled. At least that's how I can tell on my system.


Edited by AlpineGTA
  • Like 2
  • Thanks 1

i7-3770 CPU, 32GB DDR3 RAM, Sapphire AMD Radeon 5700 XT, Oculus Rift S

Link to post
Share on other sites
Posted (edited)

Thank you that's a great tipp. I didn't even know that shortcuts exist!

 

Edit: The shortcuts fixed my distortion issues! Good to know that the debug settings seem to be non functional.


Edited by TheCrysinator
Link to post
Share on other sites

Hi !

I also have problems which seem to come from the new 2.7 update, it seems that when my Quest 2 is hot it goes into "degraded" mode by swapping the signal to a low resolution version ... Which distorts the view and make the game unplayable.

 

But as soon as I interrupt the Oculus Link connection, and return to the Quest home, the resolution returns to normal. But if I reconnect again same problem. I have to restart the headset. However, I noticed that when this occurs the helmet is hot, not necessarily more than with version 2.5 ...

 

I wrote a request to Oculus support in this direction, I hope that they will be able to bring me some answers on this phenomenon.

 

What do you think ?

 

Side settings I follow more or less the recommendations of the forum see joint piece

Capture_Oculus_Client_setting.JPG

Capture_Oculus_ODT.JPG

Nvidia_Setting_01.JPG

Nvidia_Setting_02.JPG

OculusSetup.log

"If you want to grow old as a pilot, you've got to know when to push it, and when to back off."

Brigadier General, Charles Elwood Yeager, knows as "Chuck Yeager" 1923-2020. First Human at the speed of sound >>>>>>>>>>>>>>>>>

 

BeQuiet! Silent Base 801 w/ 7x Silent Wings 3 PWM | BeQuiet! Straight Power 11 850W | MSI MAG X570 Tomahawk WiFi | AMD Ryzen 9 5900X 4,7GHz | BeQuiet! Dark Rock Pro 4 | 64Go (2x32) G.Skill Trident-Z Neo DDR4-3600 CL16 | 2To Seagate Firecuda 520 M2 PCIe x4 | 2x 1To WesternDigital HDD Sata6 | MSI GeForce RTX 3080 x3 Ventus 10Go OC (undervolted) | Oculus Quest II 64Go w/ Touch Pad | Dell U2515H 1440p HDMi | MS Win 10 Pro 64B | DCS World 2.7 |  F/A-18C + Spitfire LF Mk. IX | PersianGulf + Channel & WWII Asset + SuperCarrier | ThrustMaster Warthog : Dual Throttle + Magnetic Base + Add-On F/A-18C Stick + TFRP | MonsterTech desk support for TM Throttle & TM Joystick|

Link to post
Share on other sites

New to VR, here. Just got the Quest 2 last weekend. I was about 5 minutes from shipping this POS back to Amazon when I came across this thread. It's been a nightmare to get this thing set up this week. But I think it's MY fault because I might have too much installed/running at once. Not to mention the overload my brain is feeling from all the YouTube vids I've watched and tried. I tried Link, but wasn't impressed with the speed rating of my cable (3rd party), so I tried Virtual Desktop. In the meantime, I returned the cable and got one rated for 5gb speed (it tests at 1.9gbps in the setup program). Right now, VD runs smoother than Link. Link is unusable, flickering like crazy whenever a controller pointer hits the screen. And I can't for the life of me get decent enough resolution in the cockpit to read the MFD/DDI screens. I am running the Oculus Tray Tool. My system specs are:

 

i7-9th gen 4.6hz

32gb ddr4

Nvidia 2070 Super 8gb --do any of these settings even matter, given that we're not running VR off the card?


Edited by Wolf359

Rig: Alienware Aurora R9 - 9th Gen Core i7 9700K 4.6GHz 8 Cores | NVIDIA GeForce RTX 2070 SUPER 8GB GDDR6 | 2TB M.2 PCIe NVMe SSD | 32GB Dual Channel HyperX FURY DDR4 XMP at 2933MHz | Dell 32" Curved s3220DGF | TM Warthog HOTAS w/F-18 grip | Logitech G Pro RP | TM Cougar MFDs | TrackIR 5 Pro |

 

Modules: FC3 | F/A-18C | F-16C | A-10C | F-14 | M-2000C | AV-8B | F-5E | JF-17 | P-51D | KA-50 | UH-1H | Supercarrier | Nevada | Persian Gulf | Syria

Link to post
Share on other sites

Another question: if I use a power bank to prolong time in flight, I cannot use the Link cable - correct?

Rig: Alienware Aurora R9 - 9th Gen Core i7 9700K 4.6GHz 8 Cores | NVIDIA GeForce RTX 2070 SUPER 8GB GDDR6 | 2TB M.2 PCIe NVMe SSD | 32GB Dual Channel HyperX FURY DDR4 XMP at 2933MHz | Dell 32" Curved s3220DGF | TM Warthog HOTAS w/F-18 grip | Logitech G Pro RP | TM Cougar MFDs | TrackIR 5 Pro |

 

Modules: FC3 | F/A-18C | F-16C | A-10C | F-14 | M-2000C | AV-8B | F-5E | JF-17 | P-51D | KA-50 | UH-1H | Supercarrier | Nevada | Persian Gulf | Syria

Link to post
Share on other sites
12 hours ago, Wolf359 said:

Another question: if I use a power bank to prolong time in flight, I cannot use the Link cable - correct?

The Oculus Link can supply charge to the Quest 2.

I think the trouble come from the v.28 of the Oculus Software in conjonction of the 2.7 beta whom have new features for VR like mask for exemple ... the next updates may offer more stability ?!

"If you want to grow old as a pilot, you've got to know when to push it, and when to back off."

Brigadier General, Charles Elwood Yeager, knows as "Chuck Yeager" 1923-2020. First Human at the speed of sound >>>>>>>>>>>>>>>>>

 

BeQuiet! Silent Base 801 w/ 7x Silent Wings 3 PWM | BeQuiet! Straight Power 11 850W | MSI MAG X570 Tomahawk WiFi | AMD Ryzen 9 5900X 4,7GHz | BeQuiet! Dark Rock Pro 4 | 64Go (2x32) G.Skill Trident-Z Neo DDR4-3600 CL16 | 2To Seagate Firecuda 520 M2 PCIe x4 | 2x 1To WesternDigital HDD Sata6 | MSI GeForce RTX 3080 x3 Ventus 10Go OC (undervolted) | Oculus Quest II 64Go w/ Touch Pad | Dell U2515H 1440p HDMi | MS Win 10 Pro 64B | DCS World 2.7 |  F/A-18C + Spitfire LF Mk. IX | PersianGulf + Channel & WWII Asset + SuperCarrier | ThrustMaster Warthog : Dual Throttle + Magnetic Base + Add-On F/A-18C Stick + TFRP | MonsterTech desk support for TM Throttle & TM Joystick|

Link to post
Share on other sites
vor 21 Minuten schrieb William:

I think the trouble come from the v.28 of the Oculus Software in conjonction of the 2.7 beta

 

I've tried the stable and the beta branch of the Oculus software with similar result but it feels like the stable version is more stable as of right now.

 

vor 15 Stunden schrieb William:

But as soon as I interrupt the Oculus Link connection, and return to the Quest home, the resolution returns to normal. But if I reconnect again same problem. I have to restart the headset. However, I noticed that when this occurs the helmet is hot, not necessarily more than with version 2.5 ...

 

 

I had similar issues prior to this post but I couldn't point out the exact reason.

I've tried to use the new dynamic bitrate feature and noticed that the bitrate sometimes dips to YouTube 360p levels but quickly recovers. When I force any other bitrate (350 or 500 Mbps usually) I get dropped frames. When I get a lot of dropped frames the link just stops working at some point and I have to restart DCS.

 

For now I reset all the Debug settings and I keep the Quest 2 at max. refresh and resolution. Once I load into the game I use the Ctrl+Numpad 1 shortcut to disable ASW and framelock. However the game is currently still capped to half the refresh rate in some situations and I'd really like to know why (this is the reason why I use 90 Hz right now). I can make it work like this but it's a suboptimal solution imho.

 

Bottom line is that 2.7 brought some improvements but something feels of and I'm still not sure what it is.

The Bf.109 for example is perfectly fine in 2.7 but the F-14B/Super Carrier is a pure framerate killer as of now.

Link to post
Share on other sites
vor 13 Stunden schrieb Wolf359:

New to VR, here. Just got the Quest 2 last weekend. I was about 5 minutes from shipping this POS back to Amazon when I came across this thread. It's been a nightmare to get this thing set up this week. But I think it's MY fault because I might have too much installed/running at once. Not to mention the overload my brain is feeling from all the YouTube vids I've watched and tried. I tried Link, but wasn't impressed with the speed rating of my cable (3rd party), so I tried Virtual Desktop. In the meantime, I returned the cable and got one rated for 5gb speed (it tests at 1.9gbps in the setup program). Right now, VD runs smoother than Link. Link is unusable, flickering like crazy whenever a controller pointer hits the screen. And I can't for the life of me get decent enough resolution in the cockpit to read the MFD/DDI screens. I am running the Oculus Tray Tool. My system specs are:

 

i7-9th gen 4.6hz

32gb ddr4

Nvidia 2070 Super 8gb --do any of these settings even matter, given that we're not running VR off the card?

 

 

I'm not sure if I fully understand your problem but I'll try to give some advice.

In the case of DCS you still run the game from your graphics card so the settings do matter. I started of by using the VR preset in DCS with some tuning and tweaking according to my hardware. If you have trouble reading gauges and stuff you should open the Oculus Software (Link enabled) and set your resolution slider to max. However you have to find a compromise with your DCS settings to retain a fluid framerate. In my opinion sharpness is more important than other graphic settings. Be aware that this really tanks your FPS.

 

For reference I get between 2.3 and 2.8 Gbit/s with a standard 5m USB-C cable.

Link to post
Share on other sites
2 hours ago, TheCrysinator said:

 

I'm not sure if I fully understand your problem but I'll try to give some advice.

In the case of DCS you still run the game from your graphics card so the settings do matter. I started of by using the VR preset in DCS with some tuning and tweaking according to my hardware. If you have trouble reading gauges and stuff you should open the Oculus Software (Link enabled) and set your resolution slider to max. However you have to find a compromise with your DCS settings to retain a fluid framerate. In my opinion sharpness is more important than other graphic settings. Be aware that this really tanks your FPS.

 

For reference I get between 2.3 and 2.8 Gbit/s with a standard 5m USB-C cable.


I’m agree with you, plus the use of the VR Shader last update 2.7 (use OVGME for installation, don’t forget to make a recovery folder) ! It improve the experience by adjust shaders and others things (find it on the forum)

"If you want to grow old as a pilot, you've got to know when to push it, and when to back off."

Brigadier General, Charles Elwood Yeager, knows as "Chuck Yeager" 1923-2020. First Human at the speed of sound >>>>>>>>>>>>>>>>>

 

BeQuiet! Silent Base 801 w/ 7x Silent Wings 3 PWM | BeQuiet! Straight Power 11 850W | MSI MAG X570 Tomahawk WiFi | AMD Ryzen 9 5900X 4,7GHz | BeQuiet! Dark Rock Pro 4 | 64Go (2x32) G.Skill Trident-Z Neo DDR4-3600 CL16 | 2To Seagate Firecuda 520 M2 PCIe x4 | 2x 1To WesternDigital HDD Sata6 | MSI GeForce RTX 3080 x3 Ventus 10Go OC (undervolted) | Oculus Quest II 64Go w/ Touch Pad | Dell U2515H 1440p HDMi | MS Win 10 Pro 64B | DCS World 2.7 |  F/A-18C + Spitfire LF Mk. IX | PersianGulf + Channel & WWII Asset + SuperCarrier | ThrustMaster Warthog : Dual Throttle + Magnetic Base + Add-On F/A-18C Stick + TFRP | MonsterTech desk support for TM Throttle & TM Joystick|

Link to post
Share on other sites
vor 2 Stunden schrieb William:


I’m agree with you, plus the use of the VR Shader last update 2.7 (use OVGME for installation, don’t forget to make a recovery folder) ! It improve the experience by adjust shaders and others things (find it on the forum)

Thanks for the tipp I'll check out the shaders next time I'm in DCS.

Link to post
Share on other sites

I'll go over my issues with each setup:

 

Link: cable tests fine and Link connects just fine. However, when I run virtual desktop (not the 3rd party app), and the connection is made, as soon as I point either controller at the area, the entire desktop image flickers, tears, and goes blank - in the headset only. I take the headset off and the computer monitor is fine. The Virtual Desktop streamer is installed on the PC but not running. The APP is installed on the headset, but not opened.

 

Virtual Desktop App: Is running fine. The resolution is grainy, and the DDI/MFD screen text is a bit blurry unless I physically lean closer. The overall resolution is poor enough that I can't spot the Dubai runway until I am almost on top of it - but THAT might be more realistic than spotting it from 12 miles out.

 

All that said, I followed a harpoon in until it struck its target - that was quite a ride!

Rig: Alienware Aurora R9 - 9th Gen Core i7 9700K 4.6GHz 8 Cores | NVIDIA GeForce RTX 2070 SUPER 8GB GDDR6 | 2TB M.2 PCIe NVMe SSD | 32GB Dual Channel HyperX FURY DDR4 XMP at 2933MHz | Dell 32" Curved s3220DGF | TM Warthog HOTAS w/F-18 grip | Logitech G Pro RP | TM Cougar MFDs | TrackIR 5 Pro |

 

Modules: FC3 | F/A-18C | F-16C | A-10C | F-14 | M-2000C | AV-8B | F-5E | JF-17 | P-51D | KA-50 | UH-1H | Supercarrier | Nevada | Persian Gulf | Syria

Link to post
Share on other sites
  • 2 weeks later...
On 4/21/2021 at 1:53 PM, AlpineGTA said:

I use: ctrl-keypad1 to disable ASW.

 

 

Here are all the keyboard shortcuts:

  • ctrl-keypad1 ASW Disabled.
  • ctrl-keypad2 Force 45 fps no ASW.
  • ctrl-keypad3 Force 45 fps with ASW.
  • ctrl-keypad4 Enabled ASW auto.

You have to Alt+Tab to the Oculus software window before you do it though, then Alt+Tab back to DCS, otherwise it won't take effect.

 

I definitely find it runs with less to no stutters for me with ASW disabled. An easy way to check is to go to F3 view. If your plane flies past smoothly then you have ASW disabled. If you see stutters or ghosting as it flies past then ASW is not disabled. At least that's how I can tell on my system.

 

Hey how do you do this? So you run dcs and the oculus software...once in dcs you alt tab to the oculus software and click left ctrl + 1 on the num pad? and then alt tab back into dcs?

Link to post
Share on other sites
3 hours ago, Viciam1 said:

Hey how do you do this? So you run dcs and the oculus software...once in dcs you alt tab to the oculus software and click left ctrl + 1 on the num pad? and then alt tab back into dcs?

 

It works in game, also in other games. 

Link to post
Share on other sites
4 hours ago, Viciam1 said:

Hey how do you do this? So you run dcs and the oculus software...once in dcs you alt tab to the oculus software and click left ctrl + 1 on the num pad? and then alt tab back into dcs?

With my Rift S, there is no need to press alt+tab; looking at the fps counter, you can confirm 45 or 90 (40 or 80 with the rift)

Link to post
Share on other sites
1 hour ago, lemoen said:

 

It works in game, also in other games. 

Yup I just tried it and turning ASW OFF using the hotkey in game made a huge difference. I used to get a constant 36 fps and now its going up to 72. Wowser!

Link to post
Share on other sites

Don't be fooled by the framerate. In my experience using the ctrl num1 option that disables the vsync and ASW does lead to higher framerates but they're variable and might look very stuttery. In my case that setting is basically unusable on my Rift CV1. I use the ctrl num4 option almost always, this locks mine to 45 and does the ASW so it looks like 90fps.

Link to post
Share on other sites
36 minutes ago, lemoen said:

Don't be fooled by the framerate. In my experience using the ctrl num1 option that disables the vsync and ASW does lead to higher framerates but they're variable and might look very stuttery. In my case that setting is basically unusable on my Rift CV1. I use the ctrl num4 option almost always, this locks mine to 45 and does the ASW so it looks like 90fps.


Could you repeat that again? The part about it locks to 45 and does what to the ASW?

Link to post
Share on other sites
1 hour ago, Viciam1 said:


Could you repeat that again? The part about it locks to 45 and does what to the ASW?

 

If you let VR run at a variable framerate, like with the ctrl num1 option, it might look very stuttery. If you force it to something, say 45 fps in my case with ctrl-num2, its smoother, because the same time passes between frames. If you let ASW work on top of that (ctrl num3 or ctrl num4), then it is locked to 45 fps but the software adds in the in between frames, so it looks like 90 fps, even though DCS is only rendering 45 per second. 

  • Like 1
Link to post
Share on other sites
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...