Jump to content

Syria won't use all GPU's power


Arikaj
 Share

Recommended Posts

Hey, 

as the title says the GPU utilizes only 80 percent of its power, sometimes even less. It starts to happen as I start a second mission. If I first start the Syria map first, any mission, the GPU works normally and FPS are great - 50 to 60FPS. Even when I look at some static object like the chair in the cockpit and zoom in the FPS is around 34.

The only way how to fix it is by restarting the PC, not only the game.

 

Now here is the catch... you would say it is a problem on my side (overheating and so on ( only 65°C) and no... it is not bottlenecked) but if I play the PG map or Caucasus the GPU utilizes its whole potential. 

I am a new owner of the Syria map, but I had the pleasure of trying it during the F2P period and had no problems at all. 

Specs: 
i5-6600K
GTX1070 8GB 465.89
32GB RAM

Full HD

What can I provide to give you a clue what is happening?

EDIT: I forgot to add. During the briefing screen the GPU is at 100%. But once I hit fly, it drops to mentioned percentages.

Thanks


Edited by Arikaj
Link to comment
Share on other sites

I'm pretty sure the only thing the map can max out is your GPU's VRAM.  I also have a 1070, and in my experience, Syria takes as much VRAM as it can get.  If you want to increase your GPU utilization though you might want to change up the settings a bit.  Syria might just be better optimized for come graphical settings which is why you get higher utilization on other maps.

Link to comment
Share on other sites

No, I disagree with you. I managed to get my performance back by doing a clean and a repair process. It helped, although it didn't remove/repair any files/mods. Didn't change anything in the options menu and the performance is back to maximum power with 50-60 FPS. 

Link to comment
Share on other sites

  • 1 month later...
On 4/18/2021 at 11:41 AM, Arikaj said:

No, I disagree with you. I managed to get my performance back by doing a clean and a repair process. It helped, although it didn't remove/repair any files/mods. Didn't change anything in the options menu and the performance is back to maximum power with 50-60 FPS. 

 

Could you help me with the exact steps you took? I'm experiencing the same issue.

I tried to re-install the module without success, now I'm trying a repair of DCS. This seems to be a VRAM memory leak.

 

This is my rig:

HP Reverb G2

RTX 3080

64 GB RAM 3200 MHZ

I9 10900k

DCS on a SSD

 

Latest drivers of everything


Edited by WhatAmIDoingHere
Link to comment
Share on other sites

I also had the same issue on second run of mission. 

closed DCS then used the repair DCS menu option from the ED menu ( windows/start/eagle dynamics (open beta in my case) / repair DCS)

Restarted DCS and the original mission all good. Didn't get to try second time mission.

   Hope that helps

 

KAOS

 

Kills

Anything

On

Screen

System specs; Imac i7 2.8GHz. mem 8GB 1067 MHz DDR3. ATi Radeon HD 4850. 27" 2560X1440 monitor. Stock TM HOTAS. (Tm WartHog)

Link to comment
Share on other sites

On 6/17/2021 at 3:38 AM, WhatAmIDoingHere said:

 

Could you help me with the exact steps you took? I'm experiencing the same issue.

I tried to re-install the module without success, now I'm trying a repair of DCS. This seems to be a VRAM memory leak.

 

This is my rig:

HP Reverb G2

RTX 3080

64 GB RAM 3200 MHZ

I9 10900k

DCS on a SSD

 

Latest drivers of everything

 


IIRC here you go:

1. Remove manually and completly the GPU driver. 
2. Download  it (OFC you can download it earlier) directly from Nvidia site and install it - NOT THROUGH GEFORCE EXPERIENCE

3. Then run the clean procedure on DCS.
4. At last run the full repair of the game.

These steps helped me with the issue. 

EDIT: And I would like to add I had to do it in this sequence. If I tried changing the steps, it did not help. 
EDIT 2: Maybe another step is to delete the metashaders and fxo folders


Edited by Arikaj
  • Thanks 1
Link to comment
Share on other sites

1 hour ago, Arikaj said:


IIRC here you go:

1. Remove manually and completly the GPU driver. 
2. Download  it (OFC you can download it earlier) directly from Nvidia site and install it - NOT THROUGH GEFORCE EXPERIENCE

3. Then run the clean procedure on DCS.
4. At last run the full repair of the game.

These steps helped me with the issue. 

EDIT: And I would like to add I had to do it in this sequence. If I tried changing the steps, it did not help. 

 

 

Did you delete fxo and metashaders too ?

'Shadow'

 

Everybody gotta be offended and take it personally now-a-days

Link to comment
Share on other sites

2 minutes ago, WhatAmIDoingHere said:

@Arikaj Thanks for your reply. Will check tonight. However, I'm still not sure what this is: Then run the clean procedure on DCS

Are you talking about cleaning fxo and metashaders as referenced by @Shadow KT? I google this and could not find any references. I'm sorry if I'm being dumb 🙂

 

Read this: https://www.digitalcombatsimulator.com/en/support/faq/repair/

'Shadow'

 

Everybody gotta be offended and take it personally now-a-days

Link to comment
Share on other sites

1 hour ago, Shadow KT said:

 

Did you delete fxo and metashaders too ?

 

At the time I was experiencing the second mission load crash and one of the advices was to remove the folders. So probably I did.

Link to comment
Share on other sites

4 hours ago, Shadow KT said:

Seems like this did the trick... I even get better performance overall. Thanks a lot. Somebody needs to mark this as a solution.

 

I'm happy for you, however, I'm still suffering with the same issue. First time I load the Syria map 40fps, second time 25 and it affects all other missions in any other map after that.

Did all the steps mentioned in the same order...

 

I have to say that the issue is a lot more prominent in VR, when in pancake mode I can see a drop on fps from about 100fps to 80 to 85 fps, but it is really crippling in VR (likely because is more demanding)


Edited by WhatAmIDoingHere
Link to comment
Share on other sites

6 hours ago, WhatAmIDoingHere said:

it affects all other missions in any other map after that.


Yes, I remember later on it affected all maps and not at first. That is why I created this report under Syria and later on got performance hit on all maps. Maybe try to open a report in the general performance bugs since it affects all maps and it will get more attention there than here. 

And maybe post there a link to this thread so somebody can find a probable solution for it. 

Link to comment
Share on other sites

I was having this problem. My solution was to close my VPN software. 

 

I use nordvpn.

 

Edit: I think the problem is a conflict between DCS and a software that is running  on the background, you have to check which software is that


Edited by Bruce_D
Link to comment
Share on other sites

8 hours ago, Bruce_D said:

I was having this problem. My solution was to close my VPN software. 

 

I use nordvpn.

 

Edit: I think the problem is a conflict between DCS and a software that is running  on the background, you have to check which software is that

 


Alright I have and was using NordVPN at the time too, but I have it closed all the time unless I am gonna use it. BUT here is another but...Even when closed there is a background process which is running at all times. Should be called "NordVPN services" and can be closed only manually through task manager.  

Link to comment
Share on other sites

Interesting, I don't have any vpn software installed. This PC was built for DCS and MS flight simulator.

 

I do have however some coding stuff installed like VS Code and Windows Subsystem for Linux. I will try stopping a bunch of services I don't need that might be running on the background and try again.

  • Like 1
Link to comment
Share on other sites

  • 4 weeks later...

I "solved" my problem and I will leave it here for future reference of poor souls who may run into the same issue.

 

The solution was to reduce VRAM usage by reducing the texture quality to medium (I was able to keep the terrain texture on high). Once I got the VRAM usage within my GPU limits the issues are gone. I can play any maps as long as I want without issues. I have a RTX 3080 with 10GB of VRAM which is clearly not enough for VR.

 

With that said, the performance boost I got for properly managing my VRAM allowed me to increase the graphical fidelity by increasing view distance, AA, clouds quality and VR resolution.

Another setting I changed which yielded some improvement was "disable fullscreen optimizations".  I disabled this option for DCS by right clicking in the DCS.exe file and changing the setting. (This was probably changed by me trying to improve performance at some point)

 

I still think that DCS uses way more VRAM than it should and it's mismanaging resources, but this is another topic which has extensive documentation on this forum.


Edited by WhatAmIDoingHere
  • Thanks 3
Link to comment
Share on other sites

%15 GPU Usage for me.

Modules: A-10C Warthog / A-10C II Tank Killer / F-15C / SU-33 / AV-8B Harrier / F-16C Viper / AJS-37 Viggen /  F/A-18C Hornet / SuperCarrier

Terrains: Persian Gulf / Syria

 

Wishlist: Tornado / EA-6 Prowler / EA-18 Growler AV-8 Harrier+ F-111 Aardvark

alpiinoo_signature.png

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...