Jump to content

MASSIVE fps drop after update to 2.7


Recommended Posts

Just 1 thing to discuss: In another thread a user helped himself with a clean win10 reinstall.

 

To the guys still having problems:

When switching to win10, did you update win10 from win8, or have you clean installed win10?

Link to comment
Share on other sites

5 hours ago, SCPanda said:

So, at the moment, is the dev working on improving the performance in 2.7? Kinda worried that ED is just gonna leave it there

Why do you think that? Why should they not?

2.7 is public beta. That implies, that there is still work to do and will be done.

Only problem is, we don't know the priorities and we won't be able to consent on which priorities there should be.

So patience is your best option...

and nobody stops you from adressing concrete issues...

 

Link to comment
Share on other sites

On 4/25/2021 at 2:31 AM, RedX said:

Exactly the same on my AMD 5800x, the CPU frametimes are through the roof with 2.7 update. Maybe this is some kind of thing that is CPU or chipset related as that would explain why not so many are reporting the problem? Perhaps Intel/Nvidia is more tested and optimized? Maybe ED has no AMD hardware to test with due to cryptominers buying it all? 😉

 

In any case, the performance issue has to do with DCS core(?) engine overloading the CPU. Graphics is hardly related, because if I hit "pause" everything is super smooth and un-pausing makes things go slow and jittery again. Tried to remove the infamous windows KBs (500...something) and vortex calculation - no help. Ditto driver updates.

Replying to myself... I investigated a bit further and found the following. This applies to my case, not sure about others. YMMV.

- the slowdown/jitter/cpu frametime increase depends on the mission file

- 2.7 has made it worse

- deleting saved games\dcs improved the situation a lot on certain missions; at first it was not clear why; it turns out that delete is not really necessary, but instead...

- Ta-daa! TACVIEW file recording has some issue with the new version, it was not turned on immediately after deleting saved games folder and thus things looked better. It may have something to do with the number or type of AI units or their activity in the mission.

--> if you have this issue, check out whether turning your Tacview completely off helps (options - special - tacview - completely off)


Edited by RedX

Intel Core i7 9700K@4.6GHz|ASUS Strix Z390-H|G.Skill DDR4 32GB@3200MHz|MSI GeForce RTX 2080 Ti|2xSSD 500GB Samsung 970 EVO M.2 RAID0|SSD Samsung 850 EVO|Corsair HX 750W|Fractal Design Define R6 Blackout|UWQHD 34"|Valve Index|Logitech G9|MS Natural Ergonomic Keyboard 4000|VPC WarBRD Base+MongoosT-50CM2 Grip|VPC MongoosT-50 Throttle|VKB T-Rudder|Beyerdynamic DT770|Boom mic|Windows 10 Home

Link to comment
Share on other sites

Il 23/4/2021 at 07:34, Lange_666 ha scritto:

 

C'è una versione stabile anche per te ...

What an insignificant answer ...

“Quando camminerete sulla terra dopo aver volato, guarderete il cielo perché là siete stati e là vorrete tornare.”

 

Link to comment
Share on other sites

But it's the truth.

Win10 Pro 64-bit, i7-4770K @ 4.5 GHz, Corsair H100i, AsRock Extreme4, ASUS Strix 1080Ti OC 11GB, 32 GB DDR3 G.Skill 2400. Monitors: LG 27GL850-B27 2560x1440 + Samsung SyncMaster 2443 1920x1200, HOTAS: Warthog with Virpil WarBRD base & hegykc MFG Crosswind modded pedals, TrackIR4, Oculus Rift S.

Personal Wish List: A6 Intruder, Vietnam theater, decent ATC module, better VR performance!

Link to comment
Share on other sites

But it's the truth.
which truth? Others have already answered you and have called your answer useless ... what else do you want to talk about? Don't insist on wearing blinders like horses, you make a bad impression.

Inviato dal mio SM-G950F utilizzando Tapatalk

“Quando camminerete sulla terra dopo aver volato, guarderete il cielo perché là siete stati e là vorrete tornare.”

 

Link to comment
Share on other sites

4 hours ago, JAKAL said:

Others have already answered you and have called your answer useless ... what else do you want to talk about?

 

What do you wanna talk about? Since it's bothering you so much, i'm open for any discussion, as long as it ends with me being the winner in the end, i can go on forever....

Win10 Pro 64-bit, i7-4770K @ 4.5 GHz, Corsair H100i, AsRock Extreme4, ASUS Strix 1080Ti OC 11GB, 32 GB DDR3 G.Skill 2400. Monitors: LG 27GL850-B27 2560x1440 + Samsung SyncMaster 2443 1920x1200, HOTAS: Warthog with Virpil WarBRD base & hegykc MFG Crosswind modded pedals, TrackIR4, Oculus Rift S.

Personal Wish List: A6 Intruder, Vietnam theater, decent ATC module, better VR performance!

Link to comment
Share on other sites

On 4/23/2021 at 12:27 PM, SmirkingGerbil said:

 

-snip-

@rayrayblues - here are my specs, and settings. Currently getting better performance under 2.7 than I had under 2.5 with a 1660:

 

 

 

 

 

 

I have made just a few alterations to your settings and now I am running smooth and stable. Thank you so much for pointing me in the right direction.

 

 

Settings 042521.jpg

  • Like 1

ASUS 990FX R2 Sabertooth MoBo  -  AMD FX 9590 @4.7Gb. No OC
GSkill RipJaws DDR3 32 Gb @1866 MHZ  -  EVGA GeForce GTX 1660Ti 6Gb DDR5
Game drive, Samsung 980 M.2 EVO 1Tb SSD  -  Win10 Pro 21H1 on Samsung 860 EVO 500Gb SATA SSD

Thrustmaster T-Flight HOTAS X  -  LG 32" 1920 X 1080 Monitor - Prestige ATX-PR800W PSU

Link to comment
Share on other sites

 
What do you wanna talk about? Since it's bothering you so much, i'm open for any discussion, as long as it ends with me being the winner in the end, i can go on forever....
but winner of what? don't be ridiculous and come back to the topic.

Inviato dal mio SM-G950F utilizzando Tapatalk

“Quando camminerete sulla terra dopo aver volato, guarderete il cielo perché là siete stati e là vorrete tornare.”

 

Link to comment
Share on other sites

I'm still here...

Win10 Pro 64-bit, i7-4770K @ 4.5 GHz, Corsair H100i, AsRock Extreme4, ASUS Strix 1080Ti OC 11GB, 32 GB DDR3 G.Skill 2400. Monitors: LG 27GL850-B27 2560x1440 + Samsung SyncMaster 2443 1920x1200, HOTAS: Warthog with Virpil WarBRD base & hegykc MFG Crosswind modded pedals, TrackIR4, Oculus Rift S.

Personal Wish List: A6 Intruder, Vietnam theater, decent ATC module, better VR performance!

Link to comment
Share on other sites

11 hours ago, rayrayblues said:

 

I have made just a few alterations to your settings and now I am running smooth and stable. Thank you so much for pointing me in the right direction.

 

 

Settings 042521.jpg


That is awesome Ray!

Glad it worked. I figured we should be close in performance based on your specs. I am sure as ED gets all the data, and further optimizations occur, we will get some more life out of these "mid range" systems.

  • Thanks 1

Pointy end hurt! Fire burn!!
Black Shark 2, A10C, A10CII, F-16, F/A-18, F-86, Mig-15, Mig-21, P-51, F-15, Su-27, Su-33, Mig-29, FW-190 Dora, Anton, BF 109, Normandy, Caucasus, NTTR, Persian Gulf, Channel, Syria, WWII Assets, CA. (WWII backer picked aircraft ME-262, P-47D).

Link to comment
Share on other sites

Just a low, low, low end data point.  2.7 caused MP fps drop from 17fps to 11fps from 2.5.6. 1280x768 everything LOW/OFF.

  (YES, I know it sucks and yes it's not as much fun to play.  And yes, I'm ready to order a real PC (3700x , RTX3060).)

  • Like 1

Dell e6430 i7 3.3GHz, 8GB RAM, NVS5200m w/ 1GB VRAM,  EVO 860 500GB SSD, (plus 16-32GB Perf Profile Settings), Thrustmaster Mark !! w/FCS Mk1 stick circa 1980 with USB mod, DIY Opentrack IR.

FC3 and F-16.   2.7 down to 13fps SP, 11fps MP (GS server).

Link to comment
Share on other sites

Going from 2.5.6. to 2.7 I experienced a considerable fps drop and stutter. This was with the latest graphics driver 466.  I rolled back to the 456 driver and now Stable and Beta show equal fps. I guess for lower-end GPU's  (GTX1050) this might be a solution. Back to flying again!

  • Like 2
Link to comment
Share on other sites

Performance seems to be pretty good for me overall, minus the occasional stutter which is a bit strange. I get 50-60FPS (locked) most of the time but under certain circumstances the frame rate will chug ; if I pause the game, the frame rate picks up straight away back to my locked 60FPS.

 

What I can say though is that the RAM usage is through the roof and has been causing crashes every two flights or so ; I was able to reduce the frequency of crashes by reducing my preload radius somewhat but there is definitely something odd going on there (guessing a leak, but even then RAM usage does seem quite high even considering what DCS simulates).


Edited by Althar93
Link to comment
Share on other sites

Quick update on the FPS issue on my system

 

Following the below actions which I had done before: 

- Windows updated

- Clean Saved Games folder

- Deleted temp folder

- Slow repair

 

Today I:

- Rolled back to NVIDIA drivers 461.72 (used DDU for clean install)

- Removed all custom NVIDIA control panel settings for DCS

 

Gained some of the FPS back on top of the small gain I had before. Again not quite the same performance as 2.5.6 but a small improvement nevertheless. 

 

The biggest difference with rolling back the drivers is that I am not experiencing anymore some "dips" I had with the latest drivers (466.11). 

Occasionally I would experience a drop from 60ish to 30 and then immediately back to 60 together with a GPU % utilization drop from 98%+ down to 75% and then back up to 98%+.

This does not happen anymore with the "old" 461.72 drivers.

 

The behaviour above is (was) clear on a mission I am playing with the F18C in Syria when taxing around Incirlik AB. (custom mission, some of AI and many assets parked around) 

 

just my 2c


Edited by Snakedoc
driver version typo
  • Like 1

ASUS ROG STRIX Z490 F-GAMING | i7-10700K | RTX3090 TUF OC | 32GB DDR4 3200Mhz | Windows 10 64bit

Acer Predator X34P | TrackIR 5 | TM Warthog | TM T.Flight Rudder Pedals

HP Reverb

 

A-10C | A-10C II | F/A-18C | F-16C | FC3 | PG | Syria | SC

Link to comment
Share on other sites

Update from my side. I tried everything I was able to find:

- rolled back Windows K5001330

- updated to K5001330 with hotfix from Microsoft again

- slow repaired DCS

- deleted Saved games folder, cleaned misc shaders folder

- clean reinstalled DCS openbeta (even with renaming DCS World folder, to avoid copying data from there)

- rolled back AMD GPU driver

- no Tacview installed

- clouds set to low

 

Nothing of this had noticeable impact on performance. Still 30-40% fps loss compared to 2.5.6 stable.

Since I have a low end rig and my graphics set to almost lowest level, I cannot reduce them any further.

2.7 is not playable for me at the moment.

Link to comment
Share on other sites

I have been noticing chatter in various gaming forums that Windows update has caused FPS issues across many titles. If you haven't already you may want to try installing the optional windows update April 28th KB5001391. Some not all, but some have been reporting FPS increased with this fix. I have not updated myself, but figured I'd pass this on.

 

Dave.

  • Like 1
Link to comment
Share on other sites

On 4/15/2021 at 9:33 AM, Cmptohocah said:

Well I guess that's it for me and DCS. No more Win7 and FPS drops - we had a good time over the years. 😕

Looks like I shot my self in the foot here.
After installing the Microsoft's Spy OS (Win10) 😞 and doing a fresh copy of DCS (my old installation was really old, possibly even the first version which was updated constantly), the game is smooth as butter. Much faster in every regard to my previous 2.5.6 installation Frankenstein.

i5 4960K
Asus Z-97 Pro Gamer
24GB DDR3
GTX 1660 Super
Samsung Evo 1TB SSD

  • Like 2

Cmptohocah=CMPTOHOCAH 😉

Link to comment
Share on other sites

Make empty mission and  turn clouds to "nothing' in the mission editor.
Observe framerate or frametimes. 

Then exit mission, go in mission editor and turn clouds to anything that is not 'nothing'. 
Observe framerate or frametimes. 

 

It is not "2.7" that is causing this. It's purely the clouds. Turning clouds from 'nothing' to "anything" causes the FPS drop. 

Right now you have these options:
- Hope for improvement from ED in next updates/patches
- Turn clouds to "nothing" in your mission editor
- Lower graphical settings until you have your old performance back (if you really want the new clouds that is)
- or ... accept lower performance. 

 

Please help yourselves from doing all sorts of crazy things like completely re-installing DCS , and even re-installing WINDOWS?! 
It does not help, and if you think it does it's placebo. 


 

  • Like 1

SATAL : "Summary - Tomcat limited to 2 AIM-54A mk74 Phoenix per aircraft for both Diamond and Gold leagues. All other Phoenix types, AIM-54A mk60 and AIM-54C, are currently banned."

Link to comment
Share on other sites

Posted (edited)

 

2 hours ago, Csgo GE oh yeah said:

Make empty mission and  turn clouds to "nothing' in the mission editor.
Observe framerate or frametimes. 

Then exit mission, go in mission editor and turn clouds to anything that is not 'nothing'. 
Observe framerate or frametimes. 


I tried it and only got 10FPS more, honestly I would sacrifice 10FPS or bit more for those clouds. 


Edited by RosyPlays
Link to comment
Share on other sites

Well that depends on what your total FPS is. 

10 out of 200 is not so bad. 
But 10 out of 50 is a big deal 🙂 

SATAL : "Summary - Tomcat limited to 2 AIM-54A mk74 Phoenix per aircraft for both Diamond and Gold leagues. All other Phoenix types, AIM-54A mk60 and AIM-54C, are currently banned."

Link to comment
Share on other sites

23 часа назад, Csgo GE oh yeah сказал:

It is not "2.7" that is causing this. It's purely the clouds. Turning clouds from 'nothing' to "anything" causes the FPS drop. 

Empty mission in 2.5.6 (121 FPS)

dcs_2021_05_05_15_33_17_520.png

Empty mission in 2.7 with clouds "nothing" (92FPS)

DCS_2021_05_05_15_35_46_008.png

24% FPS lose

 

  • Like 1

"Своя FM не пахнет" (С) me
"Умный любит учиться, а дурак — учить." (C) А. П. Чехов
 

Asus Z97M-PLUS, Intel Core i5 4690K OC 4126MHz, 16Gb DDR3 DIMM 2250MHz (10-10-10-26 CR2), GeForce GTX 1060 6GB

Link to comment
Share on other sites

Thanks to my friend @SmirkingGerbil I have settings that give me a steady 50 to 90 FPS depending on the scene. No stuttering or freezing except,

I have one mission on The Channel map with a "big formation" of B-17s that drop on the Dunkirk Airfield. When the bombs hit, my Frames fall through the floor.

In the picture below, I am at 17,300 feet over Calais which is 26.25 nm from Dunkirk. The picture was taken 2 minutes after the bombs hit and my frames were still down to 7-8

I would expect  a big drop like this if I was close to the target zone, but I was so far away that I couldn't see the bombs hit nor could I see the B-17's formation.

Is this normal, or do I have to tweak something else?

 

klXEUNf.jpg

  • Like 1

ASUS 990FX R2 Sabertooth MoBo  -  AMD FX 9590 @4.7Gb. No OC
GSkill RipJaws DDR3 32 Gb @1866 MHZ  -  EVGA GeForce GTX 1660Ti 6Gb DDR5
Game drive, Samsung 980 M.2 EVO 1Tb SSD  -  Win10 Pro 21H1 on Samsung 860 EVO 500Gb SATA SSD

Thrustmaster T-Flight HOTAS X  -  LG 32" 1920 X 1080 Monitor - Prestige ATX-PR800W PSU

Link to comment
Share on other sites

I still think it could be the water or lighting since apparently it was changed inevitably and cannot be controlled in the settings. To be honest it feels like something which I paid already a lot for is getting taken away - the ability to play joyfully on an unchanged system. Instead of getting something with time like X-Plane did with Vulcan (+20/30fps).

 

Question here: Is it possible on Steam to stay on a specific version? I cannot turn off the updates and some day soon 2.7 will be changed to “stable” and I don’t know how to stop it from updating??

  • Like 2
Link to comment
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...