Jump to content

2.7.0.4625 Open Beta crash at second mission load


XPACT

Recommended Posts

10 minutes ago, PeevishMonkey said:

Now (after the latest update) game crash is exactly after press "ESC". 

 

Same here unfortunately

Intel Core i7-10700K - ROG Strix Z490-H Gaming - 64GB Vengance LPX - RTX 3080 Eagle OC - non-VR - single player - open beta

 

Link to comment
Share on other sites

31 minutes ago, Fra298 said:

As a side note, it seems Metashaders2 (I started with a fresh dcs saved games folder) folder is empty. Is this ok?

 

It seems to normally be empty now. I just see it populate every once in awhile for some reason. Don't see an obvious connection as to why it populates when it does.

 

OK. After clearing FXO, TEMP/DCS, etc, I restarted the sim and flew two quick test mission without a problem. Fixed? Not fixed? Too soon to tell. I'll know more within roughly 40 hours or so, if things have improved.

31 minutes ago, Gierasimov said:

Same here unfortunately

 

Did you delete the FXO and TEMP/DCS... folders? I had a first mission issue with my first start after the update. I was in a hurry and didn't clean those out.

YouTube Channel: https://www.youtube.com/channel/UCU1...CR6IZ7crfdZxDg

 

_____

Win 10 Pro x64, ASUS Z97 Pro MoBo, Intel i7-4790K, EVGA GTX 970 4GB, HyperX Savage 16GB, Samsung 850 EVO 250 GB SSD, 2x Seagate Hybrid Drive 2TB Raid 0.

Link to comment
Share on other sites

3 minutes ago, Ironhand said:

 

It seems to normally be empty now. I just see it populate every once in awhile for some reason. Don't see an obvious connection as to why it populates when it does.

 

OK. After clearing FXO, TEMP/DCS, etc, I restarted the sim and flew two quick test mission without a problem. Fixed? Not fixed? Too soon to tell. I'll know more within roughly 40 hours or so, if things have improved.

 

Did you delete the FXO and TEMP/DCS... folders? I had a first mission issue with my first start after the update. I was in a hurry and didn't clean those out.

I did not and never done in the past. Obviously had crashes in the past, but previous beta version works well for now. I may test your approach later tonight.

Intel Core i7-10700K - ROG Strix Z490-H Gaming - 64GB Vengance LPX - RTX 3080 Eagle OC - non-VR - single player - open beta

 

Link to comment
Share on other sites

1 hour ago, PeevishMonkey said:

Now (after the latest update) game crash is exactly after press "ESC". 

 

actually after  choose "quit" in option list.

Link to comment
Share on other sites

Posted (edited)

[UPDATE : the callstack in this error is different and comes from a different place than before the patch 2.7.1.6709] 

 

I got the ESC crash (or shift-R crash, I have both).

Please find attached two logs, one for a session that works and one for a session that crashes on esc or shift-R.  The working one also has the "regenerate fxo" shaders step as I had purged them. Then I try to load one instant mission and either shift-R or escape then quit then do another one. I don't know if purging fxo each time is a solution, I'll try.

 

When I diff the two files, the first significant difference between the two files seems to be a  VFS error, and then it dumps.

2021-05-27 16:43:34.025 DEBUG   LuaGUI: ----onSimulationStop---	false	nil	nil
2021-05-27 16:43:34.025 DEBUG   LuaGUI: ----DCS.isMultiplayer()---	false
2021-05-27 16:43:34.054 INFO    Config: netview stopped
2021-05-27 16:43:34.059 ERROR   VFS: VFS_open_write: CreateFile(): Unknown error     <<<<<<<< This does not happen in the "good" log 
2021-05-27 16:43:34.059 ERROR   DCS: can't open file
2021-05-27 16:43:34.072 INFO    TERRAIN: lSystem::CleanScenes()
2021-05-27 16:43:34.075 INFO    VISUALIZER: StopSimulation
2021-05-27 16:43:34.076 INFO    VISUALIZER: Stopped collection of statistic.
2021-05-27 16:43:34.089 DEBUG   LuaGUI: --- onChatMessage---	Mission is over.	nil
2021-05-27 16:43:34.090 INFO    EDCORE: try to write dump information

 

Note : there's also a debug output that's present in the good log and missing in the bad, just a few lines above the VFS error 

2021-05-27 16:39:05.860 DEBUG   LuaGUI: ----onSimulationPause---

 

HTH,

Buzz

 

 

dcs_CRASH.log dcs_OK.log.old


Edited by BuzzLine
Link to comment
Share on other sites

Posted (edited)
1 hour ago, PeevishMonkey said:

Now (after the latest update) game crash is exactly after press "ESC". 

 

untick Full Screen option solved tihis for me. 🙂 ....

For now I have zero problems


Edited by zampe
  • Thanks 2
Link to comment
Share on other sites

Posted (edited)

And here's a variant of the previous error in initTerrain ... Slightly different callstack. We're making progress ! 😄 

Or not as my previous post above showed different errors in a different place. So maybe we're regressing, actually...

 

021-05-27 17:16:54.086 INFO    EDCORE: try to write dump information
2021-05-27 17:16:54.088 INFO    EDCORE: # -------------- 20210527-171654 --------------
2021-05-27 17:16:54.089 INFO    EDCORE: DCS/2.7.1.6709 (x86_64; Windows NT 10.0.19042)
2021-05-27 17:16:54.090 INFO    EDCORE: D:\SteamLibrary\steamapps\common\DCSWorld\bin\dx11backend.dll
2021-05-27 17:16:54.092 INFO    EDCORE: # C0000005 ACCESS_VIOLATION at 79D11E68 00:00000000
2021-05-27 17:16:54.094 INFO    EDCORE: SymInit: Symbol-SearchPath: '.;D:\SteamLibrary\steamapps\common\DCSWorld;D:\SteamLibrary\steamapps\common\DCSWorld\bin;C:\Windows;C:\Windows\system32;SRV*C:\websymbols*https://msdl.microsoft.com/download/symbols;', symOptions: 528, UserName: 'Romain'
2021-05-27 17:16:54.095 INFO    EDCORE: OS-Version: 10.0.19042 () 0x100-0x1
2021-05-27 17:16:54.439 INFO    EDCORE: 0x0000000000031E68 (dx11backend): createRenderer + 0x1A0F8
2021-05-27 17:16:54.439 INFO    EDCORE: 0x0000000000030B3E (dx11backend): createRenderer + 0x18DCE
2021-05-27 17:16:54.439 INFO    EDCORE: 0x000000000003D9F5 (dx11backend): createRenderer + 0x25C85
2021-05-27 17:16:54.439 INFO    EDCORE: 0x0000000000008F82 (Terrain): createGlobalLand + 0x272
2021-05-27 17:16:54.439 INFO    EDCORE: 0x0000000000009A09 (Terrain): createGlobalLand + 0xCF9
2021-05-27 17:16:54.439 INFO    EDCORE: 0x00000000000096FB (Terrain): createGlobalLand + 0x9EB
2021-05-27 17:16:54.439 INFO    EDCORE: 0x0000000001C5EEE3 (DCS): AmdPowerXpressRequestHighPerformance + 0xE6FEDF
2021-05-27 17:16:54.440 INFO    EDCORE: 0x0000000000001D40 (lua-terrain): (function-name not available) + 0x0
2021-05-27 17:16:54.440 INFO    EDCORE: 0x0000000000007AC5 (lua): luaD_growstack + 0x845
2021-05-27 17:16:54.440 INFO    EDCORE: 0x0000000000018D94 (lua): luaS_newlstr + 0x5254
2021-05-27 17:16:54.440 INFO    EDCORE: 0x0000000000007E04 (lua): luaD_growstack + 0xB84
2021-05-27 17:16:54.440 INFO    EDCORE: 0x0000000000006F7F (lua): lua_getinfo + 0x133F
2021-05-27 17:16:54.440 INFO    EDCORE: 0x000000000000812E (lua): lua_yield + 0x9E
2021-05-27 17:16:54.440 INFO    EDCORE: 0x0000000000002576 (lua): lua_pcall + 0x66
2021-05-27 17:16:54.440 INFO    EDCORE: 0x00000000000F2DA9 (edCore): ED_lua_pcall + 0x59
2021-05-27 17:16:54.440 INFO    EDCORE: 0x0000000000004005 (lua-dxguiWin): (function-name not available) + 0x0
2021-05-27 17:16:54.440 INFO    EDCORE: 0x00000000007D135D (DCS): SW + 0x4E085D
2021-05-27 17:16:54.441 INFO    EDCORE: 0x0000000001C5C86D (DCS): AmdPowerXpressRequestHighPerformance + 0xE6D869
2021-05-27 17:16:54.441 INFO    EDCORE: 0x0000000000A07E9E (DCS): SW + 0x71739E
2021-05-27 17:16:54.441 INFO    EDCORE: 0x0000000000017034 (KERNEL32): BaseThreadInitThunk + 0x14
2021-05-27 17:16:54.441 INFO    EDCORE: 0x0000000000052651 (ntdll): RtlUserThreadStart + 0x21
2021-05-27 17:16:54.734 INFO    EDCORE: Minidump created.
2021-05-27 17:16:54.734 INFO    Lua::Config: stack traceback:
	[C]: in function 'Init'
	[string "./MissionEditor/modules/me_map_window.lua"]:817: in function 'initTerrain'
	[string "./MissionEditor/modules/me_mission.lua"]:1637: in function 'load'
	[string "./MissionEditor/modules/me_quickstart.lua"]:274: in function 'func'
	[string "./Scripts/UI/ProgressBarDialog.lua"]:154: in function 'updater'
	[string "./Scripts/UpdateManager.lua"]:64: in function <[string "./Scripts/UpdateManager.lua"]:40>
2021-05-27 17:16:54.734 INFO    Lua::Config: stack traceback:
2021-05-27 17:16:54.734 WARNING LOG: 1 duplicate message(s) skipped.

 

dcs.log


Edited by BuzzLine
Link to comment
Share on other sites

Thanks Zampe - Unchecking the full screen option seems to have solved my crashing issue.  I tested immediately after todays update with the full screen option selected and would get crashes as soon as I quit a mission.  Upon unchecking the full screen option as Zampe suggested, I have experienced no crashes so far with multiple mission changes.

  • Like 1
Link to comment
Share on other sites

Full Screen is borked since the first 2.7 !!!

I plea to get Full Screen mode as in pre 2.7 back instead of what we have now!!!

  • Like 1

Win10 Pro 64-bit, i7-4770K @ 4.5 GHz, Corsair H100i, AsRock Extreme4, ASUS Strix 1080Ti OC 11GB, 32 GB DDR3 G.Skill 2400. Monitors: LG 27GL850-B27 2560x1440 + Samsung SyncMaster 2443 1920x1200, HOTAS: Warthog with Virpil WarBRD base & hegykc MFG Crosswind modded pedals, TrackIR4, Oculus Rift S.

Personal Wish List: A6 Intruder, Vietnam theater, decent ATC module, better VR performance!

Link to comment
Share on other sites

I have had a crash when exit too ! after deleting FXO and metashaders2 Folders , no crash , even after second mission load . I think ED is on the right way . We believe in You🙂 !!!!

 

  • Like 1
Link to comment
Share on other sites

1 hour ago, zampe said:

actually after  choose "quit" in option list.

Yes same here, after the 1st mission.

 

Spoiler

Ryzen 9 5900X | 64GB G.Skill TridentZ 3600MHz CL16 | Gigabyte RX6900XT | ASUS ROG Strix X570-E GAMING | Samsung 960Pro NVMe 1TB | HP Reverb G2
Pro Flight Trainer Puma | VIRPIL MT-50CM2 base/grip with 200 mm S-curve extension + CM3 throttle + CP2 + FSSB R3L mounted on Monstertech MFC-1 | TPR rudder pedals

My in-game DCS settings (PD 1.0 SteamSS 76%):

 

Link to comment
Share on other sites

Posted (edited)
3 hours ago, casserole said:

This is worth a try guys:

No more crashes after relocating your "Missions" Folder in Saved Games/DCS.openbeta by doing this

- Copy the Mission folder

- Paste it somewhere else (I pasted it in Saved Games at the root).

- Delete all your missions in the "Missions" folder at the default location, as they are now saved at the new location.

Now you won't have crashes anymore!

- If you want to load one of those relocated missions, you need to navigate to it by double clicking the "folder.."  icon.

Loading your personal missions won't generate the infamous 2nd mission crash.

 

It worked for me 100 %, not 80, not 90 not 99%, but 100% for the past FEW (I know it is too soon to say) hours. (hehe, sounds like a commercial)

Now while writing this, I noticed that a new update came online, maybe it fixed all the crashes now.

So my suggestion is maybe obsolete.

But anyhow, if it isn't, this may help.

Of course there is the 48 hours state of grace where all changes seem to work. Maybe my work around is also doomed to fail, but who knows....

Having said this lets try out this new update.

 

 

 

Aaaargh, it went sour again.

I installed a fresh DCS World an a fresh Windows 10 Pro on a new SSD in the same Rig yesterday. No other application installed, just the game and game controllers.

Nothing was imported from the old install. Game options and HOTAS settings were freshly configured by memory.

Yesterday all went well.

Today, after the 2.7.1.6709 update, it went crashing again with a vengeance, although I had no mission in my Missions folder at the default location (Saved Games/DCS.openbeta).

Now I dread the same on my old SSD where it all started and from which I tested the game earlier on today.

I'm out of options now.

From now on I'll stop proposing any suggestions on the forum. It all ends up misleading people. Sorry about that.

dcs.log-20210528-023424.zip dcs.log-20210528-024306.zip dcs.log-20210528-024913.zip


Edited by casserole
Link to comment
Share on other sites

Crashes continue for me after today's update...seems even more unstable.  Along with the continued crashes on 2nd mission load, I received a crash right after install of the patch and then another crash upon mission exit.  Some crashes make the PC unresponsive and require a reboot. Crashes are with the Hornet and Tomcat and I have been doing Instant Action only.  
 

Crash logs are being sent to ED if/when created.

i5 7600K @4.8GHz | 1080 Ti | 32GB 3200MHz | SSD | DCS SETTINGS | "COCKPIT"

Link to comment
Share on other sites

3 hours ago, scoobie said:

My PC seems to like this crash, so it's easy for me:
1. Turned off Win8 compatibility, because dcs_updater was complaining.

 

That's interesting. When I updated the updater wasn't bothered at all with the Win8 compatibility.....

Link to comment
Share on other sites

On 5/26/2021 at 2:27 AM, Ironhand said:

 

For me, about 36 hrs.

 

Mine just crashed as well, soon after today's update. Started on Caucasus,  rand 4 missions in a row. Switched to Nevada, ran the first one, and then crash freeze on the second 😕

Current modules:

FC3, Mirage 2000C, Harrier AV-8B NA, F-5, AJS-37 Viggen, F-14B, F-14A, Combined Arms, F/A-18C, F-16C, MiG-19P, F-86, FW-190A, Spitfire Mk IX, UH-1 Huey, Su-25, P-51PD, Caucasus map, Nevada map, Persian Gulf map, Marianas map, Syria Map......ah yes, forgot the Super Carrier! Shows you how often i fly these days....

Modules in waiting: MiG-23, A-6, F-4U, F-8, Falklands Map

Wish list: South East Asia map, F-4J/N, F-15A/C, Su-27, Sea Harrier FRS.1, Mirage III, MiG-17.

Link to comment
Share on other sites

And im crashing again. After cca 40 mins flight in Mig-21 over Syrim map. I just press Shift+R to restart a mission and crashed as always.

PC: i7 9700K, 32 GB RAM, RTX 2080 SUPER, Tir 5, Hotas Warthog Throttle, VPC MongoosT-50CM2 Base with VPC MongoosT-50CM2 Grip, VKB-SIM T-RUDDER PEDALS MK.IV. Modules : NEVADA, F-5E, M-2000C, BF-109K4, A-10C, FC3, P-51D, MIG-21BIS, MI-8MTV2, F-86F, FW-190D9, UH-1H, L-39, MIG-15BIS, AJS37, SPITFIRE-MKIX, AV8BNA, PERSIAN GULF, F/A-18C HORNET, YAK-52, KA-50, F-14,SA342, C-101, F-16, JF-17, Supercarrier,I-16,MIG-19P, P-47D,A-10C_II

Link to comment
Share on other sites

so far in 2D mode I am not crashing with factory GPU timings or even user overclocked on the GPU... I am running with the VR graphics preset (because I'm trying to use my VR) and DCS in not fullscreen mode. Using the same instant action F-16 mission "fighter sweep" I can actually get to a point now where the AI aircraft all RTB and land whereas before, I could not get to a point with any landed aircraft. Now all the aircraft can be landed and me spectating them (it does take some time tho)

 

I will try testing to see if 2nd mission crash is still happening to me, but right now it isn't and I was able to load 5 other missions after running this mission for a long time, i'm going to see if the water setting causes crash still too when I change that ingame also.

 

So far on my particular end tho, the crashing has stopped in 2D mode, my problem exists constant crashing in VR mode however and I will make a new forums post for that. 

Link to comment
Share on other sites

5 hours ago, Gierasimov said:

I did not and never done in the past. Obviously had crashes in the past, but previous beta version works well for now. I may test your approach later tonight.

@Ironhand Thanks mate. I cleared FXO files and also running my MIZ files from outside of \Saved Games\DCS.openbeta and it works really good so far. No crash whatsoever for now. 

I am on DCS 2.7.1.6709 now and it looks good!

Intel Core i7-10700K - ROG Strix Z490-H Gaming - 64GB Vengance LPX - RTX 3080 Eagle OC - non-VR - single player - open beta

 

Link to comment
Share on other sites

Update did not resolve the issue as far as it goes for me. Un-checking full screen makes no difference either. Again when loading a second mission CTD...It will sometimes do that a few times and stop crashing for days . Other times it will crash constantly on a second mission load for days on end before it mysteriously stops. None of the fixes people here say works for them has made any difference for me. This all started with the  update before these last two updates.

Link to comment
Share on other sites

Posted (edited)

Good News Here!
I tried the recommendation mentioned somewhere in this topic about creating a blank mission, basically this - Open mission editor, don't add any objects at all, not even a flight for yourself, steps - from main menu, click mission editor, then choose a map(I chose Persian Gulf), let the mission editor load, don't add anything to the mission, then click the Green Fly button on the left side menu, mission loads and you are in F11 view over an airport. Look around for a few seconds, hit ESC, on debriefing, click mission editor, let it load, then close the mission editor. I then closed DCS and Oculus, reloaded them, and have now played 4 instant action missions without it crashing.

 

Thank you to whomever put that suggestion out there. It appears to have worked for me at the present time. I've used the F-16 doing various Instant Action Missions on the Persion Gulf map since and all appears to be working as it should be now. Will try other planes and terrains and report back if there's issues.
I'm using VR, someone asked in the thread someplace(using Quest 2 non Steam version of game), I'm also using a Radeon Card as others asked, Radeon 5700xt.

Glad to not have to restart after every mission. Thank you for the suggestion!


Edited by VRimulator
Just adding more details
Link to comment
Share on other sites

3 hours ago, VRimulator said:

Thank you to whomever put that suggestion out there. 

 

It was the famous DCS Veteran IRONHAND who suggested this special procedure.

I've tried his method but apart from a placebo effect in some games after that, I'm now again as far as before. 

Other than that, any creative idea is welcome, I just hope the devs have them too.

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...