Jump to content

Recent drop in VR performance.......need help. (Resolved)


Recommended Posts

Hello all,

Has anybody else noticed/experienced a substantial decrease in VR performance in DCS in the past week to 10 days? My set-up started to act strangely about a week ago and I can’t nail down what’s triggering it. Bottom line is I’m suddenly bottlenecked at the CPU with frame times in the mid to high 30s ms where before there was no issue.

 

Here the background info:


CPU: Intel i9-10900k OC’d to 5.1
GPU: 2080 TI w/ 11Gb VRAM
RAM: 32gb @ 3200mhz
Headset: Valve Index w/ Steam VR Beta
DCS ver: Open Beta

 

For months, everything ran smooth. With PD in DCS at 1.0, refresh set at 90hz, and Custom resolution at 100% Global at 150%), it ran at an average of 45fps with a few leaps up to 60fps in single and multiplayer flights. See settings below.

DCS Settings.jpg

Steam VR Global.png

Per App Settings.png

 

I then came across Lucas’ now defunct vid on setting PD low in DCS and high Custom Res in Steam VR. I gave it a shot and did pick up about 5fps with no issues, so I left it there. Yes, we now know where the performance increase came from, but the bottom line is that I had no performance issues during single or multiplayer flights. Then, a few days later, I began to notice a problem when looking through the HUD (F-18) on public multiplayer servers. Not the typical stutter, this is more like a sporadic distortion similar to what you would see in a mirror at a carnival funhouse. It makes gun tracking with the pipper impossible. My FPS’ also dropped to 30. Switched everything back to my original settings. No change, still 30fps and sporadic distortions.

 

Ran some test last night using FpsVR. In singleplayer, there are constant CPU frame times spikes up 35ms in the red zone while GPU frame times stay green at 10ms. CPU usage was only 12% max though. FPS averages about 40.  Reprojection was in the 55 to 65% range. Multiplayer, as expected, things just got worse. CPU frame times did not fall below 50ms. Backed my original settings down a bit to what you see now (86% Custom Res at 80hz) and the only thing that improved reprojection dropped to 35 – 45%. CPU frame times are still high, but the frequency of spikes dropped ever so slightly. Sporadic distortions are still there. FPS still at 40.

 

I’ve tried these steps without any improvement:
1.    Updated Nvidia driver
2.    Updated Steam VR beta
3.    Ran repair of DCS
4.    Started to throw things


Can someone please tell me what am I missing here, because at this point for me, DCS is unplayable in multiplayer and borderline in single. Very frustrating.... since just a few weeks ago, life was all good.
 


Edited by serpent64

DCS Open Beta, I9-10900K(5.1 OC), Asus Z490 Maximus Hero XII, EVGA FTW3 2080TI, 32 GB, TM Wathog Throttle and Stick (Virpil base), Valve Index VR

Link to post
Share on other sites

Since no DCS updates came out recently, the only thing I can think of is that your Windows has updated something for the worse. Have a look at updates history and maybe roll back anything suspicious, like Nvidia drivers. Also, the distortions you describe seem to be side effects of SteamVR reprojection. Try disabling it. 


Edited by impalor

i5-4670K@4.5, 16GB DDR3, 1080ti, NVMe, W10pro, Warthog HOTAS, ButtKicker, G2

Link to post
Share on other sites

Windows Update installed some system updates (KB4589212, KB4601154, KB5001567) around the 20th-21st March on my rig, which led to stutters in DCS VR. The stutters disappeared when I rolled back the updates. As impalor suggests, try looking at the update history. In a different sim, there has also been quite a few reports on degrading performance in VR with some of the latest NVIDIA drivers

Link to post
Share on other sites
10 hours ago, BIGNEWY said:

Have a look here at this thread, it has helped others 

 

Thank you, I am familiar with that thread and already have implimented most of the recommendations a few months ago. This morning I did try the threads recommended NVidia settings which resulted in a slight decrease in the frequency of CPU frame time spikes but overall image quality decreased. 

8 hours ago, Zohardv said:

I've also noticed recently in a decrease of performance. The sound becomes disturbed and fragmented to point it is unusable.

So far for me, no sound issues.

37 minutes ago, impalor said:

Since no DCS updates came out recently, the only thing I can think of is that your Windows has updated something for the worse. Have a look at updates history and maybe roll back anything suspicious, like Nvidia drivers. Also, the distortions you describe seem to be side effects of SteamVR reprojection. Try disabling it. 

 

Yeah, I was suspecting the cause may be a Windows update and a rollback will may be my next test. NVidia and Steam VR updates were pushed out after my problems started so I don't believe they're the cause. As for SteamVR reprojection, I'm assume you're refering to Motion Smoothing. I did try turning it off which did help slightly with the distortions but of course, all objects began to blur. If SteamVR reprojection is different from Motion Smoothing, how do I turn it off?

DCS Open Beta, I9-10900K(5.1 OC), Asus Z490 Maximus Hero XII, EVGA FTW3 2080TI, 32 GB, TM Wathog Throttle and Stick (Virpil base), Valve Index VR

Link to post
Share on other sites

Problem Solved!

The culprit was SimAppPro from Winwing. Not the App itself but an after effect from installation. Appearently SimAppPro installs a script that occurs within DCS to export the data to the App. I had ordered an Orion throttle to replace my Thrustmaster WH and it arrived about 10 days ago. I installed the app in order to check calibrations and functioning, but then decided it wasn't needed for my intended application. Hadn't touch it since.

 

Late last night, I stumbled across this thread: 

Since I had not been running SimAppPro, it was low on my suspect list. I immediately went to the mentioned file, and sure enough, the two line of script were there. I nullified them and ran a test. CPU frame times dropped to < 8ms without a single spike to be seen. My rig is back to its old self again. Thank you all for your help.

DCS Open Beta, I9-10900K(5.1 OC), Asus Z490 Maximus Hero XII, EVGA FTW3 2080TI, 32 GB, TM Wathog Throttle and Stick (Virpil base), Valve Index VR

Link to post
Share on other sites
  • serpent64 changed the title to Recent drop in VR performance.......need help. (Resolved)
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...