Jump to content

How to prevent comms menu from appearing when using mic switches?


Recommended Posts

When using SRS for comms during multiplayer missions, the default comms menu always appears in the upper right screen whenever I use any of the mic switches even though I haven't pressed the \ key.  This means I have to exit out of the comms menu before using any of the F keys which is cumbersome, and if I forget and hit an F key before exiting, it changes my radio frequencies.

 

Is there any way to activate the mic switches without pulling up the comms menu?

Link to post
Share on other sites

Buttons you use in SRS for mic - unassign them in DCS for mic. You need separate keys for comms many than for SRS mic.

 

"\" key is only if you're using "easy communication" or for Intercom. In realistic comms you need to use correct mic switch in DCS to get in contact with station on correct radio with correct freq.

  • Like 2
Link to post
Share on other sites

image.png

 

⬆️ Is probably what you are looking for. Had this problem too for long time.

I do not have the comms menu pop up anymore when i use my (in SRS) assigned radio keys. The keys i got assigned below are the TM Warthog Throttle mic keys

 

A-10C example: four-way (buttons 3, 4, 5, 6) mic switch with extra push (button 2):

 

image.png

 

The modifier used for ingame comms menus (fwd = VHF/AM, aft = VHF/FM, down = UHF, up = no function in the A-10C hence i put the overlay toggle there and didnt bind in DCS) is the pinky lever on the stick.

 

image.png

 

Settings in DCS and SRS:

 

image.png

Using same buttons for SRS and ingame. For SRS, radio keys just select the radio, PTT then transmits on the selected radio. With the modifier + buttons i can call up the comms menus for all three radios (three different comms menus, one for each of the radios with non-easy comms).

 

Alternatively you can also just assign keys in DCS to the different mic switches and use those if you like no modifiers.

 

Edit: if you dont want to use a PTT button but have the mic switches transmit directly, set "Radio switch works as push-to-talk (PTT)" to ON.

 

Hope that helps, ask if it still doesnt work.


Edited by Desert Fox

bts_100.jpg.22eae5ddd2a463fc09375990ad043870.jpg

 

Hardware: MSI B450 Gaming Plus MAX | Ryzen 5 3600X (6*3.8 Ghz) | 32 GB RAM | MSI Radeon RX5700 | Samsung SSD 860 QVO 1TB | DCS dedicated @ WD Blue 500 GB SSD | Win 10 (64-bit) | TM Warthog HOTAS, MFD and rudder pedals, TrackIR5

 

Wishlist:  Northern Germany/Baltic Sea theater | Full Fidelity Su-25A | Asset packs (80s Iran, Lebanon 1982, Syria 2011+ factions)

Link to post
Share on other sites
10 hours ago, dporter22 said:

SRS doesn't use assigned keys, you use your mic switch in DCS and SRS uses it for comms so there's nothing to unassign.

 

You assign keys in SRS. I tend to assign the standard mic switches in SRS, then in DCS bind modifier+mic switch for in-game comms. Example: COM switch down for SRS UHF, modifier+COM switch down for in-game UHF.

  • Like 1

YouTube Channel: "Clutch"

 

Z390 Aorus Elite | i5-9600k @4.7Ghz | RTX2070 | 32GB DDR4 | Windows 10 | Odyssey Plus | Warthog HOTAS | 20cm Extension

Link to post
Share on other sites

Thanks guys. 

 

I set the SRS keys to the same keys as in DCS (I have to use keys because I don't have a mic switch on my throttle), I have "Radio Switch works as PTT" to On, and "Allow INCOCKPIT DCS Controlled PTT" to Off.

 

Correct?

 

 

Link to post
Share on other sites
Posted (edited)

Unfortunately none of the suggested settings worked for me.  No matter what combination of settings I try the comms menu still shows up.


Edited by dporter22
Link to post
Share on other sites

If your input into SRS and DCS is the same then both programs will respond to this singular input. They must be made into different buttons.

 

DCS>HOTAS MIC Switch Forward>Keyboard "A"

SRS>Radio 1>Keyboard "A"

You press "A" and both things will happen.

 

Instead:

DCS>HOTAS MIC Switch Forward>Keyboard "A"

SRS>Radio 1>Keyboard "B"

You press "B" and only SRS thing will happen.

  • Like 1
Link to post
Share on other sites

Got it, thanks.

 

Interestingly, when I changed the DCS keys to 4, 5, and 6 for the radios to make them different than SRS as you explained, somehow it changed the SRS keys from what I had (1, 2, and 3) to 3, 4, and 5 for the radios, yet 1, 2, and 3 are the SRS keys that work in game and the comms menu doesn't appear.

 

It works though, so I'm not going to mess with it.

  • Like 1
Link to post
Share on other sites
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...