Jump to content

Extensive VR bug + my research around it. F10 + other view changes kicks you out of VR


Recommended Posts

Computer, 10700k, 3080, 32 gb ddr4 ram

VR: Quest 2 via link, Standalone launched with DCS Updater Utility

 

So this is about the F10 VR "crash". I write "crash" because it is not really a game crash per say. What happens is that you get kicked out of VR and the game continues to work in the background. For me on the Quest 2 it kicks me out to the home screen and then I can connect back to the PC but I cannot get back to the VR view in the game. The game is running in the background and I can glance at my flatscreen and control the game but my headset is black.

Things I have done to try and resolve it:

Repair / Reinstall DCS

Remove OC from Ram and CPU, my GPU is standard as it arrived

 

Here is my research around it:

Very likely to happen in multiplayer servers
Going the the F10 Map can cause the kickout

Changing view (F2, looking at other airplanes etc) can cause the kickout

Playing for a longer duration seems to increase the odds of the kickout happening

I experience the game being more and more sluggish, when changing views, before the game kicks me out

After a kickout, when I quit the game and restart it without rebooting, the kickout seems more likely, actually sometimes when I have restarted the game without reboot I have been kicked out on the very first F10 press right after I have spawned to the MP server

After a clean reboot the kickout seems more unlikely to happen

I have experienced playing on the Syria map without touching the F10 or changing views, after 50 mins of running fine, the game starts to stutter and become yanky. I then crashed the plane and after the plane crash, the game automatically switches viewport to another, and the VR kickout happens

I can force the bug to happen by quickly chaning view (F10 press, wait until loaded, F2 press wait until everything loaded, change to look at another airplane, wait until loaded, etc etc, After about 10-20 viewchanges the game kicks me out of VR) This is after a fresh reboot and just 10 min in to playing on the server.

 

I am part of a very active squadron and we are many VR players that experience this type of VR kickout. One time I flew a mission with another friend who was also in VR and it kicks us both out (not at the same time). We had to try to land the plane using the flatscreen without the ability to look around. Very challening on the carrier.

 

I would love some reply from ED about this, can you reporduce this problem? Are you working on it? Such a shame an 11/10 game like this is marred with such a frustrating bug.

 

Much love, your fan

Loki

 


 


Edited by Loki 1-1
  • Like 4
  • Thanks 1
Link to post
Share on other sites

Hello! I experience the same as above. Running this setup: Ryzen 2700X on X470, 32GB 3000 mhz DDR4, GTX 1070, Reverb G2 with DCS on SSD.

 

Would be nice to eventually see a solution to this. Keep up the good work guys!

 

Hugs and kisses /Johnny

  • Like 2
Link to post
Share on other sites
  • 2 weeks later...

I too, am having this issue, I am wondering what kind of cable you are using...   I got the "off-brand" cable from amazon, but I believe it has the same specs as the oculus cable, so I'm not sure that's the issue...But I'd be curious to know...  Many Thanks

Link to post
Share on other sites

Hi,

 

I will take another look at this issue, so far on my machine I have not been able to reproduce, I will ask other testers to check also.

 

can you attach your dcs log after the event so we can continue to look for more clues. 

 

thanks

  • Like 1

smallCATPILOT.PNG.04bbece1b27ff1b2c193b174ec410fc0.PNG

Forum rules - DCS Crashing? Try this first - Cleanup and Repair - Discord BIGNEWY#8703 - Youtube - Patch Status

Windows 10 Pro x64, NVIDIA MSI RTX 2080Ti VENTUS GP, Intel® i9-10900K 3.70GHz, 5.30GHz Turbo, Corsair Hydro Series H150i Pro, 32GB DDR @3000, ASUS ROG Strix Z490-F Gaming, HP Reverb G2

Link to post
Share on other sites

Strangely, I am having better connection, while streaming DCS to my Quest 2.  The resolution seems a bit nervous, but at least it doesn't break connection. At this point I am streaming, and able to have a 22-30 fps...

ASUS G20b Intel(R) Core(TM) i7-6700 CPU @ 3.40GHz   3.40 GHz   32GB ram   NVIDIA  GTX 1080

 


Edited by epipkin911
Link to post
Share on other sites
20 hours ago, epipkin911 said:

I too, am having this issue, I am wondering what kind of cable you are using...   I got the "off-brand" cable from amazon, but I believe it has the same specs as the oculus cable, so I'm not sure that's the issue...But I'd be curious to know...  Many Thanks

I have a thrid party cable of good quality. I have tried reducing the resolution = lowering the bandwidth, and it does nothing. I do not think the cable is the problem.
 

 

20 hours ago, BIGNEWY said:

Hi,

 

I will take another look at this issue, so far on my machine I have not been able to reproduce, I will ask other testers to check also.

 

can you attach your dcs log after the event so we can continue to look for more clues. 

 

thanks

 

Thank you, to reproduce it this time I used the Swedish multiplayer server RedMed (you can find it if you search RedMed) and tried to go in to the F10 map. I have attached the Log. The bug happened at the start of the 10:40 mark, around 20 seconds after the kick out I was able to reconnect the headset to the computer and then I just had the black screen. I glanced at my flatscreen monitor, logged out of the server and quit the game.

 

The real question is why does it happen when changing view? I have only had it in multiplayer servers IIRC. Most common culprit is the F10 press. Is it some windows thing that is happening? But then why only on view changes and specifically multiplayer servers? Could it be connected to the amount of units in the game? Could it be something with the netcode? Could it be connected with VRAM somehow? Perhaps if the 3080 had more the 10 GB VRAM it would not happen? But then again it should be fixable in DCS code... Many questions. Very intriguing. Best Regards

dcs - kopia.log

Link to post
Share on other sites

I've had this happen only once, after playing a pretty big multiplayer mission for a couple of hours, and then pressing F10. It happened to two other VR pilots on the server around the same time.

 

The only clue I've got for you is that the longer you're in game, the longer the game freezes when opening the F10 map. It was almost as if something timed out when VR/WMR crashed on me. If you want to have a good go at reproducing I'd suggest running a big multiplayer mission with lots of different modules on Syria map for at least a couple of hours before you press F10. I was flying the F-16 if that is likely to matter.

 

I'm going to try to reproduce the way I outlined above. I'll just avoid the F10 maps for a couple of hours while doing my regular flying.

 

5600X

32 GB RAM

RTX 3080

Reverb G2

 

 

 

 

 

 

  • Like 1
Link to post
Share on other sites
1 hour ago, Katj said:

I've had this happen only once, after playing a pretty big multiplayer mission for a couple of hours, and then pressing F10. It happened to two other VR pilots on the server around the same time.

 

The only clue I've got for you is that the longer you're in game, the longer the game freezes when opening the F10 map. It was almost as if something timed out when VR/WMR crashed on me. If you want to have a good go at reproducing I'd suggest running a big multiplayer mission with lots of different modules on Syria map for at least a couple of hours before you press F10. I was flying the F-16 if that is likely to matter.

 

I'm going to try to reproduce the way I outlined above. I'll just avoid the F10 maps for a couple of hours while doing my regular flying.

 

5600X

32 GB RAM

RTX 3080

Reverb G2

 

 

 

 

 

 

I will second this. The amount of units (AI) in the multiplayer server seems like it affects the possibility of this crash happening. With greater numbers meaning greater chance of it happening.

Link to post
Share on other sites
On 3/15/2021 at 10:25 AM, BIGNEWY said:

Hi,

 

I will take another look at this issue, so far on my machine I have not been able to reproduce, I will ask other testers to check also.

 

can you attach your dcs log after the event so we can continue to look for more clues. 

 

thanks

Seems there may be a fix for this issue...  Virus said I shoud disable the "Power management" to the USB hubs...I did just that, and thus far I have had no breaks...  Will continue to test it...Have also disabled Pwr Mgt in wireless adapter settings as well...   Streams better than with the 'Link'...   

Link to post
Share on other sites
45 minutes ago, epipkin911 said:

Seems there may be a fix for this issue...  Virus said I shoud disable the "Power management" to the USB hubs...I did just that, and thus far I have had no breaks...  Will continue to test it...Have also disabled Pwr Mgt in wireless adapter settings as well...   Streams better than with the 'Link'...   

cool keep me informed, 

 

I do have USB power management disabled already so maybe why I am not seeing the issue. 

 

thanks

smallCATPILOT.PNG.04bbece1b27ff1b2c193b174ec410fc0.PNG

Forum rules - DCS Crashing? Try this first - Cleanup and Repair - Discord BIGNEWY#8703 - Youtube - Patch Status

Windows 10 Pro x64, NVIDIA MSI RTX 2080Ti VENTUS GP, Intel® i9-10900K 3.70GHz, 5.30GHz Turbo, Corsair Hydro Series H150i Pro, 32GB DDR @3000, ASUS ROG Strix Z490-F Gaming, HP Reverb G2

Link to post
Share on other sites
15 hours ago, epipkin911 said:

Seems there may be a fix for this issue...  Virus said I shoud disable the "Power management" to the USB hubs...I did just that, and thus far I have had no breaks...  Will continue to test it...Have also disabled Pwr Mgt in wireless adapter settings as well...   Streams better than with the 'Link'...   

I have tried this already but it did not solve my problems.

 

Link to post
Share on other sites

I have had a few issues recently with G2 going blue screen or just black whilst DCS carries on running in the background.

Also noticeable to me is a funny jerky effect with my in goggs VR view, its like my head instantly twitches a few cm to the left or right and then back to where it was.

I found not using the full mirror screen on the monitor "Alt enter" cleaned the problem up and then going back to full mirror screen brought the problems back.

 

I wonder if these problems are related


Edited by Rogue Trooper

HP pro Reverb.

Current settings:

Windows VR setting: IPD is 64.5mm, High image quality, 90Hz refresh rate.

Steam: VR SS set to 100%, motionReprojectionMode set to "motionreproduction" and Locked in at 45 Hz display,

DCS: Pixel Density 1.0, Forced IPD at 55 (perceived world size), 2 X MSAA, 0 X SSAA.

My real IPD is 64.5mm. Prescription VROptition lenses installed.

VR Driver system:

I9-9900KS 5Ghz CPU. XI Hero motherboard and 2080ti graphics card, 32 gigs Ram 3

[code][code][code][code]

[/code][/code][/code][/code]200 Hz. No OC at the mo.

Link to post
Share on other sites

I have been experiencing this as well. Starting from February (perhaps January) this year:

  • The mission editor/mission planner has become really laggy in VR. Noticeable when zooming in or out on the map, even in missions with few units.
  • I've experienced near crashes and crashes to desktop using the F10 map when flying in single player missions. Usually after the mission has been running for some time.

I just flew an hour-long mission in VR on the Syria map in the Viper. I used the F10 map after about 25 minutes into the mission without any issues. When I opened the F10 map again after about 1 hour and 20 minutes, the sim froze for about 10 seconds and I lost the image in my headset. The WMR portal lost connection to the headset and the frame time in SteamVR shot through the roof. After about a minute or so, the frames stabilized, but I could never get the image back in the headset. Had a hair-rising experience landing the Viper in VR without the headset :joystick:

I've saved the DCS.log from the session and I'm happy to send it over, if it might be of any help. From the looks of it, there aren't many clues in the log file though.

 

i7-9700K, 32 GB RAM

RTX 2080

Reverb G2
Windows 10, build 19042

Link to post
Share on other sites

Ive also started having this issue.. Is there anyway this is linked to Nvidia cards?
And perhaps a specific driver?
And are we all using Oculus Link cables?
 


Edited by StevanJ
Link to post
Share on other sites

I'm also having the F10 issue in multiplayer setting after some time in the game.

I can't explain if this is a memory issue or something else because I see people with Reverb having the same problem.

System:

i7 9750H 32GB

RTX2060 mobile  6GB

DCS on SSD

Win 10 1909

Quest2 using link cable


Edited by diamond26
Link to post
Share on other sites

There is also the issue of the framerate dropping / screen tearing after some time in a mission in VR. I just experienced this again and it happened in the Syria map the same way twice.

 

Events unfolding: Take of in Syria, fly up to flir bombing altidude (14.000-30.000 feet) stay there practising for about 30 min. On my way down to land the screen starts tearing and the head turning becomes janky. Stayed this way until I landed and logged out of the server. Same thing happened twice now. It could be connected with staying at high altitude for some time then as you get closer to the ground more assets are being rendered in and then it happens. Very strange since I can take off from the ground without any framerate or screen tearing issues. Perhaps it has something to do with VRAM after all, some issue with swapping assets in and out. Perhaps Level of Detail plays a role?

 

Anyway love this game

Cheers

Link to post
Share on other sites

Here's some more more info @BIGNEWY

 

I had it happen to me just now in Stable.

 

What is happening: After a while in sim On Scene/Camera Change Steam VR enters a fault state and stops talking with VR.  Normallly either happens when

 - Go from Cockpit to F10 map.

 - Die and get teleported to an external view of a unit.

 - F# to a unit that isn't right near you.


DCS logs show NOTHING with this error as DCS is still running, it even still gets head tracking data from SteamVR etc just you have no link and can't just re-enter the sim as to fix the issue you require a full SteamVR restart which in turn causes DCS to close.

 

Relevant info:

VR System: Reverb G1, SteamVR Version: 1.16.10 (1615513459) WMR for steamvr: 1.2.536

Graphics Card: RTX 3070, Nvidia Driver: 461.72

 

logs that show what is happening, rest seem standard and contain no information.

 

steam\logs\vrcompositor.txt

 

Sat Mar 27 2021 21:49:12.852 - Creating solid play area quad for compositor construct: 1.00 x 1.10
Sat Mar 27 2021 23:20:57.051 - Error: Aborting WaitForPresent after 1.000000 seconds! TimeSinceLastVSync: 1108.133545(34)
Sat Mar 27 2021 23:20:58.052 - Aborting GetDeltas(Compositor) disjoint! (n=3)
Sat Mar 27 2021 23:20:59.052 - Aborting GetDeltas(CompositorPresent) disjoint! (n=1)
Sat Mar 27 2021 23:21:00.267 - Error: Aborting WaitForPresent after 1.000000 seconds! TimeSinceLastVSync: 4322.553711(34)
Sat Mar 27 2021 23:21:08.394 - Failed Watchdog timeout in thread Render in CGraphicsDevice::AcquireSync after 5.571448 seconds. Aborting.

steam\logs\vrclient_DCS.txt

at Mar 27 2021 21:49:12.761 - DCS.exe 1.16.10 startup with PID=4876, config=C:\Program Files (x86)\Steam\config, runtime=C:\Program Files (x86)\Steam\steamapps\common\SteamVR
Sat Mar 27 2021 21:49:12.761 - vrclient type=VRApplication_Scene
Sat Mar 27 2021 21:49:12.765 - [Settings] Load Default Json Settings from C:\Program Files (x86)\Steam\steamapps\common\SteamVR\drivers\htc\resources\settings\default.vrsettings
Sat Mar 27 2021 21:49:12.765 - [Settings] Load Default Json Settings from C:\Program Files (x86)\Steam\steamapps\common\SteamVR\drivers\lighthouse\resources\settings\default.vrsettings
Sat Mar 27 2021 21:49:12.765 - [Settings] Load Default Json Settings from C:\Program Files (x86)\Steam\steamapps\common\SteamVR\drivers\null\resources\settings\default.vrsettings
Sat Mar 27 2021 21:49:12.766 - [Settings] Load Default Json Settings from C:\Program Files (x86)\Steam\steamapps\common\MixedRealityVRDriver\resources\settings\default.vrsettings
Sat Mar 27 2021 21:49:12.766 - [Settings] Load Default Json Settings from C:\Program Files (x86)\Steam\steamapps\common\SteamVR\resources\settings\default.vrsettings
Sat Mar 27 2021 21:49:12.766 - [Settings] Load Json Settings from C:\Program Files (x86)\Steam\config\steamvr.vrsettings
Sat Mar 27 2021 21:49:12.772 - Client (SteamVR_Namespace) app container state: 1
Sat Mar 27 2021 21:49:12.777 - CSharedResourceNamespaceClient::Init(): received namespace data 29580
Sat Mar 27 2021 21:49:12.777 - Client (VR_ServerPipe_29580) app container state: 1
Sat Mar 27 2021 21:49:12.797 - Received success response from vrserver connect
Sat Mar 27 2021 21:49:12.803 - Not looking for a good app key because Steam didn't start this app
Sat Mar 27 2021 21:49:12.803 - App key after connect message:system.generated.dcs.exe
Sat Mar 27 2021 21:49:12.808 - Client (VR_CompositorPipe_29580) app container state: 1
Sat Mar 27 2021 21:49:12.812 - Received success response from vrcompositor connect
Sat Mar 27 2021 21:49:12.812 - Initializing the limited version of CVRCompositorClient
Sat Mar 27 2021 21:49:12.812 - Attempting to load initial input config
Sat Mar 27 2021 21:49:12.814 - No controllers detected. Not waiting for config.
Sat Mar 27 2021 21:49:12.814 - /user/hand/left is FFFFFFFF
Sat Mar 27 2021 21:49:12.814 - /user/hand/right is FFFFFFFF
Sat Mar 27 2021 21:49:12.815 - TrackedControllerRole_LeftHand (FFFFFFFF)-> 
Sat Mar 27 2021 21:49:12.815 - Skipping role TrackedControllerRole_LeftHand because the device is invalid
Sat Mar 27 2021 21:49:12.815 - TrackedControllerRole_RightHand (FFFFFFFF)-> 
Sat Mar 27 2021 21:49:12.815 - Skipping role TrackedControllerRole_RightHand because the device is invalid
Sat Mar 27 2021 21:49:12.815 - TrackedControllerRole_Invalid (0)-> 
Sat Mar 27 2021 21:49:17.110 - Capturing Scene Focus
Sat Mar 27 2021 21:49:17.143 - Found Windows 10 or newer, so enable advanced image processing of scene textures.
Sat Mar 27 2021 21:49:17.210 - Setting max texture dimensions to 3542x3467 before requiring downsampling
Sat Mar 27 2021 23:20:58.581 - Aborting GetDeltas(Compositor Client) disjoint! (n=1)

 

steam\logs\vrserver.txt

Sat Mar 27 2021 21:49:12.797 - Processing message VRMsg_Connect from DCS (4876) took 0.00896 seconds
Sat Mar 27 2021 21:49:12.845 - Processing message VRMsg_UpdateZeroPose from vrcompositor (15656) took 0.00501 seconds
Sat Mar 27 2021 21:49:17.219 - Processing message VRMsg_CreateSwapTextureSet from DCS (4876) took 0.0073 seconds
Sat Mar 27 2021 21:49:17.229 - Processing message VRMsg_CreateSwapTextureSet from DCS (4876) took 0.00982 seconds
Sat Mar 27 2021 23:21:12.278 - Closing pipe vrcompositor (15656) because it was broken from the other end
Sat Mar 27 2021 23:21:12.278 - Process vrcompositor (15656) disconnected (Thread(0x0000026B4E2C7700/0x000)
Sat Mar 27 2021 23:21:12.278 - AppInfoManager.ProcessQuit processid=15656 eLaunchingApp=LaunchingApp_None
Sat Mar 27 2021 23:21:12.278 - AppInfoManager.ProcessQuit: Clearing application openvr.component.vrcompositor PID was 15656
Sat Mar 27 2021 23:21:12.278 - AppInfoManager.ProcessQuit: Clearing application openvr.component.vrcompositor PID because 15656 has exited
Sat Mar 27 2021 23:21:31.246 - Process vrmonitor (22708) has initiated a quit all in preparation for a restart

 

 

  • Like 2

i7 8700k, ASrock Tachi 32gb Fury X DDR4, Warthog HOTAS, HP Reverb VR, trackir, win 10, RTX 3070

TGW Dedicated Server Admin, Australian PVE/PVP gameplay.

Link to post
Share on other sites

I have asked our QA team to take a look, I am still unable to reproduce on my system however. 

 

Thanks. 

 

  • Like 1

smallCATPILOT.PNG.04bbece1b27ff1b2c193b174ec410fc0.PNG

Forum rules - DCS Crashing? Try this first - Cleanup and Repair - Discord BIGNEWY#8703 - Youtube - Patch Status

Windows 10 Pro x64, NVIDIA MSI RTX 2080Ti VENTUS GP, Intel® i9-10900K 3.70GHz, 5.30GHz Turbo, Corsair Hydro Series H150i Pro, 32GB DDR @3000, ASUS ROG Strix Z490-F Gaming, HP Reverb G2

Link to post
Share on other sites
On 3/27/2021 at 4:53 PM, BIGNEWY said:

I have asked our QA team to take a look, I am still unable to reproduce on my system however. 

 

Thanks. 

 

You have quite a lot of more VRAM than previous posters and ~most of the VR users (11gb vs 8gb). To easily replicate these kind of situation you need to crank up the SS% or texture settings a lot so your vram usage increases to same levels..

Dcs: F/A-18C, F-16C, F-14B, A-10C, A-10C II, AV-8B, UH-1H, MiG-21bis, M2000C, Ka-50, Hind, C-101, FC3, SC

System: i5-9600k@5GHz, Asus Dual 2080S O8G, 32gb DDR4 3000MHz, HP Reverb G2, Warthog hotas with gimbalmod, logitech pedals, DIY ”UFC”, 3x TM MFD’s

Link to post
Share on other sites

i have been experiencing this issue as well, mostly on the Syria map, but infrequently on PG and Caucus during long sessions.

On Syria, I've found if I don't change views or die, I'm fine. 

 

System specs: i7 8700 @ 4.8, 2080TI, Reverb G2, 32Gb ram

Link to post
Share on other sites

This just happened on Syria, and then not as badly on Persian Gulf and actually gave me a log after swapping a video card to a different 2080ti.
Second time it happened, no log..
It boots me from the Link all the way to the Quests home page and wont allow me to re-link unless i restart the headset.

I can add the tracks linked here too, but the limit needs increasing dcs.log

 

i5 8400, 16gb ram, 2080ti

If im on Syria, It wont give me a log but its much worse and the game never lasts.

It doesnt happen on Caucasus.


Edited by StevanJ
Link to post
Share on other sites
On 3/16/2021 at 1:16 AM, Aarnoman said:

Unable to reproduce on reverb G2.

I have had this happen a few times on my G2, but only if/when I start the necessary apps out of "order".

 

Correct way: Start WMR for Steam VR (which then launches SteamVR) then start DCS. If I simply launch DCS first, the WMR and SteamVr apps will launch, but one or the other will crash me back to the WMR portal with DCS Still running on desktop and no way to get back in to it short of end tasking DCS and relaunching DCS.

AMD Ryzen R9 3900X | 64GB DDR4 3600| AMD Radeon RX 6900 XT Phantom Gaming D 16G OC | Samsung 970 Evo 1TB NVME | HP Reverb G2 | Logitech X-56 throttle/VKB NXT Premium

Link to post
Share on other sites
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...